Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

RAID1 auf Dell PowerEdge-Server defekt

Frage Hardware Festplatten, SSD, Raid

Mitglied: thommy75

thommy75 (Level 1) - Jetzt verbinden

25.07.2010 um 13:34 Uhr, 12239 Aufrufe, 6 Kommentare

Vermutlich eine Festplatte defekt, System bootet nicht mehr - es wird dringend Unterstützung benötigt

Hallo im Administrator-Forum,

Ich habe ein riesiges Problem:
Auf meinem Dell PowerEdge T300 läuft auf dem onboard SAS-RAID-Controller 6/iR ein RAID1-Volume. Gestern blieb der Server mit einem BlueScreen stehen und startete neu. Im RAID-BIOS stand daraufhin (sinngemäss), dass Festplatte 0 im Sync-Modus ist. Das installierte OS (Windows SBS2003) bootete aber ohne Probleme.
Heute das Gleiche: Absturz mit Bluescreen und Reboot. Leider scheint das RAID-Volume defekt zu sein, denn der Server bootet nicht mehr. Eigentlich dachte ich, im RAID1-Verbund darf eine Festplatte ausfallen, aber das System läuft trotzdem. Leider ist das nicht der Fall.

Nun meine Frage: Kann ich das System nicht mit einer Festplatte booten und bei Erhalt einer Ersatz-Festplatte (SAS 73GB) wieder einen Rebuild durchführen?
Wie gehe am besten vor, ohne meine Daten zu verlieren? Der Server sollte so schnell wie möglich wieder laufen.

Kann mir heute - auch wenn Sonntag ist - jemand weiterhelfen?

Grüsse, thommy75
Mitglied: n.o.b.o.d.y
25.07.2010 um 13:48 Uhr
Hallo,

klar kannst Du die defekte Platte ziehen. Dafür würde ich den Server sicherheitshalber runterfahren. Und ja, im RAID1 darf eine Festplatte ausfallen und das System tut noch. ABER: Ein RAID1 schützt nur vor einem HW-Ausfall. Denn die Installation auf dem System einen Schuß weg hat., dann hilft das RAID1 auch nicht, denn der "Schuß" wird natürlich auf beide Platten gesynct.

Hast Du mal das Eventlog geprüft, warum es zu den Abstürzen kommt? Das muß ja nichts mit dem Plattenausfall an sich zu tun haben.

Und ich sehe jetzt den akuten Zeitpunkt gekommen, noch mal schnell ein Vollbackup/Image der Installation zu machen, falls das letzte Backup schon was her ist.
Bitte warten ..
Mitglied: thommy75
25.07.2010 um 14:06 Uhr
Hallo,

Danke für die schnelle Antwort.
Die vermeintlich defekte Platte habe ich bereits gezogen, aber der Server startet dennoch nicht mehr. Normalerweise initialisiert der Dell beim Starten das RAID und installiert ein "MPT-BIOS". Da jetzt jedoch eine Festplatte fehlt, macht er dies nicht und daraufhin kommt die Meldung, dass keine bootfähige Partition gefunden wurde.
Daher meine Frage, ob ich ein RAID mit nur einer Festplatte booten kann.

Das Eventlog habe ich nach dem gestrigen Ausfall geprüft, aber nichts auffälliges feststellen können (Disk-error o.ä.). Akutell habe ich keinen Zugriff auf das OS.
Auf die Platten tippe ich, da er nach dem Reboot eine Synchronisiation macht.

Backup (Älteres Image mit täglichem NTBackup) ist vorhanden, aber derzeit nutzlos, da ich keinen funktionierenden Server habe... Muss morgen erst noch den Dell-Support kontaktieren, um Ersatzfestplatte zu ordern.

Noch einen Tipp?

Gruss, thommy
Bitte warten ..
Mitglied: n.o.b.o.d.y
25.07.2010 um 20:08 Uhr
Hallo,

ich kenn' jetzt die Dell-Kisten nicht so genau, aber hast du vielleicht die falsche Platte gezogen? Oder bootet er mit beiden und Du kannst dann eine ziehen (Achtung: hot plug!)?

Der BSoD muß ja aber auch nicht von einem Plattenfehler herrühren, sondern kann auch ein "normales" Softwareproblem sein. Aber erstmal die Platten erneuern und dann sehen ob er noch auftritt. Wenn nicht, würde ich aber auf jeden Fall bei Dell nachhaken, denn das kann ja nicht sein, dass der Ausfall einer Platte im RAID zu solchen Abstürzen führt.
Bitte warten ..
Mitglied: bernie2909
25.07.2010 um 20:52 Uhr
Hi,

Schau mal im in den Einstellungen vomm raid controller, ob du Die festplatten als Force Online stellen kannst, hatte mal Probleme mit dem 1750, wo eine FP einfach Offline gegangen ist.
Bitte warten ..
Mitglied: thommy75
25.07.2010 um 21:55 Uhr
Hallo,

Danke für die Antworten.
Habe mittlerweile noch ein wenig rumprobiert. Es scheint ein grösseres Problem mit der Backplane zu sein, da der Server mittlerweile beide Platten (also die "gute" und die vermeintlich defekte) nur sporadisch erkennt. Hab es inzwischen aufgegeben und werde mich morgen an den Dell-Support wenden.

In den letzten Tagen wurde nichts am Server geändert, weder Hardware noch Software (Updates o.ä.). Der Server lief seit der Anschaffung vor 1,5 Jahren ohne ein einziges Problem.

Werde einen Abschlussbericht liefern.

Gruss, thommy75
Bitte warten ..
Mitglied: thommy75
01.08.2010 um 16:10 Uhr
Hallo,

Wie versprochen der Abschlussbericht:

Zunächst, der Server läuft wieder. Nach etlichen Telefonaten mit dem Dell-Support und dem Besuch eines Technikers konnten wir das RAID wieder in Betrieb nehmen.
Problem an der Geschichte war, dass neben einer Festplatte auch der RAID-Controller defekt war (vermutlich Folgefehler). Deshalb das nicht nachvollziehbare Verhalten des RAIDs.
Einzig eine Partition auf dem Raid war korrupt (betroffen war dadurch der Exchange-Server und einige SQL-Instanzen), aber dies liess sich mittels Image und Backup relativ schnell beheben.

Einen Moment der Angst: Als auch der Techniker vor Ort nicht mehr weiterwusste und er selbst mit der Dell-Hotline Kontakt aufnahm, wollte er mein RAID-Volume, das eigentlich sichtbar war, plattmachen. Ich konnte ihn jedoch noch rechtzeitig davon abhalten, und die Ersatzplatte ohne Neuerstellung des RAIDs einbinden...

Und was ich während meiner Fehlereingrenzung nebenbei auch noch erfuhr:
Eine Eigenheit des preisgünstigen SAS 6/iR-RAID-Controllers in den Dell-Servern ist, dass zwar (bei einem RAID1) auf beide Platten geschrieben wird, gelesen wird jedoch nur von einer (als Primär gekennzeichneten) Platte. Da bei mir die Primärplatte ausfiehl, stürzte dadurch auch das Betriebsystem ab. Dell empfiehlt daher zum PERC-RAID-Controller (ist aber um einiges teuerer).

FAZIT 1: Wie schon oft (auch in diesen Foren) besprochen, ersetzt ein RAID1 kein Backup! Denn das beste RAID bringt nix, wenn der Controller versagt und die Platten mit unnützen Schrott vollschreibt. Ich bin froh, dass ich Image und ein regelmässiges Backup von meinen Systemen habe. Dadurch bin ich mit einem blauen Auge davongekommen.
FAZIT 2: Der Dell-Support ist meiner Ansicht nach echt klasse. Man wird immer vom selben Hotliner betreut und zumindest in der Garantiezeit ist vor-Ort-Service kein Problem. Nur der Preis für einen Techniker-Besuch ausserhalb der Garantiezeit ohne entsprechenden Service-Vertrag ist heftig (man sagte mit ca. 280.- EUR pro angefangene Stunde). Puh.

Grüsse, thommy75

Beitrag wird als gelöst markiert!
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Festplatten, SSD, Raid
DELL PowerEdge T630, RAID1 auf PERC S130 CONTROLLER, Festplattentausch (14)

Frage von EdisonHH zum Thema Festplatten, SSD, Raid ...

Windows Server
Dell Poweredge T20 Hardwaremonitoring (2)

Frage von CortexA8 zum Thema Windows Server ...

Server-Hardware
gelöst Dell Poweredge 600 SC Chassis Fan Fehlererkennung ausschalten geht das? (4)

Frage von TechnoX zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...