Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Replikation zwischen w3K und W2k Server funktioniert nicht mehr.

Frage Microsoft Windows Server

Mitglied: goaknecht

goaknecht (Level 1) - Jetzt verbinden

04.06.2008, aktualisiert 09.06.2008, 7077 Aufrufe, 8 Kommentare

Replikation

Hallo auch !

Habe hier einen W3K Server und einen W2K Server.

Seit einem Stromausfall funktioniert die Replikation zwischen den Server nicht mehr.

Rollenverteilung:

Domain Naming Master = W2K

Alle anderen Rollen liegen auf dem Windows 2003 Server.
Auf dem W3k läuft auch Exchange.

Wenn ich nun eine manuelle Replikation am W2K durchführen möchte bekomme ich entweder die Fehlermeldung Dienstprinziplname falsch oder auch Zugriff verweigert.

repadmin /syncall /force meldet keine Fahler.

Des Weiteren funktioniert der Zugriff über UNC-Pfad nicht mehr vom W2K auf den W3K. Über IP-Adresse geht alles einwandfrei. Fehlermeldung: Der Zielkontenname ist ungültig.

nslookup ist ok !!!

net view W3k vom W2K bringt Fehlermeldung Zugriff verweigert.
net view
W2K vom w3k funktioniert einwandfrei.


Aber leider ist das noch nicht alles. Seit geraumer Zeit können sich einige Clients nicht mehr sauber an der Domäne anmelden. Netlogon Event ID: 5722. ( Die Einrichtung einer Sitzung vom Computer ... ist an der Authentifizierung gescheitert. Der Kontenname in der Sicherheitsdatenbank ist ...$ / Zugriff verweigert.

Das ist noch nicht alles sondern nur der Anfang. Die Server wurden nicht von mir aufgesetzt ... ich muss mich nur jetzt um diesen Schrott kümmern ...

Wie bekomme ich das in den Griff ?

Danke für die Hilfe !
Mitglied: harald21
04.06.2008 um 10:34 Uhr
Hallo,

wenn sich die beiden Server nicht mehr synchronisieren, so kannst du alle Master-Rollen (siehe http://support.microsoft.com/kb/234790/de und http://support.microsoft.com/kb/324801/de) auf den W2k3 transferieren, den W2k herunterstufen und anschließend wieder heraufstufen.

Der Fehler "Netlogon:5722" beruht wahrscheinlich darauf, das das Passwort für die Computerkonten zwischen den PC's und dem jeweiligen Anmeldeserver nicht mehr synchron ist. Betrifft das eigentlich beide Server oder nur einen der beiden? Hier die Computerkonten einfach der Domäne neu hinzufügen (siehe auch hier: http://support.microsoft.com/kb/154501/de).


Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: goaknecht
04.06.2008 um 10:42 Uhr
Danke für die schnelle Hilfe.

Die PC's mit dem Netlogon Fehler habe ich schon aus der Domäne genommen und wieder eingepflegt. Fehler bleibt.

Habe versucht den DomainNameMaster auf den w3K zu verschieben. Ist leider fehlgeschlagen. Fehlermeldung: Die Betriebsmasterfunktion konnte nicht übertragen werden. Der angeforderte FSMO Vorgang konnte nicht ausgeführt werden. Der aktuelle FSMO Inhaber ist nicht erreichbar.

Ich vermute mein Problem ist der W3k oder liege ich da falsch ?
Bitte warten ..
Mitglied: harald21
04.06.2008 um 11:59 Uhr
Hallo,

den netlogon-Fehler solltest du erst bearbeiten, wenn der Rest behoben ist.

Von welchem Server aus hast du versucht den Domain Naming Master zu verschieben?
Versuche das bitte vom w2k3 aus zu machen, evtl. erhältst du eine Fehlermeldung, aber das Verschieben funktioniert trotzdem. Anschließend kontrolliere den Status auf dem w2k, wenn zwischen den beiden servern keine Replication stattfindet, so glaubt der w2k evtl. immer noch der Domain Naming Master zu sein. Dann kann auch ds Herunterstufen fehlschlagen. Die kann man aber mit "dcpromo /forceremoval" erzwingen. In diesem Fall sind dann noch einige anschließende Aufräumarbeiten notwendig bevor der w2k wieder der Domäne hinzugefügt werden kann (manuelles Löschen des Computerkontos in AD Benutzer+Computer, manuelle Aufräumarbeiten in AD Standorte+Dienste, manuelle Aufräumarbeiten mit ntdsutil siehe Stichwort "metadata cleanup").
Bevor du damit anfängst solltest du dich auf alle Fälle umfassend informieren, da das eine größere Aktion werden kann.

Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: goaknecht
04.06.2008 um 12:14 Uhr
Da bin ich wieder.

Ich habe versucht direkt vom W3K die Rolle des DomainNamingMaster zu übernehmen.
Das Verschieben der Rolle ist definitiv mit oben angegebenen Fehler fehlgeschlagen.

netdom query fsmo zeigt noch immer den W2K als DomainNamingMaster an.

Und nun ?
Bitte warten ..
Mitglied: harald21
04.06.2008 um 15:07 Uhr
Hallo,

was (außer der DC-Funktionalität) macht denn der w2k sonst noch (File- und Print-Services, etc.)?
Kannst du ihn temporär abschalten (evtl außerhalb der Bürozeiten) um zu testen, ob der w2k3 ordnungsgemäß funktioniert?
Im günstigsten Fall arbeiten beide noch ordnungsgemäß und replizieren nur keine Daten mehr.

Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: goaknecht
04.06.2008 um 16:22 Uhr
Hallo Harald .... danke erst einmal für Deine Hilfe ..

Der W2K ist ein Fileserver. Auf dem Server läuft eine Oracle Datenbank, die von den Usern ständig benutzt wird. Werde nun erst einmal die DNS Einträge beider Server vergleichen und evtl. den DNS vom W2K deinstallieren und dann wieder Neuinstallieren.
Normalerweise sollte sich der W2K ja dann die Einträge vom W3K holen.

Evtl. habe ich ja ein mir nicht ersichtliches DNS Problem !!!

Wie erkennt mann welcher DNS der aktueller ist ? SOA Seriennummer ?

Thanks for help.
Bitte warten ..
Mitglied: harald21
05.06.2008 um 07:41 Uhr
Hallo,

ja, die SOA-Seriennummer zeigt an, welcher Server die aktuelleren Einträge hat. Zum Test kannst du die Seriennummer auch manuell hochsetzen und nachschauen, ob das repliziert wird. Ansonsten kann man mit "replmon" aus den MS Support Tools die Replikation zwischen DC's überwachen.

Mit freundlichen Grüßen
Harald
Bitte warten ..
Mitglied: goaknecht
09.06.2008 um 22:38 Uhr
So nun ist der Fall erledigt.

Habe versucht die MS Support Tools auf dem W2k auszuführen.
Leider immer ohne Erfolg. Fehlermeldung Prozedureinstiegspunkt in...dll nicht gefunden. Ist mir bei fast allen Tools passiert.

Naja ... dann habe ich mal das SP4 neu installiert und siehe da ... alle Fehler sind weg. Supporttools wieder ausführbar und auch die Replikation zwischen den Server funktioniert wieder. ( Puh .. Glück gehabt) .

Einen Tag läuft das jetzt alles wieder und sämtliche netlogon Fehler sind verschwunden. DNS und Active Directory sind nun auch wieder ok.

Danke nochmal ... damit ist das Problem gelöst ....
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
AD Replikation zwischen untergeordneten Domäne zwingend? (1)

Frage von Gien-app zum Thema Windows Server ...

Netzwerkmanagement
gelöst Ein Gerät, zwei DHCP Server oder mehr (16)

Frage von fuddel18 zum Thema Netzwerkmanagement ...

Netzwerke
gelöst Ping zu Windows Server funktioniert im OpenVPN netz nicht (5)

Frage von ketanest112 zum Thema Netzwerke ...

Windows Server
gelöst L2TP VPN Server funktioniert nicht - Win2012R2 (33)

Frage von 118080 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Empfehlung günstiges ADSL2+ nur Modem (10)

Frage von TimMayer zum Thema Router & Routing ...

Server-Hardware
Lenovo Server System X 3650 M5 Festplatten (9)

Frage von Hendrik2586 zum Thema Server-Hardware ...