Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Restore Backup MAXDB auf einem Debian Suqeeze

Frage Entwicklung Datenbanken

Mitglied: aKaLexeD

aKaLexeD (Level 1) - Jetzt verbinden

06.12.2012, aktualisiert 11:24 Uhr, 2055 Aufrufe

Hallo,

ich versuche ein erstelltes Backup (als Vorsichtsmaßnahme) mal zurück zu spielen.

Ausgangssituation ist folgende:

Debian Datenbankserver mit 2.6.32-5-amd64 Kernel.
Auf diesem läuft die MAXDB "7.7.07","UNIX","/opt/sdb/7707",True,ASCII,2


Ich habe die Sicherungen so eingestellt, dass diese Sonntag eine Vollsicherung läuft.
An allen anderen Tagen seit der vergangenen Vollsicherung eine Differenzsicherung macht.
Ab diesen Diffsicherungen werden Autologs in 10 Minuten takt weggeschrieben.

>dbmcli -uUTL -d %DATABASE% -u %user%,%passwd%

>db_admin

>medium_getall

So sieht die Config der Sicherung aus:

AUTOLOG /var/maxdb/autolog/autolog FILE AUTO 0 8 NO NO 20100823092642 20100823092642 NONE 0
FULL1 /var/maxdb/full/full01 FILE DATA 0 8 YES NO 20120516122927 20120516122927 NONE 0
DIFF11 /var/maxdb/diff/diff11 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0
DIFF12 /var/maxdb/diff/diff12 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0
DIFF13 /var/maxdb/diff/diff13 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0
DIFF14 /var/maxdb/diff/diff14 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0
DIFF15 /var/maxdb/diff/diff15 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0
DIFF16 /var/maxdb/diff/diff16 FILE PAGES 0 8 YES NO 20120516122956 20120516122956 NONE 0


Alle Sicherungen werden erfolgreich erstellt.
Also gehe ich her und mache ein Restore:

>dbmcli -uUTL -d %DATABASE% -u %user%,%passwd%

>db_admin

>db_activate RECOVER FULL1

=> Ergebnis ohne Fehler (Test auf der DB = Alle Daten richtig)

>recover_start DIFF11

=> Ergebnis ohne Fehler (Test auf der DB = Alle Daten richtig)


... soweit so gut. Nun müsste ich die Logs einspielen. Mein Ziel ist es das Log "/var/maxdb/autolog/autolog.007" einzuspielen.
Also habe ich edliche Befehle probiert, es kommen aber immer Fehlermeldung unterschiedlichster Art und google ist da leider keine große Hilfe.

>recover_start AUTOLOG LOG 007

oder

>recover_replace AUTOLOG /var/maxdb/autolog/autolog.007

oder

> ???



Kann mir bei diesem Thema jemand helfen?
Ähnliche Inhalte
Datenbanken
Backup restore SQL Express DB (7)

Frage von franksig zum Thema Datenbanken ...

Backup
Acronis True Image 2016 - Restore dauert eine Ewigkeit (7)

Frage von Clarissa zum Thema Backup ...

Windows 10
Google Chrome Einstellungen nach Paragon Image restore alle weg

Frage von Rene1976 zum Thema Windows 10 ...

Datenbanken
SQL restore bringt Fehler (2)

Frage von franksig zum Thema Datenbanken ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(2)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Netzwerkprotokolle
gelöst Leiten "dumme" Switches VLAN-Tags mit durch? (26)

Frage von coltseavers zum Thema Netzwerkprotokolle ...

Netzwerkgrundlagen
Kann auf Freigabe nicht Zugreifen (16)

Frage von leon123 zum Thema Netzwerkgrundlagen ...

Windows Server
gelöst Neues KB für W10 1607 und W2K16 wieder mal nicht im WSUS 3.0, hat das noch jemand? (16)

Frage von departure69 zum Thema Windows Server ...

Router & Routing
FTTH bzw FTTB Router (13)

Frage von ukulele-7 zum Thema Router & Routing ...