Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Robocopy - Probleme mit dem Parameter MINAGE

Frage Microsoft Windows Tools

Mitglied: lang1609

lang1609 (Level 1) - Jetzt verbinden

30.10.2008, aktualisiert 15:52 Uhr, 7820 Aufrufe, 3 Kommentare

Hallo zusammen,

ich nutze des Tool Robocopy in der Version XP010 um in einer Windows Domäne auf einem Server Bilder im jpg Format zu archivieren.

Es sollen alle Bilder, die älter als 90 Tage sind in einen weiteren Sicherungsordner verschoben werden.

Die Bilder wurden zuvor von verschiedenen Kameras über ein spezielles Import-Tool auf den Server abgespeichert.

Habe den Robocopy-Job als peplanten Task eingebunden, der einmal nachts ausgeführt wird.

Befehlssyntax:

robocopy "Quelle" "Ziel" /E /MOVE /MINAGE:90

Nun passiert es aber häufig, dass Bilder bereits verschoben werden, obwohl diese erst 10 Tage alt sind.

Eine Überprüfung ergab, dass die Bilddateien zwar die korrekte Erstellungszeit besaßen (also die Zeit, an der sie auf den Server übertragen wurden) allerdings eine vollkommen falschen Zeitstempel für das Datum des letzten Zugriffs. Hier lagen die Werte dann immer weiter als 90 Tage in der Vergangenheit, teilweise um Jahre zurück.

Ich vermute, dass dieses Veränderungsdatum bei der Aufnahme mit der Kamera erstellt wird. Die Zeiteinstellungen auf den Kameras stimmen aber in den seltensten Fällen.

Kann ich Robocopy irgendwie dazu bringen ausschließlich die Erstellungszeit zu benutzen und das Datum des letzten Zugriffs zu ignorieren ?

Ich bin für jeden Tip dankbar.

Gruß

Dirk
Mitglied: Iwan
30.10.2008 um 12:32 Uhr
hallo,

ich weiss, das man bei DelAge32 das mit Datum als Parameter mitgeben kann:
http://home.mnet-online.de/horst.muc/win/delage.htm
http://home.mnet-online.de/horst.muc/win/delage32.zip

wäre bei dir also: delage32.exe QUELLE 90 /created /move ZIEL
mit dem Parameter /preview kannst du dir erstmal angucken, was er machen würde
Bitte warten ..
Mitglied: lang1609
30.10.2008 um 15:47 Uhr
Hi Iwan,

der Server wird in einer restriktiv standardisierten Umgebung betrieben und der Einsatz von Fremdtools außerhalb des Resource Kits ist nicht zulässig.

Dirk
Bitte warten ..
Mitglied: Iwan
30.10.2008 um 15:52 Uhr
ok, aber dann solltest du das das nächste mal vorher erwähnen

Zitat: "Die Zeiteinstellungen auf den Kameras stimmen aber in den seltensten Fällen."
dann sieh zu, das sie immer stimmen und du hast kein Problem mehr
ansonsten versuchst du einen Fehler durch Umgehen zu lösen anstatt das Problem an der Wurzel zu greifen
Bitte warten ..
Ähnliche Inhalte
Windows Server
Schattenkopien mit Robocopy (11)

Frage von AveiroCR7 zum Thema Windows Server ...

Batch & Shell
gelöst Robocopy XF und die Probleme mit der Dateiendung (2)

Frage von Ebisumaru zum Thema Batch & Shell ...

Windows Server
Robocopy Ordner-Icons behalten (5)

Frage von sebastian2608 zum Thema Windows Server ...

Batch & Shell
Robocopy soll nur spezielle Unterordner kopieren (2)

Frage von PoldiMUC zum Thema Batch & Shell ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Server-Hardware
Bestehendes Raid erweitern um 4 gleiche Platten! (Verständnis Fragen) (12)

Frage von Hendrik2586 zum Thema Server-Hardware ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...