Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Route von OpenVPN Server in anderes Subnet setzen

Frage Microsoft Windows Netzwerk

Mitglied: Lorderich

Lorderich (Level 1) - Jetzt verbinden

20.07.2013, aktualisiert 21.07.2013, 9723 Aufrufe, 6 Kommentare

Hallo zusammen,

scheinbar stelle ich mich echt zu prasselig an oder ich verstehe es bisher einfach nicht.

Also es gibt einen Server, der per OpenVPN einen VPN-Zugriff zur Verfügung stellt. Dieser Server befindet sich im IP-Adress Bereich 10.10.30.0.

Die Verbindung vom Client zum Server ist auch kein Problem, funktioniert alles tadellos. Der Client kann den Server sehen und pingen und anders herum.

An dem Server mit der OpenVPN IP-Adresse gibt es einen weiteres VPN-Tunnel, der in das interne Netz routet. Dieses interne VPN-Netz zwischen unseren Servern hat den IP-Adressbereich 10.10.20.0.

Nun möchte ich, dass die Client, die sich mit dem OpenVPN Server verbinden auch in das Subnet 10.10.20.0 kommen können und hier verschiedene Applikationen etc. aufrufen können.

Der OpenVPN Server hat damit die folgenden IP-Adressen:

WAN IP: 192.168.2.1
OpenVPN IP: 10.10.30.1
Interne VPN IP: 10.10.20.16

Wenn ich das richtig verstehe, müsste ich in Windows doch eine Route setzen ala

route ADD 10.10.20.0 MASK 255.255.255.0 10.10.20.16

Die IP-Adresse 10.10.20.16 ist ja die Verbindung in das andere Netz. Wenn ich das so setze, dann kommt der Ping aber vom VPN-Client nicht in das 10.10.20.0 Netz. Oder muss ich neben dieser Route auch noch in den Servern, welche hinter den IP-Adressen 10.10.20.0 liegen die Route zurück setzen?

Der Client bekommt vom Server folgende Push-Informationen:

push "route 10.10.20.0 255.255.255.255"
#push "redirect-gateway"
push "dhcp-option DNS 10.10.20.10"
#push "dhcp-option WINS 172.20.0.100

Habe ich da irgendwo einen Denkfehler drin?

Danke und Grüße

Der Lord
Mitglied: orcape
21.07.2013 um 20:12 Uhr
Hi Lord,

Habe ich da irgendwo einen Denkfehler drin?
Um das beurteilen zu können, wäre einfach mal ganz Nett, wenn einem der Netzwerkaufbau mal etwas verdeutlicht wird.
Wie wäre es mit einer kleinen Zeichnung das Netz betreffend.
Die push Informationen auf dem Server sehen so zwar OK aus, das ist aber die halbe Wahrheit.
Wenn der Server als Router fungieren soll, weil er beide Subnetze trennt, dann gehört da schon mehr zu.

Gruß orcape
Bitte warten ..
Mitglied: kn0rki
21.07.2013 um 21:14 Uhr
Allen beteiligten Geräten muss auch der Rückweg des Paketes bekannt sein. Sonst tut sich da nichts.
Bitte warten ..
Mitglied: Lorderich
21.07.2013 um 21:45 Uhr
Hallo zusammen,

ich habe jetzt nochmal eine grob Zeichnung des Aufbaus angehängt.

22dcfa1a0735a89d40e5ac75340a2f43 - Klicke auf das Bild, um es zu vergrößern

Vielleicht noch kurz zu Erklärung. Die beiden Server sind grundsätzlich im selben LAN-Segment (192.168.2.0). Alle Kommunikationen, welche zwischen diesen beiden Systemen übertragen werden wollen, also Datenaustausch, Replikationen etc. werden immer über die VPN Verbindung durchgeführt.

Wenn ich das also richtig verstehe, dann müsste ich auf dem OpenVPN Server die folgende Route setzen:

route ADD 10.10.20.0 MASK 255.255.255.0 10.10.20.13

Alle Anfragen an den VPN Server aus dem IP-Adress Bereich 10.10.20.0 sollen demnach über die einzige Verbindung von diesem Server in das interne VPN Netz über die Verbindung 10.10.20.13 geleitet werden. Korrekt?

Auf dem anderen Hostsystem müsste ich dann also eine Route setzen ala

route ADD 10.10.30.0 MASK 255.255.255.0 10.10.20.10

Damit sollen das andere Hostsystem wissen, dass es Anfragen aus dem IP-Adress Bereich 10.10.30.0 über die Schnittstelle 10.10.20.10 an den OpenVPN Server zurück geben soll. Oder?

Danke und Grüße

Der Lord
Bitte warten ..
Mitglied: kn0rki
21.07.2013 um 22:05 Uhr
Zitat von Lorderich:

Der Client bekommt vom Server folgende Push-Informationen:

push "route 10.10.20.0 255.255.255.255"
#push "redirect-gateway"
push "dhcp-option DNS 10.10.20.10"
#push "dhcp-option WINS 172.20.0.100
Habe ich da irgendwo einen Denkfehler drin?

ist hier nicht auch ein 255 zuviel?
push "route 10.10.20.0 255.255.255.255"

Ich vermute da soll ein /24 Netz angegeben werden und nicht /32.
Bitte warten ..
Mitglied: Lorderich
21.07.2013 um 22:17 Uhr
Hallo kn0rki,

ist korrekt.

Da war eine 255 zuviel. Sollte eigentlich 255.255.255.0 heissen.

Habs bereits korrigiert. Aber das scheint noch nicht die Lösung des Problems zu sein.

Danke und Grüße

Der Lord
Bitte warten ..
Mitglied: colinardo
22.07.2013, aktualisiert 23.07.2013
Hallo Der Lord,
zu aller erst überprüfe ob auf den OpenVPN-Server und dem Windows VPN-Server der Routing- und RAS Dienst läuft. (net start RemoteAccess)
Dieser Dienst muss gestartet sein ! sonst funktioniert dein Vorhaben nicht.

Der Client bekommt die richtige Route ja schon mitgeteilt (push "route 10.10.20.0 255.255.255.0"). Das bleibt so.

Auf dem internen VPN-Server muss noch folgende Route gesetzt werden:
route add 10.10.30.0 MASK 255.255.255.0 10.10.20.13
Auf den Servern im internen VPN Netz musst du auch Routen setzen die auf den internen VPN-Server zeigen.
add route 10.10.30.0 MASK 255.255.255.0 10.10.20.10
Zuletzt müssen natürlich die Firewalls auf den Servern im internen Netz richtig konfiguriert sein. Standardmäßig lässt Windows Pings nur aus dem eigenen Subnetz zu, ebenso wie Freigaben.

damit sollte es funktionieren ... wenn ich deine Interpretation richtig verstanden habe

Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
Routen bei openvpn (4)

Frage von davman zum Thema Netzwerkgrundlagen ...

Router & Routing
Router für OpenVPN (Client) und VLAN (24)

Frage von damnbx zum Thema Router & Routing ...

Netzwerke
Dd-wrt OpenVPN Backup-VPN auf zweit Router (10)

Frage von DonJoe zum Thema Netzwerke ...

Netzwerke
Zugriff vom LAN zu OpenVPN Server (22)

Frage von Aubanan zum Thema Netzwerke ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Windows 7
Bluesreens unternehmensweit (13)

Frage von SYS64738 zum Thema Windows 7 ...

Windows 10
Programm Installation bei Win 10 Fehlerhaft (12)

Frage von Keineahnungvonnix zum Thema Windows 10 ...

SAN, NAS, DAS
gelöst Synology DS213j (11)

Frage von Hendrik2586 zum Thema SAN, NAS, DAS ...