Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Routing Problem unter Windows 2003

Frage Netzwerke Router & Routing

Mitglied: Kampfwurst

Kampfwurst (Level 1) - Jetzt verbinden

19.06.2007, aktualisiert 24.06.2007, 5640 Aufrufe, 16 Kommentare

Hallo

Kann mir einer Sagen wie ich mit dem DOS befehl route es anstelle von einem in ein anders Netzwerk zu kommen. Weil ich scheinbar auf der Leitung stehe und das nicht hinbekomme

Netzwerk 1: 200.200.200.X
Server für Netzwerk 1: 200.200.200.1 oder 1.1.1.1
Netzwerk 2 :150.150.150.X
Server für Netzwerk 2: 150.150.150.1 oder 1.1.1.2
Backup: 1.1.1.X
Soll bei bedarf von z.B. 150.150.150.X auf 1.1.1.1 kommen


PS: Sollte von Netzwerk 2 in das Backup Netz kommen.

Es geht darum das ich 2 Server stehen habe. Auf einem sind die ganzen Programme und Updates vorhanden. Nun will ich die den Benutzern des anderen Servers auch zu verfügung stellen. Die einzige verbindung zwischen den Server ist die Backup Leitung. So nun dachte ich mir das ich das einrichten kann wenn ich z.B. 150.150.150.2 eingebe das ich dann auf die IP 1.1.1.1 ( das ist die Netzwerkadresse des Servers mit der Software ) zugreifen kann.
Wenn ich 150.150.150.1 eingebe soll er wie immer auf den dem anderen Server bleiben.

Ist das Möglich????

Wenn ja was muss ich in die CMD datei schreiben. ich probiere schon seit tagen aber es kommt immer die Fehlermedlung "Der eingegeben Maskenparameter ist ungültig (Ziel & Maske ) !=Ziel "

Mit freundlichen Grüßen christoph
Mitglied: Joggel
19.06.2007 um 15:32 Uhr
Hi Christoph,

erstmal zum Verständniss, du hast in jedem Server jeweils 2 Netzwerkkarten, ist das richtig?

Sieht das ganz so aus?

Segment1(150.150.150.x)----(NIC1 150.150.150.1)Server1(NIC2 1.1.1.2)----(NIC1 1.1.1.1)Server2(NIC2 200.200.200.1)----Segment2(200.200.200.x)

Du hast auf beiden Server Windows 2003? Dann sollte es aber funktionieren, schau mal ob unter Dienste der Dienst, Routing und RAS aktiv und gestartet ist.

edit: quatsch mit Soße, du musst statische Routen eintragen. Das der jeweilige Server weis wohin, weil die Netzte nicht direkt an einem Server hängen. Gib in der Command Line mal "route" ein dann bekommst ein Beispiel wie du statische Routen eintragen kannst.

Probier mal "route add 150.150.150.0 MASK 255.255.255.0 150.150.150.1 METRIC 3" auf Server 2 und "route add 200.200.200.0 MASK 255.255.255.0 200.200.200.1 METRIC 3" auf Server 1
Bitte warten ..
Mitglied: Kampfwurst
19.06.2007 um 15:57 Uhr
hallo


danke für die Antwort aber ich will ja nicht ins 200 netz routen sondern von 150 auf das 1 Netz
Wie muss ich das eintragen

PS: Der dienst ist gestartet

Ja ich habe jeweils 2 Netzwerkkarten 1 für das Jeweilige Netzwerk und 1 für das Backup zum 3 Server
Bitte warten ..
Mitglied: Joggel
19.06.2007 um 16:08 Uhr
von 150 auf 1, bzw. in die andere Richtung von 200 auf 1 geht automatisch weil die Netze an dem jeweiligen Server direkt angeschlossen sind.

http://www.administrator.de/Routing_mit_2_Netzwerkkarten_unter_Windows_ ...
Hier ist ein nettes HowTo von aqui. Kannst dir das ja mal durchlesen, dann kannste dich vielleicht in dein Problem hinein denken.
Bitte warten ..
Mitglied: Kampfwurst
19.06.2007 um 16:37 Uhr
ich habe das durchgelesen leider verstehe ich nur " Bahnhof"

Wieso soll das von 150 auf 1 Automatisch gegen???
WEnn ich bei den Pcs 1.1.1.1 eingebe was für den Software Server steht kommt eine Fehlermeldung und ich kann die IP auch nicht pingen
Bitte warten ..
Mitglied: Joggel
19.06.2007 um 16:49 Uhr
150.150.150.1 und 1.1.1.2 sind auf 2 verschiedenen Netzwerkkarten in Server NR1.
200.200.200.1 und 1.1.1.1 sind auf 2 verschiedenen Netzwerkkarten in Server NR2.

Wenn du jetzt von irgendeinem Client im Segment 150.150.150.x die 1.1.1.1 anpingen willst, passiert folgendes.

1. Das Paket von 150.150.150.x geht an den default Gateway (welcher hoffentlich 150.150.150.1 ist!!) Weil deine Netzwerkkarte die 1.1.1.1 nicht kennt und sich denkt: "Okay soll das doch mein Gateway erledigen"
2. Der Gateway(150.150.150.1) bekommt das Paket und sieht, aha, das Paket soll ins Netz 1.1.1.x welches ja direkt an mir angeschlossen ist (Das ist ja die 2te Netzwerkkarte) und schickt es über eben diese 2te Netzwerkkarte in das Netz.

Deshalb brauchst du dafür keine Route einzurichten.

Wenn du aber von irgeneinem Client im Segment 150.150.150.x die 200.200.200.1 anpingen willst, passiert folgendes.

1. Das Paket von 150.150.150.x geht an den default Gateway (welcher hoffentlich 150.150.150.1 ist!!) Weil deine Netzwerkkarte die 200.200.200.1 nicht kennt und sich denkt: "Okay soll das doch mein Gateway erledigen"
2. Der Gateway(150.150.150.1) bekommt das Paket und sieht, aha, das Paket soll ins Netz 200.200.200.1 aber das kenne ich nicht, und ich weis auch nicht wie ich es erreichen soll, weil ich KEINEN routing Eintrag habe.

Wenn du nun aber den routing Eintrag wie oben beschrieben machst, passiert folgendes.

1. Das Paket von 150.150.150.x geht an den default Gateway (welcher hoffentlich 150.150.150.1 ist!!) Weil deine Netzwerkkarte die 200.200.200.1 nicht kennt und sich denkt: "Okay soll das doch mein Gateway erledigen"
2. Der Gateway(150.150.150.1) bekommt das Paket und sieht, aha, das Paket soll ins Netz 200.200.200.1 das ist zwar nicht direkt an mir angeschlossen aber in meiner routing Tabelle steht, das dass Netz 200.200.200.x über die Schnittstelle 1.1.1.2 ereichbar ist.
3. Also schicke ich das Paket über die Schnittstelle 1.1.1.2 zum Server 2.
4. Der Server 2 bekommt das Paket und sieht wiederum aha, das Netz 200.200.200.x ist direkt an mir angeschlossen also schicke ich es dort hin.
Bitte warten ..
Mitglied: Kampfwurst
19.06.2007 um 17:06 Uhr
ok

Wo muss ich den Gateway eintragen beim Server oder Client??
Server 1(software) hat IP 1.1.1.1 und 200.200.200.1
Server 2 hat IP 1.1.1.2 und 150.150.150.1
So nun kann ich von 150.150.150.13 aus auf 150.150.150.1 und 1.1.1.2 pingen aber nicht auf 1.1.1.1

Wieso
Bitte warten ..
Mitglied: Joggel
19.06.2007 um 18:55 Uhr
So nun kann ich von 150.150.150.13 aus auf 150.150.150.1 und 1.1.1.2 pingen aber nicht auf 1.1.1.1

Das ist schon klar, weil die 1.1.1.1 wenn sie das Paket bekommt nicht weis was sie damit machen soll weil sie das Netz 150.150.150.1 nicht kennt. Aber dazu später mehr.

Stell deine PCs einmal wie folgt ein:

Alle Clients im 150.150.150.0 Netz:
IP-Adresse: 150.150.150.x (sollte klar sein)
Subnetzmaske: 255.255.255.0
Standartgateway: 150.150.150.1
DNS-Server: 150.150.150.1

Server1 NIC1:
IP-Adresse: 150.150.150.1
Subnetzmaske: 255.255.255.0

Server1 NIC2:
IP-Adresse: 1.1.1.2
Subnetzmaske: 255.255.255.0

Server2(Software) NIC1:
IP-Adresse: 200.200.200.1
Subnetzmaske: 255.255.255.0

Server2(Software) NIC2:
IP-Adresse: 1.1.1.1
Subnetzmaske: 255.255.255.0

Alle Clients im 200.200.200.0 Netz:
IP-Adresse: 200.200.200.x (sollte klar sein)
Subnetzmaske: 255.255.255.0
Standartgateway: 200.200.200.1
DNS-Server: 200.200.200.1

Achte darauf das alles auch an der richtigen Netzwerkkarte eingestellt ist. Sprich, nicht das du der Netzwerkkarte mit der "backup-verbindung" zwichen den beiden Server eine 200. oder eine 150. gibts etc.

So wenn die IP-Einstellungen alle stimmen, musst du die routingtabellen Einträge machen.
"route add 200.200.200.0 MASK 255.255.255.0 1.1.1.1 METRIC 3" auf Server 1
"route add 150.150.150.0 MASK 255.255.255.0 1.1.1.2 METRIC 3" auf Server 2
Bitte warten ..
Mitglied: Kampfwurst
20.06.2007 um 08:24 Uhr
noch eine Frage

Was passiert wenn in ca 2 Wochen ein 3 Netz zum Server 1 kommt. Das auch wieder für sich selbstständig ist und ebenfals zugriff haben soll. Reicht es wenn ich
route add 100.100.100.0 MASK 255.255.255.0 1.1.1.1 METRIC 3" in die Routingtabelle schreibe

IP soll statt 150. 100 haben sonst alles gleich. Also server hat 100.100.100.1 usw.

Mit freundlichen Grüßen Christoph

PS: Echt super das einem so gut und schnell geholfen wird *gg*
Bitte warten ..
Mitglied: Joggel
20.06.2007 um 09:51 Uhr
noch eine Frage

Was passiert wenn in ca 2 Wochen ein 3 Netz
zum Server 1 kommt. Das auch wieder für
sich selbstständig ist und ebenfals
zugriff haben soll.

Was genau hast du vor? Willst du in den Server 1 eine 3. Netzwerkkarte einbauen oder einen 3. Server in dein Netz integrieren?
Bitte warten ..
Mitglied: Kampfwurst
20.06.2007 um 10:23 Uhr
Ich will in Server 1 eine 3 Netzwerkkarte einbauen und die IP 100.100.100.x vergeben
Bitte warten ..
Mitglied: Joggel
20.06.2007 um 11:24 Uhr
Ich will in Server 1 eine 3 Netzwerkkarte
einbauen und die IP 100.100.100.x vergeben





Okay, Dann bekommt das Netz folgende Einstellungen:
Alle Clients im 100.100.100.0 Netz:
IP-Adresse: 100.100.100.x (sollte klar sein)
Subnetzmaske: 255.255.255.0
Standartgateway: 100.100.100.1
DNS-Server: 100.100.100.1

Server1 NIC3
IP-Adresse: 100.100.100.1
Subnetzmaske:255.255.255.1

Am Server 1 brauchsten keine weitere route eintragen.
Am Server 2 folgende:
"route add 100.100.100.0 MASK 255.255.255.0 1.1.1.2 METRIC 3"
Bitte warten ..
Mitglied: aqui
20.06.2007 um 12:26 Uhr
Deine IP Adressvergabe ist höchst bedenklich !!! Das sind alles öffentliche vergebene IPs im Internet ! Hast du schon einmal darüber nachgedacht RFC 1918 Adressen zu benutzen für private Netz wie das gemeinhin üblich ist ??!!
Falls du dabei auch nur wieder Bahnhof verstehst hilft dir sicher dies:

http://de.wikipedia.org/wiki/Private_IP-Adresse

Mit dem dritten Interface in Server 1 müsste dein Szenario dann so aussehen:

3fba777d0972aaa5ca3b83516f83f279-zeichnung2 - Klicke auf das Bild, um es zu vergrößern

Wenn du dir das alles mal genau ansiehst, kannst du erkennen das du nirgendwo in deinem Netz überhaupt statischen Routeeinträge ala route add... benötigst !!!
Es genügt völlig wenn du auf den NICs der Backup Leitung ein Default Gateway zum anderen Server einträgst !!!
Auf den Karten der anderen Segmente dürfen keine Gateways konfiguriert sein ! Die Server schicken dann alle Packete zu Netzen an den sie nicht selber angeschlossen sind (..die sie also nicht kennen !) auf den anderen Server und der kennt die dann ja !
Routingeinträge sind also vollkommen überflüssig.
Die Routing Struktur geht jetzt davon aus das du erstmal keinen Internet Router in einem der Segmente hast ! Sollte das der Fall sein ändert sich die Roouting Einstellung geringfügig !

Nun kann man nur hoffen das du nicht schonwieder nur Bahnhof verstehst und auch deine IP Adressen in diesem Konstrukt RFC 1918 konform anpasst !
Bitte warten ..
Mitglied: Joggel
20.06.2007 um 13:14 Uhr
okay, ein Bild sagt mehr als 1000 Worte

Wenn ich in dem Szenario mit den Gateway´s anstatt statischen Routen arbeite und Pinge von 200.200.200.10 nach 150.150.150.10, komme ich ja zuerst auf der Netzwerkkarte mit der IP 200.200.200.1 an, welche kein Gateway hat. So sagt sich die Schnittstelle jetzt automatisch "Ich kenne das Netzt nicht und hab keinen Gateway, also frage ich mal meine "Nachbar" Schnittstelle vielleicht weis die ja weiter"??? und die Schnittstelle 1.1.1.1 sagt dann, "Ich kenne das Netzt zwar auch nicht, aber ich hab einen Gateway, schick ichs eben dahin, nach mir die Sintflut" ??? Der rest ist ja klar.
Bitte warten ..
Mitglied: Kampfwurst
20.06.2007 um 13:33 Uhr
danke erstmal

Im Bild ist aber ein Fehler

Das Netz 100.100.100.X wird am Server 2 angeschlossen.


Ich verstehe nicht ganz wieso das so ein problem in Internen Netzwerken darstellt???

Es gibt für keinen der PCs internet
Bitte warten ..
Mitglied: aqui
20.06.2007 um 14:37 Uhr
OK, Zeichnung geändert
Gut wenn du keinerlei Internet Verbindung hast sind die Adressen mehr oder weniger egal. Gute Netzdesigner halten sich aber bei privaten Netzen trotzdem an RFC1918 !
Bitte warten ..
Mitglied: aqui
24.06.2007 um 15:19 Uhr
Wenns das war bitte:
http://www.administrator.de/index.php?faq=32
nicht vergessen !!!
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Router & Routing
gelöst VPN- Routing - Problem - Netzwer 1 kommt auf 2 aber anders herum nicht (8)

Frage von itschloegl zum Thema Router & Routing ...

Netzwerke
Integration eines fremden Netzwerks (Routing-Problem) (63)

Frage von Brian85 zum Thema Netzwerke ...

Windows Server
Rechtevergabe Fileserver Windows 2003 (1)

Frage von bluepython zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...