Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Routing zwischen 2 Netzen mit win2k3 Server und Internetrouter geht nicht.

Frage Netzwerke Router & Routing

Mitglied: eac1903

eac1903 (Level 1) - Jetzt verbinden

13.11.2006, aktualisiert 16.11.2006, 8848 Aufrufe, 27 Kommentare

Hallo ich habe 2 Netze mit 1 Router (Win2k3 Server) und 1 DSL Router. Das Routen Funktioniert zwischen den 2 Netzen. Die PCs im Netz 1 bekommen kein Internet. Was muss ich noch bei Win2k3 Server einstellen. Damit das Routing funktioniert und alle PCs in das Internet kommen.

Meine Konfiguration.

DSL Router IP 192.168.10.1

Win2k3 Server mit 2 Netzwerkkarten:

Server NIC 1:
IP: 192.168.168.10.200
Mask: 255.255.255.0
GW: 192.168.10.1
DNS: 192.168.10.200

Server NIC 2:
IP: 10.10.10.200
Mask: 255.255.255.0
GW: leer
DNS: 10.10.10.200


Clients im Netz 1
IP: 192.168.10.x
Mask: 255.255.255.0
GW: 192.168.10.200
DNS: 192.168.10.200

Clients im Netz 2
IP: 10.10.10.X
Mask: 255.255.255.0
GW: 10.10.10.200
DNS: 10.10.10.200

statische Route habe ich mit route add 10.10.10.0 mask 255.255.255.0 192.168.10.200
Im Netz 192.168.10.X gibt es den DSL router mit der IP 192.168.10.1.
Was muss ich bei Win2k3 server noch für eine Route erstellen damit die PCs aus Netz 2 auch in das Internet können???

9fb174e65df26552c20ff47ad765bea8-netzwerk - Klicke auf das Bild, um es zu vergrößern
27 Antworten
Mitglied: leknilk0815
13.11.2006 um 19:29 Uhr
Hi,
ich denke, es liegt an den DNS- Einträgen.
Laß am Server den DNS auf der 10er NIC frei und trag bei allen Clients als DNS die 192.168.10.200 ein.

Gruß - Toni
Bitte warten ..
Mitglied: MCSE-Cheffe
14.11.2006 um 07:33 Uhr
Hallo,

mit dem DNS im 10 Netz sollte es auch gehen hat der eine Weiterleitung zum 192 DNS?
Wenn nein richte eine ein dann sollte es auch gehen.

Gruß
MCSE_Cheffe
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 08:01 Uhr
Hi,
welcher DNS im 10er??
Das ist doch EIN Server mit 2 NIC's...

Gruß - Toni
Bitte warten ..
Mitglied: MCSE-Cheffe
14.11.2006 um 08:10 Uhr
Hallo,

aber auf dem Server muss doch DNS laufen wo sonst kommt denn die 10er DNS Adresse her.

Gruß
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:11 Uhr
Ich habe eine Statische Route gesetzt. route add 10.10.10.0 mask 255.255.255.0 92.168.10.200.
das müsste doch reichen oder fehlt da nochetwas.
Das Problem ist wenn ich einen Ping vom 10 Netz auf z.b google setze dann zeigt er mir die Ip von google an aber dann kommt eine Zeitüberschreitung. Also funktioniert die DNS Auflösung ja schon. Aber irgendetwas stimmt net mit dem Gateway
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 15:16 Uhr
sollte passen, gehts denn immer noch nicht? Hast Du die Einträge mal probiert?
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:20 Uhr
Ja ich habe alles Probiert, mal den DNS Server bei der 10.10.10.200 NIC rausgelassen.
Kann es vielleicht daran liegen das der DSL Router ein fli4l ist???
Ich weiss selbst nicht mehr woran das liegen kann das der 10.10.10.x bereich kein Internet hat.
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 15:24 Uhr
bis wohin kannst Du dennaus dem 10er Netz pingen?
Kriegst Du die 192.168.10.1 noch?
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 15:29 Uhr
probier mal auf den 10er Clients als GW den Router 192.168.10.1, eigentlich setzt man zwar als GW den nächsten Punkt, aber manchmal kommt man mit nichtwissen und probieren auch ans Ziel...
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:33 Uhr
wenn ich bei den 10 clients den gw auf 192.168.10.1 setze dann sehe ich das 192.168.10.x Netz gar nicht mehr.
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:35 Uhr
noch mal zu Feststellung ich habe auf dem Win2k3 server den Routing und RAs dienst gestartet. Danach habe ich eine Statische Route 10.10.10.0 mask 255.255.255.0 192.168.10.200 gesetz dass müsste doch reichen???
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 15:40 Uhr
hab ich doch oben schon gesagt - ja!
Wie siehts mit dem ping aus?
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:55 Uhr
ich kann von dem PC im 10 Netz den pc im 192.168.10 Netz anpingen und sonst auch alle anderen IP's ausser den Router.
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 15:58 Uhr
Geht der Ping auf den Router denn aus dem 192er Netz?
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 15:59 Uhr
Ja der geht weil die ja im geleichem Netz sind
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 16:00 Uhr
probier mal tracert 192.168.10.3 und dann tracert 192.168.10.1 aus dem 10er Netz
gibts da Unterschiede?
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 16:04 Uhr
bei tarcert 192.168.10.3 kommt
1 10.10.10.200
2 192.168.10.3

bei tracert 192.168.10.1 kommt
1 10.10.10.200
2 * * * * Zeitüberschreitung
Bitte warten ..
Mitglied: leknilk0815
14.11.2006 um 16:16 Uhr
ich bin sprachlos...
das Routing funktioniert, sonst würde der PC im 192er nicht antworten.
Das Inet geht nicht, weil der Router nicht antwortet, aber warum zum Teufel?
Im Moment fällt mir nichts mehr ein, sorry

Gruß - Toni

P.S. Schuss ins blaue: kannst Du evt. auf dem Router ne Route 192 - 10. einrichten (verzweifel...)
Bitte warten ..
Mitglied: eac1903
14.11.2006 um 16:38 Uhr
Mir geht es genau so.
Okay dann danke für die Infos.
Ich werd noch ein bisschen daran rumfummeln und mal schaun vielleciht geht es durch einen dummen zufall.
Bitte warten ..
Mitglied: aqui
14.11.2006 um 23:11 Uhr
WO ! hast du denn die statische Route eingegeben ???
Auf dem Server mit den 2 NICs ist die statische Route vollkommener Unsinn, denn der Server kennt ja beide Netze da sie an ihn direkt selber angeschlossenen sind !!!
Ist die Route hier eingegeben muss sie unbedingt entfernt werden.

Wichtig ist diese Route am DSL Router !!! Denn der kennt natürlich das 10.10.10.0er Netz nicht ...woher auch !
Hier ist es also essentiell eine statische Route einzutragen, damit der den Rückweg ins 10er Segment findet.
Also hier muss sowas wie "route add..." stehen wenn der DSL Router ein Windows Rechner ist (Hoffentlich nicht...)
Ists einer der normalen Consumer Systeme (...und hoffentlich kein D-Link denn der kann keine statischen Routen...oder nur mit einem SW Update) musst du mal ins Settup gehen. Da gibt es irgendwo ein Menü zum Eintragen weiterer Netze oder Gateways.
Da muss dann sowas rein wie:
Zielnetz: 10.10.10.0 Maske: 255.255.255.0 Gateway: 192.168.10.200

Damit sollte ein Ping der 10.10.10er Clients auf den Router problemlos klappen.
Bitte warten ..
Mitglied: leknilk0815
15.11.2006 um 07:46 Uhr
Hi Aqui,
ich glaube nicht, das Du ohnen Routeneintrag auf dem Server vom 192er Netz ins 10er Netz kommst. Der Server selbst kennt seine Netze,, aber die Clients...?
Bitte warten ..
Mitglied: eac1903
15.11.2006 um 08:16 Uhr
Hi
Der DSL Router ist ein fli4l.
Also wenn ich das richtig Verstanden habe muss ich nur bei dem fli4l Router eine statische Route eintragen. Ansonsten ändert sich nichts an den Einstellungen der clients und des win2k3 routers.
Ich denke auch das die statische Route bei dem Win2k3 server bleiben muss sonst sehen sich die 2 Netze ja nicht. oder??
Bitte warten ..
Mitglied: eac1903
15.11.2006 um 17:23 Uhr
So jetzt geht es endlich. habe noch auf dem DSL router die Gesagte Route eingerichtet und jetzt kommen beide Netzte in das Internet und sehen sichauch gegenseitig.

Danke für die Tipps, alleine währe ich da nicht drauf gekommen.
Bitte warten ..
Mitglied: leknilk0815
15.11.2006 um 22:08 Uhr
Viel Spass damit

Gruß - Toni
Bitte warten ..
Mitglied: aqui
16.11.2006 um 19:32 Uhr
Hallo Toni !

Der DSL Router ist der Schlüssel ! Das ist immer so und das vergessen fast alle Benutzer die solche Threads mit 2 Netzwerk Segmenten im Design hier eröffnen. Arm dran sind dann die die dort bei Billigstsystemen keine Route konfigurieren können.

Zurück zu deinem Punkt der statischen Route auf dem Server bzw. Clients:
Die Clients spielen ja gar keine Rolle in diesem Routing Spiel !! Sie kennen nur ihr default Gateway was dann immer auf den korrespondierenden Serverport bzw. IP Adresse am Server LAN Interface zeigt ! Also auch hier ist keinerlei statische Route oder Routeeinträge vonnöten. Auf den Clients sowieso nie....nur in sehr seltenen Ausnahmen ! Die sollen ja auch in einem gut designtem IP Netz niemals eine Route Entscheidung treffen (Performance)

Der Ablauf eines Client Pings vom 10er ins 192er Netz ist dann wie folgt:
1.) Ping 192.168.1.3, Netzwerk ist nicht mein Segment -> Ist Gateway Eintrag vorhanden -> Nein = schmeiss das Packet weg und schick "Network unreachable" an den Stack !
Gateway Eintrag vorhanden = schick das Packet an den Router (hier der Server) denn der sollte wissen wo es hin muss.
Damit ist für den Client der Fall erledigt...

2.) Ping Packet mit Zieladresse 192.168.1.3 vom Client 10.10.10.34 trifft beim Server ein. Der sieht auf die Zieladresse, sieht das 192.168.1er Netz und "denkt" sich. Klasse ! das ist an mir direkt dran, ich muss meine statische Routing Tabelle nicht durchsuchen und forwardet es auf seiner NIC in diesem Segment an den Zielclient.

3.) Hier angekommen dreht dieser Quell- und Zieladresse um und schickt das Packet zurück.
Der Ablauf rückwärts ist dann dergleiche.

Also du siehst, Clients sind an der Routing Entscheidung gar nicht beteiligt. Sie haben ja ein Default Gateway und der Client IP Stack verfährt nach dem Verfahren:
"Alles was ich nicht kenn bzw. was nicht für mein lokales Netzwerk ist forwarde ich an den Router (hier der Server) und der Fall ist erledigt für mich !"

Die Antworten Server und Clients mit statischen Routen dichtzupflastern hier im Forum sind bei solchen Szenarien wie hier fast immer falsch und überflüssig. Schlimmer noch sie können bewirken das gar nichts mehr geht wenn sie falsch angewandt werden !
Bitte warten ..
Mitglied: leknilk0815
16.11.2006 um 22:47 Uhr
Hi Aqui,
danke für die Erklärung, aber Du hast da was falsch verstanden. Eine Route auf den Clients wollte ich nicht einrichten, das wäre Unfug. Ich meinte (und meine dies immer noch), daß auf dem Server eine Route draufmuß. Wenn Deine Aussage stimmen würde, müsste ich nur auf dem Router, welcher sich im 192er Netz befindet (und keinerlei Verbindung zum 10er Netz hat) eine Route ins 10er Netz einrichten, und schon können alle Clients im 192er Netz auf das 10er zugreifen und umgekehrt. Da ich es nicht glauben kann, richte ich im Moment grade einen W2K3 Server mit 2 NIC's ein, um es nun endgültig zu testen. Das Ergebnis poste ich (wird aber erst morgen was, die Installation läuft gerade).

Gruß - Toni
Bitte warten ..
Mitglied: leknilk0815
16.11.2006 um 23:21 Uhr
Asche auf mein Haupt!
Server installiert, Route am DSL- Router eingetragen, angepingt von irgendeinem PC aus dem 192er Netz - das 10er antwortet, ohne Route auf dem Server.
Wieder was gelernt, das man eigentlich wissen sollte...
Danke noch mal an Aqui, ich stimme hiermit seinem letzten Beitrag in vollem Umfang zu (geschwollener gings nicht mehr)

Gruß - Toni
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Router & Routing
gelöst Routing zwischen zwei Netzen (31)

Frage von Xaero1982 zum Thema Router & Routing ...

Windows Server
gelöst Routing und Ras bei Windows Server 2012 R2 (12)

Frage von BlacksGood zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (14)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...