Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Runas unter Windows XP Embedded

Frage Microsoft Windows XP

Mitglied: IziBizi

IziBizi (Level 1) - Jetzt verbinden

20.07.2011 um 13:42 Uhr, 3526 Aufrufe, 2 Kommentare

Hallo Community,

ich habe ein Problem mit der Implementierung von dem RunAs-Kommando unter Windows XP Embedded.
In unserem XPE System ist die Datei RunAs.exe leider nicht vorhanden. Da kam mir die Idee sie einfach von einem
Windows XP PC auf den XPE PC zu kopieren. Allerdings hat dies nicht ganz so funktioniert wie gedacht, denn das RunAs
Kommando benötigt des weiteren die Datei seclogon.dll. Also habe ich diese auch auf das XPE System kopiert und als
Service registriert. Wenn ich nun im Service Manager (services.msc) nachschaue wird der Dienst (Secondary Logon) auch aufgelistet,
allerdings ist er nicht aktiv. Bei der Aktivierung des Dienstes bekomme ich folgenden Fehler:

Could not start the Secondary Logon service on Local Computer.
Error2 : The System cannot find the file specified.

Bei der Suche nach dem Fehlers bei Google bin ich darauf gestoßen, dass dieser Fehler durch eine Fehlerhafte Pfadangabe
in der Registry verursacht werden könnte. Dies habe ich überprüft und der einzige Pfad im Zusammenhang mit
seclogon verweist auf die svchost.exe, welche im richtigen Ordner (WINDOWS/system32) vorhanden ist.

Eine Frage wäre nun ob noch andere Dateien von RunAs benötigt werden. Wenn ja welche?

Oder hat jemand eine andere Idee?

Gruß
Mitglied: HStumpf
20.07.2011 um 16:56 Uhr
Hallo,

vieleicht hilft es im Target Designer nur das Paket RunAs zu paketieren und schauen
was registriert wird. (werden muss)

Horst
Bitte warten ..
Mitglied: IziBizi
21.07.2011 um 08:00 Uhr
Hallo Horst,

danke für die Antwort. Allerdings habe ich keine Möglichkeit den Target Designer zu benutzen,
da das System von einer Fremdfirma installiert wurde und ich nur ein Image des ganzen Rechners habe,
das immer auf den/die Rechner spielen.
Oder gibt es einen anderen Weg den Designer zu verwenden außer bei der Installation?

Gruß
Bitte warten ..
Ähnliche Inhalte
Microsoft
Windows XP Embedded Partition verschwunden
Frage von TiloklomMicrosoft4 Kommentare

Hallo, Auf der Arbeit haben wir ein ganz großes Problem, welches mit Windows XP Embedded zusammen hängt. Ich hoffe ...

Windows XP
SP3 für Windows XP Embedded Version 2002
Frage von Michael-24Windows XP4 Kommentare

Hallo Gemeinde, ich bräuchte für Windows XP Embedded Version 2002 das Servicepack 3 zum download? Hat jemand von euch ...

Windows 10
Phänomen von Windows 10 runas
gelöst Frage von DerWoWussteWindows 1012 Kommentare

Moin Kollegen. Eigentlich zu früh am Nachmittag für Denksport, ich versuch's trotzdem: Ich habe hier meine administrative Workstation, (Win10 ...

Windows 7
Windows 7 Embedded sichern
Frage von GarnalothWindows 71 Kommentar

Hallo, ich würde gerne von unseren Futro S700 mit Windows 7 Embedded Std. eine Sicherung machen. Mich würde interessieren ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 13 StundenApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 18 StundenWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 18 StundenWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Windows XP
Windows XP Aktivieren geht nicht
Frage von tetikmiroWindows XP13 Kommentare

Hallo Ich habe einen Windows XP mit einen vCenter Converter umgezogen auf eine ESXI. Soweit funktioniert dies auch ohne ...

Blogs
Immer wiederkehrende PHP Fehlermeldung bei Wordpress UTF-8 - ASCII
gelöst Frage von vcdweltBlogs11 Kommentare

Hi, seit einiger Zeit wird mein error_log meines Wordpress Blogs mit immer der gleichen Fehlermeldung überschwemmt. 14-Dec-2017 08:18:05 UTC ...

Switche und Hubs
Redundante L2 LWL Leitung über 2 Standorte - Spanning Tree - HP Equipment
gelöst Frage von ResolvSwitche und Hubs10 Kommentare

Hallo, ich stehe vor der Herausforderung eine Redundante L2 LWL Leitung über 2 Standorte herzustellen. Grundsätzliches Switching Know How ...