Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Sage New Classic auf Linux Server

Frage Linux

Mitglied: fckoelle

fckoelle (Level 1) - Jetzt verbinden

28.03.2012, aktualisiert 20:03 Uhr, 7281 Aufrufe, 8 Kommentare, 1 Danke

Hallo zusammen,

ich versuche derzeit die Sage New Classic 5.1 (2012) auf einem Linuxserver zu installieren.
Im Folgenden die Konstellation:

Server: openSUSE 11.3 x64
Clients: Windows 7 & Windows XP

Ich habe die Installation anhand des Skripts von Sage vorgenommen, aber leider hat das nicht so ganz funktioniert.

Ich bin wie folgt vorgegangen:
- Verzeichnis auf dem Linuxserver über Samba freigegeben und Sambauser erstellt -> Windows Clients haben Zugriff auf freigegebenes Linuxverzeichnis
- Dann habe ich das Linuxsetup von einem Windows-Client ausgeführt und als Zielpfad der Basis das freigegebene Linuxverzeichnis angegeben -> Installation klappt
- Jetzt befindet sich die Basis der SNC auf dem Linuxserver
- Danach habe ich das Shell-Skript "cldbdaemon.sh" in der Konsole ausgeführt und danach die MySQL Tools installiert.
- Im nächsten Schritt habe ich die Workstation-Installation über WSSETUP ausgeführt -> Klappt
- Stationskonfiguration (station.ini) -> Klappt auch
- Starten der SNC auf dem Client -> "Es wurde kein CL-Server gefunden" (Unter Runlevel auf dem Linuxserver steht, dass der CLDBDAEMON gestartet ist)

Freue mich über Tipps oder eventuell andere Anleitungen als die auf der Sageseite ;)

Viele Grüße
FCKÖLLE
Mitglied: goodoldboy
28.03.2012 um 21:10 Uhr
Hi,

da ich dasselbse Problem (allerdings Windows-Clients mit Windows-Server) hatte, hier meine Lösung (die ich eher durch rumprobieren als durch Wissen fand):

Auf dem Client unter Dienstprogramme "Administrator" starten und die station.ini auswählen
Unter erweiterte Einstellungen war standardmäßig ein Haken gesetzt (leider weiß ich nicht mehr, welcher) - wenn alle Haken draußen sind, klappt die Verbindung

Also meine station.ini sieht dann folgendermaßen aus:

Basispfad: \\server\sage\sage new classic\2011\
Dokumentenpfad: \\server\sage new classic\dat\

Server Host: server Port 4135
Globale Datenbank; SageCLGlobal

unter erweiterte Einstellungen:
lokaler Pfad; \\server\sage\sage new classic\2011\prw\
Hilfsprogrammpfad: C:\Programme\Sage New Classic\2011\MySQL510_Tools\BIN\ (hier musste ich die jeweils lokalen Tools nehmen, weil Server 64bit, Clients 32bit)
Timeout Standard 30
Timeout erweitert 3600
die drei Haken unten raus

Wenn Du dann auf OK klickst, wird eine Verbindung zur SQL-Datenbank aufgebaut mit Kennwort root und dem während der Installation vergebenen Passwort - wenn das klappt, dann läufts!


Ich hoffe, dass es jetzt funktioniert - ich bin vor einigen WOchen fast daran verzweifelt, weil es auf dem Server (mit installiertem Client zum Testen) optimal lief und in der Buchhaltung aufeinmal nicht mehr.

Gruß

Markus
Bitte warten ..
Mitglied: fckoelle
29.03.2012 um 10:22 Uhr
Hallo Markus,

Danke erstmal für die Antwort, ich werde es nachher mal so testen.
Wäre natürlich gut wenns so klappt, jedoch denke ich, dass der Fehler bei der Konfiguration des Linux Servers liegt, aber mal gucken ;)
Bitte warten ..
Mitglied: goodoldboy
29.03.2012 um 11:37 Uhr
Wenn's ein Linuxproblem ist, bin ich raus
Aber ich hatte damals mit der Standardkonfiguration auf Windows den gleichen Fehler, mein Vorteil (da ich dadurch wusste, dass es theoretisch funktionieret) war, dass ich auf dem Windowsserver auch die Clientsoftware installiert habe. Da ich lokal auf dem Server arbeiten konnte, nur von externen Clients nicht, habe ich halt solange an der station.ini rumgespielt, bis ich mich in die SQl-Datenbank einloggen konnte.
Vorher hatte ich die gleiche Fehlermeldung, sodass ich im Moment nicht von einem Linux-Konfiguration-Problem ausgehe.
Bitte warten ..
Mitglied: PREUSSE
28.04.2015 um 13:12 Uhr
Hallo FCKÖLLE,

ist das Problem noch akut ?
Bei mir läuft SNC 2015 auf OpenSuSE 12.2 und Windows 7 Prof Clients problemlos.

Jetzt will ich auf OpenSuSE 13.2 aktualisieren und habe selber Probleme, da es keine SysV Runlevels mehr gibt
und damit der CLDBDAEMON nicht gestartet wird.

Alle meine Versuche ein neues systemd - Script zu erzeugen sind bis jetzt schiefgelaufen.

Vielleicht können wir uns gegenseitig helfen.

Servus

PREUSSE
Bitte warten ..
Mitglied: PREUSSE
29.04.2015 um 10:05 Uhr
SYSTEMD - Service funktioniert in der Zwischenzeit !
Bitte warten ..
Mitglied: PREUSSE
30.04.2015 um 08:45 Uhr
Leider Fehlschlag ! Korrektur !

SYSTEMD funktioniert doch noch nicht !
Bitte warten ..
Mitglied: fckoelle
12.05.2015 um 10:11 Uhr
Hallo Preusse,

bei mir ist das Problem nicht mehr akut, würde mich jedoch trotzdem interessieren die SNC auf einem Linuxserver zu installieren.
Ich weiß nicht genau wie groß die Unterschiede zwischen openSUSE 12.2 und 13.2 sind, jedoch ist die Version 13.2 von Sage laut Systemvoraussetzungen nicht freigegeben.

Viele Grüße
fckoelle
Bitte warten ..
Mitglied: PREUSSE
12.05.2015 um 11:02 Uhr
Hallo fckoelle,

hab in der Zwischenzeit alle Probleme lösen können, so dass bei mir unter Hyper-V ein OpenSuSE 13.2 mit Sage New Classic 5.3.3
aktiv als Testversion läuft. Leider will sich aber - laut Aussage von unserem Software-Betreuungs-Haus Sage mangels aktiver Masse
an Kunden wohl von der Linux-Variante verabschieden. - Schade wär's !

Bei Interesse könnte ich Dir evtl. entsprechende Anleitungen per Mail zukommen lassen.

Servus

PREUSSE
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Linux
Linux-Server (IGEL UMS5) auf Windows umziehen (2)

Frage von Holywarrior1 zum Thema Linux ...

Debian
gelöst Kein Zugriff auf Linux Server nach Neustart - Alle Ports zu (22)

Frage von itschloegl zum Thema Debian ...

Linux Netzwerk
VPN Server mit Drosselung Linux Debian basiert (4)

Frage von Niklas434 zum Thema Linux Netzwerk ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (24)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...