Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SATA: erst deaktivieren - dann Hot Plug ?

Frage Hardware Festplatten, SSD, Raid

Mitglied: cashmere

cashmere (Level 1) - Jetzt verbinden

05.09.2005, aktualisiert 21.05.2007, 25172 Aufrufe, 6 Kommentare

Hallo zusammen,
folgende Problemstellung:
Wir haben hier 4 SATA Seagate Festplatten à 200 GB, die in Wechselrahmen eingebaut sind und über einen Dawicontrol DC-154 Controller angeschlossen sind. Wechselrahmen und Controller sind laut Herstellerbeschreibung Hot Plug fähig.
Wenn ich jetzt im laufenden Betrieb die Festplatte rausziehe bekomme ich den Fehler:

Das Gerät "ST320082 2AS SCSI Disk Device" (SCSI\Disk&Ven_ST320082&Prod_2AS&Rev_3.01\4&2b51064&0&300) wurde ohne vorbereitende Maßnahmen vom System entfernt. <<<

Das hat meiner Meinung nach nichts mit Hot-Plugging zu tun, da das auch zu Datenverlust führt (führen kann) und der HDD nicht unbedingt gut tut.
Die HDDs werden auch nicht als Wechseldatenträger erkannt, daher gibt es auch kein grünes Icon in der Taskleiste.
Wenn ich jetzt via Gerätemanager die Platte deaktiviere, kann ich sie ohne Fehlermeldung herausziehen. Das ist meiner Auffassung nach aber kein echtes Hot-Plugging und ist für unseren Nutzen auch nicht zu gebrauchen.

Die Lösung wäre ein kleines Script (Batchfile o.ä.) das die Platten automatisch deaktiviert /ausschaltet.
Ziel ist es auf dem Rechner einen Copyjob laufen zu lassen, der gewisse Files auf eine Platte kopiert und man dann die Platte ziehen kann OHNE den Rechner zu bedienen.
Aber wie nun die Platten via Script abmelden / deaktivieren ?
Mitglied: Karo
05.09.2005 um 17:08 Uhr
war das nicht so, das erst ab SATA II Hot Plug möglich ist?

Karo
Bitte warten ..
Mitglied: cashmere
05.09.2005 um 17:24 Uhr
Naja, es steht auf der Packung (:
.. soweit ich mich im Netz informiert habe, sollten alle SATA Festplatten Hot Plug fähig sein.
Bitte warten ..
Mitglied: Karo
05.09.2005 um 17:31 Uhr
nö, so isses nicht ganz. Der IDE 4 PIN Power Anschluss sind nicht Hot Plug fähig. Außerdem muss das SATA Interface nach dem Standard V2.0 sein.

Karo
Bitte warten ..
Mitglied: BluePanther
06.12.2005 um 14:49 Uhr
Hallo,

bist du mit deinem script zum abmelden schon weiter?
Vielelicht hilft dir sync.exe von sysinternals.com weiter.

-BP-
Bitte warten ..
Mitglied: Nicolas
25.07.2006 um 10:25 Uhr
Auch auf die Gefahr hin, dass das Problem schon per Script gelöst wurde (was in Anbetracht des Datums nicht verwunderlich wäre) hier noch die - meiner Meinung nach - richtige Lösung des Problems.

Windows (2000 sowie XP) besitzen eine Einstellung im Gerätemanager welche es erlaubt, Laufwerke dahingegend zu konfigurieren, ob man sie mit oder ohne das Symbol "Sicheres entfernen" im Systray herausnehmen kann. So kommen Sie zu der Einstellung:

Rechtsklick auf Arbeitsplatz / Verwalten / Geräte-Manager / Laufwerke / Rechtsklick auf gewünschtes Laufwerk / Eigenschaften / Richtlinien.
Hier finden sich zwei Radio Buttons. Eines davon nennt sich (Win XP): "Für schnelles Entfernen optimieren". Der Schreibcache wird dann deaktiviert und die Daten direkt auf das Laufwerk geschrieben (ohne Benutzung des Schreibcaches halt ;) ). Nun nurnoch bestätigen und fortan können Laufwerke einfach so herausgenommen werden. Datenverluste sind hiermit dann auch auszuschließen.

Edit: Zu erwähnen wäre noch, dass hierunter die Geschwindigkeit ein wenig leidet, was aber kein Hinderungsgrund darstellen sollte, da es ab und an beim sicheren Entfernen mittels des Symbols im Systray zu Fehlermeldungen kommt.


Viele Grüße, Nicolas
Bitte warten ..
Mitglied: quaestor
21.05.2007 um 17:07 Uhr
Hallo Cashmere,
ich habe ein Jahr später genau das gleiche Problem wie du.
DawiControl, Wechelrahmen(HotPlug fähig), SataII - Platte(HotPlugfähig laut Spezifikation)
Hast du eine Lösung für das Problem gefunden?
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(5)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Router & Routing
gelöst MikroTik hAP ac Winbox Zugriff deaktivieren (1)

Frage von horstvogel zum Thema Router & Routing ...

Sicherheit
gelöst Libreoffice Makros deaktivieren - Button fehlt in LO 5 (2)

Frage von Der-Phil zum Thema Sicherheit ...

Hardware
Banana Pi M2 Ultra: Bastelrechner bietet native SATA-Unterstützung

Link von runasservice zum Thema Hardware ...

Festplatten, SSD, Raid
gelöst RAID 1 SATA durch SAS HDDs tauschen (8)

Frage von oce zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (17)

Frage von Unwichtig zum Thema Netzwerkmanagement ...