Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SBS 11 Logonscripte funktionieren nicht

Frage Microsoft Windows Userverwaltung

Mitglied: wescraven07

wescraven07 (Level 2) - Jetzt verbinden

06.05.2014 um 18:49 Uhr, 1852 Aufrufe, 3 Kommentare

Hallo Leude,

habe folgendes Problem. Ich habe für jeden unserer 4 Mitarbeiter einen Logonscript via batch erstellt. Wenn sich der Domainbenutzer am Terminal anmeldet und das Scritp aus dem Autostart ausgeführt wird, funktioniert alles.

Jetzt wollen wir damit beginnen, unsere Benutzerprofile Servergespeichert abzulegen und das ganze via Logonscript zu lösen.

Die Logonscipte im Netlogon-Ordner abgelegt und mit dem jeweiligen Benutzerprofil verknüpft. Funktioniert aber nicht.

Die Lösungsansätze hier haben wir schon versucht.

Beim SBS11 die Richtlinie "Scripte gleichzeitig ausführen", "Nach Neustart auf das Netzwerk warten". aktiviert. Es hat bisher alles nicht funktioniert.

Die scripte sind so benannt:

user1.bat
user2.bat
etc...

und sehen so aus:

net use k: \\Server\Ordner1 /user:domain.local\User passwort /opersistent:no
net use k: \\Server\Ordner2 /user:domain.local\User passwort /opersistent:no

wobei die Ordnerfreigaben unterschiedlich sind, je Benutzer, je Script.

Zunächst habe ich versucht nur die "user1" ohne Ordnerpfad und .bat zu hinterlegen, das hat gar nicht funktioniert, dann habe ich beim Admin getestet den gesamten Pfad mit

C:\Windows\sysvol\domain\scripts\admin.bat hinterlegt, dann gings es für den Domainadmin.

Dann habe ich dasselbe für einen der Domainuser hinterlegt nur mit user1.bat statt admin.bat, dann gingen beide nicht mehr. Auch nicht als ich die Richtlinie "Scripte gleichzeitig ausführen" beim SBS DC aktiviert hatte.

Mir ist aber am Terminal aufgefallen, dass das Script nicht sichtbar ausgeführt wird, obwohl ich auch diese Richtlinie aktiviert habe, beim SBS DC und am Terminal. Schinebarwird also das Script gar nicht ausgeführt?

Wo kann da der Fehler liegen, hat jemand noch eine Idee?

Danke für Eure Tips.

Greetz
Der Wes
Mitglied: flow.ryan
06.05.2014 um 21:28 Uhr
Hallo,

hast du das Script im Benutzerobjekt des AD eingetragen? -> Konto -> Anmeldescript. Hier muss der Scriptname stehen.
Schaue einmal, ob das Script in \\localhost\NETLOGON auf?

Wieso baust du dafür denn keine GPO bzw. GPP?
Alternativ könntest du auch den Profilpfad im AD unter -> Konto hinterlegen.

Gruß,
Florian
Bitte warten ..
Mitglied: wescraven07
06.05.2014, aktualisiert um 23:03 Uhr
Ja, das Script ist unter "Konto" "profil" "Anmeldescript" eingetragen. Eine GPO hatte ich bisher nicht in Betrach gezogen, da es mir am einfachsten erscheint, das Script im AD-Konto zu hinterlegen.

Ich habe wie gesagt beim Administratorkonto im AD-Benutzer den gesamten Scriptpfad hinterlegt:

C:\Windows\sysvol\domain\scripts\admin.bat. Das hat einmal funktioniert, bei der Anmledung als Admin beim Terminal.

Dann habe ich dasselbe bei einem Domainbenutzer hinterlegt, selber Pfad nur anders Logonscript

C:\Windows\sysvol\domain\scripts\user1.bat

Dann hat es bei deiden Benutzern nicht merh funktioniert. Eigentlich sollte man ja nur "user1" oder "admin" eintragen, und dass script wird im netlogonordner automatisch zugewiesen. So steht es zumindest fast überall. Aber so funktioniert es gar nicht.

Die Scripte liegen auch ordnungsgemäss im Ordner

C:\Windows\sysvol\domain\scripts\

also wo sie hinmüssen, und unter

\\Localhost\Netlogon werden die Scripte alle angezeigt

daher weiss ich nicht wo der Fehler liegen könnte.

Gruss
Bitte warten ..
Mitglied: wescraven07
07.05.2014 um 10:38 Uhr
Das Problem ist gelöst. Der Name des Scripts hatte eine einen Punkt "a.user1.bat". Dadurch wurde das Script anscheinen nicht erkannt.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Exchange Server
gelöst SBS2011 Owa und Activesync funktionieren nach V2V Umzug nicht mehr (2)

Frage von Anulu1 zum Thema Exchange Server ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Windows Server
gelöst SBS 2011 - Domäne (7)

Frage von MiSt zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...