Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SBS 2011 - internes Relay - Loop Detected - Emails werden nicht an Provider weitergeleitet

Frage Microsoft Exchange Server

Mitglied: JaroslawS

JaroslawS (Level 1) - Jetzt verbinden

03.07.2012 um 01:29 Uhr, 5107 Aufrufe, 12 Kommentare, 1 Danke


Hallo,
folgende Situation:
bisher alle Emails beim Provider. Jetzt soll für eine Zweigstelle ein Exchange Server (SBS 2011) eingerichtet werden. 10 von den ca. 100 Emailadressen soll auf dem Exchange verwaltet werden, der Rest beim Provider.

Lösungsansatz:

MX Eintrag: Prio 10 - Exchange
Prio 30 - Provider (für Ausfallzeiten des Exchange)

Auf dem Exchangeserver wird die firma.de als Akzeptierte Domäne eingerichtet (internes Relay)

Windows SBS Internet Send Connector wird mit einem Smarthost versehen (ein Emailaccount beim Privder)

Der Exchange soll jetzt also alle Emails empfangen. Emails, die er AD Benutzern zuordnen kann, soll er auch zuordnen. Emails, die er nicht zuordnen kann, soll er per Smarthost an Provider weiterleiten.

Der Exchange empfängt jetzt alle Emails, ordnet sie den AD Benutzern zu und der Rest landet im "Loop Detected".

Wie komme ich aus dem Loop raus?

Vielen Dank,

Jaroslaw
Mitglied: Bodzinsky
03.07.2012 um 08:25 Uhr
Hallo,

das Problem:

... er nicht zuordnen kann, soll er per Smarthost an Provider weiterleiten.
Das klappt soweit,
aber durch ...
... MX Eintrag: Prio 10 - Exchange
Prio 30 - Provider (für Ausfallzeiten des Exchange)
kommen ja die eMails vom Provider wieder zum Exchange. (Die Prio sorgt ja lediglich dafür, dass ein 2. Server da ist, falls der erste Server offline ist.)

Ich gehe im Folgenden davon aus, dass jeder Benutzer sein eigenes Postfach hat, wie bei uns.

Hier habe ich das selbe Problem so gelöst, dass ich einen POP3-Connector (POPcon, http://www.servolutions.de/popcon.htm) auf unserem Server eingerichtet habe. Dieser ruft in einstellbarem Intervall per POP3 die (in Deinem Fall 10) eMail-Postfächer ab und leitet *nur diese* an den Exchange weiter.

AFAIR gab es mal einen POP3-Connector im SBS, ich bin aber grade nicht informiert, ob das noch aktuell ist.

Gruß
Chris
Bitte warten ..
Mitglied: GuentherH
03.07.2012, aktualisiert um 08:55 Uhr
Hallo.

a) dein Suchbegriff für dein Problem lautet "shared Namespace" - suche hier einmal am Board, gibt fast wöchentlich Beiträge dazu
b) ein 2. MX ist heute nicht mehr notwendig, da er eher Nachteile (SPAM) als Vorteile bringt

Hier habe ich das selbe Problem so gelöst, dass ich einen POP3-Connector

Auch auf dem Exchange 2003 musstest du Shared Namespace konfigurieren, dass hast du vergessen zu erwähnen.

LG Günther
Bitte warten ..
Mitglied: Bodzinsky
03.07.2012, aktualisiert um 09:03 Uhr
Auch auf dem Exchange 2003 musstest du Shared Namespace konfigurieren, dass hast du vergessen zu erwähnen.

Habe nie mit dem E2003 gearbeitet, nur mit dem 2010. ;)

LG Chris
Bitte warten ..
Mitglied: JaroslawS
03.07.2012 um 12:54 Uhr
Irgendwie fehlt mir da noch die Gesamtübersicht. Ich habe das ganze nach der Anleitung eingerichtet:
http://technet.microsoft.com/en-us/library/bb676395.aspx
Aber anscheinden etwas falsch gemacht.

Mal eine Verständnisfrage:
Die zwei MX Einträge sollen zunächst bleiben. Wenn der Server sich bewährt hat und alles reibungslos läuft, kann ich über das Löschen des zweiten MX Eintrags nachdenken.

Jemand sendet eine EMail an uns. Im Normalfall schaut der Server des Absenders nach den MX Einträge und kontaktiert den Server mit der kleinsten Prio Zahl. In unserem Fall den Exchange Server.
Der Exchange Server schaut nach, ob die Domäne akzeptiert wird und nimmt die EMail an.
Nun schaut Exchange, ob die EMail lokal zugestellt werden kann. Wenn ja, tut er das. Wenn nein, schickt er die Email weiter, per Smarthost.

Nun: Im normalfall würde der Exchange sich jetzt die MX Einträge anschauen und versuchen, die EMail an sich selbst zu verschicken. Damit kommt es zu einem Loopback.
Oder aber: der Smarthost läuft über einen Account bei dem Provider, der die restlichen Emailadressen verwaltet. Der Provider merkt, dass die Email bei ihm lokal zugestellt werden kann, stellt diese zu und versucht gar nicht erst an dern ersten MX Eintrag zu senden. Falls der Useraccount dort auch nicht zu finden ist, geht die Email an die die Catchall Mailadresse.

Ist das so richtig?

Was passiert, wenn der Smarthost über einen anderen Provider läuft, als der, der die restlichen Emailadressen verwaltet? Dann haben wir auf jedem Fall einen Loopback.

Was passiert, wenn der keine Catchall Adresse eingerichtet ist? Der Absender hat die Mail an den Exchange erfolgreich abgesetzt. Der Provider blockiert den Smarthost mit dem Hinweis Benutzer unbekannt. Wo landet jetzt die Fehlermeldung?


Ich setzte mich weiter mit dem Exchange auseinander.
Bitte warten ..
Mitglied: GuentherH
03.07.2012 um 13:19 Uhr
Hallo.

Sorry, ich habe in der Eile einen wichtigen Teil deines Eröffnungsbeitrages irgenwie nicht richtig mitbekommen.

Fakt ist, wie Bodzinsky geschrieben hat, dass es so nicht klappt. Der MX Eintrag darf in diesem Fall nicht auf den Exchange Server zeigen sondern auf den Server beim Provider.
Daher die 10 Postfächer mit POP3 abholen, Rest holt beim Provider ab. Shared Namespace musst du trotzdem konfigurieren, damit die die 10 User, die am Exchange angelegt sind and die restlichen 90 externen senden können.

LG Günther
Bitte warten ..
Mitglied: Bodzinsky
03.07.2012, aktualisiert um 14:26 Uhr
Hallo nochmal

Mal eine Verständnisfrage:
gerne

Die zwei MX Einträge sollen zunächst bleiben. Wenn der Server sich bewährt hat und alles reibungslos läuft,
kann ich über das Löschen des zweiten MX Eintrags nachdenken.
ok


Jemand sendet eine EMail an uns. Im Normalfall schaut der Server des Absenders nach den MX Einträge und kontaktiert den
Server mit der kleinsten Prio Zahl. In unserem Fall den Exchange Server.
richtig

Der Exchange Server schaut nach, ob die Domäne akzeptiert wird und nimmt die EMail an.
richtig

Nun schaut Exchange, ob die EMail lokal zugestellt werden kann. Wenn ja, tut er das. Wenn nein, schickt er die Email weiter, per
Smarthost.
richtig

Nun: Im normalfall würde der Exchange sich jetzt die MX Einträge anschauen und versuchen, die EMail an sich selbst zu
verschicken. Damit kommt es zu einem Loopback.
richtig

Oder aber: der Smarthost läuft über einen Account bei dem Provider, der die restlichen Emailadressen verwaltet. Der
Provider merkt, dass die Email bei ihm lokal zugestellt werden kann, stellt diese zu und versucht gar nicht erst an dern > ersten MX Eintrag zu senden...
leider nein: eMails werden *immer* an die eingetragene MX-Adresse geliefert. Die Reihenfolge ist hier die Krux: Zunächst bekommt der MX die Mail, danach wird erst der Empfänger/die Domäne geprüft.

Falls der Useraccount dort auch nicht zu finden ist, geht die Email an die die Catchall Mailadresse.
edit: die eMail wird beim Provider nicht geprüft, da dieser nicht als (erster) MX eingetragen ist.

Was passiert, wenn der Smarthost über einen anderen Provider läuft, als der, der die restlichen Emailadressen verwaltet?
Dann haben wir auf jedem Fall einen Loopback.
...und somit keinen Unterschied (im Ergebnis) zur jetzigen Situation.

Was passiert, wenn der keine Catchall Adresse eingerichtet ist? Der Absender hat die Mail an den Exchange erfolgreich abgesetzt.
Der Provider blockiert den Smarthost mit dem Hinweis Benutzer unbekannt. Wo landet jetzt die Fehlermeldung?
Der Provider blockiert nichts. Als nicht-MX ist es ja eben nicht Aufgabe des Provider-Servers, eMails auf korrekte Angaben zu prüfen. Er wird auf jeden Fall die Nachricht (zurück) an den Exchange geben, welcher die eMail mit Status 554 (mail loop detected) bounced. Diese Fehlermeldung wird von Exchange via Smarthost per E-Mail an den Absender der unzustellbaren E-Mail gesendet und hat selbst einen leeren Envelope Sender (<>), um eMail-Loops zu verhindern. Das funktioniert natürlich wiederum nur dann, wenn der jetzige Empfänger (also der ursprüngliche Absender) der Nachricht nicht zu den 90 eMail-Adressen beim Provider gehört. Falls doch, wird die Nachricht gedropt, also "einfach fallengelassen" oder an den lokal vorhandenen Postmaster gesendet, je nach Einstellung im Exchange.

Ich setzte mich weiter mit dem Exchange auseinander.
Wir unterstützen Dich gerne dabei.

Gruß
Chris
Bitte warten ..
Mitglied: Bodzinsky
03.07.2012 um 14:08 Uhr
Shared Namespace musst du trotzdem konfigurieren, damit
die die 10 User, die am Exchange angelegt sind and die restlichen 90 externen senden können.
Sicher, ist das aber nicht durch

>...Akzeptierte Domäne eingerichtet...
schon hinreichend passiert? Ich meine mich zu erinnern, dass das gereicht hat, damit Exchange lokal nicht zustellbare eMails an den Smarthost weitergibt...
Bitte warten ..
Mitglied: GuentherH
03.07.2012, aktualisiert um 14:38 Uhr
Hi.

Ich meine mich zu erinnern, dass das gereicht hat, damit Exchange lokal nicht zustellbare eMails an den Smarthost weitergibt...

Genau. Dein Satz ist die Langform für "Shared Namespace"

LG Günther
Bitte warten ..
Mitglied: Bodzinsky
03.07.2012 um 19:59 Uhr
Genau. Dein Satz ist die Langform für "Shared Namespace"

Schon wieder schlauer geworden, danke!

LG
Chris
Bitte warten ..
Mitglied: JaroslawS
03.07.2012 um 21:25 Uhr
Die Sache wäre so oder so nichts geworden.
Die EMails werden bei DomainFactory gehostet. Die haben auf Ihren Servern eine Einstellung, dass der Mailserver regelmäßig überprüft, ob er selbst der erste Server im MX Eintrag ist. Wenn das nicht der Fall ist, versetzt er sich in einen Backupmodus. Damit verteilt er nicht die EMails auf die vorhandenen Postfächer, sondern speichert sie zwischen, um an den ersten Server im MX Eintrag zuzustellen, sobald dieser verfügbar ist.
Ich habe mit Hosteurope telefoniert, bei denen soll das anders sein. Ich werde das mal spasseshalber ausprobieren, sobald ich etwas Zeit habe.

Was mich noch etwas beschäftigt:
Ist es nicht möglich, im Smarthost statt eines MX-Eintrags "mail.firma.de" direkt den Server beim Provider anzugeben, also etwas "mailserver0815.hosteurope.de"? Ich werde das jetzt nicht ausprobieren, sonst bin ich morgen einen Kopf kürzer.

Ich habe jetzt den POP3-Connector eingerichtet, aber so richtig glücklich bin ich damit nicht.

Vielen Dank für Eure Hilfe und schöne Grüße,

Jaroslaw
Bitte warten ..
Mitglied: GuentherH
03.07.2012 um 22:21 Uhr
Hallo.

Ist es nicht möglich, im Smarthost statt eines MX-Eintrags "mail.firma.de" direkt den Server beim Provider anzugeben

Der Smarthost ist immer ein Relayserver, hat also mit MX-Eintrag nichts zu tun.

LG Günther
Bitte warten ..
Mitglied: JaroslawS
25.04.2013, aktualisiert um 13:22 Uhr
Also nur mal kurz als Rückmeldung, wie ich das Problem gelöst habe.

Die domain.tld und die Postfächer wurden bei DomainFactory belassen.
Ich habe eine subdomain remote.domain.tld bei DF eingerichtet. Die Benutzer, die auf dem SBS gehostet werden sollen, haben statt eines Postfachs bei DF eine Weiterleitung an benutzer@remote.domain.tld bekommen. Remote.domain.tld ist die zweite akzeptierte Domain auf dem SBS. Die Hauptdomain, über die auch die EMail verschickt werden, ist immernoch domain.tld.
Die Benutzer und die Empfänger merken nichts von der Weiterleitungsgeschichte.

Vielen Dank für Eure Unterstützung.
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Server
gelöst SBS 2011 - Domäne (7)

Frage von MiSt zum Thema Windows Server ...

Windows Server
gelöst Einrichten SBS 2011 mit Hybrid Router (12)

Frage von stolli zum Thema Windows Server ...

Exchange Server
SBS 2011 Exchange Multidomain kein senden über Outlook möglich (1)

Frage von pla112 zum Thema Exchange Server ...

Windows Server
SBS 2011 - Fehler bei Server-Sicherung (20)

Frage von Irolan zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...