Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SBS11-Server fährt regelmässig von alleine runter.

Frage Microsoft Windows Server

Mitglied: wescraven07

wescraven07 (Level 2) - Jetzt verbinden

26.02.2014 um 18:15 Uhr, 3151 Aufrufe, 25 Kommentare, 2 Danke

Hallo Leude, ich hatte hier meine Problematik schon mal vereinzelt gepostet, aber da jetzt eigentlich eigentlich kein Lösungsansatz mehr im Raum steht, schildere ich das Problem hier nochmal detailliert, vielleicht hat ja einer von Euch eine Idee oder einen bisher noch nicht bedachten Lösungsansatz.

Ausgangsituation:

Vor ca. 6 Monaten habe ich mir für mein kleines Büro einen SBS11 von DELL geleast. Sinn und Zweck hauptsächllich, die Nutzung von Exchange. Vorher hatte ich einen Windows 2003 Server, der DC, DNS, DHCP und Fileserver war. Eine Exchange-Alternative fürs LAN lief ebenfalls drauf.

SBS11 Poweredge E320 kam, und wurde migriert. Nach der Migration stellen wir fest, dass DELL das falsche Raid eingerichtet hatte.

Also nochmal neu migriert, den alten SBS11 manuell aus dem AD vom Windows 2003 Server und dem neu migrierten entfernt.

Ca. 2 Wochen später hat es angefangen:
Der SBS11 fährt alle 3 Tage von alleine und anscheinend kontrolliert runter, geht also ganz aus.

Ohne Eventlog. Nach dem der Server normal wieder hochgefahren ist, ohne Fehlermeldung und Eventlog, läuft das Gerät wieder für die nächsten 3 Tage. Zunächst dachten wir an einen Hardwaredefekt und haben DELL das Ding komplett durchchecken lassen, haben einen DESET-Report erstellt, den DELL ausgewertet hat.

Aussage: Nichts feststellbar, definitiv kein Hardwaredefekt.

Jetzt hatten wir noch folgenden Situation:

Sowohl der Windows 2003 Server als auch der SBS waren DC, aber der SBS hatte alle Rollen übernommen. Ich hatte zwar gelesen, dass es zwar nicht üblich, aber theoretisch nicht problematisch ist, nebend em SBS einen zweiten DC in der Domain zu haben.

Nachdem diese Problematik mit dem Runterfahren entstanden war, änderten wir das. Wir haben den 2003 Server heruntergestuft und das AD entfernt. Das hat auch alles funktioniert. Der SBS ist jetzt alleiniger DC, DNS und DHCP. Allerdings besteht das Problem mit dem SBS weiterhin. Nur fährt er nicht mehr alle 3 sondern alle 8 Tage runter.

Wir haben also DELL wieder ins Boot geholt und die sagten evtl. könnte es an ESET liegen. ESET selbst und mehre andere Quellen sagen aber, dass Sie mit ESET noch nie Probleme in gleichen Umgebungen hatten.

Wir sind jetzt also ein wenig ratlos. Es liegt kein Hardwaredefekt vor, kein Eventlog, der auf einen Crash hinweist. Habt Ihr vielleicht eine noch eine Idee, was wir übersehen haben könnten? Vielleicht ein Hinweis, nachdem ich EVENT-Log suchen könnte, der den Shutdown auslöst, den wir noch nicht in Betracht gezogen haben?
Kennt Ihr dieses Problem vielleicht schon oder hattest es selbst schonmal?
Ich kann auch gerne mal den Eventlog posten, wenn das weiterhilft.

Freue mich auf Eure Tips.

Greetz
Der Wes
Mitglied: keine-ahnung
26.02.2014 um 18:25 Uhr
Moin,
Wir haben den 2003 Server heruntergestuft und das AD entfernt.
Was so alles geht ...
Wir haben also DELL wieder ins Boot geholt und die sagten evtl. könnte es an ESET liegen.
Hast Du das nun mal runtergeschmissen?
Aktiviert ist der SBS aber?
Ich kann auch gerne mal den Eventlog posten, wenn das weiterhilft.
Ich denk, da steht nix drin?

LG, Thomas
Bitte warten ..
Mitglied: goscho
26.02.2014 um 20:09 Uhr
Hi,
hängt der SBS an einer USV, die regelmäßig den Server herunterfährt?
Bitte warten ..
Mitglied: wescraven07
26.02.2014 um 20:55 Uhr
@ Keine Ahnung,

was meinst Du mit "was so alles geht"? war das fachlich nicht korrekt?

Zu Deinen Fragen:

Der SBS ist aktviert. ESET habe ich mal über das WE deinstalliert und Security Essentials installiert. Selbes Resultat.

Es stehen natürlich einige Einträge im Eventlog, aber nichts was laut DELL auf den Shutdown hinweist. Wir sind gerade dabei, die Fehler aus dem eventlog nacheinander zu analysieren und zu beheben.

@goscho

Der 2003 Server, unsere Telefonanlage, Router und SBS hängen an der USV. Aber die Probleme mit dem SBS bestanden auch schon vorher, bevor die Gerät alle an die USV angeschlossen wurden. Die ist er seit kurzem wieder in Betrieb (ja ich weiss, etwas leichtsinnig)
Bitte warten ..
Mitglied: certifiedit.net
26.02.2014 um 21:07 Uhr
https://www.administrator.de/forum/poweredge-320-sbs-11-crashed-228639.h ...

ach was solls:
https://www.administrator.de/userid/45639

Damit wir auch die ganze Historie haben. Sollen wir jedes mal wieder bei Null anfangen mit den Fragen, macht dir das Spaß, oder schreibst du dir darüber den Kummer von der Seele?

Ich würde darauf tippen, dass irgendwas zu schwach ist für die geforderte Leistung oder das der Server an sich eine Macke durch das Stromnetz bekommen hat.

Aber ich glaube, das hab ich auch schonmal geschrieben.

Grüße,

Christian
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 00:16 Uhr
Ja, ich weiss. Ich wollte es einfach nochmal in einem Post zusammenfassen.

Der Server hat 32 GB Ram und nichts was grossartig drauf läuft, sollte als nicht überlastet sein.

Wenn es ein Spannunsproblem wäre, sollte doch ein Bluescreen passieren und crashdump erstellt werden oder?

Kannman dass irgendwie messen, ob es doch ein Stromproblem ist?
Bitte warten ..
Mitglied: certifiedit.net
27.02.2014, aktualisiert um 00:25 Uhr
Ja, so, wie es ein Elektriker es tut. Ob deswegen etwas schaden genommen hat, möglich.

RAM Ist nicht alles, wenn du in ein System mit einem Pentium 500GB RAM steckst bringt dir das genauso viel (abgesehen davon, dass es nicht geht, Beispielhaft übertrieben), wie wenn du einen DecaCore mit 0,5GB RAM betreibst. Darum muss das System auch nach allen Ecken hin rund aufgebaut sein.

Ansonsten: Ggf. doch das System Fehlerhaft eingerichtet (hast du imho selbst gemacht und nicht extern vergeben)?
Bitte warten ..
Mitglied: keine-ahnung
27.02.2014 um 08:53 Uhr
Ansonsten: Ggf. doch das System Fehlerhaft eingerichtet (hast du imho selbst gemacht und nicht extern vergeben)?
Gibt es da einen shutdown-Automatismus, wenn man die Büchse selber aufsetzt ...?

LG, Thomas
Bitte warten ..
Mitglied: goscho
27.02.2014, aktualisiert um 09:00 Uhr
Zitat von keine-ahnung:

> Ansonsten: Ggf. doch das System Fehlerhaft eingerichtet (hast du imho selbst gemacht und nicht extern vergeben)?
Gibt es da einen shutdown-Automatismus, wenn man die Büchse selber aufsetzt ...?
Warum fragst du?
Ist dir das auch schon passiert bei deinen SBSen?

Ich setze die auch meist selber auf. Mach ich zwar nicht für mich, aber trotzdem lasse ich mich dazu herab.

Ich hatte mal einen ähnlich gelagerten Fall bei einem Kunden. Der Server (kein SBS aber auch Windose) fuhr regelmäßig herunter, kein Bluescreen, keine Meldungen.
Ich habe das Netzteil getauscht und seither läuft das Teil ohne Fehler.

Es handelte sich um einen HP ML350G5.
Bitte warten ..
Mitglied: keine-ahnung
27.02.2014 um 09:07 Uhr
Warum fragst du? Ist dir das auch schon passiert bei deinen SBSen?
Eigentlich ständig ... Ich behelfe mir durch den Einsatz eines SBS-Clusters aus > 10 SBS, die zeitlich gestaffelt den auto-shotdown machen. Dadurch stelle ich sicher, dass zumindest während der Sprechzeiten mindestens einer "on" ist .

LG, Thomas
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 09:28 Uhr
Ich habe eben noch einen Fehler gefunden:

Habe eben auf demSBS die FSMO Rollen überprüft. Die Domainnamen-Betriebsmasterrolle ist noch bei dem alten SBS, der manuell gelöscht wurde. Kurz zum Verständniss. Der alte SBS hiess "SBS2011" der jetzige, neue heisst "SBS11".

Habe jetzt versucht die Rolle zu verschieben, über das Active-Directory-Vertrauensstellung-Snap-In, habe aber das Problem, das ich die Fehlermeldung erhalte:

"der aktuelle Betriebsmaster ist offline. Die Funktion kann nicht übertragen werden".

Also die Rolle liegt noch beim SBS2011 und ich muss sie zum SBS11 übertragen.

Welche alternative Möglichkeit habe ich, um die Rolle auf den SBS11 zu übertragen, da der SBS2011 gelöscht ist?
Bitte warten ..
Mitglied: goscho
27.02.2014 um 09:35 Uhr
Zitat von wescraven07:

Ich habe eben noch einen Fehler gefunden:
"der aktuelle Betriebsmaster ist offline. Die Funktion kann nicht übertragen werden".

Also die Rolle liegt noch beim SBS2011 und ich muss sie zum SBS11 übertragen.

Welche alternative Möglichkeit habe ich, um die Rolle auf den SBS11 zu übertragen, da der SBS2011 gelöscht ist?
Du musst das manuell mit ntdsutil machen.
Guggst du hier:
Übertragen von FSMO-Funktionen auf einen Domänencontroller mithilfe des Programms "Ntdsutil.exe"

Trotzdem denke ich nicht, dass dies dein Problem mit den Shutdowns verursacht, denn sonst hättest du dazu bestimmt Logeinträge.
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 10:30 Uhr
ja, wer weiss.

aber vielleicht haben wir ja glück und es liegt doch daran und ist "nur" ein Konfigurationsfehler. Ich habe zumindest mal gelesen, dass in solchen Szenarien: "SBS ist nicht der einizige DC, zweiter SBS ist in der Domain, der SBS hat nicht alle Rollen zugewiesen" dieser Fehler auftreten kann.

Ich werds einfach jetzt mal testen, den SBS neutsraten und beobachten. Danke für Deinen Link.

Ich meld mich wieder.
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 12:25 Uhr
Ok, habe folgendes Problem, beim Übertragen der Rolle, sie wird abgebrochen, mit folgender Fehlermeldung:

ldap_modify_sW-Fehler 0x < 12 (kritische Erweiterung nicht verfügbar)

LDAP-Fehlermeldung: 000020AE: SvcErr: DSID-03210384, problem 5010 (UNAVAIL EXTENSION) data 8434

WIN 32-Fehler: 0x20ae (Das Funksionsbesitzerattribut konnte nicht gelesen werden)
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 16:30 Uhr
was sich noch ergänzend fragen wollte:

Ich versuche gerade herauszufinden, was es mit diesem Fehler auf sich hat und lese überall, das der DC, der die Rollen auf den neuen DC überträgt, als in meinem Fall der 2003 Server auf den SBS11 danach für immer offline sein muss.

Kann es sein, dass das die Ursache des Problems ist, dass der SBS runterfährt? Muss ich den 2003 Server neuaufsetzten, umbenennen und neuinstalliert, mit neuem Namen und IP-Adresse weider in die Domain einbinden?

Das löst zwar das obere Probelm mit dem Rollentransfer nicht, aber könnte das die Ursache sein?
Bitte warten ..
Mitglied: goscho
27.02.2014 um 16:33 Uhr
Zitat von wescraven07:
Ich versuche gerade herauszufinden, was es mit diesem Fehler auf sich hat und lese überall, das der DC, der die Rollen auf
den neuen DC überträgt, als in meinem Fall der 2003 Server auf den SBS11 danach für immer offline sein muss.
Wer hat das wo geschrieben?
Kann es sein, dass das die Ursache des Problems ist, dass der SBS runterfährt? Muss ich den 2003 Server neuaufsetzten,
umbenennen und neuinstalliert, mit neuem Namen und IP-Adresse weider in die Domain einbinden?
Nein, du hättest ihn sogar als DC weiterbetreiben können.
Es handelte sich doch um einen Windows Server 2003 Standard und nicht um einen SBS 2003, oder?
Das löst zwar das obere Probelm mit dem Rollentransfer nicht, aber könnte das die Ursache sein?
Eher nicht.
Bitte warten ..
Mitglied: Dobby
27.02.2014 um 17:23 Uhr
Hallo zusammen schon wieder,

Aber ich glaube, das hab ich auch schonmal geschrieben.
Ach was soll es ich ja auch, wie viele Stromleitungen sind denn
in dem Gebäude vorhanden!?

Gruß
Dobby
Bitte warten ..
Mitglied: Chonta
27.02.2014 um 17:58 Uhr
Hallo,

ein SBS muss immer alle FMSO haben. Hält ein anderer Server eine FMSO Rolle dann macht der SBS mitunter komische Sachen.
Wurde von einem SBS 2003 migriert oder von einem normalen Server 2003?

Wenn es ein SBS 2003 war, dann dard der natürlich nicht weiter in derselben Domäne sein, weil pro Domäne nur ein SBS erlaubt ist, ausser bei Migrierung, für eine bestimmte Zeit der Migrierung.
Wird die Zeit überschritten und es sind beide Server noch in der selben Domäne.....

Ein SBS muss auch immer DC sein.
In einer SBS Dömäne dürfen belibig viele DC erlaubt, aber der DC mus immer alle FMSO halten.

Gruß

Chonta
Bitte warten ..
Mitglied: wescraven07
27.02.2014 um 19:24 Uhr
Eine Stromproblematik schliesse ich aus. Wenn das Nezteil defekt wäre würde das Gerät nicht immer regeömässig nach 8 Tagen runterfahren, sondern sicherlich unkonrtolliert crahsen.

Ausserm hätte das sicher auch Auswirkungen auf die anderen Geräte.


@Chonta

Es wurde von einem normalen Windows 2003 Server migriert.

Der SBS hat alle Rollen bis auf die Domainname Master. Die hatte wohl noch der alte SBS2011, der zuerst migriert und dann gelöscht wurde.

Ich versuche im Momen eben diese Domainname Master Rolle zu übertragen via Ntdsutil erhlate aber die oben gennate Fehlermeldung.

Ein transfer name master geht sowieso nicht und eine erzwungene Übertragung per seize name master bringt oben genannte Fehlermeldung...

Vielleicht kann mir einer bei der Meldung behilflich sein, ich finde bei Google nämlich keinen brauchbaren Hinweis...
Bitte warten ..
Mitglied: reiser
28.02.2014 um 15:14 Uhr
Ich würde das Problem so wie Chonta bei den Microsoft Richtlinien für SBS Server suchen.

Wenn ein SBS ein einen anderen SBS im Netz erblickt fährt er nach gewisser Zeit runter.
Schon mal versucht den SBSCore-Dienst nur mal zum Test zu deaktivieren?

Evtl. sogar auf dem SBS 2003 den SBSCore mal deaktivieren.

Beschreibungen wie das geht gibt es ja genug im Netz.
Bitte warten ..
Mitglied: wescraven07
28.02.2014 um 16:07 Uhr
das kann ich zwar mal testen, aber ich habe ja keinen anderen SBS im Netz.

Falls ich da falsch verstanden wurde:

Es befinden sich ein SBS11 und ein Server 2003 im Netz.

Als der SBS geliefert wurde habe ich Ihn migriert unter dem Namen SBS2011. WIr haben dann gleich bemerkt, dass von DELL das Raid nicht wie gewünscht konfiguriert war und haben die Migration rückgängig gemacht, den alten SBS2011 manuell gelöscht und nochmal neu migriert diesmal unter dem Namen SBS11.

der SBS2011 war aber teils noch im AD des SBS11 eingetragen, sodass wir ihn manuell gelöscht haben. Daher auch jetzt die Probelmtik, dass die DomainName Master Rolle noch beim SBS2011 liegt, dieser aber gelsöcht ist und die Rolle nicht auf den SBS11 übertragen werden kann.
Bitte warten ..
Mitglied: Chonta
28.02.2014 um 17:08 Uhr
Hallo,

hießen die SBS2011 bei beiden Versuchen gleich?

Wenn ja, benenne den jetzigen um und dann entferne die Verweise vom alten Namen aus der Domäne.
Mache vorher ein Desasterbackup/AD Backup um alles auf Ausgang zurückzusteln um nicht noch mehr zu crashen.

Mit entfernen meine ich nicht nur alte Computerkonten in der Adansicht, sondern alles das auf den ganz alten SBS2011 verweißt und mit ADSIEDIT zu finden ist.
Da Mit ADSIEDIT dein AD zerstören kannst ist Vorsicht geboten und ein Backup ist wichtig.

Wenn das AD bereinigt ist, kannst Du denke ich auch die FMSO umziehen, ggf reicht auch schon ein Umbenennen des SBS.

Gruß

Chonta
Bitte warten ..
Mitglied: reiser
28.02.2014 um 17:51 Uhr
Ah OK, der 2003 war kein SBS. Das hatte ich überlesen.
Aber der SBS2011 als Small Business Server ist dem SBS11 bekannt, obwohl die ja nie gleichzeitig da waren.

Das Problem des ungewollten Runterfahrens und die DomainName Master Rolle auf einem Server der nicht mehr existiert hängen für mich zusammen.
Bitte warten ..
Mitglied: wescraven07
28.02.2014 um 18:39 Uhr
@ Chonta:

Nein, beim ersten Versuch hiess der SBS "SBS2011" und beim zweiten Versuch, bzw. jetzt aktuell heisst der SBS "SBS11".

Also umbenennen muss ich den SBS wohl nicht, aber ganz offensichtlich sind im AD noch Verweise auf den SBS2011

also mit ADSIEDIT kann ich alles bereinigen, was noch auf den aletenm SBS2011 verweist und ich evtl. beim bisherigen manuellen Reinigen übrsehen habe? Ist das auch ein Snapin?

Gibt es noch igrendwas was ich beachten muss, oder vielleicht ein How To AD bereinigen, auf das ich im Notfall zurückgreifen kann.


@ reiser, ich bin ganz Deiner Meinung. Für imch hängt das auch zusammen.

Ich denke, wenn ich die DomainName Master rolle auf den SBS11 umgezogen bekommen, sollte das Problem gelöst sein.
Bitte warten ..
Mitglied: wescraven07
06.03.2014 um 22:13 Uhr
also es lag ganz offensichtlich an der falsch zu geordneten Domannamen Master Rolle.

Trotz Fehlermeldung bei NTDSUTIL wurde die Rolle korrekt auf den neuen SBS übertragen. Der netdom query fsmo zeigt jetzt alle Rollen korrekt beim neuen SBS und das Gerät läuft seither stabil. Ich beobachte den Server zwar noch bis Sonntag, aber ich gehe davon aus, das Problem ist gelöst.
Bitte warten ..
Mitglied: wescraven07
11.03.2014 um 18:11 Uhr
Server läuft seit 2 Wochen stabil. ich würde sagen, dass Problem ist behoben.
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
Ubuntu
Ubuntu auf Akoya (Notebook fährt nicht runter) (15)

Frage von How-To zum Thema Ubuntu ...

Windows Server
gelöst Sehen wer einen Server herunter fährt (9)

Frage von NoobNerd zum Thema Windows Server ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...