Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sehr schlechte SSD Performance

Frage Hardware Benchmarks

Mitglied: Henere

Henere (Level 2) - Jetzt verbinden

20.02.2016, aktualisiert 21.02.2016, 1731 Aufrufe, 9 Kommentare

Hallo zusammen,

Hardware:
ASUS Z10PE 16-WS
Xeon 2620 v3
64 GB Reg ECC Ram
Samsung 950pro SSD NVMe

Im Betrieb gefühlt sehr schnell, aber im Benchmark unter aller Sau.
Hat da jemand eine Idee wo die Bremse der NVM-SSD sitzt ?
Die SSD sollte bis zu 2500MB/s lesen und bis zu 1500MB/s schreiben. Das ich diese Werte nicht erreiche ist klar, aber so weit unter den angegebenen Werten ?
Wird auch direkt von einem Lüfter angeblasen, das Thermal Throtteling ist nicht die Bremse.
Der Samsung NVMe Driver ist auch installiert. Chipsatztreiber sind auch auf dem Neuesten Stand.

9e7052e88343df876055d83b8207cd36 - Klicke auf das Bild, um es zu vergrößern

Hier im Vergleich dazu auf dem selben Board 2 Toshiba X300 4TB HDDs im Raid 0

1f3bc81b7b1624608ca4e885f746b605 - Klicke auf das Bild, um es zu vergrößern

Hier im Vergleich auf meinem PC:
Asus Z87A
Samsung 850pro SSD

b8ad8c0520b30b02aea7c9dae97638f3 - Klicke auf das Bild, um es zu vergrößern


Danke vorab und Grüße, Henere

Mitglied: SamvanRatt
20.02.2016 um 17:35 Uhr
Hi
hast du schon mal OS unabhängige Tests probiert (dd unter eine Linux CD)? Das Caching bei Windows kann Messwerte super verfälschen; Benchmarks minimum genauso.
Was sagt denn ein OS interner robocopy Job dazu? Sofern du genügend RAM hast würde ich den Weg gehen eine RAMDisk mit z.B. Arbeitsspeicher -2GB zu erzeugen, dort mittels bigfile ein randomisierten Inhalt (volle Größe) dort ablegen zu lassen und dann mit robocopy zu kopieren (hin und her). Wichtig ist das kein Speicher für Cache übrig bleibt.
Ich habe NVM(e) bisher nirgends im Einsatz (dafür Ramdisks im 100GB Bereich), da die schlechte OS Abdeckung und die oftmals gefunden Bugs (da war erst vor kurzem was mit Intels NVMe) in neuen Technologien (ich erinnere mich da das Thema Storport....) hindern mich daran da viel Geld zu investieren (ist bei mir ja nur Hobby), wenn ich mit "Standardsystemen" (RAID oder in meinem Fall Fibrechannel) auch zu meinen 3GB/s Durchsatz kommen.
Trotz alledem liebe ich moderne Ansätze

Gruß
SAm
Bitte warten ..
Mitglied: Henere
20.02.2016 um 19:23 Uhr
Hi Sam,

OS unabhängig hab ich nur mal den MEMTest laufen lassen, Die Werte passen.
Wenn er ja wenigstens cachen würde, aber das AS SSD soll angeblich die Caches dazu deaktivieren. Und selbst wenn mit aktiven Caches getestet würde, müssten deutlich höhere Werte rauskommen als die angezeigten. Die gleiche Software auf meinem PC unter Win7 bringen ja schon mit der 850pro deutlich höhere Werte als die NVM unter 2012R2.
Was meinst Du mit Bigfile ? Finde dazu in Google nur Webdienste.
Welche Software nutzt Du für die Ramdisk ? Wie genau kann ich das unter Linux testen ?

Bis jetzt hab ich auch noch nichts negatives über die Samsung 950pro NVM gelesen, ausser halt dem Thermal Throtteling. Und die 98° bei denen er das Tempo drosselt habe ich auch noch nie erreicht.

Ist bei mir auch nur ein Hobby, aber 2500€ für den Server sind halt traurig, wenn nur diese Performance dabei rauskommt.

Ich seh es halt auch am Backup auf mein NAS, mehr als 85MB/s habe ich da noch nicht gesehen. Und das NAS kann ich per iSCSI auf die vollen 100MBit/s bringen.

Finde halt nur die Handbremse nicht, auch BIOS und IPMI FIrmware sind auf dem neuesten Stand.
Wenn ich jetzt bei ASUS ein Ticket aufmache, verweisen die mich an Samsung, und Samsung an ASUS.

Das ist halt der Nachteil, wenn man die Komponenten einzeln kauft und nicht ein Komplettsystem bei einem großen Anbieter. Kostet dafür halt auch deutlich weniger.

Grüße, Henere
Bitte warten ..
Mitglied: Henere
20.02.2016 um 19:59 Uhr
Kann es vielleicht daran liegen ?
Die sollte doch eher auf 10 Gbps und auf 4x stehen ?
Wenn ja, weiss jemand wie ich das ändern kann ?

e3adaaa22e3e12b4825c80d84c303bd7 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Dobby
LÖSUNG 21.02.2016, aktualisiert um 04:04 Uhr
Hallo zusammen,

Die SSD sollte bis zu 2500MB/s lesen und bis zu 1500MB/s schreiben.
Es handelt sich hier um eine PCIe 3.0 x4 M.2 SSD und Du hast leider nur einen PCIe 2.0 x2
M.2 Slot zur Verfügung also kann die gesamte Power der M.2 SSD nicht entfesselt und genutzt werden.

Das ich diese Werte nicht erreiche ist klar, aber so weit unter den angegebenen Werten ?
Ja die sind in der Tat eher schxxße, aber dann würde ich mal fragen was denn genau noch
an den SATA Ports und PCIe Slots angeschlossen worden ist.

Wird auch direkt von einem Lüfter angeblasen, das Thermal Throtteling ist nicht die Bremse.
Gut, das sollte dann aber immer noch nicht die schlechten Werte erklären!

Der Samsung NVMe Driver ist auch installiert. Chipsatztreiber sind auch auf dem Neuesten Stand.
Das ist auch richtig so herum, aber dann erklärt immer noch nicht die schlechten Werte die wir sehen!

Da wird wohl eher ein Board mit einem PCIe 3.0 x4 M.2 Slot benötigt um die gesamte Power
der M.2 SSD zu bestaunen zu können und Du hast eben nur PCIe 2.0 x2 am Start und somit wohl
auch nur die halbe Power zur Verfügung.

Wenn ja, weiss jemand wie ich das ändern kann ?
Ja da sollte man mal in das Handbuch schauen manchmal teilt sich der M.2 Slot auch die gesamte
Bandbreite mit einem oder mehreren PCIe Slots und/oder einem oder mehreren SATA Ports.

Gruß
Dobby
Bitte warten ..
Mitglied: Henere
21.02.2016, aktualisiert um 04:18 Uhr
Hi Dobby,

ja das scheint das Problem zu sein. Ich habe noch in anderen Foren um Hilfe gebeten und habe dann weitere Infos gefunden.
Intel (die #**9323!!!) unterstützen mit dem Chipsatz und dem M.2-Port nur PCIe 2.0x2
Aus dem Handbuch: "This motherboard features the M.2 slot which shares bandwidth with the SATA 6Gb/s port
and PCI-E Gen2 x2 and is dedicated only to the operating system"
Somit "fährt" die SSD nur mit "Viertel-Gas" ... also weit unter dem, was sie könnte.
Abhilfe wird wohl nur in Form eines Adapters möglich sein.
Den hier hab ich im Moment gefunden.
http://www.asus.com/Motherboard-Accessories/HYPER_M2_X4_MINI_CARD/
Aber ober der auch vom 612er Chipsatz unterstützt wird (was ich aber glaube) muss ich noch abklären.

Der M.2 belegt einen der 10 SATA-Ports, aber darauf konnte ich verzichten.
Bitte warten ..
Mitglied: Dobby
21.02.2016 um 04:33 Uhr
Den hier hab ich im Moment gefunden.
http://www.asus.com/Motherboard-Accessories/HYPER_M2_X4_MINI_CARD/
Aber ober der auch vom 612er Chipsatz unterstützt wird (was ich aber glaube) muss ich noch abklären.
Kein Thema, ließ mal die nächste Zeile:
Support ASUS Z170/H170/X99/Z97/H97/B85 series motherboard models
Also wenn Du ein X99 Board hast wird es unterstützt und der Adapter ist auch für
PCIe 3.0 x4 ausgelegt und dann sollte die M.2 SSD auch voll loslegen können.
Werden ja auch alle längen unterstützt von 2230 (30 mm) bis 22110 (110 mm).

Den würde ich auch kaufen wollen, aber bei mir läuft die Samsung950 Pro gut auf einem
ASUS X99-E WS / USB 3.1, das hat gleich einen PCIe 3.0 x4 M.2 Slot gehabt.

Nur die Thunderboltkarte kann ich noch nicht testen, da das NAS dazu noch fehlt noch, aber
dann brauche ich keine extra HDD/SSDs mehr einbauen, alles auf dem TB NAS und gut.

Von daher ist die Samsung950 Pro schon die richtige Überlegung denke ich.
Kannst ja mal schreiben was Du dann für Werte hast, wenn die Karte eingebaut ist.

Gruß
Dobby
Bitte warten ..
Mitglied: Henere
21.02.2016 um 15:56 Uhr
Ich hab mal geklotzt statt gekleckert und mir hauptsächlich wegen dem M.2 Slot das hier gekauft:
https://www.asus.com/de/Motherboards/Z10PED16_WS/

Ja sobald ich jemanden gefunden habe, der das Teil liefern kann (Bei Asus kann man es scheinbar nicht direkt bestellen) dann wird sofort nach dem Einbau der Benchmark angeworfen. Ich hab schon Bilder gesehen mit über 2200MB/s lesend.

Grüße, Henere
Bitte warten ..
Mitglied: Dobby
22.02.2016 um 14:36 Uhr
Zitat von Henere:

Ich hab mal geklotzt statt gekleckert und mir hauptsächlich wegen dem M.2 Slot das hier gekauft:
https://www.asus.com/de/Motherboards/Z10PED16_WS/

Ja sobald ich jemanden gefunden habe, der das Teil liefern kann (Bei Asus kann man es scheinbar nicht direkt bestellen) dann wird sofort nach dem Einbau der Benchmark angeworfen. Ich hab schon Bilder gesehen mit über 2200MB/s lesend.

Grüße, Henere
Für ~40 € & Versandkosten kann man den ASUS Hyper M.2 x4 mini hier bei www.CaseKing.de bestellen.
Ich habe den einfach mal verlinkt.

Gruß
Dobby
Bitte warten ..
Mitglied: Henere
22.02.2016 um 14:46 Uhr
Genau da habe ich bestellt, ist der einzige in DE der im Moment liefern kann.... wobei... Ware ist auch bei denen im Zulauf, soll heute oder morgen reinkommen. Alternate kann das Teil erst ab Mitte März liefern. Sonst bleibt ein Ebay Anbieter in UK oder USA.

Danke und Grüße, Henere
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
Suche richtig schlechte SSD und HDD (33)

Frage von Hyperion69 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
Performance Problem mit SSDs im RAID 5 (13)

Frage von p-m-a-d-m-i-n zum Thema Festplatten, SSD, Raid ...

Server
Freenas schlechte Schreib Performance bei NFS (17)

Frage von janosch12 zum Thema Server ...

Netzwerkmanagement
Schlechte Performance im Heimnetz - Optimierungsmöglichkeiten (39)

Frage von Matthias182 zum Thema Netzwerkmanagement ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
gelöst Raid-Controller (Areca) Datenverlust trotz R5 (16)

Frage von sebastian2608 zum Thema Festplatten, SSD, Raid ...

Windows Netzwerk
DNS ins mehreren Subnetzen (11)

Frage von joerg zum Thema Windows Netzwerk ...

Server-Hardware
Starker PC zum Virtualisieren (10)

Frage von canlot zum Thema Server-Hardware ...

Server-Hardware
HP ProLiant DL380 G7, POST Error: 1785-Drive Array not Configured (10)

Frage von Paderman zum Thema Server-Hardware ...