Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Script funktioniert auf einmal nicht mehr

Frage Entwicklung PHP

Mitglied: Homer99

Homer99 (Level 1) - Jetzt verbinden

21.04.2006, aktualisiert 26.04.2006, 4092 Aufrufe, 5 Kommentare

Hallo,

seid einiger Zeit kann ich aus meinem Script keine Newsletter mehr verschicken.
Ich glaube bei meinen Provider wurde die Software getauscht, denn zuvor hat alles jahrelang geklappt.
Jetzt ist MySQL 4.1.12 und phpMyAdmin 2.8.0 installiert.

So nun zum Problem: Ich gebe im Admin-Formular den Betreff und den Text ein. Klicke ich auf absenden, werden die Newsletter versendet, aber ohne den Text(Betreff wird übernommen). Also erhalten die User eine Mail mit Absender und Betreff aber leeren Textfeld.

Und ich erhalte vom Script folgende Meldung:

Warning: ereg_replace(): Invalid preceding regular expression in /home/.sites/68/site404/web/Programm/admin/newsletter2.php on line 55

Warning: ereg_replace(): Invalid preceding regular expression in /home/.sites/68/site404/web/Programm/admin/newsletter2.php on line 56

Warning: ereg_replace(): Invalid preceding regular expression in /home/.sites/68/site404/web/Programm/admin/newsletter2.php on line 57

Warning: ereg_replace(): Invalid preceding regular expression in /home/.sites/68/site404/web/Programm/admin/newsletter2.php on line 58

Warning: ereg_replace(): Invalid preceding regular expression in /home/.sites/68/site404/web/Programm/admin/newsletter2.php on line 59

Hier der Script-Teil: die 4.Zeile ist die line 55

$result=mysql_query("select id, name, prename, password, email from V4_accounts $pu");
while($zeile=mysql_fetch_row($result)) {
$text=$mailtext;
$text=ereg_replace("{password}",$zeile[3],$text);
$text=ereg_replace("{vorname}",$zeile[2],$text);
$text=ereg_replace("{name}",$zeile[1],$text);
$text=ereg_replace("{login}",$zeile[4],$text);
$text=ereg_replace("{link}","$script_url/_p.php?userid=$zeile[0]&mailid",$text);
mail("$zeile[4]","$betreff","$text","From: $seitenname <$adminmail>");

Hatte vielleicht auch jemand dieses Problem? Wäre für jede Hilfe dankbar!
Mitglied: Dani
21.04.2006 um 21:01 Uhr
Hi,
probier das hier mal. Hab's in meinen Stil mal umgeschrieben. Vielleicht gehts so:

01.
$sql="SELECT id, name, prename, password, email FROM V4_accounts $pu;"; 
02.
$result=mysql_query($sql); 
03.
while($row=mysql_fetch_object($result)) 
04.
05.
  $text=$mailtext; 
06.
   
07.
  $text=ereg_replace("{password}",$row->password,$text);  
08.
  $text=ereg_replace("{vorname}",$row->prename,$text); 
09.
  $text=ereg_replace("{name}",$row->name,$text); 
10.
  $text=ereg_replace("{login}",$row->email,$text); 
11.
  $text=ereg_replace("{link}","$script_url/_p.php?userid=$row->id&mailid",$text); 
12.
13.
  
14.
mail("$row->email","$betreff","$text","From: $seitenname <$adminmail>");
Kl. Hinweis:
Leerzeichen in Tabellen oder Banknamen ist ganz schlecht (V4_accounts $pu)!!!


Gruß
DAni
Bitte warten ..
Mitglied: Homer99
21.04.2006 um 21:57 Uhr
Funktioniert leider nicht,
gibt die gleiche Fehlermeldung aus, nur das er jetzt gar keine Mails mehr verschickt!
Bitte warten ..
Mitglied: Homer99
26.04.2006 um 11:29 Uhr
Danke für die Hilfe. Problem gelöst!
Bitte warten ..
Mitglied: Dani
26.04.2006 um 11:37 Uhr
Hi,
an was hat es gelegen?!


Gruß
Dani
Bitte warten ..
Mitglied: Homer99
26.04.2006 um 11:42 Uhr
Hallo,

ich habe die Intervalloperatoren "{password}" maskiert, "\{\?password\}
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Batch & Shell
gelöst Powershell Datei kopieren mit ACL Script funktioniert nicht (4)

Frage von xpxy15 zum Thema Batch & Shell ...

Batch & Shell
Systemvariable funktioniert im Script nicht (4)

Frage von miczar zum Thema Batch & Shell ...

Exchange Server
gelöst Senden Als funktioniert auf einmal nicht mehr (8)

Frage von salixhorigan zum Thema Exchange Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...