Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SCSI-Scanner wird nur unter bestimmten Voraussetzungen erkannt

Frage Hardware Drucker und Scanner

Mitglied: da-brain

da-brain (Level 1) - Jetzt verbinden

21.09.2006, aktualisiert 14:27 Uhr, 7185 Aufrufe, 8 Kommentare

Scanner mus vor dem Bootvorgang eingeschaltet sein um ihn nutzen zu können.

Hallo,

ich habe im Netzwerk einen Computer der für alle Mitarbeiter verwendet werden kann um Grafiken zu erzeugen oder zu bearbeiten.
An diesem Rechner ist ein SCSI-Scanner aus "vergangenen" Tagen angeschlossen, ein Microtek ScanMaker4. Dieser war vorher auch schon im Betrieb an einem Windows NT-System. Da es sich um ein SCSI-Scanner handelt ist beim Umzug die SCSI-Karte aus der NT-Kiste gleich mitgewandert, eine Adaptec AIC-7850.

Das neue System hat ein ASUS A8N32-SLI-Mainboard mit ´nem Athlon 64 X2 Prozessor und drauf läuft Windwos XP SP2.

Das Problem ist nun folgendermaßen:
Wenn der Scanner eingeschaltet ist und danach das system gebootet wird funktioniert Alles einwandfrei. Probleme gibt es jedoch wenn der Scanner erst nach dem System eingeschaltet wird. Meine Vermutung war die SCSI-ID, jedoch komm ich in kein SCSI-BIOS von der Adaptec-Karte (hat die überhaupt eins???). Der Scanner wurde trotz das am Gerät selbst die ID 6 eingestellt war unter Windows bzw. dem Microtek SCSI-ScanTool unter der ID 0 geführt. Also hab ich die ID vom Scanner auch auf 0 eingestellt -> ohne Erfolg.
So eine Art Abhilfe gibt es aber: Wenn man unter Windows die Hardwareerkennung durchführt und dann sagt "Ja, das Gerät ist angeschlossen!" und ihn nun noch darauf aufmerksam macht das es sich um den eigentlich installierten Scanner handelt, funktioniert dieser danach auch. Nach dieser Prozedur kann ich den Scanner auch wahllos Ein- bzw. Ausschalten oder einen anderen Benutzer anmelden etc. Ich kann diese Prozedur jedoch nur als Admin durchführen. Die User welche eigentlich an dieser Arbeitsstation "tüfteln" haben einen eingeschränkten Zugang an dem möchte ich auch nur ungern etwas tun.

Hat jemand eine Idee, wie man dem ganzen abhilfe schaffen kann?

Es riecht meiner Meinung nach immer noch sehr nach einer fehlerhaften Initialisierung der SCSI-Karte bzw. der angeschlossenen Geräte.

Vielen Dank im Vorraus.

mfG da_brain
Mitglied: filippg
21.09.2006 um 13:34 Uhr
Hallo,

ist SCSI denn Hotplug fähig? Meines Wissens nach nicht. Somit käme dein Tip mit der fehlerhaften Initialisierung schon hin, wenn beim Booten kein Gerät erkannt wird, wird es nicht initialisiert, und eine Überwachung der Schnittstelle, um später zu initialisieren ist nicht vorgesehen.
Ich hatte übrigens mal genau das selbe Problem und habe es dann mit einem Stück Papier gelöst. Es klebte am Computer und es stand drauf "Wenn der Scanner benutzt werden soll, so muss dieser vor dem Hochfahren des Computers angeschaltet werden" .

Filipp

Btw: es gibt SCSI Hot-Swap - Platten. Aber das heisst ja nicht, dass SCSI an sich Hotplug fähig ist, genauso gibt es auch IDE Hot-Swap - Platten.
Bitte warten ..
Mitglied: leknilk0815
21.09.2006 um 13:41 Uhr
Hi,
das Problem liegt keinesfalls an der SCSI- ID, solange Du die nicht auf 7 setzt (das ist der HBA selber). Ins Menü kommst Du bei jedem Adaptec mit "CTRL+A" beim booten, falls der Kontroller nicht sichtbar ist, einfach mehrmals drücken. Ist aber, wie gesagt, egal, solange nicht mehrere Geräte angeschlossen sind.
Das Problem dürfte sein, daß XP nicht weiß, daß ein ausgeschalteter Scanner am HBA hängt, wenn es hochgefahren wird. Und wenn die User keine Rechte zur HW- Installation haben, gehts eben nicht. Das gleiche Problem müsste auftauchen, wenn ein User ein USB- Gerät anschließt. Auch das müsste fehlschlagen.
Leider kann ich Dir aber nicht sagen, ob es hierfür eine Lösung gibt, ich denke aber schon. Vielleicht kann hier ja am Beispiel USB jemand "aushelfen".

Gruß - Toni

EDIT:
Das was Filipp schreibt, hat was. Ich bin mir auch nicht sicher, ob XP Änderungen am SCSI- Bus im eingeschalteten Zustand mitbekommt.
Aber wieso lasst ihr das Ding nicht einfach laufen? Soo viel Strom frisst der Scanner auch nicht, und der "Hauptsauger", nämlich das Steckernetzteil, ist vermutlich sowieso dauernd an...
Bitte warten ..
Mitglied: DaSam
21.09.2006 um 13:54 Uhr
Hi,

unter NT konnte man den SCSI Controller nochmals scannen lassen - das hat auch gut mit den Scannern geklappt. Versuch doch mal testhalber, in den Eigenschaften des Arbeitsplatzes bei der Hardware im SCSI-Controller nach geänderter Hardware zu suchen, nachdem der Scanner eingeschaltet wurde.

cu,
Alex
Bitte warten ..
Mitglied: leknilk0815
21.09.2006 um 14:02 Uhr
mit HW - Scan findet er den Scanner auf jeden Fall, die Frage ist, ob er das automatisch auch mitbekommt.

Gruß - Toni
Bitte warten ..
Mitglied: da-brain
21.09.2006 um 14:14 Uhr
Ich wollte es halt eigentlich eleganter lösen, hab aber, das muss ich gestehen, auch schon über die Zettelmethode nachgedacht ;o)

Danke erstmal für die Mühe
Bitte warten ..
Mitglied: da-brain
21.09.2006 um 14:18 Uhr
Das Ding einfach laufen lassen? Ich hätte da Bedenken hinsichtlich der Lebenszeit des Scanners. Gibt´s da Aussagen drüber???
Bitte warten ..
Mitglied: da-brain
21.09.2006 um 14:20 Uhr
Ja, genau - wie schon im ersten Beitrag geschrieben, nach dem HW-Scan funktioniert der Scanner und wird auch entsprechend initialisiert. Da gibt es keine Probleme - aber wie kann man das automatisieren, wenn das überhaupt möglich ist ;o)
Bitte warten ..
Mitglied: leknilk0815
21.09.2006 um 14:27 Uhr
wenn Du den rechner ohne Scanner hochfährst, Dich anmeldest und dann den Scanner einschaltest, tut sich da was oder muß man erst einen HW- Scan anwerfen, damit er den Scanner findet?
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
PCIe SSD wird nicht erkannt (6)

Frage von miichiii9 zum Thema Festplatten, SSD, Raid ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...