Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SD Karte Partionieren - klappt nicht

Frage Hardware Speicherkarten

Mitglied: BigSnakeye

BigSnakeye (Level 1) - Jetzt verbinden

06.05.2014 um 07:37 Uhr, 9872 Aufrufe, 19 Kommentare

Hallo!
Ich habe eine Sandisk Micro SD Karte mit 64-GB.

Für mein Samsung Galaxy Note 10.1 wollte ich sie partitionieren. Dafür verwendete ich das neueste gparted. Es sollte zunächst eine NTFS Partition und dann eine ca. 2GB große EXT4 Partition (für Link2SD) eingerichtet werden.

Doch das will nicht klappen. Erstelle ich die NTFS Partition, wird sie als fehlerhaft angezeigt. Dann die ext4 Partition, die wird dann überhaupt nicht erkannt. Mache ich es umgekehrt (zuerst ext4, dann NTFS), dann wird die ext4 erkannt, die NTFS aber garnicht.

Egal was ich mache, es werden keine 2 Partitionen als "OK" erkannt. Es gibt immer Probleme.

Was passiert da?
Mitglied: Lochkartenstanzer
06.05.2014, aktualisiert um 08:05 Uhr
Zitat von BigSnakeye:

Egal was ich mache, es werden keine 2 Partitionen als "OK" erkannt. Es gibt immer Probleme.

Und das OS, unter dem Du das partitionierst ist welches?

Oder machst Du das mit dem Tab selbst?

lks
Bitte warten ..
Mitglied: BigSnakeye
06.05.2014 um 08:31 Uhr
Es ist eine gparted live cd - also Linux.
Bitte warten ..
Mitglied: Lochkartenstanzer
06.05.2014 um 08:35 Uhr
Zitat von BigSnakeye:

Es ist eine gparted live cd - also Linux.

Tauchen die Ferhler nur auf dem Tab auf oder auch unter Linux?

lks
Bitte warten ..
Mitglied: BigSnakeye
06.05.2014 um 08:45 Uhr
Der Tab erkennt die Partitionen nicht, Linux meldet die o.g. Fehler.
Bitte warten ..
Mitglied: Lochkartenstanzer
06.05.2014, aktualisiert um 08:47 Uhr
Zitat von BigSnakeye:

Der Tab erkennt die Partitionen nicht, Linux meldet die o.g. Fehler.

Hast Du geprüft, ob die Karte überhaupt in Ordnung ist oder Dein Kartenleser die 64GB-Karte überhaupt ordentlich lesen kann?

das kannst Du z.B. mit h2testw von der c't machen. oder mit md5sum/shasum zusammen mit ddrescue.
lks
Bitte warten ..
Mitglied: BigSnakeye
17.05.2014 um 13:19 Uhr
Hi, du hast Recht. Ich habe den h2testw durchlaufen lassen und nach einiger Zeit zeigt er Fehler:
01.
Achtung: Nur 61680 von 62719 MByte getestet. 
02.
Der Datenträger ist wahrscheinlich defekt. 
03.
6,9 GByte OK (14608863 Sektoren) 
04.
12,9 GByte DATEN VERLOREN (27110945 Sektoren) 
05.
Details: 
06.
0 KByte überschrieben (0 Sektoren) 
07.
0 KByte leicht verfälscht (< 8 Bit/Sektor, 0 Sektoren) 
08.
12,9 GByte mit Datenmüll (27110945 Sektoren) 
09.
0 KByte mehrfach genutzt (0 Sektoren) 
10.
Erster Fehler bei Offset: 0x00000001bdd3be00 
11.
Soll: 0x00000001bdd3be00 
12.
Ist: 0x61b3be8cbabb8688 
13.
H2testw Version 1.3
Bitte warten ..
Mitglied: BigSnakeye
18.05.2014 um 15:26 Uhr
Eine 8GB micro SDHC Karte kann ich ohne Probleme partitionieren und verwenden.
Bitte warten ..
Mitglied: Lochkartenstanzer
18.05.2014 um 16:03 Uhr
Zitat von BigSnakeye:

Eine 8GB micro SDHC Karte kann ich ohne Probleme partitionieren und verwenden.

Dann soltlest Du prüfen, ob der Kartenleser nur 8 GB kann, oder ob tatsächlich die 64GB-Karte kaputt ist.

lks
Bitte warten ..
Mitglied: BigSnakeye
18.05.2014 um 18:30 Uhr
Ich habe mit der Karte einen microSD auf SD Kartenadapter erworben (war im set). Original von Sandisk. Ich habe einen normalen USB Stick-Reader mit SD Kartenslot. So einen wie den hier:
http://www.ebay.de/itm/USB-Stick-Kartenlesegerat-f-SD-SDHC-Speicherkart ...

Zudem habe ich noch einen für micro SD Karten. Möglicherweise hast du Recht... es ist eine SDXC und nicht SDHC Karte. Aber sie wird immerhin erkannt und lässt sich partitionieren - nur halt mit Fehlern. Mein Galaxy Tablet erkennt sie auch vollständigt und formatiert die Karte, jedoch auch nur eine Partition. Über den Recovery CWM kann ich nichts formatieren. Ich hatte mir eine weitere (identische) 64GB SDXC bestellt und warte bis sie kommt. Mal sehen was dann rauskommt.
Bitte warten ..
Mitglied: BigSnakeye
30.05.2014, aktualisiert um 08:36 Uhr
Hi,
das ist aber total verrückt. Ich habe mir jetzt folgendes besorgt:
- 2 verschiedene 32GB Karten
- 1 andere 64GB SDXC Karte
- 2 verschiedene SDHC/SDXC Kartenleser
- einen anderen Windows 7 Rechner

Trotzdem kann ich die 2. Partition nicht erstellen. Beim MiniTool Partition Wizard Home Edition v8.1.1 heißt es nach der Formatierung der 2. Partiton "Other" da wo "ext4" (oder ext2,ext3,fat32,ntfs) stehen sollte. Ich habe alle Formate durchprobiert. Die Karten können nicht alle kaputt sein.

Egal ob mit den Minitool oder mit gParted - immer ist das Problem gleich. gParted sagt mir einfach "unknown" bei der Partition. Die Wahl der Eigenschaften dieser Partition - "other" - im Minitool identifiziert sie als 0x83 FileSystem.

Doch dann habe ich folgendes gemacht da ich ein Verdacht hatte. Ich löschte die (32GB) Karte wieder komplett und erstellte am Anfang eine ganz kleine primäre Partition (egal was, ich verwendete aber ntfs) in ntfs. Dahinter eine ebenfalls ganz kleine in ext4. Und plötzlich hatte es geklappt.

073544ce8201723fe7dcef088116cfd0 - Klicke auf das Bild, um es zu vergrößern

Ich vermute ein Problem mit den Speicher, doch irgendwie seltsam, denn nirgendwo (und ich habe fast unendlich viele Artikel und Forendiskussionen dazu durch-/ bzw. angelesen) wird davon gesprochen, daß Speicher evtl. ein Problem sein kann (?!). Mein Rechner hat 8GB DDR3 RAM. Das müsste doch eigentlich ausreichend sein. Alle Programme bis auf das Minitool sind abgeschaltet. Ich habe noch über 3,8-4,1GB RAM zur Verfügung während ich das mache.

Was ist eigentlich los hier? Das Problem habe ich auf beiden Rechnern, der andere hat nur 4GB RAM.
Bitte warten ..
Mitglied: Lochkartenstanzer
30.05.2014 um 09:50 Uhr
Zitat von BigSnakeye:

Ich vermute ein Problem mit den Speicher, doch irgendwie seltsam, denn nirgendwo (und ich habe fast unendlich viele Artikel und
Forendiskussionen dazu durch-/ bzw. angelesen) wird davon gesprochen, daß Speicher evtl. ein Problem sein kann (?!). Mein
Rechner hat 8GB DDR3 RAM. Das müsste doch eigentlich ausreichend sein. Alle Programme bis auf das Minitool sind abgeschaltet.
Ich habe noch über 3,8-4,1GB RAM zur Verfügung während ich das mache.

Überprüfe den Kartenleser.

lks
Bitte warten ..
Mitglied: BigSnakeye
30.05.2014, aktualisiert um 10:00 Uhr
Wie? Ich habe mir 2 verschiedene neue Kartenleser angeschafft die angeblich bis 64GB lesen und schreiben können - siehe oben. Beide erkennen und lesen die Karte, ich kann eine Partition fehlerfrei damit erstellen. Aber nicht zwei - außer so wie oben auf dem Bild. Das verschieben, vergrößern klappt dann aber auch nicht. Ich hatte sogar 3 Partitionen erstellt, aber weiter bringt es mich nicht.

Insgesamt habe ich 4 verschiedene Kartenleser ausprobiert. Doch es war immer das gleiche. Die Karten habe ich mit und ohne SD Kartenadapter getestet - kein Unterschied.
Bitte warten ..
Mitglied: BigSnakeye
30.05.2014 um 10:20 Uhr
So sieht es übrigens aus, wenn ich so formatiere wie ich möchte (mit 64GB Karte hier) - 87503daf1068b69a25f3a7cf3a5242e6 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Lochkartenstanzer
30.05.2014 um 14:01 Uhr
Zitat von BigSnakeye:

Insgesamt habe ich 4 verschiedene Kartenleser ausprobiert. Doch es war immer das gleiche. Die Karten habe ich mit und ohne SD
Kartenadapter getestet - kein Unterschied.

Hast Du gparted unter wndows benutzt oder von einer linux-live-CD (knopopix o.ä)

lks
Bitte warten ..
Mitglied: BigSnakeye
30.05.2014 um 20:35 Uhr
Ich habe die Live CD benutzt - neueste Version.
Bitte warten ..
Mitglied: BigSnakeye
01.06.2014 um 08:15 Uhr
Ich weiß nicht mehr weiter. Meine 64GB SDXC microSD Karte ist von Sandisk, meine 32GB SDHC Karten sind von Kingston. Ich habe jetzt schon 4 verschiedene microSD->SD Adapter, mehrere USB Kartenleser, einen eingebauten SD Kartenleser (Notebook), MiniTool Partition Wizard unter Windows 7 und LiveCD mit gParted ausprobiert. Nichts hilft. Ich kriege es nicht hin die ganze Karte mit 2 Partitionen zu belegen. Ab einem bestimmten Punkt kann keine korrekte 2. Partition erstellt werden.

Ich habe die microSD 32GB Karte mit H2testw geprüft:
01.
Fehler beim Lesen der Datei 'E:\13.h2w', Offset 0x14b00000. 
02.
(Das System kann die angegebene Datei nicht finden. Code 2) 
03.
Der Datenträger ist wahrscheinlich defekt. 
04.
7,7 GByte OK (16218599 Sektoren) 
05.
4,5 GByte DATEN VERLOREN (9625113 Sektoren) 
06.
Details: 
07.
0 KByte überschrieben (0 Sektoren) 
08.
0 KByte leicht verfälscht (< 8 Bit/Sektor, 0 Sektoren) 
09.
4,5 GByte mit Datenmüll (9625113 Sektoren) 
10.
0 KByte mehrfach genutzt (0 Sektoren) 
11.
Erster Fehler bei Offset: 0x00000001eef3ce00 
12.
Soll: 0x00000001eef3ce00 
13.
Ist: 0x69d1486bc0f083e0 
14.
H2testw Version 1.3 
15.
Schreibrate: 5,54 MByte/s 
16.
Leserate: 15,7 MByte/s 
17.
H2testw v1.4
Aber ich kann sie mit einer Partition problemlos formatieren und benutzen.
Bitte warten ..
Mitglied: BigSnakeye
01.06.2014 um 17:54 Uhr
Ich glaube, ich habs - möglicherweise zerstört ein microSD zu SD Adapter die Karten. Gibt es eventuell ein Tool um solche Karten zu reparieren? h2testw hat bei allen von mir benutzten Karten, welche keine 2. Partition erstellen wollten, Fehler gefunden. Außer bei der 8GB microSD Karte.
Bitte warten ..
Mitglied: Lochkartenstanzer
01.06.2014, aktualisiert um 20:03 Uhr
Zitat von BigSnakeye:

Ich glaube, ich habs - möglicherweise zerstört ein microSD zu SD Adapter die Karten. Gibt es eventuell ein Tool um
solche Karten zu reparieren? h2testw hat bei allen von mir benutzten Karten, welche keine 2. Partition erstellen wollten, Fehler
gefunden. Außer bei der 8GB microSD Karte.

Kann es sein, daß Dein Adapter eine Macke hat udn keine allzu-großen Karten mag? Nimm mal eine normale SD-Karte und keinen MicroSD mit Adapter oder gleich einen MicroSD-Kartenleser, wie z.B. den hier.

lks
Bitte warten ..
Mitglied: BigSnakeye
02.06.2014, aktualisiert um 18:12 Uhr
Ich habe jetzt noch eine andere 64GB Karte von AData aufgetrieben und mit den Cardreader, aber mit einem anderen Adapter formatiert. Damit klappte es. Doch die anderen Karten sind alle hin - sie wollen auch mit den anderen Adapter nicht formatiert/partitionert werden.
Bitte warten ..
Ähnliche Inhalte
Speicherkarten
Micro SD Karte - Schreibschutz
Frage von MaclcleLSpeicherkarten3 Kommentare

Hallo Leute =) Ich habe ein Problem mit meiner neu erworbenen SD Karte. Als ich sie in mein Lenovo ...

Windows 10
Upgrade über SD Karte
gelöst Frage von DogukannWindows 109 Kommentare

Hallo, ich will es kurz fassen und sofort zur frage kommen. Ich habe einen Dell Venue 8 Pro mit ...

Linux Netzwerk
Raspberry Sd Karte schützen
Frage von raspiNullLinux Netzwerk16 Kommentare

Hallo ich habe einen Raspberry und verwende einige Sachen von! Leider habe ich das Problem das meine SD Karte ...

Batch & Shell
Überprüfen, ob SD-Karte im Laufwerk ist
gelöst Frage von kaeptenbleiBatch & Shell9 Kommentare

Hallo zusammen, ich muss Euch mal wieder nerven, ich verzweifele daran, mit hilfe einer Batch, zu überprüfen, ob eine ...

Neue Wissensbeiträge
Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 11 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 15 StundenRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 3 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Heiß diskutierte Inhalte
Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Vmware
DOS 6.22 in VMWare mit CD-ROM
gelöst Frage von hesperVmware10 Kommentare

Hallo zusammen! Ich hab ein saublödes Problem. Es ist eine VMWare mit DOS 6.22 zu erstellen auf dem ein ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Cloud-Dienste
PIM als SaaS Nutzungsgebühr
Frage von vanTastCloud-Dienste8 Kommentare

Moin, wir haben uns ein PIM (Product Information Management) nach unseren Ansprüchen für viel Geld als SaaS-Lösung bauen lassen. ...