Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Server 2008 R2 Ldap - Apache Auth.

Frage Linux Apache Server

Mitglied: Marco-83

Marco-83 (Level 1) - Jetzt verbinden

08.07.2010 um 16:02 Uhr, 5939 Aufrufe, 4 Kommentare

Ldap Abfrage Windows Server 2008 R2 v2 v3

Hallo zusammen,
ich habe hier ein etwas merkwürdiges Problem. Vielleicht hat ja jemand schnell eine Antwort parat. Wir nutzen im Netzwerk bei uns einige Tools wie z.B ein Wiki eine selbt pragrammierte Projektdatenbank die zur Benutzer Authentifizierung unseren Ldap Server (Server 2008 R2) abfragen. Soweit so gut. Funktioniert auch alles. Jetzt bin ich grad dabei Subversion auf Ldap Authentifizierung umzuschalten. Konfiguration ist soweit fertig, und ein Kollege von mir hat es auf einer virtuellen umgebung getstet (dort funktioniert es). Doch bei uns in der Produktiv Umgebung macht es Ärger. Scheinbar gibt unser Server nicht die richtigen Informationen raus. Wenn ich auf dem Testserver mit Ldap Explorer eine Anfrage Starte mit z.B Server= Unser Server DC=meinedomain,DC=local dann bekomme ich den Inhalt unseres AD's zu sehen. Benutzer, Ou's,Gruppen usw usw. Passt. Im Ldap Explorer ist Ldap v3 ausgewählt. Mache ich genau die gleiche Anfrage an unseren Produktiv Server, dann bekomme ich keinen Baum angezeigt. Stelle ich jedoch den Ldap Explorer auf Ldap v2 um funktioniert es. Gibt es eine Möglichkeit die Ldap Version am Server einzustellen oder hängt das mit dem Domänen Schema zusammen ? Unser AD Schema ist 47.

Danke für eure Hilfen
Mitglied: uran246
08.06.2011 um 09:10 Uhr
Hallo,

ich bin am gleichen Problem. Hast Du auch CentOS im Einsatz?

Grüße aus Chemnitz

URan
Bitte warten ..
Mitglied: Marco-83
08.06.2011 um 09:27 Uhr
Hi,

ich konnte das Problem lösen. Und zwar über den Ldap Port 389 anfragen.

Hier eine Ausschnitt aus meiner Konfiguration:

<Location /svn/>
DAV svn
SVNParentPath "D:\SVN_Repos"
SVNReposName "CollabNet Subversion Repository"
SVNListParentPath On
AuthType Basic
AuthName "HST Subversion Repositories"
#AuthBasicProvider ldap-users
AuthBasicProvider ldap
AuthLDAPURL "ldap://filesrv1.systemtechnik.local:3268/OU=2 HST Benutzer,DC=SYSTEMTECHNIK,DC=LOCAL?sAMAccountName"
AuthLDAPBindDN "CN=wiki,OU=intern,DC=SYSTEMTECHNIK,DC=LOCAL"
AuthLDAPBindPassword "deinpasswort"
require ldap-group cn=svn-allgemein,OU=Subversion,DC=Systemtechnik,DC=local
</Location>
Bitte warten ..
Mitglied: uran246
08.06.2011 um 09:29 Uhr
Vielen Dank werde ich gleich mal testen!

Danke Uran
Bitte warten ..
Mitglied: uran246
08.06.2011 um 09:31 Uhr
You are the BEST!!!


Danke hast mir viel Arbeit erspart!

Beste Grüße

URan
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (13)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...