Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SMC GS 10C-Switch und tagged VLANs

Frage Netzwerke LAN, WAN, Wireless

Mitglied: chiefteddy

chiefteddy (Level 2) - Jetzt verbinden

27.08.2014, aktualisiert 14:19 Uhr, 1720 Aufrufe, 4 Kommentare

Hallo,

ich habe ein Problem mit der Konfiguration von taggeg VLANs auf einem SMC GS-10C Switch aus der Web-Smart-Serie EZ-Switch von SMC Networks.

Scenario: Zentraler L3-Gigabit-Switch (Dell PowerConnect 7048); mehere geroutete VLANs (für unterschiedliche Abteilungen, Gäste-WLAN usw), einige entferntere Abteilungen sind mit eigenen Abteilungs-Switchen (VLAN-fähig) ausgestattet

Diese Abteilungs-Switche sind über einen LWL-Link an den zentralen Switch angeschlossen. Da an den Abteilungs-Switchen auch WLAN-AccessPoints mit Multi-SSID-Funktion (Abteilungs-WLAN, Gäste-WLAN) angeschlossen sind, sind die Links zum zentralen Switch als tagged VLAN konfiguriert. Das funktioniert auch problemlos.

Nun soll eine weitere kleine Abteilung (Meisterbüro in einer Werkstatt) angeschlossen werden. Dazu soll obiger SMC-Switch genutzt werden.

Nun mein Problem:

Ich konfiguriere den SMC GS-10C "nach besten Wissen" mit einem tagged Port als Uplink zum zentralen Switch und die anderen Ports als untagged in den jeweiligen VLANs. Ich bekomme aber keine Verbindung zum zentralen Switch.

Tausche ich den SMC-Switch gegen einen anderen (alten) VLAN-fähigen Switch aus (HP, ATI), funktioniert alles.

Setze ich den Uplink auf untegged für das zugehörige Abteilungs-VLAN (auf beiden Seiten), funktioniert auch alles.

Hat jemand Erfahrung mit der Konfiguration der SMC-Switche aus der EZ-Serie (SMC GS-10C, -18C, -26C und -50C) und kann mir einen Tipp geben.

Danke.

Jürgen

SMC: Firmware-Stand
aa310b9c8c7e80174f128c6336024164 - Klicke auf das Bild, um es zu vergrößern

Untagged Konfiguration

Dell: VLAN 100 Port 48 untagged
2c95e217cdbf78b5c1c444ef7a6e4093 - Klicke auf das Bild, um es zu vergrößern

Dell: VLAN 350 Port 48 nicht Mitglied
ce2bcfe4823957172cdaad3af0477515 - Klicke auf das Bild, um es zu vergrößern

Dell: Konfiguration Port 48
d5f7216dc210d425152d3f0666e95275 - Klicke auf das Bild, um es zu vergrößern

SMC: Portzuordnung (Port 9 --> Uplink)
40012f16eab36627c723456d2e266938 - Klicke auf das Bild, um es zu vergrößern

SMC: Port-Konfiguration
257e0938bb957a73ed4efbc9ce8f704a - Klicke auf das Bild, um es zu vergrößern

Tagged Konfiguration

Dell: VLAN 100 Port 48 tagged
81bd8aa2edf59ef19da01340cc6d3f04 - Klicke auf das Bild, um es zu vergrößern

Dell: VLAN 350 Port 48 tagged
4e1ae5290a8e2095ea0f143b4aebcad3 - Klicke auf das Bild, um es zu vergrößern

Dell: Konfiguration Port 48
dfc049e251d3c5f1a13436986fd946c2 - Klicke auf das Bild, um es zu vergrößern

SMC: Portzuordnung (Port 9 --> Uplink)
8975bdbcaa6779ac4b1a3f49a66310f8 - Klicke auf das Bild, um es zu vergrößern

SMC: Port-Konfiguration
a44e23d87ebcdd63bd19467fcc4a27d3 - Klicke auf das Bild, um es zu vergrößern
Mitglied: aqui
27.08.2014, aktualisiert um 11:59 Uhr
Hast du den SMC mit der aktuellsten Firmware betankt ?? Das solltest du unbedingt machen !
Nach deiner Fehlerbeschreibung zu urteilen liegt das Problem ja ganz klar auf Seiten des SMC. Man kann zu 98% davon ausgehen das der NICHT tagged auf dem Switch Uplink und es deshalb nicht funktioniert.
Kannst du einen Screenshot oder Konfig Auszug des VLAN Setups des SMC hier posten ? Ohne das wird eine zielführende Hilfe schwer.
Grundlegende Infos zu Tagging Setups auf Switches auch hier:
http://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...

Im Handbuch http://www.smc-asia.com/microsite/smart_switch_web/images/manual/SMCGS1 ...
wird das ja auch Seite 159 im Chapter 4 relativ genau erklärt:
  • Unter Configuration, VLANs, VLAN Membership Add VLAN klicken und das VLAN mit ID anlegen und zugehörige Ports definieren
  • Jetzt macht es SMC aber unnözig kompliziert weil sie mit der Gurke auch double Tagging supporten. Versteht man es richtig mussen alle Ports die du Endgeräten zuweist den Port Type C-Port haben ! NICHT aber der Uplink Port, denn der muss den Type Unaware haben. Nur dort wird die VLAN ID NICHT entfernt wie am C-Port. Am Uplink MUSS die VLAN ID gesendet werden (Tagging) damit die Dell Gurke die VLANs identifizieren kann.
  • Ingress Filtering bleibt auf "disabled"
  • Frame Type auf ALL da die Dell Gurke das Default VLAN 1 untagged mit den tagged Frames überträgt. Er muss also sowohl tagged als auch untagged hier akzeptieren.
  • Port VLAN Mode auf None (Note that this mode is normally used for ports connected to VLAN-aware switches. = Mit "VLAN aware" ist hier auch die Dell Gurke gemeint)
  • Port VLAN ID bleibt auf 1
Das zeigt mal wieder wie kompliziert man es bei Taiwan Switches machen kann....

Ansonsten die alte leier wie immer:
Klemm einen Wireshark Sniffer an den Uplink Port der SMC Gurke und checke ob sie tagged auf dem Port ! Da kommt man doch als netzwerker gleich als Erstesdrauf, oder ?!
Nächstes Mal kaufst du dann aber auch was Anständiges und nicht wieder so ein Billigstprodukt von Accton. Edge Core zu dem SMC gehört ist eine NoName Marke von Accton, das ist der größte Billighersteller von Barebone Switches in Fernost. Da lassen alle Billigheimer ihre Kisten zusammenkloppen und bäppeln dann nur D-Link, HP, NetGear, Zyxel usw. drauf...
Bitte warten ..
Mitglied: chiefteddy
27.08.2014 um 14:28 Uhr
Hallo,

danke für die schnelle Antwort.

Ich habe meine Frage mit den gewünschten Screenshots ergänzt.

Die Anleitung hatte ich natürlich auch schon durchgearbeitet und im Wesentlichen genauso interpretiert und entsprechend getestet. Ohne Erfolg.

Ich habe jetzt noch einmal genau Deine Konfiguration übernommen (siehe 2. Teil der Bilder). Auch ohne Erfolg.

Das ist ja genau mein Problem: Ich bin der Meinung, alles ist richtig konfiguriert. Trotzdem funktioniert es nicht.

Einen Trace mit Wireshark probiere ich noch aus.

Als ich den Switch beschafft habe, brauchte ich einen preiswerten 10"-Switch mit mind. 8 Ports und LWL-Anschluß. Da ist die Auswahl nicht so groß.

Jürgen
Bitte warten ..
Mitglied: aqui
27.08.2014, aktualisiert um 18:00 Uhr
Mach den Wireshark Trace dann sehen wir weiter weil wir dann Gewissheit haben !!!
Das kann nur was mit den schwachsinnigen Paket Types und Ethertypes in diesem Switch zu tun haben was verwirrend ist.
Ganz sicher tagged der Switch den Uplink nicht, oder... ordnet tagged eingehende Frames nicht korrekt den VLANs zu.
Das wird der Wireshark Trace sicher zeigen...
Den Dell kannst du mal komplett außen vor lassen, denn wie du selber sagst funktioniert der tagged Uplink dort ja fehlerlos mit anderen Switches die man an die gleiche Leitung hängt.
Der Dell scheidet also somit ganz sicher aus !
Einen Fehler hast du oben noch gemacht.
Die Ports die du dem VLAN 100 zugewiesen hast musst du natürlich aus dem default VLAN 1 entfernen !! Ein Port kann niemals Memeber von 2 VLANs sein !
Bitte warten ..
Mitglied: chiefteddy
04.02.2016, aktualisiert um 10:29 Uhr
Hallo,

ich hatte den Switch in die Ecke geschmissen und ihn jetzt aber noch einmal hervorgeholt.

Um eine Lösung zu finden, habe ich eine Supportanfrage an SMC gestellt, die an Edge-Core weitergeleitet wurde. Von dort habe ich sehr schnell eine Antwort bekommen, die das Problem löste. Damit wir alle davon profitieren können, hier die Lösung:

Ausgangslage:

- VLAN100 auf Port 2 untagged

- VLAN200 auf Port 3 untagged

- Port 8 als Uplink tagged

Lösung:


This is John from Edge-Core Technical Support dept.

you can use the following step to set your switch


At VLANs --> VLAN Membership

1. Click "Add New Vlan" to add two new vlan

2. Change each clan ID to 200 and 300

3. At vlan 200, pickup 2 and 8 in port Members, 3 and 8 for vlan 300.

4. Click "save"


At VLANs --> Ports

1. At port 2, change "Port VLAN -> ID" to 200, and 300 for port 3.

2. Change port 8's "Port VLAN -> Mode" to "None"


Warum auch immer, der tagged Uplink-Port muß vom Typ "C-port" bleiben und nicht auf "unaware" gesetzt werden.

41d4aaf4f266d258b31b5d3abed74b80 - Klicke auf das Bild, um es zu vergrößern


Vielleicht hilft das ja auch noch jemand anderem.

Jürgen
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Hyper-V
Hyper-V SPAN Port - Tagged VLANs (3)

Frage von Hitman4021 zum Thema Hyper-V ...

LAN, WAN, Wireless
gelöst Tagged VLANs richtig konfigurieren (9)

Frage von jakobdoering zum Thema LAN, WAN, Wireless ...

Netzwerkmanagement
gelöst Port Sicherheit verbessern Lancom Switch GS-23xx (13)

Frage von Hipstertown zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...