Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Software Raid 5

Frage Hardware Festplatten, SSD, Raid

Mitglied: 9750

9750 (Level 1)

18.02.2005, aktualisiert 03.08.2006, 12703 Aufrufe, 20 Kommentare

Hallo!

Ich hoffe Ihr können mir bei meinem Problem helfen.

Ich möchte unter Windows XP ein Software-Raid 5 betreiben und zwar mit folgendem Produkt:

MB-810 SKF http://www.raidsonic.de/detailseiten/backplanesysteme/MB810SKF.html

Meine Frage ist nun, wie reagiert Windows wenn ich im laufenden Betrieb die 5 Festplatten des Raids einschiebe und eine nach der anderen anspringt bzw. von Windows erkannt wird.
Baut sich da das Raid richtig auf oder muß ich zum in Betrieb nehmen des Raids den Rechner jedesmal runterfahren.
Hot-Swap und Raid fähig ist das Backplane ja .

Ich möchte das im laufenden Betrieb machen, weil ich über das Gerät 2 Raid 5 mit je 5 Platten betreiben möchte.

Oder gibt es da wenn das nicht geht eine andere Hardwarelösung die nicht so teuer ist?

Ich hoffe Ihr können mir weiterhelfen.

Danke
Mitglied: 2P
18.02.2005 um 18:52 Uhr
Zu deiner Frage kann ich dir leider keine Antwort liefern (auch wenn ich vom Gefühl her eher in Richtung "Nein" tendiere).
Aber ich hätte da eine Frage:

Windows XP beherrscht tatsächlich ein Software Raid 5 ???

Ich war immer der Meinung, dass das den Server Versionen vorbehalten sei.



p.s.
Diesen Satz verstehe ich im übrigen nicht:

"Ich möchte das im laufenden Betrieb machen, weil ich über das Gerät 2 Raid 5 mit je 5 Platten betreiben möchte."
Bitte warten ..
Mitglied: 9750
18.02.2005 um 19:05 Uhr
Also erstmal zu meinem Satz.

Ich möchte ein Raid 5 bestehend aus 5 Platten machen.
Dieses möchte ich während Windows läuft ein und ausbauen können.
Ich möchte halt den Rechner nicht immer ausmachen um das Raid zu starten.

Jep Windows XP kann das:

http://www.de.tomshardware.com/storage/20041028/index.html

Etwas Bastelarbeit, aber es geht.
Bitte warten ..
Mitglied: helpi
18.02.2005 um 20:58 Uhr
nochmals zum Verständis:
5 Platten als ein RAID-5 und dann nochmals 5 andere Platten auch ein RAID-5, richtig?

Dann im laufenden Betrieb die 5 Platten raus und dann die 5 anderen rein ...?

Dann gib's folgendes Problem:
1. Platte raus im laufenden Betrieb, RAID ist regraded ...
2. Platte raus im laufenden Betrieb, RAID ist defekt, Daten sind weg ...
3. ...
4. ...
5. ...

Beim Einbau habe ich keine Ahnung was Windows dazu sagt, aber wahrscheinlich erkennt es zwar das auf den Platten mal ne RAID war, aber da nicht alle Platten zur gleichen Zeit eingeschoben werden, wirds wahrscheinlich auch schiefgehen ...

Einzige Lösung wäre, wenn Windows ein RAID deaktivieren könnte, ohne Daten zu löschen. Hab bei W2003 kurz geschaut, aber nichts gefunden.
Aber bei einem Hardware-RAID-Controller wirds auch nicht besser ...

Was da wohl ginge wäre ein externes RAID über USB angebunden, da sollte das klappen. USB entfernen, dann das USB-RAID runterfahren, Platten tauschen, USB-RAID wieder hochfahren und anstöpseln ... Kost aber etwas mehr Geld!

Gruss
Stephan
Bitte warten ..
Mitglied: 2P
18.02.2005 um 22:24 Uhr
Sehe ich das richtig, dass dieses Gerät mit einem (1) SATA Kabel an einen SATA-Controller angeschlossen wird ?
Bitte warten ..
Mitglied: leknilk0815
19.02.2005 um 10:55 Uhr
Hi, die ganze Diskussion erscheint mir etwas abstrus. Was ist der Sinn einer Raid5- Lösung? -- Höchstmögliche Ausfallsicherheit bei optimaler Recourcennutzung. Wenn ich mir nun eine Lösung bastle (die im übrigen ohnehin nicht funktionieren wird), bei der ich im laufenden Betrieb mehrere Platten tausche, ist das Sicherheitsprinzip bereits ad absurdum geführt, da sowohl ein menschliches Versagen als auch ein technischer Defekt einen Vollcrash zur Folge hätte. Da also die Sicherheit hier wohl keine Rolle spielt (oder das Prinzip falsch verstanden wurde) wäre eine Lösung mit einzelnen Platten ohne Raid vorzuziehen und auch machbar (z. B. USB). Nun zu den Problemen, die auftreten würden: Wie Stephan schon richtig ausführte, ist ein hochfahren Platte für Platte nacheinander bei einem Raid5 nicht möglich, ohne es zu zerstören (auch nicht mit einem Profi Hardware Raid!). Um 5 Platten gleichzeitig im laufenden Betrieb "anzuwerfen", ist wegen des hohen Einschaltstroms schon mal ein Monsternetzteil nötig, um nicht die ganze Kiste in den Keller zu befördern, und selbst dann ist es noch von Zufällen abhängig (geht vielleicht 10mal gut, einmal knallts). Aus diesem Grund werden externe Raid- Arrays mit eigenen Stromversorgungen ausgestattet - was im übrigen die einzig mögliche sinnvolle Lösung darstellen würde. Fazit - selbst wenn es mit einigen Kopfständen technisch machbar wäre - Sinn ergibt das ganze nicht! - Gruß - Toni
Bitte warten ..
Mitglied: 2P
19.02.2005 um 12:18 Uhr
Wäre der Energiebedarf zum "Einschalten" der 5 Festplatten im laufenden Betrieb etwa höher als wenn die 5 Festplatten bereits beim Einschalten des PC´s eingebaut wären ???
Bitte warten ..
Mitglied: leknilk0815
19.02.2005 um 12:38 Uhr
Ja - der Einschaltstrom dürfte, wenn auch nur für Bruchteile einer Sekunde, etwa das 10fache des Normalbetriebs sein. Gruß - Toni
Bitte warten ..
Mitglied: 2P
19.02.2005 um 12:38 Uhr
Wenn ich ihn richtig verstehe, besteht seine Absicht darin, dass komplette Gerät im laufenden Betrieb anzuschliessen bzw. zu entfernen - und nicht einzelne Platten.
Unter dem Gesichtspunkt ist das Ganze eigentlich gar nicht so abstrus.
Man darf den Schwerpunkt nur nicht bei dem Raid suchen, sondern bei der Möglichkeit/Fähigkeit es im laufenden Betrieb zu tun.
Damit hätte man nämlich im Endeffekt eine "Raid5 Wechselfestplatte" mit (im Vergleich zu USB-Wechselfestplatten) fantastischen Übertragungsraten und beeindruckender Grösse.
Zudem - zusätzlich noch die Sicherheit eines Raid.
Fraglich mag indes immer noch die Funktionsfähigkeit dieses Konstrukts sein.
Bitte warten ..
Mitglied: 2P
19.02.2005 um 12:40 Uhr
- "Ja - der Einschaltstrom dürfte, wenn auch nur für Bruchteile einer Sekunde,
- etwa das 10fache des Normalbetriebs sein. Gruß - Toni"

Und das wäre beim Einschalten des PC´s nicht der Fall ?
Bitte warten ..
Mitglied: leknilk0815
19.02.2005 um 20:00 Uhr
Hi, nun bin ich doch einigermassen platt. Die IT bietet doch immer wieder Überraschungen. Ich hab nun, weil mir der "Blödsinn" nicht aus dem Kopf ging, die ganze Geschichte mal nachvollzogen - und siehe da - es funktioniert doch! Ich habe die Modifikationen nach der Beschreibung von Tom's Hardware Guide durchgeführt, und schon bietet XP Raid 5 an. Nach dem Einbinden der Platten (2x 2.1GB und 1x 4,2GB SCSI an einem Billig- Kontroller) stand ein Raid 5 zur Verfügung. Nach dem Runterfahren hab ich die Platten vom Kontroller abgesteckt, Reboot - Windows meutert nicht mal wegen des fehlenden Raids! Platten im LAUFENDEN Betrieb wieder an den Kontroller (alle drei auf einmal, da die Trennung am Kontroller erfolgte), Gerätemanager - Hardwareerkennung - Platten wieder da! Diskmanager aufgerufen - Raid auch wieder da, ebenso die darauf befindlichen Daten. Ein vorangegangener Test mit 2 Platten und Striping funktionierte ebenfalls, die Platten ließen sich im Betrieb ab- und wieder anstecken, auch einzeln, lediglich das Laufwerk wurde dann im Diskmanager als defekt angezeigt, was sich durch reaktivieren ohne Datenverlust beheben ließ. Nun habe ich noch den finalen Gau produziert, indem ich im Betrieb eine Platte aus dem Raid5- Verbund entfernte. Erwartungsgemäß setzte XP das Array auf degraded, nach dem wiedeanschließen der Disk habe ich, um wieder ein Array zu haben, XP veranlasst, das Array neu zu bilden. 20 Minuten später: Raid 5 steht wieder und die Daten sind komplett vorhanden.
In meinem Arbeitszimmer sieht es jetzt aus wie Sau, ich hab mich bis auf die Knochen blamiert (...kann nicht funktionieren...), aber nach über einem Jahrzehnt Schrauberei an den Kisten wieder was gelernt (man soll nie nie sagen).
Fazit: Es funktioniert, die Datensicherheit scheint ganz passabel zu sein, einzig das Problem mit dem Einschaltstrom bleibt natürlich, ist aber sicher lösbar.
Gruß - Toni (auch an alle, die sich jetzt einen grinsen)
Bitte warten ..
Mitglied: meinereiner
19.02.2005 um 20:15 Uhr
@toni

also ich grinse ja jetzt auch, aber eher weil ich mir dein Zimmer vorstelle indem es "wie Sau" aussieht.
Das man mal heftig daneben liegt halte ich für ganz normal!
Bitte warten ..
Mitglied: 2P
19.02.2005 um 20:20 Uhr
Also ich bin auch einigermassen überrascht das das funktioniert - hätte ich nicht gedacht.
Aber klasse das du´s ausprobiert hast.
Ich war schon den ganzen Tag am überlegen ob ich´s mal versuche - war dann aber doch zu faul

Was das Problem mit dem "Einschaltstrom" angeht, bin ich ja der Meinung, dass wenn der Rechner mit allen angeschlossenen HD´s startet, er auch im laufenden Betrieb damit kein Problem haben sollte.

---

Wie auch immer - prima Sache ...
Bitte warten ..
Mitglied: leknilk0815
19.02.2005 um 20:29 Uhr
Danke für die Blumen - mit dem Einschaltstrom hast Du natürlich recht, die Überlastung tritt nur auf, wenn man mehrere Platten im Betrieb auf einmal anschließt, dadurch kann es, obwohl das Netzteil genügend Strom für den laufenden Betrieb liefert, zu einem kurzfristigen Spannungseinbruch kommen, was den Rechner in der Regel zu einem Crash oder Reboot veranlaßt. Das ist mir schon des öfteren passiert, selbst beim anstecken eines CD- Roms. Es liegt auch nicht nur am Stromverbrauch, sondern auch an Induktionsspitzen, die bei solchen Aktionen entstehen können. So - und nun werd ich es mir vor der Glotze bequem machen! - Gruß - Toni
Bitte warten ..
Mitglied: maelcum
02.03.2005 um 14:11 Uhr
Hallo, schaue hier gerade so vorbei... bei dem Backplane-Teil aus dem Ursprungsposting (Raidsonic Icy Dock MB-810SKF) kann man eine Einschaltverzögerung für die einzelnen Platten einstellen. Damit sollten sich die Spannungsspitzen eigentlich erledigt haben.
Bitte warten ..
Mitglied: ZeroQool
29.12.2005 um 10:02 Uhr
Hallo....ich habe auch vor mir mit WinXP ein Raid 5 aufzubauen.... 4x 160GB IDE als RAID5, mein Betriebssystem ist seperat auf einer 30GB HDD.

Meine Frage ist dazu, wie würde es aussehen, wenn ich zB meine 30GB formatiere um das Betriebssystem neu zu installieren (Grund zB. das System ist vollgemüllt, Virus, System ist zerschossen usw.) Mein Raid5 ist theoretisch auch weg, nachdem ich das System neu installiert habe oder? Danke im voraus
Bitte warten ..
Mitglied: maelcum
29.12.2005 um 10:14 Uhr
Normal nicht. Das ist ja der grosse Vorteil, wenn man das OS auf einer separaten Platte hat.

Eigentlich solltest Du ein XP-RAID-Volume nach einer Neuinstallation wieder 'importieren' können. Weiss jemand die genauen Klicks? Ich denke mal, in der Datenträgerverwaltung erscheint das RAID als Fremdes oder Unbekanntes Volume, das man dann ins System integrieren kann.

Hab's aber mit einem XP-RAID noch nicht live zu tun gehabt. Hardwarelösungen sind einfach besser. Wenn man sich schon 4x160GB leisten kann...
Bitte warten ..
Mitglied: ZeroQool
29.12.2005 um 10:21 Uhr
Wenn man die Einstellungen des Raid exportieren bzw importieren könnte, wäre das klasse, aber ich habe soetwas noch nicht gefunden.
Hardwarelösungen sind auf jeden Fall besser, aber ich habe ehrlich gesagt keine Lust ca. 150 EUR für einen IDE RAIDController rauszuwerfen. Die günstigen Controller können ja in der Regel nur 0/1 0+1 jobbed =(
Bitte warten ..
Mitglied: ZeroQool
03.01.2006 um 13:02 Uhr
Keiner eine Antwort!? =(
Bitte warten ..
Mitglied: Flachkopf
11.01.2006 um 21:09 Uhr
Moin !

Ich habe kürzlich ein Software - RAID 5 eingerichtet unter WIN XP Pro und bin richtig begeistert.

Mein System :
Mutterbrett Asus CUBX-E
Intel P3-1000 @31406 MHz
4x 256 MB Infineon CL2
Bootplatte Seagate Cheetah 18 GB 15000 Upm an Adaptec 29160
RAID 5 aus 4x Maxtor 120 GB 8MB Cache 7200 Upm

Mittels RAID-Patch wurde der 5er Modus aktiviert und die Platten als Raid 5 eingerichtet und formatiert - dies dauerte etwa 3,5 Stunden. Anschließend wurden ca. 240 GB an Daten auf das RAID gespielt, was etwa 9 Stunden dauerte.

In diesem System bewegen sich die Transferraten (abhängig von der Dateigröße- und Art) auf dem RAID-Verbund etwa wie folgt :
Schreiben auf das RAID etwa 10 bis 25 MB/s
Lesen vom RAID bis zu 90 MB/s

Testweise wurde der Verbund mal in einen anderen Rechner in Betrieb genommen (auch mit RAID-Patch) und wurde sofort nach dem importieren anstandslos angenommen.

Fazit : wenn es um Datensicherheit und große Datenträgerkapazitäten geht ist diese Methode per RAID 5 nur wärmstens zu empfehlen.


Gruß Jürgen
Bitte warten ..
Mitglied: Pogo
03.08.2006 um 17:16 Uhr
Also ich habe mir auch vor einigen Wochen ein Software-Raid mit Windows XP aufgebaut. An sich funktioniert es auch prima, solange ich den Rechner nicht neu starte, denn danach muss ich leider immer feststellen, dass der Laufwerksbuchstabe nicht mehr zugeordnet ist. Ein Blick in die Datenträgerverwaltung verrät, dass die 4 Laufwerke als "Fehlerhaft" gekennzeichnet werden. Nach Durchstöbern des Internets bin ich auf die Zwischenlösung gekommen, dass man das fehlerhafte Raid mit diskpart bearbeitet. Wenn ich mit diesem Befehl das Raid aufrufe und einen der beteiligten Datenträger auf online setze, wird das Raid repariert und funktioniert umgehend wieder. Der Rebuild dauert jedoch noch einige Zeit (Stunden) an. Nutzbar sind die Daten aber bereits (Kopieren auf den Datenträger auch möglich).
Natürlich muss ich dem Datenträger dann erst sienen alten Buchstaben zuweisen und die Freigaben wieder einstellen.

Weiß hier jemand Rat, was da bei mir schiefläuft, denn scheinbar läuft der Kram bei vielen anderen ja problemlos.

Wäre für jede konstruktive Hilfe dankbar.

Gruß, Pogo
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(2)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Festplatten, SSD, Raid
gelöst Software RAID 10 mit bester Perfomance (7)

Frage von ketanest112 zum Thema Festplatten, SSD, Raid ...

Festplatten, SSD, Raid
Performancesteigerung des RAID Arrays möglich? (13)

Frage von takvorian zum Thema Festplatten, SSD, Raid ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

LAN, WAN, Wireless
Software für Backup oder Datensynchronisation über WAN gesucht (4)

Frage von Rubiks zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...