Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sonderzeichen werden in der cmd shell nicht richtig dargestellt

Frage Microsoft

Mitglied: Slashdot

Slashdot (Level 1) - Jetzt verbinden

20.05.2009, aktualisiert 10:07 Uhr, 11319 Aufrufe, 3 Kommentare

Hallo Leute

Folgendes Situation:

Das System:
- Win 2k3 R2
- SP1
- Englisch
- DE-CH Tastatur Layout

Das Problem:
Wenn ich in der cmd shell ein ® machen will (mit einfügen oder alt+0174) erscheint nur ein r (selbes mit © --> c)

Zusätzlich funktioniert der Backslash mit ALt Gr nicht (s. Thread http://www.administrator.de/index.php?content=34912 ) Alt Gr+< ergibt ein ^\


Das Merkwürdige:
Auf einem anderen Win2k3 System funktioniert das mit dem Backslash und dem ® problemlos. Einziger Unterschied ist der neuere Patchstand des "guten" Systems.

Ich greife auf beide Systeme per mstsc zu da beide virtuelle Maschinen sind (auf XEN)


Der Hintergrund:
Ich möchte per Nagios bzw. NRPE div. Windows Services überwachen und spreche diese per Service Namen an. Leider hat ein zu überwachender Dienst ein ® im Namen und da das Zeichen nicht richtig dargestellt wird, kann Nagios den Namen nicht richtig auswerten.


Kann sein, dass es nicht an der Darstellung liegt aber es ist ein Ansatz und es nervt mich irgendwie das es auf dem einem System geht und ich nicht weiss warum ;)


Besten Dank schon im Voraus


Gruss
Slashdot
Mitglied: LotPings
20.05.2009 um 11:03 Uhr
Hallo /.

Schau dir mal auf beiden Systemen an welche Code Page in der Konsole aktiv ist:

chcp /?

Beim Verarbeiten von Ausgaben in Pipes / Datein könntest du auch gezielt die CMD Optionen /A oder /U verwenden.
Die Konsole kannst du umstellen mit :

Den Backslash solltest du mit AltGr+092 auf allen System bekommen können.

Gruß
LotPings
Bitte warten ..
Mitglied: Slashdot
20.05.2009 um 11:33 Uhr
Hallo LotPings

Danke für die schnelle Antwort.

Die Code Page kannte ich bis jetzt noch nicht. Danke für den aha-Effekt ;)


Leider brachte es nicht das gewünschte Ergebnis:

Wenn ich auf die Code Page 850 umstelle und alt+0174 eintippe (bzw.das ® reinkopiere) bekomme ich nun ein ?

Laut dem gelinkten wiki Eintrag sollte dies das Zeichen für die Codepage 437 sein.

Weitere Ideen?

Gruss
/.

PS: das mit dem Backslash funktioniert seit einem reconnect. Ist wohl wirklich ein mstsc Problem


[SOLVED]


Ich musste zusätzlich in den Länderneinstellungen unter Advanced den punkt Language for non-Unicode programs von English (US) auf German (Switzerland) ändern --> neustart --> funktioniert.

Nun mal schauen, ob ich den Dienst überwachen kann.

Jedenfalls Danke für die Hilfe!


[edit #2]
Dienst überwachen funktioniert nun. Jedoch denke ich, dass der Fehler nicht an der Code Page lag.

Der Service Name hatte auser dem ® noch einen Leerschlag am Ende (Kopf --> Tisch)
Aus diesem Grund hat mir mein Nagios Plugin einen Fehler ausgegeben.......

Naja..immerhin etwas gelernt ;)

Schöne Woche noch..
Bitte warten ..
Mitglied: 76109
20.05.2009 um 12:16 Uhr
Hallo Slashdot,

Zitat von Slashdot:
Wenn ich auf die Code Page 850 umstelle und alt+0174 eintippe bekomme ich nun ein ?

das ist kein Wunder, weil die Zahlenwerte nur dreistellig sein dürfen und ausserdem
ist es nicht 174 sondern 169 (hA9 = 10*16+9).

Also Eingabe [ALT+169] = ®

Gruß Dieter
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
gelöst Sonderzeichen in der CMD Konsole darstellen? (1)

Frage von PinkFLuffyUnicorn zum Thema Batch & Shell ...

Microsoft Office
Sonderzeichen bei Terminen - Office 2016

Frage von Martinaaa zum Thema Microsoft Office ...

Exchange Server
E-Mails werden nicht richtig dargestellt (Exchange 2013) (2)

Frage von Philipp.S zum Thema Exchange Server ...

CMS
gelöst PhpMyAdmin Login-Seite wird nicht dargestellt (3)

Frage von Static zum Thema CMS ...

Neue Wissensbeiträge
Windows 10

Heise Newsticker: Microsoft veröffentlicht das "Fall Creators Update

(8)

Information von Penny.Cilin zum Thema Windows 10 ...

LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Hosting & Housing
Mailserver Software Empfehlungen (20)

Frage von sunics zum Thema Hosting & Housing ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...