Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SQLOLEDB kein Provider gefunden

Frage Entwicklung Datenbanken

Mitglied: Osmo

Osmo (Level 1) - Jetzt verbinden

03.02.2007, aktualisiert 05.02.2007, 5398 Aufrufe, 4 Kommentare

Nach Installation von MS SQL Server 2000 Workgroup auf Windows 2003 Server Enterprise (ohne SP1) ist keine Verbindung via SQL Client mit dem SQL Server möglich.

Hallo,

habe auf einem Win 2003 Server Enterprise einen SQL Server 2000 Workgroup installiert.
Alles lief soweit problemlos. Mittels Enterprise Manager kann man sich einloggen und mit dem SQL Server arbeiten.
Es soll eine Anwendung zum Einsatz kommen, die den SQL Server als Datenbank verwendet.
Auch diese Anwendung liess sich problemlos installieren.
Innerhalb dieser Installationsroutine wird auch auf dem SQL Server via SQL Script eine Datenbank eingerichtet.
Diese Datenbank kann mit dem Enterprise Manager verwaltet werden, und weist keine Fehler auf.
Versucht man aber mit dem Programm via SQLOLEDB eine Verbindung mit dem Server aufzubauen
Wir gemeldet, dass kein Provider gefunden wurde, und dieser evtl. nicht korrekt installiert wurde.

Hatte jemand bereits ein solches Problem vorliegen?
Bin für jeden Hinweis dankbar.

Grüße Osmo
Mitglied: MadMax
05.02.2007 um 01:07 Uhr
Hallo Osmo,

prüf mal Eure MDAC-Version auf den Clients, vielleicht müssen die nur aktualisiert werden. Daß auf dem SQL Server das neuste SP drauf ist, setze ich jetzt mal einfach voraus.

Gruß, Mad Max
Bitte warten ..
Mitglied: Osmo
05.02.2007 um 10:06 Uhr
Hallo Osmo,

prüf mal Eure MDAC-Version auf den
Clients, vielleicht müssen die nur
aktualisiert werden. Daß auf dem SQL
Server das neuste SP drauf ist, setze ich
jetzt mal einfach voraus.

Gruß, Mad Max

Hallo Mad Max,

vielend Dank für Deinen Tipp.
Ich muss vielleicht doch etwas genauer beschreiben was durchgeführt wurde.
Habe ein vorhandenes Netz mit Windows 2003 Server übernommen.
Jemand hatte auf dem Server eine MSDE 1.0 (SQL Server 7.0) installiert.
Das die MSDE 1.0 nicht mit dem Serverbetriebsystem kompatibel ist wurde beim
Installationsvorgang wohl ignoriert (Fehlermeldung wird angezeigt).
Trotzdem wurde das System so betrieben, und es wurden knappe 2GB an Daten
gespeichert. Die 2GB Grenze war nun das Aus für die MSDE.
Also wurde diese von mir deinstalliert, und die SQL Server 2000 Workgroup installiert, und
abschließend die Daten via Enterprise Manager übernommen (attach).

An den funktionierenden Clients im LAN wurde nichts verändert, aber trotzdem können diese sich nicht mehr mit der neuen DB verbinden.
Selbst lokal am Server kann der Client keine Verbindung aufbauen (SQLOLEDB kein Provider gefunden).
Die Netzwerkprotokolle des SQL Servers sind auch aktiviert.
Der SQL Server 2000 hat SP3 integriert die Installation des SP4 von der beiliegenden CD Rom schlug fehl, auch das Installieren von SP1 von Windows 2003 Server hat nicht funktioniert.
Die MDAC wir bei der Installation der Anwendung geprüft und bei Bedarf aktualisiert, inwiefern eine beschädigte Installation erkannt und repariert wird kann ich nicht bewerten.

Könnten verbliebene Reste der MSDE 1.0 für obigen Zustand verantwortlich sein?
Kann man die vorhandene MDAC Version löschen, und neu aufsetzen?

Schon mal vorab vielen Dank.

Grüße Osmo
Bitte warten ..
Mitglied: MadMax
05.02.2007 um 12:48 Uhr
Hallo Osmo,

Du hast also eine SQL Server 7.0 Datenbank einfach an den SQL Server 2000 angehängt, habe ich das richtig verstanden?

Normalerweise kann man SQL Server 2000 einfach über SQL Server 7 drüberinstallieren, dann aktualisiert er die Datenbanken. Da Du das nicht gemacht hast, kannst Du das aber auch nachträglich noch machen. Klicke im Enterprise Manger mit der rechten Maustaste auf Deinen Server, Alle Tasks, Assistent zum Kopieren von Datenbanken... Dadurch kann die DB auch auf SQL Server 2000 aktualisiert werden.

MDAC kann einfach über eine bestehende Version installiert werden, um sie zu aktualisieren.

Gruß, Mad Max
Bitte warten ..
Mitglied: Osmo
05.02.2007 um 14:46 Uhr
Hallo Mad Max,

das mit dem Aktualisieren einer SQL Server Instanz durch drüberinstallieren funktioniert bei der Workgroup Edition leider nicht. Hier muss wirklich von einem Blancosystem aus installiert werden.
Wenn man mit dem Attach-Befehl eine SQL Server 7 DB in einen SQL 2000 Server einhängt wird meiner Meinung nach automatisch konvertiert. Hatte diesbezüglich noch nie Probleme. Habe das gerade mit einer Testinstallation verifiziert.

Gibt es noch eine andere mögliche Ursache (ausser MDAC) für die Fehlermeldung "SQLOLEDB kein Provider gefunden"?

Grüße Osmo
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
gelöst Mail Provider erlaubt kein Fremdnetz (20)

Frage von rike34 zum Thema Server-Hardware ...

Windows Server
gelöst Import-PfxCertificate: Provider angeben (6)

Frage von Badger zum Thema Windows Server ...

Voice over IP
Zwangstrennung vom Provider bei IP-Telefonie? (6)

Frage von vanTast zum Thema Voice over IP ...

Windows XP
gelöst Server nicht gefunden (7)

Frage von Antimon zum Thema Windows XP ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

(3)

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(8)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Monitoring
Netzwerk-Monitoring Software (18)

Frage von Ghost108 zum Thema Monitoring ...

Windows 10
Seekrank bei Windows 10 (17)

Frage von zauberer123 zum Thema Windows 10 ...

Windows Server
gelöst Kopiervorgang schlägt fehl, weil Datei- und Ordnername zu lang sind (14)

Frage von Schroedi zum Thema Windows Server ...

Windows 10
Windows 10 Fall Creators Update Fehler (13)

Frage von ZeroCool23 zum Thema Windows 10 ...