Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

SQLOLEDB kein Provider gefunden

Frage Entwicklung Datenbanken

Mitglied: Osmo

Osmo (Level 1) - Jetzt verbinden

03.02.2007, aktualisiert 05.02.2007, 5407 Aufrufe, 4 Kommentare

Nach Installation von MS SQL Server 2000 Workgroup auf Windows 2003 Server Enterprise (ohne SP1) ist keine Verbindung via SQL Client mit dem SQL Server möglich.

Hallo,

habe auf einem Win 2003 Server Enterprise einen SQL Server 2000 Workgroup installiert.
Alles lief soweit problemlos. Mittels Enterprise Manager kann man sich einloggen und mit dem SQL Server arbeiten.
Es soll eine Anwendung zum Einsatz kommen, die den SQL Server als Datenbank verwendet.
Auch diese Anwendung liess sich problemlos installieren.
Innerhalb dieser Installationsroutine wird auch auf dem SQL Server via SQL Script eine Datenbank eingerichtet.
Diese Datenbank kann mit dem Enterprise Manager verwaltet werden, und weist keine Fehler auf.
Versucht man aber mit dem Programm via SQLOLEDB eine Verbindung mit dem Server aufzubauen
Wir gemeldet, dass kein Provider gefunden wurde, und dieser evtl. nicht korrekt installiert wurde.

Hatte jemand bereits ein solches Problem vorliegen?
Bin für jeden Hinweis dankbar.

Grüße Osmo
Mitglied: MadMax
05.02.2007 um 01:07 Uhr
Hallo Osmo,

prüf mal Eure MDAC-Version auf den Clients, vielleicht müssen die nur aktualisiert werden. Daß auf dem SQL Server das neuste SP drauf ist, setze ich jetzt mal einfach voraus.

Gruß, Mad Max
Bitte warten ..
Mitglied: Osmo
05.02.2007 um 10:06 Uhr
Hallo Osmo,

prüf mal Eure MDAC-Version auf den
Clients, vielleicht müssen die nur
aktualisiert werden. Daß auf dem SQL
Server das neuste SP drauf ist, setze ich
jetzt mal einfach voraus.

Gruß, Mad Max

Hallo Mad Max,

vielend Dank für Deinen Tipp.
Ich muss vielleicht doch etwas genauer beschreiben was durchgeführt wurde.
Habe ein vorhandenes Netz mit Windows 2003 Server übernommen.
Jemand hatte auf dem Server eine MSDE 1.0 (SQL Server 7.0) installiert.
Das die MSDE 1.0 nicht mit dem Serverbetriebsystem kompatibel ist wurde beim
Installationsvorgang wohl ignoriert (Fehlermeldung wird angezeigt).
Trotzdem wurde das System so betrieben, und es wurden knappe 2GB an Daten
gespeichert. Die 2GB Grenze war nun das Aus für die MSDE.
Also wurde diese von mir deinstalliert, und die SQL Server 2000 Workgroup installiert, und
abschließend die Daten via Enterprise Manager übernommen (attach).

An den funktionierenden Clients im LAN wurde nichts verändert, aber trotzdem können diese sich nicht mehr mit der neuen DB verbinden.
Selbst lokal am Server kann der Client keine Verbindung aufbauen (SQLOLEDB kein Provider gefunden).
Die Netzwerkprotokolle des SQL Servers sind auch aktiviert.
Der SQL Server 2000 hat SP3 integriert die Installation des SP4 von der beiliegenden CD Rom schlug fehl, auch das Installieren von SP1 von Windows 2003 Server hat nicht funktioniert.
Die MDAC wir bei der Installation der Anwendung geprüft und bei Bedarf aktualisiert, inwiefern eine beschädigte Installation erkannt und repariert wird kann ich nicht bewerten.

Könnten verbliebene Reste der MSDE 1.0 für obigen Zustand verantwortlich sein?
Kann man die vorhandene MDAC Version löschen, und neu aufsetzen?

Schon mal vorab vielen Dank.

Grüße Osmo
Bitte warten ..
Mitglied: MadMax
05.02.2007 um 12:48 Uhr
Hallo Osmo,

Du hast also eine SQL Server 7.0 Datenbank einfach an den SQL Server 2000 angehängt, habe ich das richtig verstanden?

Normalerweise kann man SQL Server 2000 einfach über SQL Server 7 drüberinstallieren, dann aktualisiert er die Datenbanken. Da Du das nicht gemacht hast, kannst Du das aber auch nachträglich noch machen. Klicke im Enterprise Manger mit der rechten Maustaste auf Deinen Server, Alle Tasks, Assistent zum Kopieren von Datenbanken... Dadurch kann die DB auch auf SQL Server 2000 aktualisiert werden.

MDAC kann einfach über eine bestehende Version installiert werden, um sie zu aktualisieren.

Gruß, Mad Max
Bitte warten ..
Mitglied: Osmo
05.02.2007 um 14:46 Uhr
Hallo Mad Max,

das mit dem Aktualisieren einer SQL Server Instanz durch drüberinstallieren funktioniert bei der Workgroup Edition leider nicht. Hier muss wirklich von einem Blancosystem aus installiert werden.
Wenn man mit dem Attach-Befehl eine SQL Server 7 DB in einen SQL 2000 Server einhängt wird meiner Meinung nach automatisch konvertiert. Hatte diesbezüglich noch nie Probleme. Habe das gerade mit einer Testinstallation verifiziert.

Gibt es noch eine andere mögliche Ursache (ausser MDAC) für die Fehlermeldung "SQLOLEDB kein Provider gefunden"?

Grüße Osmo
Bitte warten ..
Ähnliche Inhalte
Cloud-Dienste
Datensyncronisation zwischen email-Provider und owncloud-Provider
Frage von LinuxTuxFanCloud-Dienste

Guten Tag, trotz googlen bin ich nicht wirklich fündig geworden. Gegeben: Erster Provider: Email-Account (historisch älter) Mit Kalender & ...

Hosting & Housing
Provider für Firmenwiki
Frage von hajowiHosting & Housing5 Kommentare

Hallo, welchen Provider könnt Ihr für ein Firmenwiki empfehlen? Benötigt wird PHP und MySQL. Das Wiki ist geplant für ...

LAN, WAN, Wireless
WIrd ein Rechenzentrum von einem Provider betrieben ?
gelöst Frage von HucksterLAN, WAN, Wireless23 Kommentare

Guten Morgen, ich wohne in einem Studentenwohnheim mit Internetanschluss und habe mir eine Fritzbox zugelegt, allerdings benötigt die Fritzbox ...

LAN, WAN, Wireless
Hohe Latenz zum Provider
Frage von ValexusLAN, WAN, Wireless8 Kommentare

Hallo Kollegen, wir haben seit einiger Zeit das Problem, dass unsere VOIP Gespräche (SIP-Trunk beim gleichen Anbieter) kurzzeitig in ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 106 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell16 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Hardware
Fujitsu Workstation mit K80 und Quadro P5000, Fehlermeldung: Connect Power Adapter
Frage von MachelloHardware7 Kommentare

Hallo Zusammen, ich benötige euren Rat da ich ratlos bin. Folgende Konfiguration im Büro: Fujitsu Workstation Celcius R940 Power ...