Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Squid Anmeldemaske erscheint nicht

Frage Linux Linux Netzwerk

Mitglied: Unrealfighter

Unrealfighter (Level 1) - Jetzt verbinden

04.04.2007, aktualisiert 12.04.2007, 5628 Aufrufe, 8 Kommentare

Hallo!

Habe mir einen SQUID gebastelt. Das Internet funktioniert auch wunderbar mit Cache usw.
Das einzige was nicht funktioniert ist das ein Anmeldefenster erscheinnt wenn einer meiner Clients aufs Inet zugreift.
Die User haben direkt Zugriff zum Internet und das sollte nicht sein.

Und was auch nicht funktioniert, ist das wörter die in urls enthalten sind geblockt werden sollen.

Ich bin mit meinem Latein am ende.

Vllt findet ihr ja den Fehler.

Hier meine squid.conf

http://www.cbs-welt.de/FILES/squid.txt

Also die Pfade zu ncsa hab ich überprüft. Die stimmen und die Datei liegt auch da.

Hier der abschnitt für die Anmeldung:

acl our_networks src 192.168.0.16 255.255.255.240
acl auth_users proxy_auth REQUIRED
http_access allow our_networks auth_users
http_access allow localhost

Und hier der für die geblockten wörter:

acl gesperrt url_regex -i "/etc/squid/gesperrt"
Mitglied: Dani
04.04.2007 um 19:28 Uhr
G' Abend,
also ich habe folgene Konfiguration (squid.conf). Dabei wird bei jedem Zutritt der Passwortdialog erscheinen. Ein URL Filter ist auch drin:
Dieser Teil legt fest, in welcher Datei Benutzer + Passwort stehen
01.
...auth_param basic program /usr/sbin/ncsa_auth /etc/squid/squid.pw 
02.
auth_param basic realm Squid Proxy-Server | DSL Flatrate 
03.
...
Dann hier noch die Reihenfolge der ACL's:
01.
acl mitpw  proxy_auth REQUIRED 
02.
acl all src 0.0.0.0/0.0.0.0 
03.
acl manager proto cache_object 
04.
acl localhost src 127.0.0.1/255.255.255.255 
05.
acl to_localhost dst 127.0.0.0/8 
06.
acl WERBUNG url_regex "/etc/squid/werbefrei.urls"
Und hier die Anwendung der oben erstellten Regeln:
01.
acl CONNECT method CONNECT 
02.
 
03.
http_access allow mitpw 
04.
http_access allow manager localhost 
05.
http_access deny manager 
06.
http_access deny !Safe_ports 
07.
http_access deny CONNECT !SSL_ports 
08.
http_access allow localhost 
09.
http_access deny all 
10.
http_reply_access allow all 
11.
http_access deny WERBUNG
Viel Spa
Bitte warten ..
Mitglied: Unrealfighter
10.04.2007 um 16:17 Uhr
hi!

danke. also die anmeldemaske erscheint jetzt nur das mit der url filterung funktioniert weiterhin nicht

Hier mein Skript:

acl mitpw proxy_auth REQUIRED
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563
acl WERBUNG url_regex "/etc/squid/gesperrt.url"

acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http

acl CONNECT method CONNECT

http_access allow mitpw
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access deny all
http_reply_access allow all
http_access deny WERBUNG

Und hier der Inhalt der gesperrt.url:

google
warez
crack

die datei gesperrt.url hat 777 als rechte

wo ist mein fehler hab das so geändert wie es in deinem skript ist

greetz
chris
Bitte warten ..
Mitglied: Dani
10.04.2007 um 17:19 Uhr
Hi,
ah....Sry, mein Fehler!
Probier es mal so:
01.
acl WERBUNG url_regex -i "/etc/squid/gesperrt.url"
Gruß
Dani
Bitte warten ..
Mitglied: Unrealfighter
10.04.2007 um 22:51 Uhr
hi!

sry aber es funktioniert immer noch nicht.

habe das jetzt so:

cl mitpw proxy_auth REQUIRED
acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563
acl WERBUNG url_regex -i "/etc/squid/gesperrt.url"
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http



http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access deny all
http_reply_access allow all
http_access deny WERBUNG
Bitte warten ..
Mitglied: Dani
10.04.2007 um 23:21 Uhr
G' Abend,
also jetzt machts mich dann sprachlos!
Hier mal eine kl. Anleitung:
http://www.linux-club.de/viewtopic.php?t=53960&highlight=squid+seit ...
http://www.linux-club.de/viewtopic.php?t=45863

Alternative wäre SquidGuard:
http://www.linux-club.de/viewtopic.php?t=56698&highlight=squid+seit ...

Bei Zugriff auf die BlackSeite kannst du eine eigene Anzeigen lassen:
http://www.linux-club.de/viewtopic.php?t=51513&highlight=squid+seit ...


Gruß
Dani
Bitte warten ..
Mitglied: Unrealfighter
12.04.2007 um 11:58 Uhr
danke für die links


bin jetzt ein stückchen weiter gekommen nur hab noch nicht das was raus kommen soll

wenn ich das so im skript schreibe funktioniert die filterung jedoch erscheint bei start vom IE die Anmeldemaske nicht. Diese erscheint erst nachdem ich in der Adressleiste ne Adresse eingebe.

Hier das Skript:

MIT ANMELDUNG
acl mitpw proxy_auth REQUIRED

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563

VERBOTEN
acl WERBUNG url_regex -i "/etc/squid/gesperrt.url"
http_access deny WERBUNG


acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 563 # https, snews
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http

acl CONNECT method CONNECT

http_access allow mitpw

Only allow cachemgr access from localhost
http_access allow manager localhost
http_access deny manager
Deny requests to unknown ports
http_access deny !Safe_ports
### Deny CONNECT to other than SSL ports
http_access deny CONNECT !SSL_ports
### Deny gesperrt liste
http_access deny all
http_reply_access allow all
http_access deny WERBUNG


heisst also sobald ich das http_access deny WERBUNG direkt unter acl WERBUNG url_regex -i "/etc/squid/gesperrt.url" packe funktioniert der filter nur die anmeldemaske erscheint nicht, sondern erst nach eingabe einer url.

mache ich das andersrum heisst http_access deny WERBUNG unten zu den http_access regeln dann kommt die anmeldemaske sofort nur der filter greift nicht

habt ihr noch ne idee woran es liegen kann?

habe mal die ganzen kommentare aus der squid.conf rausgeschmissen.
hier die squid.conf ohne kommentare .... vllt seht ihr ja den fehler
http://www.cbs-welt.de/FILES/squid.conf.small

greetz
chris
Bitte warten ..
Mitglied: Dani
12.04.2007 um 16:06 Uhr
packe funktioniert der filter nur die anmeldemaske erscheint nicht, sondern erst nach
eingabe einer url.
Und warum ist das ein Problem??? Wenn er eine Intranetadresse eingibt, soll doch keine Abfrage erscheinen, oder?


Gruß
Dani
Bitte warten ..
Mitglied: Unrealfighter
12.04.2007 um 16:42 Uhr
ja aber wenn die startseite nicht gesperrt ist baut der browser die seite auf was er ja nicht soll....

z.B google als startseite
wenn man dann den Browser öffnet wird google aufgebaut und die anmeldemaske erscheint erst wenn man eine adresse adresse eingibt

greetz
chris
Bitte warten ..
Ähnliche Inhalte
Windows 7
Anmeldemaske bearbeiten
gelöst Frage von RhoninnWindows 712 Kommentare

Ich arbeite gerade an einer Arbeit zum Thema Self Service. Die umgebung ist eine Windows Domain-Netzwerk mit Domaincontroller und ...

Windows 7
Laufwerksbuchstabe erscheint, verschwindet, erscheint, verschwindet,
gelöst Frage von WirdnochWindows 78 Kommentare

Ein herzliches Hallo an alle! Es geht um einen PC mit Win 7 Pro 64bit Folgende Problematik: Im Windows-Explorer ...

Windows 7
Vorherigen User in der Windows Anmeldemaske
Frage von PampersjoeWindows 719 Kommentare

Hallo zusammen, mal vllt. eine doofe Frage (die meisten kennen vllt. das Thema) da wir demnächst eine große Inventur ...

Windows 10
Windows 10 Anmeldemaske wird nicht geladen
gelöst Frage von BeslindWindows 101 Kommentar

Hallo. Wenn ich meinen Laptop hochfahre dann wird nur das Sperrhintergrund Bild gezeigt sonst nichts. Kein Herunterfahr Zeichen einfach ...

Neue Wissensbeiträge
MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 10 StundenMikroTik RouterOS4 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Sicherheit

Sicherheitslücke in HP-Druckern - Firmware-Updates stehen bereit

Information von BassFishFox vor 11 StundenSicherheit

Ein weiterer Grund, dass Drucker keinerlei Verbindung nach "auswaerts" haben sollen. Unter Verwendung spezieller Malware können Angreifer aus der ...

Administrator.de Feedback

Entwicklertagebuch: Die Startseite wurde überarbeitet

Information von admtech vor 13 StundenAdministrator.de Feedback9 Kommentare

Hallo Administrator User, mit dem Release 5.7 haben wir unsere Startseite überarbeitet und die Beiträge und Fragen voneinander getrennt. ...

Vmware

VMware Desktopprodukte sind verwundbar

Information von Penny.Cilin vor 18 StundenVmware

Die VMware-Anwendungen zum Umgang mit virtuellen Maschinen Fusion, Horizon Client und Workstation sowie die Plattform NSX sind verwundbar. Davon ...

Heiß diskutierte Inhalte
Visual Studio
Vb.net-Tool zum Erzeugen einer Outlook-E-Mail
Frage von ahstaxVisual Studio24 Kommentare

Hallo, ich möchte gerne ein vb.net-Tool schreiben, das am Ende eine Outlook-E-Mail erzeugt. Grundsätzlich ist mir klar, wie das ...

Windows Server
RDP macht Server schneller???
Frage von JaniDJWindows Server16 Kommentare

Hallo Community, wir betrieben seit geraumer Zeit diverse virtuelle Maschinen und Server mit Windows Server 2012. Leider haben wir ...

Windows Netzwerk
Netzwerk Neustrukturierung
Frage von IT-DreamerWindows Netzwerk16 Kommentare

Hallo verehrte Community und Admins, bei uns im Haus steht eine Neustrukturierung an. Dafür benötige ich von euch ein ...

Windows 10
Windows 10 dunkler Bildschirm nach Umfallen
Frage von AkcentWindows 1015 Kommentare

Hallo, habe hier einen Windows 10 Rechner der von einem User umgefallen wurde (Beine übers Knie, an den PC ...