Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Squid einrichten

Frage Linux Linux Netzwerk

Mitglied: Franzmann

Franzmann (Level 1) - Jetzt verbinden

04.09.2007, aktualisiert 15.10.2007, 5941 Aufrufe, 4 Kommentare

Hallo,
ich will einen Squid auf einem SLES 10.2 ans laufen bekommen.
Meine Konfig sieht im Wesentlichen so aus:
--- schnipp ---

http_port SERVERIP:8080

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 81 8003
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl FTP_ports port 21 # ftp

acl Safe_ports port 90 5000 81 8801 8003 53900 # verschiedene Ports

acl CONNECT method CONNECT

acl meinegruppe src 10.222.200.0/21-10.222.207.254/21
http_access allow meinegruppe

cache_peer GATEWAYIP parent 8080

http_access deny all

--- schnapp ---

Lokal auf ner virtuellen Maschine funktioniert das auch.
Wenn ich das jetzt bei uns ins Firmennetz implementiere, geht er nicht.
Meine Frage, ist dieser Parameter so richtig ?
--> cache_peer GATEWAYIP parent 8080
Wo gebe ich die IP oder den DNS der Internetverbindung an ?
Und was ist für den Squid die Internetverbindung ? Das Gateway oder die Firewall ?

Danke !!!
Mitglied: Dani
07.09.2007 um 19:30 Uhr
Hi Franzmann,
Lokal auf ner virtuellen Maschine funktioniert das auch.
Wenn ich das jetzt bei uns ins Firmennetz implementiere, geht er nicht.
Hmm...sind die beiden Maschinen identisch. Sprich die Lokale und der Server / Client auf dem nachher Squid laufen soll??

Wo gebe ich die IP oder den DNS der Internetverbindung an ?
Hää.....? Die Clients haben doch die IP (GW, DNS, WINS) statisch oder per DHCP bekommen. Der Server hat auch 1 (2) IP-Adresse(n) und bei einer Karte ist ein Default DNS und Backup DNS hinterlegt.


Grüße
Dani
Bitte warten ..
Mitglied: Franzmann
11.09.2007 um 11:18 Uhr
Ja beide Maschinen sind identisch!

Ah ok, das wusste ich nicht, ich dachte da gibts im Squid noch Parameter die diesbezüglich angepasst werden müssen.

Also ich glaube mittlerweile das es daran liegt das ich net ricchtig rauskomme.
Ping funktioniert, traceroute und wget nicht...

IP-Config der Linux Maschine
eth0
...
inet addr:IP_des_Servers Bcast:BD__des_Servers Mask:SBN_des_Servers
...
IP-Config des Squid auf der Linux Maschine
eth0:0
...
inet addr:IP_des_Servers Bcast:BD__des_Servers Mask:SBN_des_Servers
...

Hmm wo kanns denn noch hängen ?!
Bitte warten ..
Mitglied: Franzmann
11.09.2007 um 12:08 Uhr
Wenn ich mit dem squidclient intern teste, bekommen ich folgende Meldung:
1189502450.154 179899 MEINE_SQUID_IP TCP_MISS/504 1376 GET http://www.gmx.de - DIRECT/217.72.204.254 text/html

Lässt das auf was schließen ?
Bitte warten ..
Mitglied: Franzmann
15.10.2007 um 15:16 Uhr
Wenn ich mit dem squidclient intern teste,
bekommen ich folgende Meldung:
> 1189502450.154 179899 MEINE_SQUID_IP
TCP_MISS/504 1376 GET http://www.gmx.de -
DIRECT/217.72.204.254 text/html

Lässt das auf was schließen ?

Es lag an den Ports, waren falsch freigeschaltet.
Thx@all
Bitte warten ..
Ähnliche Inhalte
Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Hosting & Housing
gelöst DDNS-Update über curl einrichten (2)

Frage von Static zum Thema Hosting & Housing ...

Neue Wissensbeiträge
Google Android

Cyanogenmod alternative Downloadquelle

(5)

Tipp von Lochkartenstanzer zum Thema Google Android ...

Batch & Shell

Batch als Dienst bei Systemstart ohne Anmeldung ausführen

(5)

Tipp von tralveller zum Thema Batch & Shell ...

Sicherheits-Tools

Sicherheitstest von Passwörtern für ganze DB-Tabellen

(1)

Tipp von gdconsult zum Thema Sicherheits-Tools ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Statische Routen mit ISC-DHCP Server für Android Devices (22)

Frage von terminator zum Thema LAN, WAN, Wireless ...

Server
gelöst Wie erkennen, dass nur deutsche IPs Zugang zu einer Website haben? (22)

Frage von Coreknabe zum Thema Server ...

Exchange Server
gelöst Migration Exchange 2007 zu 2013 - Public Folder teilweise weg (16)

Frage von Andy1987 zum Thema Exchange Server ...

Outlook & Mail
Outlook 2010 mit Exchange 2016 (15)

Frage von slansky zum Thema Outlook & Mail ...