Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Squid Problem bei https über cache peer

Frage Linux Linux Tools

Mitglied: Chribu

Chribu (Level 1) - Jetzt verbinden

14.07.2008, aktualisiert 15.07.2008, 11440 Aufrufe, 4 Kommentare

Hallo Leute,

ich habe meinen Squid-Proxy so eingerichtet, dass er über einen übergeordneten Proxy ins Internet kommt.
Dies habe ich mit der cache_peer Option eingestellt und das läuft auch wunderbar, solange ich keine SSL verschlüsselten Seiten (https://) aufrufe!
Dann taucht nämlich folgender Fehler im access.log, des Squids auf:

01.
192.168.2.1 TCP_MISS/000 729 CONNECT banking.postbank.de:443 - DEFAULT_PARENT/192.168.2.20 -
Wenn ich also eine https-Seite aufrufe, bekomme ich im Client einen Servererror 500!

So sieht mein cache_peer-Eintrag aus:

01.
cache_peer 192.168.2.20       parent    8080  0     proxy-only default no-query no-digest
Ich habe mal ein bisschen im Internet recherchiert und herausgefunden, dass die "never_direct allow all" Option eine wichtige Rolle spielt und habe ich sie auskommentiert!

Das hat mich aber leider nicht weitergebracht.

Wisst ihr weiter?

Gruß
Chribu
Mitglied: Nailara
15.07.2008 um 00:03 Uhr
Hi,

meine Güte ist das lange her , doch wenn ich mich recht erinnere, ist die Fehlerzeile oben keine Fehlerzeile. Er sagt halt nur, dass er nix im Cache hat und das deshalb an den Parent weitergibt.

In der Default-Einstellung des Squid sind ein paar ACL's gesetzt, die unter Umständen das Problem verursachen könnten. Schalte die doch mal ab und schau, was dann geht ...

Grüße Mathias
Bitte warten ..
Mitglied: Chribu
15.07.2008 um 08:29 Uhr
Morgen Mathias,

es lag doch nciht an meiner Konfiguration, sondern am Parentproxy
Es hat nämlich auf Anhieb mit einem anderen Parentproxy funktioniert!
-->Meine Konfiguration war also in Ordnung!

Jetzt habe ich aber ein anderes Problem:
Beim Starten von Squid, bekomme ich folgende Fehlermeldung ausgegeben:

01.
cache_cf.cc(346) squid.conf:2710 unrecognized: 'broken_vary_encoding'
Der Proxy funktioniert aber trotzdem!
habe leider noch keine Lösung für diesen Fehler gefunden.

Vielleicht weist du ja weiter


Gruß
Chribu
Bitte warten ..
Mitglied: Nailara
15.07.2008 um 09:07 Uhr
Morsche,

hatte ich auch noch nicht, wenn ich aber die Quellen im Internet recht deute, dann hat das keine Bedeutung. Es dreht sich vorzugsweise um komprimierte Seiten, die der Squid nicht so recht interpretieren mag, weil sie Zeichen enthalten, die nicht RFC-konform sind. Ursache sind aber die Webserver, die die Seiten nicht als mit mod_gzip oder mod_deflate komprimiert kennzeichnen - Squid "bemerkt" diesen Lapsus und mault.

Gefunden habe ich auch, dass es wohl ab Squid 2.6 eine Option gibt, mit der das Caching dieser Daten abgeschaltet wird - eingesteuert über eine ACL:

\# TAG: broken_vary_encoding
\# Many servers have broken support for on-the-fly Content-Encoding,
\# returning the same ETag on both plain and gzip:ed variants.
\# Vary replies matching this access list will have the cache split
\# on the Accept-Encoding header of the request and not trusting the
\# ETag to be unique.
\#
\# Apache mod_gzip and mod_deflate known to be broken so don't trust
\# Apache to signal ETag correctly on such responses
acl apache rep_header Server ^Apache
broken_vary_encoding allow apache

Wenn ich nun Deine Fehlermeldung richtig interpretiere, dann hast Du die Option gesetzt, obwohl Dein Squid die nicht kann - "unrecognized" bedeutet wohl "unerkannt" ...


Grüße Mathias
Bitte warten ..
Mitglied: Chribu
15.07.2008 um 09:30 Uhr
Hi Mathias,

genau das gleiche habe ich auch eben gefunden

Habe diese Option einfach auskommentiert und schon lief er einwandfrei!

Danke nochmal für deine Hilfe!

Schönen Tag noch!

Gruß
Chribu
Bitte warten ..
Ähnliche Inhalte
Debian
Squid Proxyserver - HTTPS Problem (1)

Frage von Cartman zum Thema Debian ...

Exchange Server
Problem mit Exchange 2010 und Cache Modus (1)

Frage von Leo-le zum Thema Exchange Server ...

Firewall
gelöst Squid Logging Problem Extern (10)

Frage von wurscht12 zum Thema Firewall ...

Entwicklung
Jasper Reports Server 6 Cache automatisch löschen (3)

Frage von Pizzamann zum Thema Entwicklung ...

Neue Wissensbeiträge
Tipps & Tricks

Wie Hackt man sich am besten in ein Computernetzwerk ein

(29)

Erfahrungsbericht von Herbrich19 zum Thema Tipps & Tricks ...

Humor (lol)

Bester Vorschlag eines Supporttechnikers ever: APC

(15)

Erfahrungsbericht von DerWoWusste zum Thema Humor (lol) ...

Windows Server

Exchange 2010 Active Directory und Windows Server 2016

(4)

Erfahrungsbericht von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Internet
gelöst Mitarbeiter surft auf unerwünschter Seite - Wie damit umgehen? (41)

Frage von sabines zum Thema Internet ...

Netzwerke
Wie erstelle ich ein Intranet (19)

Frage von Leonardnet zum Thema Netzwerke ...

Netzwerke
VPN-Server einrichten PPTPD-Einrichtung gescheitert (15)

Frage von MIlexx zum Thema Netzwerke ...

LAN, WAN, Wireless
gelöst Eintägige Netzwerkunterbrechung trotz Backupleitung (15)

Frage von iAmbricksta zum Thema LAN, WAN, Wireless ...