Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

squidGuard einrichten

Frage Internet Utilities

Mitglied: vaevictis

vaevictis (Level 1) - Jetzt verbinden

12.02.2007, aktualisiert 30.04.2007, 12093 Aufrufe, 8 Kommentare

squidGuard falsche Version?

Hallo zusammen!
Ich hab hier einen kleinen Suse 10.2 Proxy-Server laufen. Funktioniert mit squid soweit ganz gut.
Ich will jetzt einen Webseitenfilter mit squidGuard zum laufen bringen.

Ich soll gemäß der Anleitung in der squid.conf.in den Eintrag
redirect_program /usr/local/bin/squidGuard
einfügen.

Die Datei hab ich aber lustigerweise nicht. Also hab ich mal gegoogelt und herausgefunden, daß ich in der squid.conf den Eintrag
redirect_program /usr/local/bin/squidGuard -c /etc/squid/squidGuard.conf
einzufügen hätte.

Die Pfade stimmen, nur funktionieren tut's auch mit der Squid.conf statt der squid.conf.in nicht.

Könnte es sein, daß es sich da um nen Versionskonflikt handelt? Daß mein squidguard n anderes squid will?

Oder wie kann ich in der squid.conf auf squidguard verweisen?


Das Ausführen von /usr/local/bin/squidGuard
führt zu folgendem EIntrag in der log-Datei:

2007-02-12 13:36:57 [10599] squidGuard 1.1.4 started (1171283817.530)
2007-02-12 13:36:57 [10599] squidGuard ready for requests (1171283817.602)
2007-02-12 13:36:57 [10599] squidGuard stopped (1171283817.602)


Also funzen tut er wohl. Wenn ich aber ne normale URL aufrufe gibt es keinen Eintrag in der log-Datei. Deshalb vermute ich, daß der Eintrag
redirect_program /usr/local/bin/squidGuard -c /etc/squid/squidGuard.conf
in der squid.conf wohl nicht funktioniert. Vielleicht muß der ja an eine ganz bestimmte Stelle geschrieben werden?!?

Wäre echt dankbar um jede Hilfe! Viel Spaß beim Grübeln!
Mitglied: RelaSoft
12.02.2007 um 14:25 Uhr
hi ...

also mein eintrag lautet :

redirect_program /usr/sbin/squidGuard

... und funktinoert spitze ) .... hab mal in meine .../usr/local/bin ... reingeschaut ... also bei mir steht da nix!
Bitte warten ..
Mitglied: vaevictis
12.02.2007 um 15:05 Uhr
Hab's nochmal überprüft.

Der Pfad ist schon richtig.
Die squidGuard-Datei ist in /usr/local/bin.
Is ja egal wohin man das installiert....

Ich hab auch mal das -c /etc/squid/squidGuard.conf aus der Zeile entfernt.
Bringt auch nix. Ich denk, die Zeile braucht er ja auch, sonst bekommt er ja keine ACLs und weiß nicht, welche Filterlisten er verwenden soll...

Muß man das redirect_program... vielleicht an eine bestimmte Stelle in der squid.conf schreiben?
Oder braucht man das # davor oder braucht man es explizit nicht?
Bitte warten ..
Mitglied: RelaSoft
12.02.2007 um 16:27 Uhr
die # ist zur auskommentierung der entsprechnden zeile ...
d.h. ... wenn du den eintrag verwenden willst MUSS die # weg!
Bitte warten ..
Mitglied: vaevictis
12.02.2007 um 16:41 Uhr
Na, dann stimmt ja alles.

Naja, klappen tut's trotzdem nicht*g

ich kann die Zeile aber ganz einfach an den Kopf der conf-Datei schreiben, oder?
Bitte warten ..
Mitglied: RelaSoft
16.02.2007 um 10:07 Uhr
also wohin du die zeile in der squid.conf schreibst ist egal ...

hast du denn in der squidgard.conf ...

die "src", die "dst" und die "acl" drin?
Bitte warten ..
Mitglied: vaevictis
16.02.2007 um 12:17 Uhr
hm, hier is meine squidGuard.conf, möge sie für Erleuchtung sorgen*g:


logdir /var/log/squidGuard
dbhome /var/spool/squidGuard/db

dest ads {
domainlist ads/domains
urllist ads/urls
redirect 302:http://192.168.0.1/1x1.gif
}

dest aggressive {
domainlist aggressive/domains
urllist aggressive/urls
log blocked.log
}

dest audio-video {
domainlist audio-video/domains
urllist audio-video/urls
log blocked.log
}

dest drugs {
domainlist drugs/domains
urllist drugs/urls
log blocked.log
}

dest gambling {
domainlist gambling/domains
urllist gambling/urls
log blocked.log
}

dest hacking {
domainlist hacking/domains
urllist hacking/urls
log blocked.log
}

dest porn {
domainlist porn/domains
urllist porn/urls
log blocked.log
}

dest violence {
domainlist violence/domains
urllist violence/urls
log blocked.log
}

dest warez {
domainlist warez/domains
urllist warez/urls
log blocked.log
}

dest good {
domainlist custom/good/domains
urllist custom/good/urls
}

destination bad {
domainlist custom/bad/domains
urllist custom/bad/urls
log blocked.log
}


acl {
default {
pass good !bad !ads !aggressive !audio-video !drugs !gambling !hacking !porn !violence !warez all

redirect 302:http://192.168.0.1/cgi-bin/squidGuard.cgi/?clientaddr=%a&clientname ...

}
}
Bitte warten ..
Mitglied: RelaSoft
16.02.2007 um 15:50 Uhr
also meiner meinung fehlt was

du hast keine src's drin ?!?!?!?! oder brauchst die nicht
bei mir hab ich nen eintrag ...

xxx1 (subnet) und xxx2 (ip) sind hier jetzt mal bezeichner ... sind jetzt mal nur als darstellung


  1. net
src "xxx1" (
ip 192.168.0.0/24
)
  1. user
src "xxx2" (
ip 192.168.0.10/32
)

....
dann die dst's
dest ads (
domainlist ads/domain
urllist ads/url
)

... weitere dst ....
und zu guter letzt die acl's

acl (
xxx1 (
pass !ads (..... etc.....) all
)

xxx2 (
pass !porn all
)

default (
pass none
redirect http://www.meine-firma.de/errors/error.html
)

)

und bei mir geht es .... )

kannst es ja mal so versuchen .... vielleicht hilft es
die dbhome verweist auch auf den richtigen pfad? ...
Bitte warten ..
Mitglied: vaevictis
30.04.2007 um 09:57 Uhr
So,
Rechner hatte Totalschaden womit sich das Problem von alleine gelöst hat.
*g
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst TP-Link WA501G als Client einrichten - Keine IP Adresse wir bezogen (14)

Frage von bestelitt zum Thema LAN, WAN, Wireless ...

Apache Server
Alias bzw. Weiterleitung unter Apache 2.4 einrichten (2)

Frage von m.reeger zum Thema Apache Server ...

Windows Server
gelöst Einrichten SBS 2011 mit Hybrid Router (12)

Frage von stolli zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...