Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

SSO Single-Sign-On über CredSSP funktioniert an XP SP3 Client nicht - Terminalserver 2008 R2

Frage Microsoft Windows Server

Mitglied: Excaliburx

Excaliburx (Level 2) - Jetzt verbinden

22.02.2011, aktualisiert 23:10 Uhr, 9132 Aufrufe, 10 Kommentare

Hallo zusammen,

die User sollen von den XP SP3 Clients mit RDC 6.1 und .Net Framework auf Win 2008 Terminalserver zugreifen und RemoteApps starten.

Die XP Clients gehören der Domäne an.

Ziel:
Die User sollen sich nur einmalig an den Clients anmelden müssen und nicht noch mals ihr Passwort nach Aufruf eines RemoteApps eingeben müssen.

Daher habe ich nun bei XP SP3 das CredSSP aktiviert (lt. dem Buch Windows Server 2008 Terminaldienste).

Als lokal am Client angemeldeter Administrator habe ich folgende Zwei Änderugen in der Registry vorgenommen:

1.
den Eintrag "tspkg" dem Schlüssel HKLMSYSTEMCurrentControlSetControlLsa hinzugefügt.

2.
den Eintrag "Credssp.dll" dem Schlüssel HKLMSYSTEMCurrentControlSetControlSecurityProviders hinzugefügt.


Problem:
Am XP Client erschein nun beim Start eines RemoteApps bzw einer normalen Remotedesktopsitzung die Fehlermeldung mit folgendem Text:

Remotedesktopverbindung
Es wird keine Verbindung hergestellt, da die Anmeldeinformationen nicht an den Remotecomputer gesendet werden können. Wenden Sie sich an den Systemadministrator, um Unterstützung zu erhalten.
OK Hilfe

Kennt jemand die Ursache dieses Problems? Und hat eine Lösung dazu?


Danke für Unterstützung!

Gruß
Mitglied: DerWoWusste
22.02.2011 um 23:15 Uhr
Da fehlen weitere Einstellungen. Siehe http://support.microsoft.com/kb/951608
Bitte warten ..
Mitglied: DerWoWusste
22.02.2011 um 23:15 Uhr
doppelt...
Bitte warten ..
Mitglied: Excaliburx
23.02.2011 um 00:59 Uhr
Hallo,

danke für schnelle Hilfestellung.

Ich habe die Einstellungen lt. der Beschreibung in der Registry des XP Clients eingestellt.

Das Verhalten beim Start eines RemoteApps bzw. einer Remotedesktopverbindung hat sich zwar dahingehend verändert, dass die besagte Fehlermeldung nicht mehr erscheint, jetzt aber nach wie vor die Anmeldedaten vom User nochmal eingegeben werden müssen (am Terminalserver, um sich am Terminalserver zu authentifizieren).

Kennt jemand nun dieses Problem?

Zudem ist mir nicht klar, welche Registry-Enträge auf 1 und welche auf 0 zu stellen sind. Dies geht aus dem oben genannten Microsoft-Artikel nicht hervor.
Eventuell hat hierzu auch jemand nähere Infos?

Vielen Dank für Tipps zur Lösung!

Gruß
Bitte warten ..
Mitglied: o0ByteRebel0o
23.02.2011 um 15:29 Uhr
Hi

gibt es einen Hotfix für: 1

CU Jens
Bitte warten ..
Mitglied: DerWoWusste
23.02.2011 um 16:26 Uhr
Wie's im Beispiel steht:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation

REG_DWORD: AllowDefaultCredentials
Value data: 00000001

REG_DWORD: ConcatenateDefaults_AllowDefault
Value data: 00000001

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation\AllowDefaultCredentials

"1"="TERMSRV/*"
Bei uns war der Hotfix nicht nötig - dennoch testen.
Bitte warten ..
Mitglied: Excaliburx
23.02.2011 um 20:42 Uhr
Hallo,

diese Fehlermeldung bekomme ich an einem Windows 7 Client, wenn ich die Remotedesktopverbindung starte:

c0b32963be114a87c9910aebd42dccca - Klicke auf das Bild, um es zu vergrößern

Am Server habe ich bezüglich dieser Fehlermeldung jedoch keine Richtlinen geändert.

Bei Win 7 müsste ja Single Sign On von Haus aus funktionieren.


Kennt jemand die Lösung, sodass die Anmeldedaten übertragen und vom Server akzeptiert werden?

PS:
Das Passwort vom User, welches er bei der Domänenanmeldung am Win 7 Client eingegeben hat ist im CredSSP gespeichert.


Danke im Voraus!

Gruß
Bitte warten ..
Mitglied: Excaliburx
23.02.2011 um 22:29 Uhr
Hi,

die Einstellungen von dieser Seite

http://windows.microsoft.com/de-DE/windows7/Why-can-t-I-connect-using-R ...

haben leider auch auf dem Win 7 Client nichts gebracht.

Unter Win XP SP3 gibt es diesen Pfad in den lokalen Gruppenrichtlinien gar nicht.


Hat jemand noch Infos dazu?

Gruß
Bitte warten ..
Mitglied: DerWoWusste
23.02.2011 um 23:55 Uhr
Auf Win7 geht es von Haus aus? Wer sagt das?
http://technet.microsoft.com/en-us/library/cc772108(WS.10).aspx durchführen, dann geht es auf Vista/Win7.
An anderer Stelle wird bei MS betont, dass TERMSERV unbedingt groß geschrieben werden muss.

Hast Du bei xp den Patch schon getestet? Hast Du die genannten Regeinträge gemacht? Hast Du mal einfach den Fixit von meinem Link ausgeführt?
Bitte warten ..
Mitglied: Excaliburx
02.03.2011 um 17:40 Uhr
Hi,

vielen Dank für die Hilfe. Nun hat es an den Win 7 und XP SP3 Clients funktioniert.

Gruß
Bitte warten ..
Mitglied: DerWoWusste
02.03.2011 um 17:43 Uhr
Schön.
Damit andere es auch verwerten können, schreib kurz dazu, was zur Lösung geführt hat.
Bitte warten ..
Ähnliche Inhalte
Vmware
VMware Single Sign on und VDP

Frage von Greyson zum Thema Vmware ...

Windows Server
SQL Server 2008 R2 SP3 neue Instanz (10)

Frage von technikdealer zum Thema Windows Server ...

Windows Server
gelöst Netzlaufwerk RemoteApp auf Win 2012 R2 Terminalserver funktioniert nicht (12)

Frage von grenzde zum Thema Windows Server ...

Windows 10
gelöst Wake on LAN mit Win10x64 funktioniert nicht (16)

Frage von Rene1976 zum Thema Windows 10 ...

Neue Wissensbeiträge
Ubuntu

Ubuntu 17.10 steht zum Download bereit

Information von Frank zum Thema Ubuntu ...

Datenschutz

Autofahrer-Pranger - Bewertungsportal illegal

(8)

Information von BassFishFox zum Thema Datenschutz ...

Windows 10

Neues Win10 Funktionsupdate verbuggt RemoteApp

(6)

Information von thomasreischer zum Thema Windows 10 ...

Microsoft

Die neuen RSAT-Tools für Win10 1709 sind da

(2)

Information von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
Router & Routing
Allnet - VDSL2 Modem - SFP (mini-GBIC) (20)

Frage von Dobby zum Thema Router & Routing ...

Voice over IP
DeutschlandLAN IP Voice Data M Premium, Erfahrung mit Faxgeräte? (17)

Frage von liquidbase zum Thema Voice over IP ...

Windows 10
Windows 10 Ordnerfreigabe (14)

Frage von Xaero1982 zum Thema Windows 10 ...