Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Standardwerte in Access

Frage Entwicklung Datenbanken

Mitglied: Falkster

Falkster (Level 1) - Jetzt verbinden

15.11.2005, aktualisiert 16.11.2005, 4599 Aufrufe, 12 Kommentare

mit "0" oder "--- " beginnen???

hi leute,

da gibt es doch das feld "standardwert" in access....
habe folgendes problem:
ich setze in den formulareigenschaften das standardwert- feld auf "0", weil ich mit einem
leeren, bzw. mit "0" gefüllten wert beginnen will. es würde so gesehen jeder platzhalter OK sein.

trotzdem werden bei eingabe ins formular diverse felder immer mit den werten des vorhergegangenen
datensatzes begonnen. z.b.: "personalnummer" mit "84" statt mit "0" , oder halt auch "---", oder "?" etc.....

wie bekomme ich eine "saubere" eingabemaske bei beginn?????
vielen dank für eure hilfe.

gruß
fm
Mitglied: Atti58
15.11.2005 um 15:08 Uhr
... indem Du nicht dem Formular sondern der Tabelle den Standardwert zuweist,

Gruß

Atti.
Bitte warten ..
Mitglied: Falkster
15.11.2005 um 15:25 Uhr
hi!

habe ich gemacht, will aber noch nicht...
gruß
fm
Bitte warten ..
Mitglied: Atti58
15.11.2005 um 15:40 Uhr
Redest Du von einem neuen Datensatz und dessen Standardwert?

Gruß

Atti
Bitte warten ..
Mitglied: Falkster
15.11.2005 um 15:53 Uhr
genau, ich will einfach nur leere felder bei beginn.
Bitte warten ..
Mitglied: Atti58
15.11.2005 um 15:59 Uhr
... also, bei mir werden die vorgegebenen Standardwerte sofort übernommen ... Mit welcher ACCESS-Version arbeitest Du denn?

Gruß

Atti
Bitte warten ..
Mitglied: Falkster
15.11.2005 um 16:06 Uhr
ms access 2003 build: 11.5614.5606
Bitte warten ..
Mitglied: Atti58
15.11.2005 um 16:32 Uhr
Ich habe schon SP 2 Build 11.6566.6568 ... das dürfte es aber nicht sein, bei mir sieht das so aus:

4683cf57266e7690cba1e788687cd4f8-access1 - Klicke auf das Bild, um es zu vergrößern

1. Feld ist Text 50 Zeichen Standardwert XXX
2. Feld ist Numerisch Standardwert -1

Hast Du vielleicht andere Dinge (Masken, Formate o.ä) deklariert?

Gruß

Atti
Bitte warten ..
Mitglied: Falkster
16.11.2005 um 11:52 Uhr
danke schonmal atti,
ich werd mal schaun, kann mir das noch nicht erklären,
aber so wie bei dir will ich das haben.
gruß
fm
Bitte warten ..
Mitglied: Atti58
16.11.2005 um 13:00 Uhr
Hast Du es denn schon mal in der Tabelle alleine versucht, funktioniert es in der Tabellenansicht ohne Formular?

Gruß

Atti
Bitte warten ..
Mitglied: Falkster
16.11.2005 um 13:32 Uhr
ja, das geht!!!!!!
-... aber wie kriege ich das formular sauber??

gruß
fm
Bitte warten ..
Mitglied: Atti58
16.11.2005 um 13:52 Uhr
Wenn Du möchtest, kannst Du mir Deine DB mal schicken (wenn sie nicht zu groß ist), dann sehe ich sie mir mal an (vorher bitte mit "Extras" -> "Datenbank-Tools" -> "Komprimieren und Reparieren" verkeinern) - atti58 at gmail.com,

Gruß

Atti.
Bitte warten ..
Mitglied: Falkster
16.11.2005 um 14:32 Uhr
hi atti!

danke für das angebot!
... habe wohl einen dummen fehler gemacht.

es geht hier um listenfelder, hätte ich sagen sollen, nun wird mir auch alles klar *schäm*

... klar, wenn das listenfeld keinen wert "0" oder "xxx" beinhaltet kanns ja net gehen.

gruß
fm
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Datenbanken
gelöst Access 2010 Filter zurücksetzen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Microsoft Office
gelöst Nach Office 2010 SP2 Update - Kein Sharepoint export zu Access möglich (1)

Frage von paddl82 zum Thema Microsoft Office ...

LAN, WAN, Wireless
Access Point (VLAN, Multi-SSID) legt Netzwerk lahm (8)

Frage von humbeldi zum Thema LAN, WAN, Wireless ...

Datenbanken
gelöst Access 2010 SQL Tabellen Datensätze einfügen (6)

Frage von Dr.Cornwallis zum Thema Datenbanken ...

Heiß diskutierte Inhalte
Zusammenarbeit
Als Administrator im Großraumbüro (29)

Frage von Dopamin85 zum Thema Zusammenarbeit ...

Exchange Server
Test-ActiveSyncConnectivity Error nach neuem Zertifikat (22)

Frage von Driphex zum Thema Exchange Server ...

Hardware
Laptop ins Salzwasser gefallen (18)

Frage von Marcel94 zum Thema Hardware ...

Hardware
Lenovo Yoga 500 über angeschlossene USB Tastatur booten (12)

Frage von thomasreischer zum Thema Hardware ...