Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Startdiskette Windows 2003 Server

Frage Microsoft Windows Installation

Mitglied: Ariani

Ariani (Level 1) - Jetzt verbinden

07.07.2008, aktualisiert 08.07.2008, 6301 Aufrufe, 29 Kommentare

Hallo Liebe Community,

ich weis nicht recht ob es der richtige Bereich ist, aber hab weder in der SuFu noch bei Google brauchbare Tipps enthalten.

Folgendes Problem:

Heute morgen ist uns der Server abgestürzt bzw. der Raid-Controller hat seine einstellungen verloren. Da es nicht das erstemal war das dies passiert ist. Habe ich über den Adaptec manager das Raid neu aufbauen lassen. Nachdem dieses abgeschlossen war wollt ich den rechner booten. und bekamm die meldung das die datei Ntoskrnl.exe nicht vorhanden oder beschädigt sei, ich soll eine neue Version der Datei Installieren(nicht Original Wortlaut).

Wollte hierdraufhin über die Wiederheerstellungsconsole der InstallCD die Datei neu entpacken. Aber die Windows Installation findet keine Festplatten.

Nun ist meine Frage wie bekomme ich diese Dati in mein System rein ?!

Es handelt sich um einen Fujitsu Primergy TX200 mit einem Adaptec scsi Controller. Bin mit meinem Latein am Ende.

Vllt. kann mir jemand Helfen.

Gruss Ari
29 Antworten
Mitglied: 67027
07.07.2008 um 14:01 Uhr
Die Fehlermeldung bedeutet nicht zwangsläufig, dass Dateien fehlen. ;)

Stimmen die Einträge in der Boot.ini, wurden dort spezielle Einträge für /KERNEL= oder /HAL= benötigt?

Stimmen die Namenskonventionen?
http://support.microsoft.com/kb/102873

Du kannst eine unter einem NT-System formatierte Diskette verwenden, darauf die boot.ini kopieren oder erstellen und die Dateien NTLDR, ntdetect.com und NTBOOTDD.SYS kopieren und den Bootvorgang damit testweise einleiten, evtl. verschiedene Zeilen für die boot.ini ausprobieren.
Bitte warten ..
Mitglied: sysad
07.07.2008 um 14:15 Uhr
Schau Dir folgendes an:

http://support.microsoft.com/kb/102873


Meist kommt die Meldung dann, wenn sich die Zahl, Lage oder der LW-Buchstabe irgendwie geändert haben und W versucht, beim Booten z.B. von E: zu laden, dort findet er aber den NTLDR oder was auch immer nicht mehr. Es muss also nicht sein, dass die Datei fehlt.

HTH
Bitte warten ..
Mitglied: 67027
07.07.2008 um 14:29 Uhr
@sysad

Noch nicht ganz wach? Was wurde denn 15 Minuten vor deinem Beitrag geschrieben?
Bitte warten ..
Mitglied: sysad
07.07.2008 um 14:34 Uhr
Hast recht, aber als ich das Antwortfenster aufgemacht hatte, war noch kein Antwortbeitrag da, der Deinige tauchte erst beim Posten auf. Aber wenn wir zwei an das gleiche als Lösung gedacht haben, ist der Ratsuchende ja bestens bedient!
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 14:55 Uhr
Liebe Leute,

erstmal danke für die beiden Antworten.

@67027: Kann die Boot.ini nicht kontrollieren da ich nicht auf die Festplatte zugreifen kann.

Ich habe zum Glück 2 Identische Server stehen wo die Boot.ini folgendermassen aussieht:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003 fr Small Business Server" /fastdetect /NoExecute=OptOut

Soviel ich verstanden habe benötigt er die Ntbootdd.sys bei der einstellung garnicht. Grund ist auch das auf keinem der anderen Server soeine Datei vorhanden ist.

@sysad: Es wurde aber an der Hard oder SOftware nichts geändert. Samstag lief der Server noch ohne Probleme nur Heute morgen kam der Fehler.

Ich habe schon probiert eine Startdiskette zu erstellen um die Datei per Eingabeaufforderung wieder reinzukopieren. Nur stosse ich hier an meine Grenzen denke ich. Jemand noch eine Idee?

Gruss Ari
Bitte warten ..
Mitglied: 67027
07.07.2008 um 14:59 Uhr
NTBOOTDD.SYS wird für Risc- oder SCSI-Konfigurationen verwendet. Erläuterungen stehen im Link.

Du kannst die boot.ini von einem der beiden identischen Server auf die Diskette kopieren und damit versuchen, den Server zu starten. Dann kannst du sie von der Diskette kopieren, wenn der Start funktioniert.
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 15:03 Uhr
Hallo Tatuff,


habe bereits deinen Rat befolgt und wie in deinem ersten Post beschreiben eine Diskette mit den Datein erstellt. Dieses blieb ohne erfolg.

Invalid System Disk

Oder muss ich die Datein auf einen Startdiskette kopieren ?!

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
07.07.2008 um 15:19 Uhr
Hast du über F6 die Treiber für dein RAID geladen, bevor du die Wiederherstellungskonsole gestartet hast?

geTuemII
Bitte warten ..
Mitglied: 67027
07.07.2008 um 15:23 Uhr
Du musst die Diskette ganz normal (NICHT als MS-DOS-Startdiskette !) unter XP oder W2k formatiert haben und die Dateien incl. der "geklonten" Boot.ini darauf kopieren.

Edit 16.02 Uhr:
Nimm das mal als boot.ini:

---->
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003 Partition 1" /fastdetect /NoExecute=OptOut
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows Server 2003 Partition 2" /fastdetect /NoExecute=OptOut

<-----
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 16:05 Uhr
Muss ich die Treiber für den Raid oder für den Controller laden.

Beim Versuch die Treiber für den Controller zu laden, sagt mir Windows das Treiber für den Controller bereits in Windows vorhanden sind und fügt diesen trotzdem nicht zu.

Das Booten über die Boot.ini per Diskette funktioniert nach wie vor nicht.

Gruss Ari
Bitte warten ..
Mitglied: 67027
07.07.2008 um 16:09 Uhr
"Funktioniert nicht" ist immer sehr aussagekräftig. Natürlich gibt es keine konkrete Fehlermeldung, oder?

Hast du meinen Nachtrag beachtet?
Bitte warten ..
Mitglied: geTuemII
07.07.2008 um 16:25 Uhr
Muss ich die Treiber für den Raid oder für den Controller laden.

Falls es sich bei diesem Satz um eine Frage handelt: du mußt den Treiber für den RAID-Controller laden, sonst wird die Wiederherstellungskonsole deine Platten nicht finden.

geTuemII
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 16:37 Uhr
Sorry tatuff,

hab deinem Nachtrag nach die Boot.ini geändert und mit den anderen Datein auf eine frisch formatierte Diskette kopiert (die NTbootdd.sys ist nicht mit drauf da diese nicht vorhanden).

Bekomme nach dem Bootversuch den fehler:

Windows konnte nicht gestartet werden da die Datei <Windows root>\System32\ntoskrnl.exe fehlt oder beschädigt ist.

Gruss Ari

Ps.: Nochmal vielen dank an alle die sich die mühe mach.
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 16:40 Uhr
Klar war das eine frage geTuemII, entschuldige bitte
Bin hier total unter Strom.

Wie bekomme ich raus was für einen Controller ich im Server verbaut habe. In den Server unterlagen gibt es zig Variationen welcher Controller verbaut sein könnte.

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
07.07.2008 um 16:44 Uhr
Falls du bei FSC erweiterten Support hast, rufe die an, die sehen das in ihrer DB. Ansonsten hattest du oben was von von Adaptec geschrieben. Im Notfall hilft es nur, auf die verbaute Karte zu sehen.

geTuemII
Bitte warten ..
Mitglied: 67027
07.07.2008 um 16:45 Uhr
1. Hast du beide Konfigurationseinträge ausprobiert?

2. kannst du dich in der Wiederherstellungskonsole anmelden, oder kommt vorher bereits
die Fehlermeldung, dass keine Platten gefunden werden?
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 16:55 Uhr
Ich habe Leider keinen erweiterten Support da der Erwerb und die EInrichtung damals über eine 3. Firma gelaufen ist. Leider haben die auch keine Daten von den Server mehr irgenwo und nun steh ich wie ein Ochse vorm Berg

Ja der Controller ist von Adaptec. Kannst du erkennen um welche Karte es sich handelt wenn ich dir Fotos zukommen lasse?

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
07.07.2008 um 17:05 Uhr
Sieh dir die Karte an, da steht außer Adaptec auch die genaue Bezeichnung drauf.

geTuemII
Bitte warten ..
Mitglied: 67027
07.07.2008 um 17:10 Uhr
Ich steig aus, meine Fragen werden ja doch nicht beantwortet.

Aber vielleicht geht euch ja doch noch das Licht auf, dass von einer Platte, die nicht gefunden werden kann, auch keine Systemdateien geladen werden können, in denen Fehlermeldungen stehen, die dann auf dem Bildschirm ausgegeben werden (#1).
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 17:28 Uhr
@ Tatuff: Entschuldige bitte das ich dich übersehen habe ist/war keine Absicht.

Das mit den Konfigurationeinträgen verstehe ich nicht so ganz?!

Ich komme leider nichtmal in die Konsole rein, das Installprogramm sagt vorher das es keine Festplatte erkennen konnte, was ja auch irgendwie logisch ist.

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
07.07.2008 um 17:38 Uhr
@67027:

Aber vielleicht geht euch ja doch noch das Licht auf, dass von einer Platte, die nicht gefunden werden kann, auch keine Systemdateien geladen
werden können, in denen Fehlermeldungen stehen, die dann auf dem Bildschirm ausgegeben werden (#1).

Ähm, kannst du mir bitte kurz erklären, warum du mich hier so von der Seite anmachst? Ich bin deiner Meinung, daß eine Platte gefunden werden muß, wenn der Rechner davon booten soll. Wenn also Ariani über die Wiederherstellungskonsole Systemdateien nachinstallieren will, müssen zunächst mal die Treiber für den RAID-Controller geladen werden.

Dein Ansatz ist ein anderer, du gehst davon aus, daß die Dateien nicht wirklich verloren sind, sondern nur der Zugriff darauf durch den Absturz der RAID-Konfiguiration gestört wurde. Ja, auch das kann sein. Ich weiß nicht, wie du das hälst, aber ich gehe davon aus, daß ein Problem zum einen mehrere Ursachen haben kann und zum anderen verschiedene Lösungsansätze zielführend sein können. In keinem Fall bin ich aber der Meinung, daß dein Tonfall passend ist.

Ganz unabhängig davon würde mich der Sinn der Passage "in denen Fehlermeldungen stehen, die dann auf dem Bildschirm ausgegeben werden" wirklich mal interessieren.

geTuemII
Bitte warten ..
Mitglied: 67027
07.07.2008 um 17:56 Uhr
@geTuemII

Ich mach niemand von der Seite an, ich habe lediglich keine Lust, auf 2 Hochzeiten gleichzeitig zu tanzen, alles der Reihe nach. Und wenn ich Fragen stelle, hätte ich darauf erst einmal gern eine Antwort.

Nachdem dieses abgeschlossen war wollt ich den rechner booten. und bekamm die meldung
das die datei Ntoskrnl.exe nicht vorhanden oder beschädigt sei, ich soll eine neue Version
der Datei Installieren(nicht Original Wortlaut).

Diese Meldung steht in einer der 2 Bootdateien, die auf der (nicht auffindbaren) Platte durch den Bootloader geladen wurden, nachdem durch die Routinen in dieser ebenfalls von dieser (nicht auffindbaren) Platte die Registry mit dem Systempfad gescannt wurde.

In der Wiederherstellungskonsole stellt Windows dann (ebenfalls auf der nicht auffindbaren Platte) fest, dass die Dateien, die über F6 geladen werden sollen, bereits vorhanden sind.

Wenn dir an diesen Merkwürdigkeiten nichts auffällt ......

Inzwischen wurde meine Frage nach der Anmeldemöglichkeit in der Wiederherstellungskonsole ja beantwortet. Trotzdem verabschiede ich mich aus dem Thread.

@Ariani
Das mit den Konfigurationeinträgen verstehe ich nicht so ganz?!
In der Boot.ini stehen 2 Zeilen mit 2 unterschiedlichen Konfigurationen.
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 20:00 Uhr
Vllt. hab ich mich da etwas undeutlich ausgedrückt. Wenn ich mit f6 die treiber für die scsi karte zufügen will sagt windows das in windows solche treiber bereits existieren. aber gutuemII sagte ja ich muss die treiber vom raid zufügen, welche ich ja noch nicht habe...

nun seit wieder lieb, wir sind alles nur menschen

gruss Ari
Bitte warten ..
Mitglied: 51705
07.07.2008 um 21:05 Uhr
Hallo tatuff,

das Nichtfinden der 'Ntoskrnl.exe' deutet auf eine nicht zugreifbare Platte (oder Raid) aufgrund fehlender Treiber hin.

In der Wiederherstellungskonsole stellt Windows dann (ebenfalls auf der nicht auffindbaren Platte)
fest, dass die Dateien, die über F6 geladen werden sollen, bereits vorhanden sind.

Ein TX200 verwendet üblicherweise einen Adaptec 29160 für Bandlaufwerke. Für die Platten wird ein LSI Logic MegaRaid verwendet. Daher können die Treiber für den Adaptec durchaus enthalten sein, ein Zugriff auf die Platten ist jedoch nicht möglich. Der einzig zielführende Hinweis in diesem Thread ist der von geTuemII bzgl. der Treibereinbindung mittels 'F6'.

Grüße, Steffen
Bitte warten ..
Mitglied: Ariani
07.07.2008 um 22:01 Uhr
Hallo Srmerlin,

und danke für die Tipps, werde morgen mal treiber für ein Megaraid probieren und hier meine erfahrungen posten.

Gruss Ari
Bitte warten ..
Mitglied: Ariani
08.07.2008 um 11:48 Uhr
So,

durch unser IT-Systemhaus konnten wir den Treiber ausfindig machen. Nun meine Frage da ich nicht weiss ob nun eine Funktionierendes Backup erstellt wurde. Ist es möglich Windows zu Installieren und nicht zu Formatieren, die Daten zu sichern und danach alles neu machen ?!

Oder ist das bei Raidlaufwerken anders?

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
08.07.2008 um 13:06 Uhr
Wieso willst du denn auf einmal neu installieren? Wir sprachen doch die ganze Zeit von der Wiederherstellungskonsole?! Und um dort Zugriff auf die Platten zu erhalten, mußt du den Treiber am Beginn des Setup laden. Der Neuaufbau des Servers bringt es jedenfalls nicht, es sein denn, du hast ein Desaster Recovery Backup. Falls der Server Domain Controller ist, baust du sonst dein komplettes System neu auf.

BTW: wenn du nicht sicher bist, ob du ein funktionierendes Backup hast, solltest du dich vielleicht mit deinem IT-Systemhaus unterhalten...

geTuemII
Bitte warten ..
Mitglied: Ariani
08.07.2008 um 13:14 Uhr
Hey geTuemII,

über die Console konnten wir auf C: zugreifen aber leider konnte ich mir weder mir "DIR" die Verzeichnissstruktur anzeigen lassen noch konnte ich mit CHKDSK ne Fehlerüberprüfung einleiten.

Auf dem Datenträger gibt es mindestens ein Problem (ca. der Wortlaut).

Gruss Ari
Bitte warten ..
Mitglied: geTuemII
08.07.2008 um 13:41 Uhr
Es wäre wirklich gut, wenn du Fehlermeldungen im Wortlaut posten würdest.

geTuemII
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst Exchange 2003 von Windows 2003 Server lösen bzw. entfernen (3)

Frage von plexxus zum Thema Exchange Server ...

Windows Server
gelöst Lokale Windows Firewall Server 2012R2 für virtuelle Maschine? (4)

Frage von 1410640014 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...