Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Subdomain leitet automatisch auf das root-Directory

Frage Internet

Mitglied: Voodoc

Voodoc (Level 1) - Jetzt verbinden

11.08.2010 um 10:19 Uhr, 4645 Aufrufe, 4 Kommentare

Hallo,

ich habe das folgende Problem:

Ich habe bei 1und1 einen Root-Server. Dieser wird zum Teil über Plesk, zum Teil über die Shell konfiguriert.
Nun habe ich mehrere Domains, die als vhosts konfiguriert sind. Es funktioniert alles auch soweit. Jedoch gebe ich
eine x-beliebige Subdomain ein (egal von welchem vhost/domain), wird man auf das root-Directory umgeleitet.

Sprich, die Domain: http://www.domain.de

http://egalwas.domain.de oder http://www.egalwas.domain.de landet aber auch immer im root-dir. Sollte es aber eigentlich nicht.

Hat jemand eine Idee? Vlt. eine Apache Einstellung?

Es ist eine Suse-Linux Maschine mit einem Apache-Server.

LG ch3fkoch/Voodoc
Mitglied: DrBulla
11.08.2010 um 10:52 Uhr
Hast du die .htaccess angepasst bzw. was steht dort drin?
Bitte warten ..
Mitglied: Crusher79
11.08.2010 um 10:56 Uhr
Hi,

schon mal google bemüht?

http://enarion.net/web/plesk/plesk-subdomain-www/?lang=de

Gibt zig Anleitungen. Du hast auch nicht deine akt. Plesk Version aufgeführt. Ggf. ist bei 1und1 alles anders. Was steht denn drot in den FAQ? Würde einfach mal die Anleitungen abarbeiten und wenn das nicht hilft, den 1und1 Support bemühen! Oft kochen die Anbieter ihr eigens Süppchen.

mfg Crusher
Bitte warten ..
Mitglied: Voodoc
11.08.2010 um 11:18 Uhr
@ DrBulla

Das Problem trifft auf alle vhosts zu. Manche haben eine .htaccess für den mod_rewrite, manche nicht. Scheint also nicht an der .htaccess zu liegen.
Bitte warten ..
Mitglied: Voodoc
11.08.2010 um 11:23 Uhr
Zitat von Crusher79:
Hi,

schon mal google bemüht?

http://enarion.net/web/plesk/plesk-subdomain-www/?lang=de

Gibt zig Anleitungen. Du hast auch nicht deine akt. Plesk Version aufgeführt. Ggf. ist bei 1und1 alles anders. Was steht denn
drot in den FAQ? Würde einfach mal die Anleitungen abarbeiten und wenn das nicht hilft, den 1und1 Support bemühen! Oft
kochen die Anbieter ihr eigens Süppchen.

mfg Crusher

Hi,
ja, habe google bemüht, leider nichts gefunden. Bei Deinem Link wird das Problem leider auch nicht angesprochen.
Habe Plsesk v. 9.0

Vlt. noch eine Zusatzinfo bzw. habe ich mich vlt. faslch ausgedrückt. Man wird zu dem Root-Dir des default-vhosts weitergeleitet und nicht zum jeweiligen des vhosts. Es scheint so etwas wie eine "catch-all" Funktionalität zu sein.

Aber ich werde mich wohl oder übel an 1und1 wenden müssen.

Trotzdem danke
Bitte warten ..
Ähnliche Inhalte
Webentwicklung
Webseiteninhalte auf Subdomains (4)

Frage von wescraven07 zum Thema Webentwicklung ...

Windows Server
ARR leitet nicht weiter (1)

Frage von AlexG82 zum Thema Windows Server ...

Verschlüsselung & Zertifikate
SSL Zertifikat für Subdomain (2)

Frage von tomi93 zum Thema Verschlüsselung & Zertifikate ...

Verschlüsselung & Zertifikate
gelöst Root Zertifikat in Firefox importieren (6)

Frage von DarkScabs zum Thema Verschlüsselung & Zertifikate ...

Neue Wissensbeiträge
Windows Server

Umstellung SHA 1 auf SHA 2 - Migration der CA von CSP auf KSP

Tipp von Badger zum Thema Windows Server ...

Windows 10

Quato DTP94 unter Windows 10 x64 installieren und verwenden

Anleitung von anteNope zum Thema Windows 10 ...

Windows 10

Win10 1703 und Nutzerkennwörter bei Ersteinrichtung - erstaunliche Erkenntnis

(15)

Erfahrungsbericht von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
CNC Maschinen verlieren Netzwerkverbindung (kurioser Fehler) (22)

Frage von NoHopeNoFear zum Thema LAN, WAN, Wireless ...

Webentwicklung
Aktuellen Mitarbeiter auf Homepage anzeigen (13)

Frage von alemanne21 zum Thema Webentwicklung ...

Windows Server
gelöst Parameter Übergabe Terminal Server (9)

Frage von ThomasKern zum Thema Windows Server ...

Batch & Shell
Anfängerfragen - Powershell - Mailboxvertretung im Pulk einrichten (8)

Frage von Yoshimitsu zum Thema Batch & Shell ...