Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Sysprep nur Computername-Eingabe

Frage Microsoft Windows Installation

Mitglied: Ravelux

Ravelux (Level 1) - Jetzt verbinden

23.03.2011 um 15:10 Uhr, 6894 Aufrufe, 1 Kommentar

Mein Ziel: Automatisches Image nur mit einer einfachen Computername-Eingabe

Guten Tag,

Zuerst mal zu meinem System. Ich benutze Windows 7 also mit integriertem Sysprep.
Ich probiere schon seit Tagen an meiner Antwortdatei vom Sysprep herum und er macht einfach nicht das was ich will.
Festgelegt habe ich schon, dass er die EULA, etc. überspringen soll und OOBE gar nicht anzeigen soll.

Mein Ziel ist folgendes:
Wir installieren das Image dann per PXE. Jeder unserer Mitarbeiter soll dann letzten Endes nur eine Computername-Eingabe eintippen und auf Weiter klicken.
Ich weiss nicht ob es funktioniert, aber es soll festgelegt sein, dass der Computer dann auch in meine Domain reinkommt, jedoch das Passwort dann aber eingeben muss beim ersten Start.
Zeitzone, Sprache, EULA, etc soll alles nicht erscheinen.

Meine derzeitige Antwort-Datei:
<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<NetworkLocation>Work</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>true</SkipUserOOBE>
</OOBE>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UILanguageFallback>en-US</UILanguageFallback>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Identification>
<Credentials>
<Domain>DOMAIN</Domain>
<Password>PASSWORT</Password>
<Username>USERNAME</Username>
</Credentials>
<JoinDomain>DOMAIN</JoinDomain>
</Identification>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" >xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Display>
<HorizontalResolution>1280</HorizontalResolution>
<VerticalResolution>1024</VerticalResolution>
</Display>
<ShowWindowsLive>false</ShowWindowsLive>
<BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
</component>
</settings>
<cpi:offlineImage cpi:source="catalog:\\192.168.33.3\MichaelC\Daten\Hinterlegungen\SW_DVD5_SA_Win_Ent_7_64BIT_German_Full_MLF_X15-70789\sources\install_windows 7 enterprise.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Ich hoffe ihr könnt mir weiterhelfen.
Mitglied: ahe
31.03.2011 um 18:07 Uhr
Ich vermute mal, ihr startet per PXE ein WinPE und dieses dann über eine Kommandozeile das Setup mit der Autounattend.xml.

Wir lösen das Problem, in dem wir VOR der eigentlichen Installation den Mitarbeiter nach dem Namen des Rechners fragen und diesen dann in die XML Datei eintragen.
Dies kann per Skipt rel. einfach eledigt werden. Dazu muss nur in dem Startskript des PE Images eine entsprechende Abfrage hinein.

. . .
- <settings pass="specialize">
- <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<ComputerName>My_Comp_Name</ComputerName>
. . .

Verwendet ihr eine XML für 32bit und 64bit?
Wenn nein, prüfe mal eure XML, da sind nämlich Komponenten von amd64 und X86 gemischt...
Wenn ja, dann sollte auch alles doppelt sein (außer Winpe...)

Mit freundlichen Grüßen
Axel
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 7
gelöst Sysprep nach Aufnahme in die Domäne, (4)

Frage von PizzaPepperoni zum Thema Windows 7 ...

Windows 10
SYSPREP Unattend Datei (1)

Frage von Patrick-IT zum Thema Windows 10 ...

Windows 7
gelöst Nervige Eingabeaufforderung für Benutzername und Kennwort Eingabe (7)

Frage von Freddy0013 zum Thema Windows 7 ...

Windows Installation
gelöst HP840 G3 und sysprep beim Original Image (9)

Frage von PizzaPepperoni zum Thema Windows Installation ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...