Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Taskplaner startet batch Datei nicht

Frage Microsoft Windows Server

Mitglied: Diddi-tb

Diddi-tb (Level 1) - Jetzt verbinden

23.05.2014, aktualisiert 12:40 Uhr, 3801 Aufrufe, 3 Kommentare

Hallo,

habe mal wieder ein Problem mit dem starten einer Batch Datei über die Windows Taskplanung. Google hat mich leider nicht wirklich weitergebracht.

Im Ordner D:\Scripte liegt eine Batchdatei Steckdosen_aus.bat mit folgendem Inhalt:

"C:\Program Files\Power Manager\pm.exe" -off -Device1 -Luefter
"C:\Program Files\Power Manager\pm.exe" -off -Device1 -Klima
pause

Wenn ich die Datei mit einem Doppelclick starte funktioniert alles perfekt.

Im Windwos Taskplaner ist der Task wie folgt angelegt:

Im Tab Allgemein ist der Benutzer Administrator ausgewählt (Passwort stimmt auch), Unabhängig von der Benutzeranmeldung ist gewählt und mit höchsten Privilegien ausführen ist angehakt.

Im Tab Aktionen ist folgende Aktion hinterlegt:
Aktion: Programm starten
Programm/Skript: C\Windows\System32\cmd.exe
Argumente hinzufügen: /c "D:\Scripte\Steckdosen_aus.bat"
Starten in: D:\Scripte

Wenn ich den Task manuell starte steht bei Status "Wird ausgeführt". Im Verlauf steht dann folgende Meldung:

Die Aufgabenplanung hat die Aufgabe "\Steckdosen_aus", Instanz "C:\Windows\System32\cmd.exe" mit der Prozess-ID 2588 gestartet.

Aus meinem Gefühl heraus würde ich sagen, das bei Argument oder Starten in ein Fehler drin ist. Komme aber nicht dahinter.

Betriebssystem ist Windows Server 2008

Vorab schon mal vielen Dank an alle!
Mitglied: Mullmull
LÖSUNG 23.05.2014, aktualisiert um 12:40 Uhr
Hallo Diddi.

Ich habe das ganze gerade mal auf einem unserer Test 2008 R2 nachgestellt ( Natürlich mit einer anderen .bat)
Hat bei mir leider auch nicht funktioniert.
Ein anderes Programm zu starten brachte mir das gleiche Ergebnis.
Werde mir das jetzt mal genauer ansehen.

Probiere doch mal was passiert, wenn du irgendeine .exe starten lässt, ohne Argumente.
Grüße Mulle

NACHTRAG:

Bei mir werden die Aufgaben nur ausgeführt, wenn bei Sicherheitsoptionen Nur ausführen, wenn der Benutzer angemeldet ist ausgewählt ist.
Bitte warten ..
Mitglied: SlainteMhath
23.05.2014 um 12:16 Uhr
Moin,

lass das ...\cmd.exe weg und setz die .bat direkt in "Programm/ausführen" - und nimm das "pause" aus der Script raus, das führt u.U. z ueiner (falschen) Abbruchmeldung beim Task.

lg
Slainte
Bitte warten ..
Mitglied: Diddi-tb
23.05.2014 um 12:39 Uhr
In der Tat läuft der Task nur wenn ich es so einstelle das der Benutzer angemeldet sein muss. Funktioniert jetzt so wie es soll. Vielen Dank für die schnelle Hilfe!!!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...