Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

TCP SYN ACK wird gesendet aber geht irgendwie verloren

Frage Linux Linux Netzwerk

Mitglied: mfernau

mfernau (Level 1) - Jetzt verbinden

31.10.2012 um 11:09 Uhr, 3530 Aufrufe, 3 Kommentare

Hallo liebe Profis,

ich stehe hier bei einer Sache total auf dem Schlauch. Ich habe bei einem Kunden einen kleine Linux-Router stehen (pcengines) der einen Dienst anbieten soll. Wenn sich die entsprechende Gegenstelle mit diesem Dienst verbinden möchte, kommt die Kommunikation schon auf der TCP/IP-Ebene nicht zustande. Der Aufrufer sendet das SYN-Bit und meine Linux-Box quittiert das mit SYN,ACK. Doch das scheint bei der Gegenstelle nie anzukommen und fragt abermals mit SYN nach einem Verbindungsaufbau.
Also irgendwo versumpfen diese Quittierungen. Lasse ich denselben Dienst jedoch auf einer anderen Maschine mit Windows laufen und verwende den gleichen Aufrufer für diesen Dienst, funktioniert es.
Ich hab das ganze mit Wireshark mitgeschnitten. Den einzigen Unterschied den ich zwischen der Linux und der Windows-Antwort (also das SYN,ACK Paket) sehen kann ist, dass unter Windows eine Window-Size von 8192 angegeben wird, während das bei meiner Linux-Box 14600 ist. Aber ob es daran liegen kann bezweifle ich.

Ich hab das Wireshark-Protokoll hochgeladen und stelle es hier bereit:
http://www.martin-fernau.de/files/public/linux_server.pcap

Ich hoffe es nimmt sich jemand die Zeit und schaut sich das kurz an - ich habe echt keine Idee wo ich da ansetzen soll. Übersteigt irgendwie meinen Horizont.

Schöne Grüße
Martin
Mitglied: MrNetman
31.10.2012 um 11:38 Uhr
Hi Martin,

Die SYN-Anfrage wird zweimal gestellt und zweimal beantwortet.
Aber:
Der anfragende Rechner schickt das ACK nicht.
P1 Anfrage
P2 Antwort
P3 Anfrage Wiederholung
P4 Antwort
P5 Antwort
P6 Reset

Aus die Maus.
Was fehlt ist die Bestätigung des Syn Ack, das ACK. fehlt als P3 und als P5

Gruß
Netman
Bitte warten ..
Mitglied: mfernau
31.10.2012 um 11:56 Uhr
Korrekt. Aber ich glaube ich hab das Problem gefunden.
Schau Dir mal genau den Absender des SYN-Pakets an. Insbesondere die MAC-Adresse

-> Ethernet II, Src: BintecCo_33:0d:b4 (00:a0:f9:33:0d:b4), Dst: PcEngine_27:2d:5c (00:0d:b9:27:2d:5c)

So, und nun schau Dir mal den Empfänger meines SYN,ACK Pakets an

-> Ethernet II, Src: PcEngine_27:2d:5c (00:0d:b9:27:2d:5c), Dst: Avm_1b:8f:a8 (00:1c:4a:1b:8f:a8)

Das ist ein vollkommen anderer Empfänger auf Ethernet-Ebene. Wie kann das sein?
Hier stimmt was mit meinem ARP-Cache nicht vermute ich mal
Bitte warten ..
Mitglied: mfernau
31.10.2012 um 12:04 Uhr
Okay ich habe den Fehler gefunden. Schande über mich - da war eine Route verkehrt gesetzt...
Meine Linux-Kiste hat den Frame auf die Standard-Route beantwortet was dementsprechend der falsche Empfänger war.

Oh man.. wo ist nur mein Hirn..

Danke für die Zeit!!
Bitte warten ..
Ähnliche Inhalte
Outlook & Mail
gelöst Nachricht per Regel aus "Gesendete Elemente" verschieben - Outlook (3)

Frage von slansky zum Thema Outlook & Mail ...

Erkennung und -Abwehr
TCP Acceleration (1)

Frage von MikePost zum Thema Erkennung und -Abwehr ...

LAN, WAN, Wireless
VPN Tunel geht verloren nach VM Switching (5)

Frage von staybb zum Thema LAN, WAN, Wireless ...

Visual Studio
gelöst C-Sharp MVVM DataContext geht verloren (1)

Frage von mayho33 zum Thema Visual Studio ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Batch & Shell
Batch Programm verhalten bei shoutdown -p (17)

Frage von Michael-ITler zum Thema Batch & Shell ...

Linux Desktop
Bildschirmauflösung unter Linux festlegen (12)

Frage von itebob zum Thema Linux Desktop ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (12)

Frage von jensgebken zum Thema Windows Server ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...