Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Tera Station 3 NAS zu langsam

Frage Hardware SAN, NAS, DAS

Mitglied: mschmidtm

mschmidtm (Level 1) - Jetzt verbinden

30.05.2013 um 10:28 Uhr, 3025 Aufrufe, 5 Kommentare

Guten Morgen! Ich hoffe ich bin hier einigermaßen richtig und jemand hat einen Tipp für mich. Mein NAS (Buffalo TeraStation 3, Raid 10) erreicht leider nicht annährend die Geschwindigkeit, die der Hersteller so angibt.

Die TeraStation hängt mit 2 Netzwerkkabeln an einem D-Link DGS 1210-24 (der Port-Trunking beherrscht, Typ: Statisch oder LACP), an der TeraStation ist Port Trunking (Dynamische Link-Aggregation) ebenfalls aktiviert. Wenn ich am Switch die Ports per LACP zusammenschalte, wird das NAS im Netz nicht mehr gefunden (kann die Box wohl nicht) bei statischer Zusammenschaltung kommen folgende Werte dabei heraus:

Schreiben: max. 15MB/s
Lesen: max. 35MB/s

Kabel sind alle heile, auf der TeraStation ist die aktuellste Firmware installiert, der PC läuft unter Windows 7.

Hat irgendjemand einen Tipp wie man das Ding etwas flotter bekommt?

Tausend Dank im Voraus
Markus
Mitglied: aqui
30.05.2013, aktualisiert um 10:55 Uhr
Deine Schilderung ist recht oberflächlich, denn der Knackpunkt ist die Frage WIE du das testest ??
Schlimm ist das die Link Aggregation mit LACP (was ein weltweiter Standard ist) bei dir nicht zustandekommt !
Das sollte dir erstmal grundsätzlich zu denken geben, denn es ist zweifelsohne ein Indiz das irgendwo was fehlerhaft konfiguriert wurde und der LAG gar nicht aktiv ist.
Statische LAGs sind immer kontraproduktiv da es zu eine inkonsitenten LAG Konfiguration auf beiden Seiten kommen kann was zu Teillooops im Netz und damit zu erheblichem Performanceverlust und Ausfall kommen kann.
Es ist in jedem Falle besser die LAGs mit LACP zu betreiben zumal du sowohl am Switch als auch am NAS über den LACP Status sofort sehen kannst ob der LAG sauber geformt ist.

Ist er geformt, kommt es auf Basis der Mac Adressen zwischen den beidne Endgeräten (NAS und Client) zu einer Hashberechnung am Switch oder NAS welchen der beiden Links dieses Pärchen fest belegt.
Keinesfalls findet hier eine Round Robin Verteilung des Traffics auf Paketbasis statt. Das kann 802.3ad Link Aggregation mit LACP technisch nicht !
Testetst du also nur mit einem Client, dann ist das so als ob der nur mit einem einzelnen Link angebunden ist. Im worst Case bringt die Hash Berechnung eines 2ten Pärchens den gleichen Link und dann tummeln sich 2 User auf einem Link.
Das ist leider der Nachteil von 802.3ad das es keine homogene Verteilung der Sessions gibt sondern je nachdem was das hashing derletzten 4 Bits der Mac Adressen ergibt.
Näheres dazu auch in diesen Administrator.de Threads hier:
http://www.administrator.de/index.php?content=173909
http://www.administrator.de/index.php?content=110462
http://www.administrator.de/index.php?content=112965
http://www.administrator.de/index.php?content=113735
http://www.administrator.de/index.php?content=117829

Du kannst also nur eine mehr oder minder gute Verteilung der Sessions auf dem LAG erreichen. Das solltest du also bei deinen Performance Berechnungen immer berücksichtigen.
35 MByte Lesen entspricht ungefähr 280 Mbit/s, was in einem GiG Netzwerk ein recht mickriger Wert ist auch wenn das NAS nur mit einem einzigen GiG Link angebunden ist.
Allerdings hängt das auch von der NAS CPU ab. Eine billige Marvell CPU kann auch nicht mehr. Es sollte also mindestens ein entsprechender Atom oder Celeron sein.

Als weiteren sinnvollen Tip solltest du bei statischen und LACP LAGs (wovon bei statischen besser abzuraten ist, siehe oben) immer mal SNMP auf dem Switch und auch auf dem NAS aktivieren.
Mit einem kleinen Online Tool wie dem SNMPTG:
http://leonidvm.chat.ru/
kannst du dann in Echtzeit beide LAG Links sowohl auf Switchseite als auch parallel auf NAS Seite über einen Zeitraum überwachen und überhaupt erstmal checken ob dein LAG wirklich aktiv ist und es zu einer aktiven Lastverteilung kommt !!
So wie du es oben schilderst ist das vermutlich gar nicht der Fall !
Bitte warten ..
Mitglied: MrNetman
30.05.2013, aktualisiert um 17:30 Uhr
Wie schnell sind denn deine beiden Ports, wenn du sie ohne Link-Agregation betreibst?
Sind in die Linkaggregation welche von den sowohl- alsauch Ports (21-24) eingebunden?
Im Handbuch http://www.dlink.com/-/media/Business_Products/DGS/DGS%201210%2024/Manu ..., Seite 42/46 wird erwartet, dass wenigstens einer der beiden Teilnehmenden Stationen (Switch-NAS) LACP Control Frames sendet.

Gruß
Netman
Bitte warten ..
Mitglied: mschmidtm
04.06.2013 um 09:00 Uhr
Hallo Aqui,

erst mal vielen Dank für Deine ausführliche Antwort - leider muss ich zu meiner Schande gestehen, das ich nur die Hälfte davon verstehe. Netzwerke und alles was dazugehört sind leider nichts von dem ich behaupten könnte, besonders viel Ahnung zu haben. Ich dachte in meinem jugendlichen Leichtsinn: zusammenstecken, läuft. In diversen Tests hat das NAS Schreibraten von bis zu 30MB/s und Leseraten bis zu 70MB/s erreicht - ohne Port-Trunking. Wenn ich das ausschalte und jeden Port für sich teste, komme ich (bzw. das NAS) schreibend nicht über 10 und lesend nicht über 22 hinaus.

Soweit meine Recherchen ergaben, werkelt in der TS tatsächlich ein eine langsame Marvell CPU. Dennoch würde ich gern ansatzweise in die Nähe der im Test erreichten Geschwindigkeiten kommen.

Gern würde ich die Einstellungen auch von einem der Experten hier (gegen Bezahlung versteht sich) einmal überprüfen lassen. Wenn also jemand Interesse hätte, zu helfen, würde ich mich da sehr freuen

Viele Grüße und einen angenehmen Start in die Woche
Markus
Bitte warten ..
Mitglied: mschmidtm
04.06.2013 um 09:03 Uhr
Hallo Netman,

ohne Link-Aggregation komme ich an beiden Ports nicht über 10(schreibend) und 25(lesend) MB/s hinaus. Die aggregierten Ports sind Port 1 und 2. Die Anleitung habe ich auch gelesen (und versucht zu verstehen), dachte jedoch, das der Switch, wenn ich LACP einschalte, dieser die entsprechenden Control Frames auch an das NAS sendet. Ob die TeraStation damit jedoch etwas anfangen kann, ist der Anleitung leider nicht zu entnehmen

Ansonsten verweise ich hier gern nochmals auf meine Frage in der Antwort auf Aquis Antwort

Viele Grüße
Markus
Bitte warten ..
Mitglied: MrNetman
04.06.2013, aktualisiert um 10:14 Uhr
Warum kümmerst du dich um LACP, Link Aggregation und weitere Dinge, wenn ein einzelner, sauberer Link knapp 120MByte schaffen könnte/müsste und du noch bei 25MB/s liegst.
Das bringt dich da nicht weiter.

Gibt es vieleicht ein Problem mit den Links generell?
Kabeltester würden helfen, aber auch NETio über die aktive Strecke. Da kannst du dann erkennen ob du and der Hardware schrauben kannst.
Ein weiteres Problem könnten auch Duplexfehler der beteiltigten Ports sein. Ich hoffe nicht, dass Autonegation auf feste Duplexeinstellungen treffen. Das würde ich die unterschiedliche Up- und Downloadgeschwindigkeit erklären.

und defekte Patchkabel oder Crossoverkabel können auch zu Problemen führen.

Gruß
Netman
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS
NAS Station mit PostGres Datenbank
gelöst Frage von unique24SAN, NAS, DAS8 Kommentare

Hallo! Suche eine einfach NAS Station, jedoch mit. integrierter Postgre Datenbank. Habe Synology und QNAP geschaut, aber finde dort ...

Netzwerkgrundlagen
3 Netzwerke mit einer NAS verbinden
Frage von Sauhund17Netzwerkgrundlagen10 Kommentare

Hallo, habe ein kleines Problem, wo ich nicht wirklich weiter komme. Wir haben 3 getrennte Netzwerke, jedes Netzwerk hat ...

Samba
NAS - Langsame GBit Verbindung
gelöst Frage von PanubuSamba8 Kommentare

Hallo zusammen, ich habe folgendes Problem: Ich habe eine selbstgebaute NAS hier im Büro, welche ich mit einer GBit-Schnittstelle ...

TK-Netze & Geräte
Teamspeak 3 Server auf Lenovo NAS
gelöst Frage von noob6633TK-Netze & Geräte4 Kommentare

Hallo Administratoren Ich wollte mal fragen ob es eine Möglichkeit gibt einen Teamspeak 3 Server auf einem LenovoEMC px2-300d ...

Neue Wissensbeiträge
Microsoft Office

Office 2010 Starter erneut auf einer frischen Windows-Version installieren

Tipp von Lochkartenstanzer vor 22 StundenMicrosoft Office8 Kommentare

Moin, vor ein paar Tagen schlug bei mir ein Kunde auf, der sein Widnows 7 geschrottet und es inklusive ...

Datenbanken

Upgrade MongoDB 3.4 auf 3.6

Erfahrungsbericht von Frank vor 1 TagDatenbanken

Seit kurzem gibt es das 3.6 Update für die MongoDB: Sicherheit, das Sortieren, Aggregation und auch die Performance wurde ...

SAN, NAS, DAS

Backdoor Zugang und Upload-Bug in vielen Western Digital MyCloud Geräten

Information von Frank vor 1 TagSAN, NAS, DAS2 Kommentare

James Bercegay von der Firma Gulftech hat die Fehler an Western Digital gemeldet und das Unternehmen stellt bereits ein ...

Microsoft Office

Outlook 2016 - Beim Weiterleiten keine PDF Anhänge mehr - KB4011626 entfernen

Erfahrungsbericht von Deepsys vor 1 TagMicrosoft Office3 Kommentare

Wenn ihr feststellt das ihr beim Weiterleiten von E-Mails keine PDF Anhänge mehr versendent, dann dankt Microsoft. Diese tolle ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

iOS
Einladung vom iphone kalender
Frage von jensgebkeniOS15 Kommentare

Hallo Gemeinschaft, folgendes Problem - immer wenn ich von meinem Iphone einen Termin einztrage und diesem Termin Teilnehmer zuweise, ...

Windows Netzwerk
Drucker isolieren in Windows Domäne
gelöst Frage von lcer00Windows Netzwerk14 Kommentare

Hallo zusammen, habe eine Windows-AD (2012R2) in der es einen Druckerserver gibt. Mittlerweile verliere ich das Vertrauen in die ...

Drucker und Scanner
Gesucht DIN A3 Drucker
Frage von NebellichtDrucker und Scanner14 Kommentare

Hallo, ich möchte einen neuen DIN A3 Drucker kaufen. Um ab und zu, ca. 1 mal die Woche Farbausdrucke ...