Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Testumgebung (AD, Exchange...) als Clone des Produktivsystems erstellen?

Frage Microsoft Windows Netzwerk

Mitglied: AdminKnecht

AdminKnecht (Level 1) - Jetzt verbinden

25.04.2014, aktualisiert 13:14 Uhr, 2756 Aufrufe, 10 Kommentare, 1 Danke

Hallo zusammen,

ich wollte mal in die Runde fragen, wie ihr das macht, wenn ihr etwas in der Domäne austesten wollte, z.B. Hochstufen, Upgraden auf einen neueren DC, Konfig-Änderungen im Exchange usw.?

Grundsätzlich kann ich ja immer eine virtuelle Umgebung aufbauen mit frischem DC inkl. DNS, WINS, DHCP und ein paar Testusern und dazu dann den Exchange usw., diese Umgebung ist aber a) aufwendig zu erzeugen und b) natürlich "synthetisch", da sie nicht der realen Umgebung (mit all ihren Ecken und Kanten ) entspricht!

Gibt es daher eine Möglichkeit, aus der bestehenden Infrastruktur (alles virtuell per ESXi 5.1.0) bestimmte Systeme (DCs, Exchange...) zu klonen und in ein separat laufendes Testnetz zu setzen? Mit einzelnen Anwendungsservern ist das kein Problem (Starten des Clones ohne Netzwerkkarte, ändern der IP und verschieben in eine Arbeitsgruppe, Neustart mit NIC, fertig), beim AD mit DNS-Einträgen etc. stelle ich mir das schwieriger vor...

Bin für jeden Tipp oder Link dankbar!

Schönes Wochenende

Marcus




Mitglied: SlainteMhath
25.04.2014 um 09:07 Uhr
Moin,

wenn alles als VM läuft ist das eigentl. kein Problem. Einfach einen Klon der jeweiligen Maschinen ziehen (DC und Exchange ggfs. vor runterfahren damit die DBs auch wirklich konsistent bleiben) und gut.

Du musst nur absolut!! hunderprozentig!! sicherstellen!! das die Testumgebung keinerlei Kontakt mit der Produktivumgebung hat - sonst wird's komisch Realisierung würde ich das entweder über einen separaten Host der zwar die gleichen vSwitches hat wie im Prod-System, aber ohne zugeordnente phys. NICs, oder über entsprechende vSwitches ohne Uplinks bzw im abgegrenzten VLAN direkt auf den Produktiv Host(s)

lg,
Slainte
Bitte warten ..
Mitglied: AdminKnecht
25.04.2014 um 09:38 Uhr
Zitat von SlainteMhath:

Realisierung würde ich das entweder über einen separaten Host der zwar die gleichen
vSwitches hat wie im Prod-System, aber ohne zugeordnente phys. NICs, oder über entsprechende vSwitches ohne Uplinks bzw im
abgegrenzten VLAN direkt auf den Produktiv Host(s)

Danke für die Infos, aber das würde bedeuten, dass die Server absolut autark laufen, auch ohne Kontakt zum Internet (über unseren Gateway-Router), oder habe ich da etwas falsch verstanden? Am Router kann ich zwar eine weitere IP eintragen, um ein separates Netz mit Internetzugang zu versorgen (statt 172.16.x.x nun auch 192.168.x.x zum Testen), aber dann muss ich ja auch meine Testserver auf 192.168.x.x. umstellen...
Bitte warten ..
Mitglied: Looser27
25.04.2014 um 09:42 Uhr
Moin,

ich hab zwar keinen Exchange, aber eine Testumgebung hab ich dennoch.
Diese besteht im wesentlichen aus ausgemusterten PCs, welche in einem VLAN getrennt vom Produktivsystem werkeln.

Erstellt wurde das Testsystem aus einer Datensicherung des Produktivsystems. Hierzu habe ich eine separate Datensicherung auf eine externe Platte durchgeführt und diese für die Recovery am Testsystem benutzt.

Nachdem ich verstanden hatte, wie das funktioniert (sowas macht man nun mal nicht jeden Tag), lief es reibungsfrei.

Gruß

Looser
Bitte warten ..
Mitglied: Chonta
25.04.2014 um 11:18 Uhr
Hallo,

wenn möglich ist es immer am besten eine Testumgebung zu haben, di eein Abbild der Produktivumgebung ist.
Weil alles was Du in der Testumgebung machst und nicht funktioniert mit sehr großer Warscheinlichkeit auch produktiv nicht gehen wird.
Und ja die Umgebung darf keinen Kontakt zum produktiv Netzwerk haben und auch nicht ins Internet, vor allem Systeme die Mails verschicken oder daten von wo anders abholen und dort evtl löschen wenn abgeholt.

Gruß

Chonta
Bitte warten ..
Mitglied: SlainteMhath
25.04.2014 um 11:32 Uhr
Zitat von Chonta:
wenn möglich ist es immer am besten eine Testumgebung zu haben, di eein Abbild der Produktivumgebung ist.
Weil alles was Du in der Testumgebung machst und nicht funktioniert mit sehr großer Warscheinlichkeit auch produktiv nicht
gehen wird.
Und ja die Umgebung darf keinen Kontakt zum produktiv Netzwerk haben und auch nicht ins Internet, vor allem Systeme die Mails
verschicken oder daten von wo anders abholen und dort evtl löschen wenn abgeholt.
Das und vor allem die/der DC(s) und die Clients kommen vollkommen aus dem Tritt
Bitte warten ..
Mitglied: Chonta
LÖSUNG 25.04.2014, aktualisiert um 13:14 Uhr
Ob der DC ins internet kann ist relativ egal. (Wenn der nur DC macht un nicht noch was anderes wie VPN, Routing, oder sonstwas)
Mit keinen Kontakt zum produktiv Netzwerk sind ja die Clients und Produktivserver mit gemeint

Mir ging es mit meien Post nur nochmal deutlich zu machen, das Internetzugriff für die geklonte Testumgebung ein Problem sein kann, das man schnell übersieht, nur weil man evtl einen Patch von MS direkt laden will oder so.

Kurzgesagt, die Testumgebung sollte eigentlich nur und einzig in einer abgeschotteten Box laufen, auf die der Admin auch nur indirekt zugreift. (Als nicht Teil der Domäne)
Wenn der Admin sich mit seiner produktiv Workstation ins TestVlan hängt und die WS vom DC als Bestandteil des Netzwerkes annimmt kann es auch knallen, wenn z.B. Passwörter oder IDs neu vergeben werden.

Gruß

Chonta
Bitte warten ..
Mitglied: AdminKnecht
25.04.2014 um 12:00 Uhr
Zitat von Chonta:

Hallo,

wenn möglich ist es immer am besten eine Testumgebung zu haben, di eein Abbild der Produktivumgebung ist.
Weil alles was Du in der Testumgebung machst und nicht funktioniert mit sehr großer Warscheinlichkeit auch produktiv nicht
gehen wird.

Richtig, so sehe ich das auch, was nützt mir die schönste "Laborumgebung", wenn die Wirklichkeit ganz andere Überraschungen bereit hält

Und ja die Umgebung darf keinen Kontakt zum produktiv Netzwerk haben und auch nicht ins Internet, vor allem Systeme die Mails
verschicken oder daten von wo anders abholen und dort evtl löschen wenn abgeholt.

Das der Test-Exchange zwar noch wie gewohnt über den 1&1-Smarthost senden, aber nicht mehr via POPcon Mails beim Provider abholen darf, ist klar, das kann ich entsprechend umkonfigurieren, und auch der Test-DC oder andere Test-Anwendungsserver (WAWI, ARchiv etc.) können problemlos ins Internet, nur ist die Frage, wie?

Denn wenn ich die Diskussion mal zusammenfasse, muss ich wohl bei den gewohnten IP-Adresskreisen bleiben (172.16.x.x), auch wenn das alles per VLAN getrennt ist, läuft es doch spätestens beim Internet-Gateway wieder zusammen --- möglicherweise kann man das dort irgendwie handeln, aber ich bin kein Router-Experte (Bintec R1200)


Gruß

Chonta

Auch schöne Grüße

Marcus
Bitte warten ..
Mitglied: SlainteMhath
LÖSUNG 25.04.2014, aktualisiert um 13:14 Uhr
Damit
Kurzgesagt, die Testumgebung sollte eigentlich nur und einzig in einer abgeschotteten Box laufen, auf die der Admin auch nur indirekt zugreift. (Als nicht
Teil der Domäne)
Wenn der Admin sich mit seiner produktiv Workstation ins TestVlan hängt und die WS vom DC als Bestandteil des Netzwerkes annimmt kann es auch
knallen, wenn z.B. Passwörter oder IDs neu vergeben werden.
hat @Chonta eigentlich schon alles zu dem Thema gesagt.

Ja, man könnte über zusätzliche Router und NAT Konstrukte sicher irgendwie einen Internetzugang für die Testumgebung basteln, aber das ist mit aufwand verbunden, benötigt entsprechendes Fachwissen und im Falle einer Falschkonfiguration wird Produktiv und Testnetz geschreddert. Wenn überhaupt dann würde ich da einen billigen consumer DSL legen lassen und darüber dann Patches etc abrufen.
Bitte warten ..
Mitglied: AdminKnecht
25.04.2014 um 13:14 Uhr
Zitat von SlainteMhath:
Wenn überhaupt dann würde ich da einen billigen consumer DSL legen lassen und darüber dann Patches etc abrufen.

..ja, das scheint mir bislang auch die praktikabelste (und sicherste) Möglichkeit zu sein! Ein Stück Hardware als ESX-Host habe ich hier noch stehen, den könnte ich dann mit den VMWare-Dateien der benötigten Server vom Produktivsystem betanken (irgendwie per USB-Platte..), und als DSL lümmelt hier irgendwo noch eine alt 2MBit/S-Testleitung herum

Danke erstmal an alle und schönes W'Ende

Marcus
Bitte warten ..
Mitglied: Chonta
28.04.2014 um 09:34 Uhr
Hallo,

zum einspielen von Patches, kann man einen dedizierten Updateserver für die Testumgebung betreiben oder per USB einspielen.
Und der Exchangeserver darf natürlich NICHT über den Smarthost von 1&1 senden.

Jeh nachdem wo eine Mailarchivierung ansetzt, würde ide evtl ausgehebelt wenn der Testserver sendet.
Gibt noch andere Sachen die dabei schief gehen können.

Gruß

Chonta
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Exchange Server
Exchange 2016 aus AD sauber entfernen (11)

Frage von JanGarbers zum Thema Exchange Server ...

Batch & Shell
Mehrere AD Benutzer aus CSV Datei mit PowerShell erstellen (1)

Frage von windelterrorist zum Thema Batch & Shell ...

Server-Hardware
gelöst DellT20 als Hyper-V host für Exchange 2013 und einer AD? (9)

Frage von bootloader zum Thema Server-Hardware ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...