Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Thinstation PXE Boot-Problem

Frage Sonstige Systeme

Mitglied: Stargatewissen

Stargatewissen (Level 1) - Jetzt verbinden

07.06.2011 um 07:39 Uhr, 7242 Aufrufe, 12 Kommentare

Hallo Forum,
ich experimentiere gerade mit meiner Windows Server 2003 Lizenz herum und möchte jetzt einen Terminalserver mit Diskless-ThinClients einrichten.
Dazu nutze ich Thinstation in der Version 2.2.

Hier jetzt mein Problem:
ich habe bisher den DHCP und TFTPD-Server eingerichtet. Die Terminals startetn auch und laden sich die erforderlichen Bootdateien von Thinstation (vmlinuz, thinstattion.conf.network, initrd).
Das wird auch alles zu meiner Zufriedenheit ausgeführt. Doch dann kommt folgender Text:
"Uncompressed Linux...OK Booting Kernel"
Und dann passiert nichts mehr. Ich muss auch gestehen, das ich nicht weiß, von wo er sich den Kernel hohlen soll, denn das kann ja nicht alles in der relativ kleinen vmlinuz Datei sein, oder?

Kann mir einer dabie weiterhelfen?

Danke schonmal für eure Hilfe :D
Mitglied: Clijsters
07.06.2011 um 16:56 Uhr
Hallo,
zu der vmlinuz das hier: VmLinuz Definition

zu deinem Problem:
Hier würde ich eher auf inkompatible hardware tippen.

Hast du schonmal versucht, den Thinclient vom USB-Stick zu booten?

Gruß
Dominique
Bitte warten ..
Mitglied: 68162
07.06.2011 um 17:55 Uhr
Ich würde sagen, 'vmlinuz' ist der Kernel? Wird auch die INITRD wirklich geladen?
Welchen Loader verwendest Du; wie sieht dessen Konfigurationsdatei aus?

MfG, FM_81
Bitte warten ..
Mitglied: Stargatewissen
07.06.2011 um 19:56 Uhr
Also, danke erstmal für eure Hilfe.
Also, ich denke nicht das es Hardwareinkompatiblität ist, insofern es nicht möglich sein sollte in einer virtuellen Maschine per PXE zu booten.

die Initrd wird erfolgreich geladen.
hier mal ein Screen, wie es asussieht, wenn nichts mehr geht:
http://stargatewissen.lordcruncher.de/Unbenannt.PNG

Ich hoffe, das hilft euch weiter, mir zu helfen. Ich freue mich auf eure Antworten!


Edit:
Nochwas. Ich muss ehrlich gestehen, das ich nicht weiß wie ich Thinstation von nem USB-Stick aus booten könnte, wie gesagt Anfänger in sachen Linux.
Und ich nutze pxelinux, hier auch mal ein Bild von der DHCP und TFTPD Konfiguration:
http://stargatewissen.lordcruncher.de/Unbenannt1.PNG
http://stargatewissen.lordcruncher.de/Unbenannt2.PNG
Bitte warten ..
Mitglied: 68162
08.06.2011 um 15:49 Uhr
Das ist wirklich nicht sehr aussagekräftig ...

Zunächst würde ich mal in der 'build.conf' den Parameter "bootverbosity" entsprechend setzen.
Das löst zwar nicht das Problem, aber vielleicht wirft es dann ein paar brauchbare Meldungen ab ...

2. Deine Datei 'pxelinux.cfg/default' ist aber so wie beim Build, also nicht händisch drin rum editiert?

MfG, FM_81
Bitte warten ..
Mitglied: Stargatewissen
08.06.2011 um 17:25 Uhr
Ok,
nochmals danke für die Antwort. ich habe nun mal in ein Zip-Archiv folgende dateien geladen:
- die default, ich habe nur den parameter console geändert (aus einem anderen Lösungsvorschlag, hat aber beides nicht geholfen), ansonsten ist die Datei wie vorher
- die thinstation.conf.network (sollte ja eigentlich der build.conf entsprechen, oder?)
- und ein Screenshot des Verzeichnisses boot, dem TFTP-Root

Wenn jemand noch mehr Infos brauch, einfach fragen :D

Ich hiffe, das wir das hier noch hinbekommen!

Anhang:
http://stargatewissen.lordcruncher.de/data.zip
Bitte warten ..
Mitglied: 68162
08.06.2011 um 18:04 Uhr
Darf man fragen, wo Du Kernel (vmlinuz) und initiale RAM-Disk (initrd) her hast? Kernel mag ja sein, aber was bitte ist eine INITRD mit 1kB Größe? Das kann meiner Ansicht nach nicht klappen! (Hab das mal getestet und bin auf ~25MB für diese Datei gekommen.)

Hier: http://tsom.paepke.net/ kannst Du sowas Online bauen lassen.
Oder du lädst das Archiv runter und baust es unter Linux,
oder aber du nimmst die vorgefertigten Images von http://thinstation.sourceforge.net/download.html

MfG, FM_81
Bitte warten ..
Mitglied: Stargatewissen
08.06.2011 um 18:16 Uhr
Genau das Harry ich auch gedacht. aber id initrd ist nur ein link auf den Ordner initrd. und der ist dann die besagte Größe. frag mich nicht wieso das so ist, das war so im runtergeladenen UOL Ordner
und id Beeren Dateien? die sind soweit richtig, ja?
Bitte warten ..
Mitglied: 68162
08.06.2011 um 18:56 Uhr
Der PXE-Loader kann vermutlich mit Links (im Windows-Style) nichts anfangen! Du brauchst schone eine richtige INITRD ...

MfG, FM_81
Bitte warten ..
Mitglied: Stargatewissen
08.06.2011 um 19:45 Uhr
Ok, dann nehem ich mal den Link, wo ich mir das mal selber bauen kann und melde mich dann wieder. Bis bals :D
Bitte warten ..
Mitglied: Stargatewissen
08.06.2011 um 20:01 Uhr
So, da bin ich wieder. Einwandfrei. Jetzt bootet die VM. Na endlich. Nur wegen der initrd. Hast wahrscheinlich recht eghabt, das der mit dem Link nicht ganz klar gekommen ist. Danke für eurer Hilfe!
Bitte warten ..
Mitglied: Stargatewissen
10.06.2011 um 20:11 Uhr
Ich hoffe, das noch einige in diesem Thema unterwegs sind, denn es gibt jetzt ein neues Problem, für das ich nicht gleich ein neues Thema aufmachen möchte:
Das Terminal zieht sich jetzt alle erforderlichen Dateien und startet auch. Es wird auch sofort eine rdp-Sitzung initiiert. Allerdings in einer so schrecklichen Grafik, das man kaum die Wörter "Windows Anmeldung" lesen kann in so einem schwarz-lila-2-Stufen-Schema.
Ich habe mir auch schon ein neues Package mit allen Grafiktreibern zusammengbaut, allerdings ändert das nicht.
Am Anfang sieht noch alles einwandfrei angezeigt aus, wenn ich aber F2 drücke steht ganz zum Schluss, nach Welcome to ThinStation folgendes:

Ls: /dev/input/event*: no such file or directory

Kann mir da einer helfen?
Bitte warten ..
Mitglied: 68162
16.06.2011 um 08:59 Uhr
Ich nehme an, Du hast die Beispielkonfig ab Zeile 155, besonders was den Parameter "-a" betrifft, schon probiert?

Ansonsten würde ich sagen, noch mal neu bauen, und beachten welche Video-Module (eigentlich nur eines, aber das Richtige) der Client braucht?

MfG, FM_81
Bitte warten ..
Ähnliche Inhalte
Windows Installation
PXE Boot-Von CD Starten
Frage von STITDKWindows Installation2 Kommentare

Schönen guten Abend, ich habe eine Frage zum PXE Boot (Sonology NAS)(diese Anleitung) Ist es möglich die Sequenz von ...

Netzwerkmanagement
PXE Boot über einem CISCO 3550
Frage von torvo81Netzwerkmanagement3 Kommentare

Guten Morgen. Wir betreiben hier einen Cisco 3550 layer3 Switch. Dieser verteilt per DHCP IP Adressen. Nun möchte ich ...

Windows Server
PXE boot funktioniert unter hyperv nicht
gelöst Frage von SchulnetzwerkWindows Server4 Kommentare

Liebe administrator.de-Community, heute wollte ich wieder mal ein neues Image für den WDS herrichten. Das Win7 Image wurde als ...

Virtualisierung
VirtualBox per PXE Booten
gelöst Frage von dan0neVirtualisierung

Hallo, wir haben hier in unserem Netzwerk einen PXE Server stehen. Um die Images zu testen, würde ich gerne ...

Neue Wissensbeiträge
Apple

IOS 11.2.1 stopft HomeKit-Remote-Lücke

Tipp von BassFishFox vor 1 TagApple

Das Update für iPhone, iPad und Apple TV soll die Fernsteuerung von Smart-Home-Geräten wieder in vollem Umfang ermöglichen. Apple ...

Windows 10

Windows 10 v1709 EN murkst bei den Regionseinstellungen

Tipp von DerWoWusste vor 1 TagWindows 10

Dieser kurze Tipp richtet sich an den kleinen Personenkreis, der Win10 v1709 EN-US frisch installiert und dabei die englische ...

Webbrowser

Kein Ton bei Firefox Quantum über RDP

Tipp von Moddry vor 1 TagWebbrowser

Hallo Kollegen! Hatte das Problem, dass der neue Firefox bei mir auf der Kiste keinen Ton hat, wenn ich ...

Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 1 TagInternet4 Kommentare

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registrierung von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Heiß diskutierte Inhalte
Windows Server
RODC kann nicht aus Domäne entfernt werden
Frage von NilsvLehnWindows Server18 Kommentare

HAllo, ich arbeite in einem Universitätsnetzwerk mit 3 Standorten. Die Standorte haben alle ein ESXi Cluster und auf diesen ...

Hardware
Kein Bild mit nur einer bestimmten Grafikkarten - Mainboard Konfiguration
gelöst Frage von bestelittHardware18 Kommentare

Hallo zusammen, ich hatte schon einmal eine ähnliche Frage gestellt. Damals hatte ich genau das gleiche Problem. Allerdings lies ...

Netzwerkmanagement
Mehrere Netzwerkadapter in einem PC zu einem Switch zusammenfügen
Frage von prodriveNetzwerkmanagement16 Kommentare

Hallo zusammen Vorweg, ich konnte schon einige IT-Probleme mit Hilfe dieses Forums lösen. Wirklich klasse hier! Doch für das ...

Hardware
Links klick bei Maus funktioniert nicht
gelöst Frage von Pablu23Hardware16 Kommentare

Hallo erstmal. Ich habe ein Problem mit meiner relativ alten maus jedoch denke ich nicht das es an der ...