Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

UDP-Kommunikation VPN und Web ja - im LAN nein?

Frage Netzwerke

Mitglied: qualidat

qualidat (Level 1) - Jetzt verbinden

18.11.2011 um 11:29 Uhr, 2887 Aufrufe, 6 Kommentare

Ein Client kann innerhalb des LAN nicht mit einem Server kommunizieren, greift man per VPN übers Internet zu, funktionert es.

Die Details: Ich abe ein Zusatztool zu einem bestehenden BDE-System geschrieben. Dieses BDE-System (Betriebsdatenerfassung) besteht aus Clients und einer Serverapplikation, die über UDP miteinander kommunizieren. An dieser Tatsache (UDP) ist nicht zu rütteln - darüber brauchen wir also nicht zu diskutieren. Ich habe im Auftrage eine Zusatzapplikation geschrieben, die ebenfalls mit dem Server kommuniziert, allerdings im Gegensatz zu den Clients recht große Datenmengen abfragt und statistische Auswertungen ausführt.

Die Entwicklung habe ich von Zuhause aus gemacht, über ein VPN gründlich getestet und Alles hat problemlos funktionert. Die erste betriebliche Installation hat auf einer testweise eingerichteten VM in der Firma stattgefunden, da lief auch noch Alles einwandfrei, allerdings zeigten sich leichte Leistungsschwächen in Form erhöhter Reaktionszeiten, deshalb hat der betriebliche Admin eine neue VM eingerichtet und dieser mehr Resourcen zugeteilt. Seit sich die Software auf der neuen VM befindet, kann sie nicht mehr mit dem Server kommunizieren. Ich sehe zwar über Test- und Log-Funktionen, dass die Anforderungen beim Server ankommen und dieser auch antwortet, aber die Antworten kommen bei meiner Applikation nicht an.

Der Admin stellt sich nun stur und verlangt, dass ich "den Fehler" in meiner Applikation behebe. Er hat wohl auch halbherzig nach möglichen Ursachen im betrieblichen Netz gesucht, aber Nichts gefunden. As Verrückte an der Geschichte ist, dass wenn ich die Anwendung von zuhause aus starte, weiterhin Alles funktioniert. Ich habe die Anwendung in RealStudio geschrieben, so dass ich sogar jeweils eine Windows- und eine Mac-Version compilieren kann. Beide funktionieren, so dass man sogar behaupten kann, dass es Nichts mit dem Betriebssystem und dessen Einstellungen zu tun haben kann.

Natürlich könnte ich nun mühsam irgendwelche Workarounds basteln, aber wieso eigentlich? Gibts irgendwelche Ideen, mit denem man dem Admin auf die Sprünge helfen könnte? Ich nehme an, die Ursache hat irgendwas mit sog. "fragmentierten Paketen" bzw. Datagrammen zu tun. Aber wenn es über Firewall und Internet funktioniert, muss doch die Ursache für das lokale Versagen auffindbar sein, oder?
Mitglied: windZ
18.11.2011 um 11:39 Uhr
Hi,

die Tatsache das die Reaktionszeiten erhöht waren und der Server anscheinend die Anfragen erhält aber der Client diese nicht zurück bekommt hört sich das für mich nach einer falschen NAT/PAT Konfiguration an. Möglicherweise ist einfach nur die Firewall falsch konfiguriert.

mfg
Bitte warten ..
Mitglied: qualidat
18.11.2011 um 11:58 Uhr
>Möglicherweise ist einfach nur die Firewall falsch konfiguriert.

Das verstehe ich nicht. Die externe Kommunikation verläuft doch über Firewall und VPN, und die funktioniert.
Die Kommunukation im LAN (m.E. ohne Firewall) klappt nicht ... oder meinst du eine "vergessene" lokale Firewall am Host der VM oder in der VM selbst?
Bitte warten ..
Mitglied: windZ
18.11.2011 um 12:26 Uhr
Ich kenne den Aufbau des Netzwerkes nicht. Die Firewall kann für VPN richtig konfiguriert sein, aber für den lokalen Gebrauch deine UDP Packete nur in eine Richtung zulassen. Wenn sich die Server IP und die Client IP nicht im gleichen Netz befinden, dann ist es sehr wahrscheinlich, dass eine Firewall dazwischen hängt.

Am besten du klärst das einfach mit deinem Auftraggeber und beweißt ihm dabei, dass deine Applikation nicht daran Schuld ist.
Bitte warten ..
Mitglied: aqui
18.11.2011 um 12:52 Uhr
Die Frage wie das Netzwerk der VM eingerichtet ist. Wenn der Admin die VM als Bridge eingerichtet hat ists kein Problem. Vermutlich hat er aber die VM ins lokale LAN geNATet (Adress Translation) da ists dann sofort aus mit VPNs sofern du selbiges auf deinem Server terminierst.
Gleiches gilt für alle Firewall/Router die im Kommunikationspfad liegen. Ist da irgendwo NAT dazwischen hast du ein Problem sofern dein Client kein NAT Traversal kann.
Da du aber hier keinerlei Aussage zur Topologie geschweige denn zum verwendeten VPN Protokoll, von dem es ja nun einige gibt..., hier machst können wir hier lustig ziellos weiterraten.
Fazit: mit den oberflächlichen Angaben von oben zu Netzwerk, VPN Terminierung, Firewalls und der VM Installation ist eine zielführende Hilfe nicht möglich !
Bitte warten ..
Mitglied: qualidat
18.11.2011 um 13:46 Uhr
Ich bin nicht der Admin und habe nur eingeschränkte Informationen. Der VPN-Tunnel ist simpelst auf PPTP aufgebaut und terminiert in dem Firewall-Rechner. Von dort aus habe ich IP-Zugriff auf das gesamte Netz. Dort drinnen befinden sich die Clients und der Server im gleichen Subnetz.
Darf ich nochmal darauf hinweisen, dass nicht VPN und Firewall (zumindest die, die den Kontakt ins Web herstellen) das Problem sind, sondern eine Verbindung innerhalb des LAN im selben Subnetz. Die fragliche Applikation läuft auf einer VM, deren Einstellungen vermutlich für das Problem verantwortlich sind, denn auf einer anderen VM im selben Netz ging es vorher. Nun bin ich aber nicht der Admin (wie betont) und der hat keine Lust, nach dem Problem zu suchen, sondern behauptet, meine App sei fehlerhaft. Da das Gespräch noch nicht völlig abgerissen ist, versuche ich hier Hinweise zu finden, die den Admin evtl. ermutigen, doch noch mal die Maus in die Hand zu nehmen ...

Auf den Host der VM habe ich keinen Zugriff, nur Adminrechte innerhalb der VM. Dort gibts einen Netzwerkadapter, der heisst "Parallels-Naetzwerkadapter". Dass lässt vermuten, dass dort (ich vergaß: sind 200 km weit weg), evtl. ein Intel-Mac oder Mac Pro als Server benutzt wird. Ist eine Druckerei, könnte also durchaus sein ... Hat diese Konstellation Probleme mit UDP? Auf welchem Host die vorherige VM zuhause war, weiss ich nicht.
Bitte warten ..
Mitglied: aqui
18.11.2011 um 15:28 Uhr
Gut das du nochmal darauf hingewiesen hast, denn das war vermutlich allen nicht klar !
OK, wenn der Zugriff aus dem VPN uneingeschränkt auf den Server selber und auch alle Clients im lokalen Netz funktioniert, dann ist natürlich vollkommen klar das das VPN selber und Firewalls in diesem Pfad niemals das Problem sein können. Keine Frage....
Ist das Problem also nur isoliert auf lokale Clients und den Server bezogen liegt der Fehler logischerweise ganz woanders.
Die VM kann es auch niemals sein, denn sonst würdest du schon gar nicht vom externem VPN auf den Server in der VM kommen und da der Server selber das PPTP VPN terminiert und du von da auch auf die anderen Geräte im LAN kommst, kann man auch die VM und deren Einstellung komplett ausschliessen.
Andernfalls wäre diese Kommunikation ins lokale Netz der Druckerei aus dem VPN unmöglich !
Ob es ein Mac oder Winblows und Parallels oder VmWare oder was auch immer ist spielt keinerlei Rolle. Das wäre gleich mit der Vermutung ob man Shell oder Esso tankt beim Auto...
Das Verhalten ist schon kurios, denn wenn du Endgeräte im lokalen Netz erreichst könnte man auch die Firewall am Rechner ausschliessen.
Da kommt man vermutlich nur mit einer Sniffer SW wie Wireshark oder MS Netmonitor weiter...
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen
gelöst Zugriff aus dem LAN auf VPN Tunnel (4)

Frage von sschultewolter zum Thema Netzwerkgrundlagen ...

LAN, WAN, Wireless
VPN Client Freigabe ins LAN von Win 10 PC? (6)

Frage von Andromeda zum Thema LAN, WAN, Wireless ...

Netzwerkmanagement
IBM USV verliert Kommunikation (4)

Frage von robbi1234 zum Thema Netzwerkmanagement ...

Netzwerkgrundlagen
gelöst DCs sehr viele UDP-Verbindungen zur Firewall (5)

Frage von watchdogg zum Thema Netzwerkgrundlagen ...

Neue Wissensbeiträge
Viren und Trojaner

Ransomware or Wiper? RedBoot Encrypts Files but also Modifies Partition Table

(3)

Information von BassFishFox zum Thema Viren und Trojaner ...

Notebook & Zubehör

WOL bei HP Notebooks

(7)

Erfahrungsbericht von Henere zum Thema Notebook & Zubehör ...

LAN, WAN, Wireless

Neue Cisco Catalyst-Serie 9000

Information von Kuemmel zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows 10
Netzwerkkarte schaltet sich erst nach dem Logon ein (23)

Frage von DerWoWusste zum Thema Windows 10 ...

Windows Server
Seit IP Umstellung DC DNS Fehler (18)

Frage von Yaimael zum Thema Windows Server ...

Weiterbildung
gelöst Fest angestellter Admin oder Systemhaus Admin mit Kundenbetreuung? (15)

Frage von Voiper zum Thema Weiterbildung ...