Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Umbenennen von Netzwerklaufwerk funkt. manchmal nicht

Frage Entwicklung

Mitglied: OROSSO

OROSSO (Level 1) - Jetzt verbinden

11.07.2007 um 09:07 Uhr, 3622 Aufrufe

Hallo!

Ich verwende ein VB Skript zum Umbenennen von verbundenen Netzwerklaufwerken. Es wird durch das Logon-Skript beim Anmelden an die Domäne ausgeführt nachdem die Laufwerke verbunden wurden.

Das hört sich jetzt bestimmt nicht besonders spektakulär an und funktioniert auch ganz gut. Nur bei einigen wenigen Benutzern nicht, bzw. an einigen Rechnern nicht (meistens, aber nicht ausnahmslos, Dual Core Systeme).

Selbst wenn das Skript manuell ausgeführt wird, lange nach der erfolgreichen Anmeldung, funktioniert das Skript an manchen Rechnern nicht. Auch nicht wenn es von einem lokalen Laufwerk ausgeführt wird. Es gibt aber auch keine Fehlermeldung.

Es funktioniert an einem Rechner, egal wer sich anmeldet, aber es funktioniert für keinen Benutzer an einem anderen Rechner. Beide Rechner wurden (automatisch) mit XP Professional Version 2002 und SP2 installiert. Ich kann keine Unterschiede feststellen, außer dass es sich bei einem um einen Dual Core handelt. Auch die WSH Version ist identisch.

Und jetzt kommts: Wenn ich ein "echo" am Ende des Skriptes hinzufüge, und es mit wscript ausführe (geht nicht mit cscript), dann funktioniert es auch an den Arbeitsplätzen wo es "normalerweise" nicht funktioniert.

Skript "logon.cmd"
01.
  @echo off 
02.
  @net use O: \domaenedatenorganisation /persistent:no 
03.
  wscript logon.vbs
Skript "logon.vbs"
01.
  Option Explicit 
02.
  Dim obj_net, obj_shell 
03.
  Set obj_shell = CreateObject("Shell.Application") 
04.
  obj_shell.NameSpace("O:").Self.Name = "Mein Titel" 
05.
  ' Es funktioniert wenn die folgende Zeile aktiviert wird: 
06.
  'wscript.echo "fertig"
Eine Pause ("sleep"), mit 1, 5, 10, oder 20 Sekunden zu Beginn oder am Ende des Skriptes ändert auch nichts.

Auch interessant: Mit dem "wscript.echo" funktioniert es beliebig oft, das Laufwerk wird umbenannt. Entferne ich aber den Befehl und führe das Skript erneut aus, erhält das Laufwerk wieder seine ursprüngliche Bezeichnung (in diesem Fall "O: an \domaenedaten...").

Habt Ihr vielleicht eine Idee warum sich das Skript so unterschiedlich verhält, oder wie und nach welchen Unterschieden ich suchen könnte?!

Grüße, Oliver.
Ähnliche Inhalte
Neue Wissensbeiträge
Heiß diskutierte Inhalte
iOS
16 iPads zentrall verwalten (18)

Frage von simonlohr zum Thema iOS ...

Viren und Trojaner
Ransomware .nm4 (15)

Frage von Zyklo92 zum Thema Viren und Trojaner ...

Zusammenarbeit
Administrator Verhalten nach Vertragskündigung (13)

Frage von sysbone zum Thema Zusammenarbeit ...

Microsoft Office
gelöst VBA Excel Problem mit UserForm, ListBox und TextBox (12)

Frage von abuelito zum Thema Microsoft Office ...