Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Unsicherer LAN-Netzwerkzugang

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Pharos45

Pharos45 (Level 1) - Jetzt verbinden

25.02.2009, aktualisiert 12:22 Uhr, 5089 Aufrufe, 8 Kommentare

DHCPNACK-Meldung

zunächst ein Hallo in die Runde, als Neuling bitte ich um Nachsicht falls das nachfolgende Problem doch schon einmal behandelt worden sein sollte. Dann habe ich es trotz intensiver Suche nicht gefunden.
Mein Problem:
Ich habe mit einer Fritz!Box WLAN 7170, 1 x Medion-XP-PC, 2 x Medion-Vista-Laptop ein LAN-Netzwerk eingerichtet. WLAN ist deaktiviert. Das Netzwerk funktioniert zeitweise, ich kann dann mit allen Rechnern kommunizieren, woraus ich schließe, dass die Grundeinstellungen, wie automatischer Bezug IP- und DNS-Adressen sowie erforderliche IP-Protokolle nicht falsch sind.
Trotzdem ist mit den Vista-Laptops zeitweise kein Netzwerkzugang möglich. Die nachfolgend versuchten Maßnahmen
- Aktualisierung des Treibers beim Netzwerkadapter Realtek RTL 8139/810x Family Fast Ethernet NIC (Medion Stand 30.05.2007, Realtek hat keinen neueren).
- Deaktivieren/Aktivieren des Netzwerkadapters
- Netzanschluß über einen USB-Netzwerkadapter
- Umstieg auf XP bei den Laptops
änderten nichts an dem Verhalten der Laptops. Beim Auftreten des Fehlers wird in der Ereignisanzeige folgende Meldung angezeigt:

"Die IP-Adressrelease 192.168.178.xx für die Netzwerkkarte mit der Netzwerkadresse 0040Dxxxxxx wurde durch den DHCP-Server 0.0.0.0 abgelehnt (der DHCP-Server hat eine DHCPNACK-Meldung gesendet)".

Neugierig geworden habe ich dann auch in der Ereignisanzeige des Desktop-PCs nachgesehen und war erstaunt, dass dort diese DHCPNACK-Meldung gelegentlich auch auftaucht, nur halt seltener. Wenn ich das DHCP-Protokoll richtig verstanden habe, wird nach Empfang einer DHCPNACK-Meldung mit einer DHCPDISCOVER-Nachricht erneut versucht eine IP-Adresse zu bekommen. Beim XP-Desktop-PC scheint das ja auch zu funktionieren nur nicht bei den Laptops.

Kann deshalb bei den Laptops auf einen nicht zuverlässig funktionierenden Netzwerkadapter geschlossen werden, da ja das Problem unabhängig von Vista und XP ist?

Könnte es eventuell eine Zusammenhang mit einem nicht gelöschten Lease geben (sollte dann aber nicht eine andere freie IP-Adresse zugewiesen werden)?

Kann man ein Lease auch manuell löschen?

Gibt es eine Möglichkeit den Netzwerkadapter gezielt zu testen?

Viele Fragen, ich hoffe auf einige Antworten.

Pharos45
Mitglied: brammer
25.02.2009 um 12:38 Uhr
Hallo,

bevor du dich auf diese tiefe Ebene begibst, solltest du zuerst mal ausprobieren ob bei einer festen Vegabe von IP Adressen und abgeschaltetem DHCP die Situation unverändert bleibt oder sich verbessert.

brammer
Bitte warten ..
Mitglied: Rykeus
25.02.2009 um 12:56 Uhr
Hallo Pharos45!

Nack Meldungen bekommt ein Client wenn er seine ip-lease beim DHCP Server meldet um sie bestätigen zu lassen.
Wenn die Adresse schon gemeldet ist, bekommt keine Bestätigung für diese Adresse.
Versuche brammes Tipp umzusetzen. Deaktiviere die DHCP Funktion der FritzBox und konfiguriere die Clients manuell.

Wenn du dir unsicher bist, kannst du die aktuelle IP Configuration mit dem Consolenbefehl "ipconfig -all" auslesen und notieren. wenn es keine Überschneidungen bei 192.168.178.xx für das xx gibt und alle Clients im gleichen Subnetz sind, sollte es keinerlei probleme geben.

Gruß Rykeus
Bitte warten ..
Mitglied: Uffschnapper
25.02.2009 um 13:43 Uhr
Bei der Fritzbox gibt es die Energiesparfunktion für die einzelnen Lan Port's sind die aktiviert ? Wen ja deaktiviere die mal
Bitte warten ..
Mitglied: Pharos45
25.02.2009 um 17:04 Uhr
Danke für den Hinweis. Ich habe es auch schon mit festen IP-Adressen probiert und kam damit auch nicht ins Netzwerk. Allerdings war ich da noch nicht auf die Ereignismeldungen gestossen, so dass nicht sagen kann welche Fehlermeldungen da angezeigt wurden. DHCPNACK war sicher nicht dabei. Ich werde aber nochmals umstellen und dann schauen was als Ereignis angezeigt wird.
Bitte warten ..
Mitglied: Pharos45
25.02.2009 um 17:24 Uhr
an Rykeus
Danke für die Hinweise, Zum Deaktivieren DHCP siehe Antwort an brammer.

Die Konfiguration habe ich schon mit ipconfig /all ausgelesen. Leider geht das ja nur bei bestehender Netzwerkverbindung und dann sind alle IP-Adressen unterschiedlich, befinden sich in derselben Arbeitsgruppe und haben dieselbe Subnetmaske.

Frage ich ipconfig bei fehlender Netzwerkverbindung ab, wird Medium getrennt gemeldet und ich kann keine Daten auslesen. Diese wäre aber gerade für die Fehlersuche von Interesse.

Gibt es einen anderen Befehl oder ein Tool zum Protokollieren des Netzwerkverbindungsaufbaus?

Gruß
Pharos45
Bitte warten ..
Mitglied: Pharos45
25.02.2009 um 17:52 Uhr
an uffschnapper
Danke für den Hinweis. Die Einstellung war "Autom. Erkennung", was in mir keinen Argwohn erzeugt hat. Von den beiden weiteren Möglichkeiten "Deaktivieren" und "immer aktivieren" habe ich abweichend vom Vorschlag "immer aktivieren" gewählt. Bei einem deaktivierten LAN-Anschluss komme ich doch wohl kaum ins Netz oder?

Und siehe da bei immer aktivieren es gibt eine reproduzierbare Reaktion. In der Ereignisanzeige wird angezeigt: "Netzwerkadapter wurde mit dem Netzwerk verbunden, und das Sytem wurde über das Netzwerk im normalen Zustand gestartet" und die Verbindung wird aufgebaut.

Volltreffer.
Nochmals vielen Dank uffschnapper.
Bitte warten ..
Mitglied: brammer
25.02.2009 um 18:44 Uhr
Hallo,

das bedeutet vermutlich aber auch das die Netzwerkkarte vom Computer deaktiviert werden darf, (Eigenschaften der Netzwerkkarte).
Ich würde lieber dieses abschalten deaktivieren als in der Fritzbox abschalten.

brammer
Bitte warten ..
Mitglied: DerSille
25.02.2009 um 20:57 Uhr
Hallo,

ähnliches Verhalten kann sich ergeben, wenn QoS in den Eigenschaften des Netzwerkadapters aktivert wurde.

Zur Frage:

Die Lease-Time der IP-Adresse wird im Router, sprich der Fritzbox, eingestellt.

Die reine IP-Adresserneuerung am Client erfolgt mittels:

"ipconfig /release" und darauf folgendem "ipconfig /renew".

Ähnlich der Option "Verbindung reparieren", nur stabiler.

Gruss
Der Sille
Bitte warten ..
Ähnliche Inhalte
CMS
Lokales Wordpress im LAN - wie aufsetzen? (16)

Frage von Static zum Thema CMS ...

Netzwerkmanagement
gelöst Mehrere Lan-Verbindungen speichern (7)

Frage von SemJon zum Thema Netzwerkmanagement ...

LAN, WAN, Wireless
W-LAN-Verbindung bricht ab, LAN bleibt stabil (8)

Frage von max.webbing zum Thema LAN, WAN, Wireless ...

Neue Wissensbeiträge
Batch & Shell

Batch - ein paar Basics die man kennen sollte

Tipp von Pedant zum Thema Batch & Shell ...

Microsoft

Restrictor: Profi-Schutz für jedes Window

(6)

Tipp von AlFalcone zum Thema Microsoft ...

Batch & Shell

Batch zum Zurücksetzen eines lokalen Profils

Tipp von Mr.Error zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft Office
Saubere HTML aus Word-Dokument (16)

Frage von peterpa zum Thema Microsoft Office ...

Router & Routing
ASUS RT-N18U mit VPN Client hinter Fritzbox - Portforwarding (15)

Frage von marshall75000 zum Thema Router & Routing ...

Hosting & Housing
gelöst Webserver bei WIX, aber DNS Server wo anders (9)

Frage von laster zum Thema Hosting & Housing ...

Debian
gelöst Plesk php-fpm Fehler (7)

Frage von sebastian2608 zum Thema Debian ...