Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Upload Script - Ich packs net

Frage Entwicklung PHP

Mitglied: Enclave

Enclave (Level 2) - Jetzt verbinden

22.02.2007, aktualisiert 16.04.2007, 4883 Aufrufe, 8 Kommentare

Hallo alle zusammen,

ich hab hier nen Upload Script. Das ist ganz simpel und ist nur für ihn und da muss keine Überprüfung drinn sein oder so. Ist fürs Intranet. Aber irgendwie hab ich was verpasst und der lädt einfach keine Dateien hoch...

Mfg

Enclave

01.
<? 
02.
$add = $_GET['add']; 
03.
$ow = $_GET['ow']; 
04.
$filename = $_FILES['file']['name']; 
05.
$file = $_FILES['file']["tmp_name"]; 
06.
if ($add == ""
07.
08.
?> 
09.
<html> 
10.
<head> 
11.
<title> 
12.
PHP Test Upload 
13.
</title> 
14.
</head> 
15.
<body bgcolor="black" text="white"
16.
<table border="0" width="100%" height="100%" align="center"><tr><td width="100%" height="100%" valign="middle" align="center"
17.
<form action="index.php?add=1" method="post"><table border="1" style="border-color:#FFFF5A; border-style:solid;" frame="void"
18.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;"><b>Dateiname:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="text" name="filename"></td></tr><tr><td style="border-color:#FFFF5A; border-style:hidden;"><br> </td></tr> 
19.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;"><b>Durchsuchen:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="file" name="file"></td></tr><tr><td style="border-color:#FFFF5A; border-style:hidden;"><br> </td></tr> 
20.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;"><b>Hochladen:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="submit" value="GOGOGO"></td></tr> 
21.
</form> 
22.
</td></tr></table></body></html> 
23.
<? 
24.
25.
else 
26.
27.
if ( $filename != "") { 
28.
	if (file_exists("files/$filename" and $ow != "1")) { 
29.
		echo "Eine Datei mit solch einem Namen existiert bereits!<br><br>Überschreiben?<br><br><a href=\"index.php?add=1&ow=1\">Ja</a><br><br><a href=\"index.php?add=\">Nein</a>"
30.
		exit
31.
32.
	copy($file,"files/$filename"); 
33.
	@chmod(files/$filename, 777); 
34.
	echo "Datei erfolgreich hochgeladen!!!<br><br><br>Link zur Datei: <a href=\"/files/$filename\">http://172.16.0.55/files/$filename</a>"
35.
36.
else 
37.
38.
echo "ERROR! Kein Dateiname angegeben!!! <a href=\"index.php\">Zurück</a>"
39.
40.
}
PS: Das HTML ist nicht vorn mir ich sollte nur die Upload Funktion reinbauen. Was hab ich das falsch gemacht?
Mitglied: Xerebus
22.02.2007 um 17:48 Uhr
Kenn mich ja nicht gut aus damit aber muss du wenn du den "<?php" tag öffnest den nicht auch wieder schliessen?
Irgendwie passt die syntax nicht.
Schau mal unter http://www.php.net/manual/de/language.basic-syntax.php
Bitte warten ..
Mitglied: Enclave
22.02.2007 um 22:32 Uhr
Ne der Syntax stimmt schon das macht der automatisch also ich hab nen ganzes Script reingehauen und der macht autmatisch ma Anfang das <?php Deswegen steht das auch 2 mal da

Mfg

Enclave
Bitte warten ..
Mitglied: AxelHahn
23.02.2007 um 08:47 Uhr
Hallo,

1) dein Formular macht ein POST. Dein PHP-Schnipsel zu Beginn fragt aber GET-variablen ab. Die werden daher wohl immer leer sein.

2) Baue testweise Debugoutput ein, um zu sehen, was bei dir passiert - etwa sowas
echo "Variablenname=" $Variablenname ."";

Viele Grüsse
-= Axel =-
Bitte warten ..
Mitglied: SteinBeiser
23.02.2007 um 09:18 Uhr
versuchs mal damit

01.
<?php 
02.
 
03.
$add = $_GET['add']; 
04.
$ow = $_GET['ow']; 
05.
$filename = $_POST['filename']; 
06.
$file = $_FILES['file']["tmp_name"]; 
07.
if ($add == "") 
08.
09.
?> 
10.
<html> 
11.
<head> 
12.
<title>PHP Test Upload</title> 
13.
</head> 
14.
<body style="background-color:black; color:white"> 
15.
<table border="0" width="100%" height="100%" align="center"><tr><td width="100%" height="100%" valign="middle" align="center"> 
16.
<form action="index.php?add=1" method="post" enctype="multipart/form-data"><table border="1" style="border-color:#FFFF5A; border-style:solid;" frame="void"> 
17.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;">Dateiname:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="text" name="filename"></td></tr><tr><td style="border-color:#FFFF5A; border-style:hidden;"> 
18.
 </td></tr> 
19.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;">Durchsuchen:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="hidden" name="MAX_FILE_SIZE" value="30000"><input type="file" name="file"></td></tr><tr><td style="border-color:#FFFF5A; border-style:hidden;"> 
20.
 </td></tr> 
21.
<tr><td align="right" valign="middle" style="border-color:#FFFF5A; border-style:solid;">Hochladen:     </td><td align="left" valign="middle" style="border-color:#FFFF5A; border-style:solid;">     <input type="submit" value="GOGOGO"></td></tr> 
22.
</form> 
23.
</td></tr></table></body></html> 
24.
<?php 
25.
26.
else 
27.
28.
if ( $filename != "") { 
29.
    if (file_exists("files/$filename") and $ow != "1") { 
30.
        echo "Eine Datei mit solch einem Namen existiert bereits! 
31.
 
32.
Überschreiben? 
33.
 
34.
<a href=\"index.php?add=1&ow=1\">Ja</a> 
35.
 
36.
<a href=\"index.php?add=\">Nein</a>"; 
37.
        exit; 
38.
39.
    copy($file,"files/$filename"); 
40.
    @chmod(files/$filename, 777); 
41.
    echo "Datei erfolgreich hochgeladen!!! 
42.
 
43.
 
44.
Link zur Datei: <a href=\"/files/$filename\">http://172.16.0.55/files/$filename</a>"; 
45.
46.
else 
47.
48.
echo "ERROR! Kein Dateiname angegeben!!! <a href=\"index.php\">Zurück</a>"; 
49.
50.
51.
 
52.
?>
Benutzt mal zum nachschalgen selfHTML & selfPHP ist ganz hilfreich.
die sache mit dem überschreiben da muste noch was anderes überlegen.
Bitte warten ..
Mitglied: Enclave
23.02.2007 um 15:47 Uhr
@Acel Hahn: Die GET's sind richtig denn die beiden Werte werden ja an die URL angehängt also ow und add. Die anderen beiden werden mit _FILES abgerufen.

@SteinBeiser: Danke das hat funktioniert. Ich weis echt nicht was los ist (bin vermutlich ausser übung). Eigentlich kann ich PHP recht gut hab auch schonmal nen System geschrieben wo auch nen DateiUpload bei war (der hat eigentlich das Zentrum davon ausgemacht) nur ich weis einfach nicht wodran es gelegen hat.

Werd mich wieder mal in PHP einarbeiten...

MFG und vor allem vielen Dank

Enclave
Bitte warten ..
Mitglied: SteinBeiser
23.02.2007 um 15:59 Uhr
Schau dir mal $filename = an.
und den form tag.
Bitte warten ..
Mitglied: Enclave
23.02.2007 um 19:37 Uhr
Ahhh

Ich hatte das auch erst mit POST aber mit dem gleichen Ergebnis. Lag dann wohl an meinem vergessenem enctype...

Danke

Enclave
Bitte warten ..
Mitglied: 17735
16.04.2007 um 19:49 Uhr
Hallo,

nur mal so am Rande: Statt der copy()-Funktion ist es sinnvoll, bei PHP-Upload-Scripten die Funktion move_uploaded_file() zu verwenden, Syntax wie bei dem hier verwendeten copy()-Syntax.

Gruß,
Ahnenforscher

PS: Dafür wurde die Funktion nämlich entwickelt
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
gelöst Net use reagiert im script anders als in der Konsole (4)

Frage von Ampheus zum Thema Windows Netzwerk ...

Windows Netzwerk
Net use persistent no (2)

Frage von Malgain zum Thema Windows Netzwerk ...

Java
gelöst Net user per script aus txt oder csv für FTP (15)

Frage von OlliPWS zum Thema Java ...

Exchange Server
gelöst MS Action Pack 2017 (2)

Frage von leon123 zum Thema Exchange Server ...

Neue Wissensbeiträge
Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(14)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

RedHat, CentOS, Fedora

Fedora 27 ist verfügbar

Information von Frank zum Thema RedHat, CentOS, Fedora ...

Heiß diskutierte Inhalte
Server
Bilder aus dem Web mit CSV runterladen (30)

Frage von Yannosch zum Thema Server ...

Windows Update
WSUS 4 (Server 2012 R2) - Windows 10 Updates nicht möglich (12)

Frage von c0d3.r3d zum Thema Windows Update ...

Windows Userverwaltung
gelöst Administrator hat alle Rechte verloren (10)

Frage von mrdead zum Thema Windows Userverwaltung ...