Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

url mit ? im mailto body versenden

Frage Entwicklung HTML

Mitglied: meckatzermichel

meckatzermichel (Level 1) - Jetzt verbinden

11.10.2006, aktualisiert 12.10.2006, 9118 Aufrufe, 8 Kommentare

hallo zusammen,

ich möchte (nein ich muss) eine url per mailto befehl versenden.
ich mache das mit
<a href='mailto:name@domain.com?subject=Irgendwas?body=http://domain.com/f?p=61::890070790'>mail</a>

und hier ist der haken, die url hat ein "?" drin. geht net anders die kommt von oracle so.
jedesmal wenn der mailclient aufgeht ist alles ab "?" weg.
%3F hab ich auch schon probiert. geht ebenfalls nicht.

hat jemand ne idee?

danke und gruss
michel
Mitglied: Biber
11.10.2006 um 14:05 Uhr
Moin meckatzermichel,

bei "?body" muss zusätzlich ein "&" dazu:
01.
<a href='mailto:name@domain.com?subject=Irgendwas?&body=http://domain.com/f?p=61::890070790'>mail</a>
Gruß
Biber
Bitte warten ..
Mitglied: meckatzermichel
11.10.2006 um 14:22 Uhr
leider nein biber.
dann kommt gar kein body-text mehr (

gruss
michel
Bitte warten ..
Mitglied: Biber
11.10.2006 um 14:38 Uhr
Hm.. bei mir schon.

Falls allerdings das "&" ein Steuerzeichen ist, musst Du es maskieren.
Wenn ich z.b. vom CMD.Prompt die obige Syntax verwende, muss ich schreiben:
01.
>start mailto:name@domain.com?subject=Irgendwas^&body=http://domain.com/f?p=61::890070790
...damit bei mir die gewünschte Mail erzeugt wird.
[Abweichend zur offiziellen Syntax muss ich sogar das "?" vor "body" weglassen, da es sonst an das "subject" gehängt wird.]

Gruß
Biber
Bitte warten ..
Mitglied: manuel-r
11.10.2006 um 15:05 Uhr
Ich habe gerade mailto:test@example.org?subject=test&body=<index.php?test=test> erfolgreich getestet.

Manuel
Bitte warten ..
Mitglied: meckatzermichel
11.10.2006 um 16:48 Uhr
funktioniert leider immer noch nicht. kann es sein dass es auch mit dem mailclient zusammenhängt?
ich habe lotus notes.
also ich brauch das ? vor dem body sonst schreibt er alles in das subject.

gruss michel
Bitte warten ..
Mitglied: MagicM
11.10.2006 um 17:33 Uhr
Hi,

dies sollte funktionieren.

mailto:info@domain.de&subject=Betreff&Body=bodytext

Hab es gerade von meiner Homepage herunterkopiert, wo es als Link funktioniert. Der Mailto-Link muss natürlich noch wo anders drauf gesetzt werden:

... schicken Sie mir eine [mailto:info@domain.de&subject=Betreff&Body=bodytext Mail]
Bitte warten ..
Mitglied: meckatzermichel
12.10.2006 um 09:44 Uhr
also wenn ich da draufklicke dann steht bei mir alles im to:-Feld.
egal ob notes oder outlook....

und nun?

man muss doch das ? irgendwie maskieren können...
gruss michel

nachtrag: das maskieren mit %3F geht mit outlook, in lotus notes nicht.
sch.... notes
Bitte warten ..
Mitglied: meckatzermichel
12.10.2006 um 13:29 Uhr
so hab ne lösung:
ist wohl ein bug im notes 6

lösung: cc und bcc auch angeben, aber leer lassen...

so ein müll.

danke trotzdem für die ideen...

gruss
meckatzermichel
Bitte warten ..
Ähnliche Inhalte
Cluster
Hilfe bei Einrichtung des MailTo Dienstes des heartbeat (4)

Frage von akadawa zum Thema Cluster ...

Batch & Shell
gelöst Batch E-Mail Body aus txt lesen und einfügen (9)

Frage von pdiddo zum Thema Batch & Shell ...

JavaScript
gelöst Per URL ein Element ausblenden (1)

Frage von Peter32 zum Thema JavaScript ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Verschlüsselung & Zertifikate
SSL Zertifikat für HTTPS (33)

Frage von Hendrik2586 zum Thema Verschlüsselung & Zertifikate ...

Grafikkarten & Monitore
24" oder 27" mit Full HD oder doch mehr Auflösung? (21)

Frage von brutzler zum Thema Grafikkarten & Monitore ...

Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...