Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

V-LAN Konfiguration zwischen Cisco SmartSwitch und Intel NIC - bekomme es nichts ans laufen

Frage Netzwerke LAN, WAN, Wireless

Mitglied: Timo83

Timo83 (Level 1) - Jetzt verbinden

18.10.2010, aktualisiert 18.10.2012, 4053 Aufrufe, 3 Kommentare

Versuche nun schon seit längerem ein paar Vlans zwischen meinen Switchen und dem SBS2003 einzurichten.
Der Server und 2 Cisco Switche bilden quasi einen Ring. Durch die Gruppe (mit SFT) ist allerding immer nur ein Pfad aktiv.
Richte ich nun V-LANs auf dem Server ein bricht sämtliche Kommunikation zusammen.

Ich habe / plane folgende Konfiguration

...........SERVER
............./.........\
........... /...........\
Switch 1 -- Switch 2
(denkt euch die Punkte weg)

Server: SBS 2003 mit 2x Intel Nics ((INTEL PRO 1000 EB)
Switch: cisco SLM224G ( http://www.cisco.com/en/US/products/ps9998/index.html )

Die beiden Karten auf dem Server habe ich zu einer Gruppe mit Switch Fehler Toleranz eingerichtet. Das ganze funktioniert super. Wenn einer der Switche oder eine Netzwerkkarte ausfällt bleibt die Gruppe aktiv die Daten gehen dann über die jeweils andere Leitung.

Nun habe ich auf beiden Switchen einige V-Lans eingerichtet.
ID BESCHREIBUNG
1 das default VLAN (macht Cisco ja automatisch) - dies wird immer untagged an alle Ports übertragen
10 Maschinen - hier sind ein paar CNC-Maschinen drinne die mit den normalen Netzwerk nix zu tun haben dürfen aber auf dem Server ihre Daten suchen
20 GAST-LAN - der Accesspoint kann mehrere SSIDs die GAST SSID liegt in diesem VLAN - hier muss eig. nur DHCP drüber laufen
30 Verwaltung - hier soll dann das ganze SNMP drüber laufen

Die V-Lans können über beide Switch verteilt sein. Die entsprechenden Ports sind fest mit dem jeweiligen V-LAN verbunden (werden also untagged übertragen)
Alle GBit-Uplink-Verbindungen (also die zwischen Server und Switch sowie die zwischen den beiden Switchen) werden getagged übertragen.

Soweit so gut.

Wenn ich nun der Gruppe am Server ein V-LAN verpasse bekomme ich eine neue Netzwerkkarte für dieses V-LAN.
Die "alte" Verbindung meint dann auf einmal sie hätte kein Kabel mehr angeschlossen und lässt sich auch nicht eines besseren belehren. Sämtliche Kommunikation auf der alten IP ist damit erstmal tot. (VLAN 1 wird also nicht übertragen) --> Super GAU

Gebe ich nun der neunen Karte eine sinnvolle Adresse ist hierüber allerdings auch keine Kommunikation möglich. --> auch nicht so toll

Lösche ich das / die V-LAN(s) wieder, ist alles wieder gut - nur das ist ja nicht das, was ich will.

Da das der erste Versuch mit V-Lans ist, nun meine Fragen:
Ist das normal, dass die Hauptverbindung "kein Netzwerkkabel angeschlossen" anzeigt wenn man ein VLAN einrichtet?
Wie bekomme ich denn dann das ungetaggte VLAN 1 auf den Server?
Warum wollen auch die wirklichen VLAN's (10, 20, 30) nicht über den Switch kommunizieren?
Ist das ganze vielleicht mit einer SFT-Gruppe nicht möglich?
Mögen sich Intel und Cisco nicht? 802.1q ist doch eigentlich neutral....
Oder generell, wo ist mein Denkfehler, was mache ich falsch?

Bin für jede Hilfe dankbar

Gruß

Timo
Mitglied: Edi.Pfisterer
18.10.2010 um 14:59 Uhr
Hallo!

Vorerst eine Frage:
was meinst Du mit
Wenn ich nun der Gruppe am Server ein V-LAN verpasse bekomme ich eine neue Netzwerkkarte für dieses V-LAN.

die VLANs werden am Layer3-Switch/Router angelegt, nicht am Server...

vielleicht liegt hier schon der Fehler...

entscheidend ist: der Server muss eine IP-Adresse auf der NIC eingetragen haben, die dem VLAN des Ports entspricht, an dem dein Server eingestöpplt ist...

Der Rest ist dann Sache des Switches/Routers

lg
Bitte warten ..
Mitglied: Timo83
19.10.2010, aktualisiert 18.10.2012
Hi,

danke für die schnelle Antwort.

Vielleicht habe ich mich ein wenig falsch ausgedrückt - oder ich habe wirklich überhaupt keine Ahnung ^^. Ich habe zwischen Server und den Switchen nur eine pyhsikalische Verbindung. Über diese Verbindung sollen die VLANS 10, 20 und 30 getagged übertragen werden (also quasi VLAN Trunking). Das VLAN 1 soll weiter ungetagged ankommen (ist einfach das einfachste, da ich sonst jeden Switchport anpacken muss).

Über den Treiber der Netzwerkkarten kann ich zum einen die Gruppen (Teaming) erstellen zum anderen kann ich dort belibiege VLANs erstellen. Für jedes VLAN erstellt der Treiber dann eine neue (virtuelle) Netzwerkkarte.

Dieser gebe ich natürlich eine entsprechende feste IP die zum jeweiligen Subnet passt. Der Einfachheit halber habe ich mir das so gedacht:
VLAN 1: 192.168.1.x\24
VLAN 10: 192.168.10.x\24
.....
Ist zwar etwas oversized aber sehr einfach strukturiert.

So wie ich das verstanden habe, wird dann über den Treiber der entsprechende Tag an jedes Paket angehangen und an einen der beiden Switche übermittelt. Dort sind die VLANs natürlich auch entsprechend eingetragen. Vom Switch erwarte ich nun, dass er das getaggte Paket empfängt, schaut wo es hinmuss
- den Tag entfernet und dann am entsprechenden Port zustellt - wenn das Ziel physikalisch an ihm angestöpselt ist, bzw.
- an den 2. Switch weiterleitet damit dieser es entsprechend zustellen kann.

Meine Switche sind nur Layer2 - aber ich will ja nicht zwischen den Netzen routen. Ich will nur ein paar Dienste des Servers in jedem Subnetz ermöglichen wobei die Netzte untereinander nix voneinander wissen sollen.

Ist doch eigentlich kein Hexenwerk, oder will ich zuviel?

Gruß

Timo

PS: habe mich hiervon zu dem ganzen inspirieren lassen:
http://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...
Bitte warten ..
Mitglied: Edi.Pfisterer
20.10.2010 um 09:19 Uhr
Hallo!
hmm...

Gebe ich nun der neunen Karte eine sinnvolle Adresse ist hierüber allerdings auch keine Kommunikation möglich. --> auch nicht so toll

Ich kann - nachdem ich Dein Ansinnen verstanden habe - leider auch keinen Fehler erkennen - zumindest nicht aus Deinen Schilderungen.

Vielleicht hilft es Dir, wenn ich Dein Vorhaben nochmal zusammenfasse:
btw: versuch zuerst einmal, dass Du dein Werkl mit 1 Switch zum laufen bekommst (ohne deine Gruppierung), danach kannst Du dich damit befassen...

Du brauchst:
n Ports im VLAN 10 untagged
n Ports im VLAN 20 untagged
Port 1 TAGGED sowohl im VLAN 10 als auch im VLAN 20 (da soll der Server drangehängt werden)
Port 2 TAGGED sowohl im VLAN 10 als auch im VLAN 20 (da soll später der 2. Switch drangehängt werden)

nun richtest Du - wie von acqui beschrieben - die VLANs am NIC ein und das wars dann auch schon

VLAN 1: 192.168.1.x\24
VLAN 10 --> 192.168.10.x\24
VLAN 20 --> 192.168.20.x\24

dann hängst Du an einen Port im VLAN 10 einen PC dran und es sollte nun auch zur Kommunikation zwischen den beiden kommen...
ACHTUNG: der Switch muss eine IP im VLAN 1 haben (weil er Layer2 ist, und somit kein Interface für die anderen VLANs hat...)

sollte eigentlich wirklich keine Hexerei sein...

bedenke, dass dein Layer2 durch die VLANs so reagiert, als wären es 2 Switches...
daher musst Du Ports, über die Traffic aus beiden VLANs "aus dem Switch raus soll" auch in beide VLANs integrieren
der TAG sorgt dann dafür, dass der Ursprung des Traffic (also, aus welchem VLAN er stammt) auch über Switch-Grenzen hinaus bekannt ist...

gutes Gelingen weiterhin
lg
Edi
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
TK-Netze & Geräte
Konfiguration einen Cisco SPA122 an einer Auerswald COMpact 5000 (4)

Frage von SarekHL zum Thema TK-Netze & Geräte ...

Router & Routing
VPN in LAN-LAN Verbindung zwischen zwei Fritzbox-Netzwerken in DMZ (3)

Frage von Molar88 zum Thema Router & Routing ...

Netzwerkmanagement
gelöst Cisco Switche im LAN aufspüren (31)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Router & Routing
Konfiguration Cisco ASA5505 (7)

Frage von Yannosch zum Thema Router & Routing ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...