Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Varnish Cache - Umleitung greift nur bei www.domain.de

Frage Linux Apache Server

Mitglied: bblanke

bblanke (Level 1) - Jetzt verbinden

07.09.2012 um 18:25 Uhr, 3408 Aufrufe, 2 Kommentare

Hallo zusammen,

ich setze mich gerade mit Varnish Cache auseinander.
Soweit klappt alles auch sehr gut, allerdings habe ich ein kleines Problem:

wenn ich die Webseite www.domain.de oder nur domain.de auf meinem Client aufrufe klappt alles super.

Allerdings habe ich mir meine default.vcl so aufgebaut das varnish erkennt ob es sich um einen mobilen user (mobiles Endgerät) handelt oder nicht, bei mobilen Endgeräten verweist Varnish auf eine andere Seite (Andere Domain)

Wenn ich nun meine Webseite www.domain.de vom mobilen Endgerät aufrufe dann komme ich auf die umgeleitete Seite (ALLES TOP),
wenn ich nun die Seite domain.de (also ohne www) aufrufe lande ich auf der normalen Seite und nicht auf die umgeleitete Seite

Meine Varnish default.vcl hat folgenden Eintrag:
01.
 
02.
    if(req.http.host ~ "www.domain.de") { 
03.
        if (req.url ~ "\.(jpg|jpeg|png|gif|gz|tgz|bz2|tbz|mp3|ogg|swf|js|css)") 
04.
05.
        } else { 
06.
            call device_detection; 
07.
            if(req.http.X-Device ~ "mobile") { 
08.
                set req.http.X-Redirect = "http://seite-fuer-mobile.de"; 
09.
                error 750 "Moved Temporarily"; 
10.
11.
12.
    } 
Wenn ich den Eintrag kopiere und das www entferne dann funktionieren beide aufrufe problemlos.

Kennt Ihr eine Möglichkeit das einfacher darzustellen ?
Sodass ich nicht jede Seite 2x in der Varnish Config habe ?!

Viele Grüße
Björn
Mitglied: dog
07.09.2012 um 18:34 Uhr
01.
if(req.http.host ~ "^(www\.)?domain\.de$") { 
Bitte warten ..
Mitglied: bblanke
07.09.2012 um 19:07 Uhr
Danke für deine Hilfe !
das hat super geklappt !

Gruß
Björn
Bitte warten ..
Ähnliche Inhalte
DNS
gelöst Domain.de auf internem DNS Server (7)

Frage von Max-Mauser zum Thema DNS ...

Outlook & Mail
Outlook greift nicht mehr auf outlook.de-Konto zu (6)

Frage von SarekHL zum Thema Outlook & Mail ...

Heiß diskutierte Inhalte
Router & Routing
Tipps für Router (ca. 100 clients, VPN) (19)

Frage von oel-auge zum Thema Router & Routing ...

Windows 7
BOOTMGR is missing (auch nach bootrec -RebuildBcd) (17)

Frage von Mipronimo zum Thema Windows 7 ...

TK-Netze & Geräte
gelöst Convert von TAPI auf CAPI gesucht (13)

Frage von StefanKittel zum Thema TK-Netze & Geräte ...