Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VBS - Dynamischer Pfad wird nicht aktzeptiert

Frage Entwicklung VB for Applications

Mitglied: Dani

Dani (Level 5) - Jetzt verbinden

19.07.2007, aktualisiert 14:40 Uhr, 3656 Aufrufe, 4 Kommentare

Guten Mittag zusammen,

ich bastle nun seit heute Morgen an einem längeren Script und stehe nun vor dem Schlussspurt. Eine einzige Zeile funktioniert nicht.

Hier mal der Ausschnitt:
01.
... 
02.
oShell.Run "C:\programme\winrar\rar.exe a -ac -m5 -y -r K:\Daten-Archiv\"& arrArtikel(intLastIndex-1) &"-"&  arrArtikel(intLastIndex) &".rar Verzeichnis.Self.Path",0,True 
03.
...
Das Problem ist "Verzeichnis.Self...". Das habe ich nun eingrenzen können. Wenn ich dort einen fixen Pfad angebe, läuft die RAR - Prozedur einwandfrei durch. Wenn ich per Dialog den Ornder wähle und dann dort mit "Verzeichnis..." angebe funktioniert es nicht!

Ich habe bereits per Wscript.echo den Inhalt von "Verzeichnis.Self.Path" ausgeben lassen um zu sehen, ob es er irgendwie etwas angehängt hat. Aber ich finde den Fehler einfach nicht.

System: Windows Server 2003 EE + SP2

Ich zähl auf euch.... ^^
Dani
Mitglied: bastla
19.07.2007 um 14:22 Uhr
Hallo Dani!

Täusche ich mich, oder sollte nicht nach ".rar " (inklusive Leerzeichen) der konstante String enden, also etwa so:
01.
... &".rar " & Verzeichnis.Self.Path,0,True
Grüße
bastla
Bitte warten ..
Mitglied: Dani
19.07.2007 um 14:26 Uhr
Hi bastla,
so läuft man sich auch mal wieder über den Weg. ^^

Also ich habe natürlich (wie solls heute auch sein), die falsche Zeile gepostet:
01.
... 
02.
oShell.Run "C:\programme\winrar\rar.exe a -ac -m5 -y -r K:\Daten-Archiv\"& arrArtikel(intLastIndex-1) &"-"&  arrArtikel(intLastIndex) &".rar"& Verzeichnis.Self.Path,0,True 
03.
...
So funktioniert es auch nicht!


Grüße
Dani
Bitte warten ..
Mitglied: bastla
19.07.2007 um 14:33 Uhr
Hallo Dani!

Ohne das Leerzeichen hinter ".rar" kann's eigentlich auch nicht gehen ...

Grüße
bastla
Bitte warten ..
Mitglied: Dani
19.07.2007 um 14:40 Uhr
Hi bastla!
jaja...die Hitze hier im Raum macht mich einfach mürrbe!
1000 Dank dir....und kühlen Kopf bewahren. *gg*


Grüße
Dani
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (19)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...