Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft

nicht verbundene Netzlaufwerke lassen sich nicht trennen

Mitglied: flojud

flojud (Level 1) - Jetzt verbinden

25.08.2009, aktualisiert 08:03 Uhr, 4480 Aufrufe, 3 Kommentare

Im Explorer werden die per VBS Logonskript verbunden Netzlaufwerke als "nicht verbunden" angezeigt. Man kann zwar auf das Laufwerk zugreifen, jedoch bleibt es stets als "nicht verbunden" angezeigt. Das führt dazu, dass Accessdatenbank, die auf Netzlaufwerken liegen nicht verwendet werden können.

Was ich bisher versucht habe (Zur Info die User haben lokale Adminrechte):

          1. Im Explorer Netzlaufwerke trennen
          2. Per net use delete
          3. Netzlaufwerkeinträge aus der Registry gelöscht:
                  • [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\Persistent Connections]
                  • [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\MountPoints2]
          4. Eine beliebige Freigabe über den Explorer gesucht. Rechte Maustaste "Netzlaufwerk verbinden ...". Überschreiben der besetzten, aber "nicht verbundenen" Laufwerksbuchstaben.
          5. Rechner runter fahren, Netzwerkstecker raus, Rechner hochfahren, versuchen zu trennen


    Leider brachte mir alles keinen Erfolg.

    Hier das Logonskript:
    01.
    Const Gruppe_1 = "cn=Gruppe1" 
    02.
    Const Gruppe_2 = "cn=Gruppe2" 
    03.
    Const Gruppe_3 = "cn=Gruppe3" 
    04.
    Const Gruppe_4 = "cn=Gruppe4" 
    05.
    Const Gruppe_5 = "cn=Gruppe5" 
    06.
    Const Gruppe_6 = "cn=Gruppe6" 
    07.
     
    08.
    Set wshNetwork = CreateObject("WScript.Network") 
    09.
     
    10.
    wshNetwork.RemoveNetworkDrive "E:", true, true 
    11.
    wshNetwork.RemoveNetworkDrive "G:", true, true 
    12.
    wshNetwork.RemoveNetworkDrive "M:", true, true 
    13.
    wshNetwork.RemoveNetworkDrive "P:", true, true 
    14.
    wshNetwork.RemoveNetworkDrive "S:", true, true 
    15.
    wshNetwork.RemoveNetworkDrive "T:", true, true 
    16.
    wshNetwork.RemoveNetworkDrive "Y:", true, true 
    17.
    wshNetwork.RemoveNetworkDrive "Z:", true, true 
    18.
     
    19.
    wshNetwork.MapNetworkDrive "E:", "\\S1\Daten" 
    20.
    wshNetwork.MapNetworkDrive "M:", "\\S1\RE" 
    21.
    wshNetwork.MapNetworkDrive "P:", "\\S1\Bilder & Grafiken" 
    22.
    wshNetwork.MapNetworkDrive "T:", "\\S1\Softlib" 
    23.
    wshNetwork.MapNetworkDrive "Y:", "\\S1\Backup" 
    24.
    wshNetwork.MapNetworkDrive "Z:", "\\S1\Privat\" & wshNetwork.UserName 
    25.
     
    26.
    Set ADSysInfo = CreateObject("ADSystemInfo") 
    27.
    Set CurrentUser = GetObject("LDAP://" & ADSysInfo.UserName) 
    28.
    strGroups = LCase(Join(CurrentUser.MemberOf)) 
    29.
     
    30.
    If InStr(strGroups, Gruppe_6) > 0 then 
    31.
        wshNetwork.MapNetworkDrive "G:", "\\S1\QS" 
    32.
    End If 
    33.
     
    34.
    If InStr(strGroups, Gruppe_5) > 0 then 
    35.
        wshNetwork.MapNetworkDrive "S:", "\\S1\SFIRM" 
    36.
    End If 
    37.
     
    38.
    If InStr(strGroups, Gruppe_1) > 0 then 
    39.
        wshNetwork.AddWindowsPrinterConnection "\\S1\HPOG1" 
    40.
    ElseIf InStr(strGroups, Gruppe_2) > 0 then 
    41.
        wshNetwork.AddWindowsPrinterConnection "\\S1\HPOG2" 
    42.
    End If 
    43.
     
    44.
    If InStr(strGroups, Gruppe_3) > 0 then 
    45.
        wshNetwork.AddWindowsPrinterConnection "\\S1\FBW" 
    46.
    ElseIf InStr(strGroups, Gruppe_4) > 0 then 
    47.
        wshNetwork.AddWindowsPrinterConnection "\\S1\AGRAR" 
    48.
    End If
Mitglied: themoon19
14.05.2010 um 20:44 Uhr
hi hast du damals eine Lösung dafür gefunden?
Ich habe auch gerade dieses Problem.
Netzlaufwerk wird im Arbeitsplatz angezeigt aber als nicht verbunden.
Der UNC Pfad ist aufrufbar.
Beim versuch die Laufwerke zu trennen kommt die Meldung das die verbindung nicht gefunden wurde und sich nicht trennen lässt.
per Net use x: /delete kommt dann nur der Hinweis auf die 2250.

komme auch nicht weiter!
Vielleicht hat ja noch jemand eine Idee
Bitte warten ..
Mitglied: flojud
15.05.2010 um 19:49 Uhr
Tut mir leid, ich habe damals keine Lösung für gefunden. Das betroffene Systeme wurde im Endeffekt neu aufgesetzt, eventuell hätte man es noch mit einer Windows Reparatur versuchen können, aber dieser Zeitaufwand war mir damals zu viel....
Bitte warten ..
Mitglied: themoon19
15.05.2010 um 20:07 Uhr
Danke trotzdem.
werd ich bestimmt auch machen (das System neu aufsetzen).
Bitte warten ..
Ähnliche Inhalte
Windows Server
Netzlaufwerk mit net use verbunden, aber doch nicht?!
Frage von jlrantWindows Server3 Kommentare

Hallo zusammen, und zunächst mal vielen Dank für Euer hilfreiches Forum. Ich habe bisher ausschließlich Linux-Server administriert, muss mich ...

Windows Server
Passwort von verbundenem Netzlaufwerk löschen
Frage von mastap2002Windows Server3 Kommentare

Hallo zusammen , ich hab da eine etwas seltsame Anfrage eines Kunden ;-). Also Wenn ich über Ausführen \\192.168 ...

Windows Server
Einmal verbundenes Netzlaufwerk löschen
gelöst Frage von killtecWindows Server10 Kommentare

Hallo, ich möchte gern an allen Clients / Benutzern ein Bestimmtes Netzlaufwerk löschen. Es soll nur bei den angegebenen ...

Windows Netzwerk
Windows Neustart - Netzlaufwerke werden nicht verbunden
gelöst Frage von it-fraggleWindows Netzwerk1 Kommentar

Hallo zusammen, vor einigen Monaten habe ich mal irgendwo gelesen, dass es eine Gruppenrichtlinie gibt mit der ich einstellen ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 18 StundenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 1 TagTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 1 TagSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 1 TagSicherheit9 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Sicherheit
Meltdown und Spectre: Die machen uns alle was vor
Information von FrankSicherheit25 Kommentare

Aktuell sieht es in den Medien so aus, als hätten die Hersteller wie Intel, Microsoft und Co den aktuellen ...

Netzwerke
Packet loss bei "InternetLeitungsvollauslastung"
gelöst Frage von Freak-On-SiliconNetzwerke17 Kommentare

Servus; Ja der Titel klingt komisch, is aber so. Wenn die Internetleitung voll ausgelastet ist, hab ich extreme packet ...

Ubuntu
Ubuntu - Starter für nicht vertrauenswürdige Anwendungen
Frage von adm2015Ubuntu17 Kommentare

Hallo zusammen, Ich verwende derzeit die Ubuntu Versionen 17.10 bzw. im Test 18.04. Ich habe mehrere .desktop Dateien in ...

Windows 10
Automatische daten kopieren, USB zu USB unter Win10 im Hintergrund
Frage von DerEisigeWindows 1016 Kommentare

Hallo Leute, ich bin auf der Suche nach einem Skript, dass von einem USB Stick automatisch nach dem einstecken ...