Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

nicht verbundene Netzlaufwerke lassen sich nicht trennen

Frage Microsoft

Mitglied: flojud

flojud (Level 1) - Jetzt verbinden

25.08.2009, aktualisiert 08:03 Uhr, 4424 Aufrufe, 3 Kommentare

Im Explorer werden die per VBS Logonskript verbunden Netzlaufwerke als "nicht verbunden" angezeigt. Man kann zwar auf das Laufwerk zugreifen, jedoch bleibt es stets als "nicht verbunden" angezeigt. Das führt dazu, dass Accessdatenbank, die auf Netzlaufwerken liegen nicht verwendet werden können.

Was ich bisher versucht habe (Zur Info die User haben lokale Adminrechte):

          1. Im Explorer Netzlaufwerke trennen
          2. Per net use delete
          3. Netzlaufwerkeinträge aus der Registry gelöscht:
                  • [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\Persistent Connections]
                  • [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ Explorer\MountPoints2]
          4. Eine beliebige Freigabe über den Explorer gesucht. Rechte Maustaste "Netzlaufwerk verbinden ...". Überschreiben der besetzten, aber "nicht verbundenen" Laufwerksbuchstaben.
          5. Rechner runter fahren, Netzwerkstecker raus, Rechner hochfahren, versuchen zu trennen


    Leider brachte mir alles keinen Erfolg.

    Hier das Logonskript:
    01.
    Const Gruppe_1 = "cn=Gruppe1" 
    02.
    Const Gruppe_2 = "cn=Gruppe2" 
    03.
    Const Gruppe_3 = "cn=Gruppe3" 
    04.
    Const Gruppe_4 = "cn=Gruppe4" 
    05.
    Const Gruppe_5 = "cn=Gruppe5" 
    06.
    Const Gruppe_6 = "cn=Gruppe6" 
    07.
     
    08.
    Set wshNetwork = CreateObject("WScript.Network") 
    09.
     
    10.
    wshNetwork.RemoveNetworkDrive "E:", true, true 
    11.
    wshNetwork.RemoveNetworkDrive "G:", true, true 
    12.
    wshNetwork.RemoveNetworkDrive "M:", true, true 
    13.
    wshNetwork.RemoveNetworkDrive "P:", true, true 
    14.
    wshNetwork.RemoveNetworkDrive "S:", true, true 
    15.
    wshNetwork.RemoveNetworkDrive "T:", true, true 
    16.
    wshNetwork.RemoveNetworkDrive "Y:", true, true 
    17.
    wshNetwork.RemoveNetworkDrive "Z:", true, true 
    18.
     
    19.
    wshNetwork.MapNetworkDrive "E:", "\\S1\Daten" 
    20.
    wshNetwork.MapNetworkDrive "M:", "\\S1\RE" 
    21.
    wshNetwork.MapNetworkDrive "P:", "\\S1\Bilder & Grafiken" 
    22.
    wshNetwork.MapNetworkDrive "T:", "\\S1\Softlib" 
    23.
    wshNetwork.MapNetworkDrive "Y:", "\\S1\Backup" 
    24.
    wshNetwork.MapNetworkDrive "Z:", "\\S1\Privat\" & wshNetwork.UserName 
    25.
     
    26.
    Set ADSysInfo = CreateObject("ADSystemInfo") 
    27.
    Set CurrentUser = GetObject("LDAP://" & ADSysInfo.UserName) 
    28.
    strGroups = LCase(Join(CurrentUser.MemberOf)) 
    29.
     
    30.
    If InStr(strGroups, Gruppe_6) > 0 then 
    31.
        wshNetwork.MapNetworkDrive "G:", "\\S1\QS" 
    32.
    End If 
    33.
     
    34.
    If InStr(strGroups, Gruppe_5) > 0 then 
    35.
        wshNetwork.MapNetworkDrive "S:", "\\S1\SFIRM" 
    36.
    End If 
    37.
     
    38.
    If InStr(strGroups, Gruppe_1) > 0 then 
    39.
        wshNetwork.AddWindowsPrinterConnection "\\S1\HPOG1" 
    40.
    ElseIf InStr(strGroups, Gruppe_2) > 0 then 
    41.
        wshNetwork.AddWindowsPrinterConnection "\\S1\HPOG2" 
    42.
    End If 
    43.
     
    44.
    If InStr(strGroups, Gruppe_3) > 0 then 
    45.
        wshNetwork.AddWindowsPrinterConnection "\\S1\FBW" 
    46.
    ElseIf InStr(strGroups, Gruppe_4) > 0 then 
    47.
        wshNetwork.AddWindowsPrinterConnection "\\S1\AGRAR" 
    48.
    End If
Mitglied: themoon19
14.05.2010 um 20:44 Uhr
hi hast du damals eine Lösung dafür gefunden?
Ich habe auch gerade dieses Problem.
Netzlaufwerk wird im Arbeitsplatz angezeigt aber als nicht verbunden.
Der UNC Pfad ist aufrufbar.
Beim versuch die Laufwerke zu trennen kommt die Meldung das die verbindung nicht gefunden wurde und sich nicht trennen lässt.
per Net use x: /delete kommt dann nur der Hinweis auf die 2250.

komme auch nicht weiter!
Vielleicht hat ja noch jemand eine Idee
Bitte warten ..
Mitglied: flojud
15.05.2010 um 19:49 Uhr
Tut mir leid, ich habe damals keine Lösung für gefunden. Das betroffene Systeme wurde im Endeffekt neu aufgesetzt, eventuell hätte man es noch mit einer Windows Reparatur versuchen können, aber dieser Zeitaufwand war mir damals zu viel....
Bitte warten ..
Mitglied: themoon19
15.05.2010 um 20:07 Uhr
Danke trotzdem.
werd ich bestimmt auch machen (das System neu aufsetzen).
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst Netzlaufwerke mit einer VPN Verbindung verbinden lassen (16)

Frage von M.Marz zum Thema Windows Server ...

Outlook & Mail
Outlook 2016 Postfächer lassen sich nicht schließen (9)

Frage von master3477 zum Thema Outlook & Mail ...

Cloud-Dienste
Lieferanten auf eigenem Server arbeiten lassen (1)

Frage von pmsfw22 zum Thema Cloud-Dienste ...

Heiß diskutierte Inhalte
Viren und Trojaner
gelöst Wie werde ich den Mist "fanli90" wieder los? (18)

Frage von Taumel zum Thema Viren und Trojaner ...

Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (16)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...