Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Virtual Technology VT bzw. VT-X aktivieren ohne BIOS

Frage Virtualisierung

Mitglied: mayho33

mayho33 (Level 2) - Jetzt verbinden

26.04.2013 um 10:35 Uhr, 4705 Aufrufe, 2 Kommentare, 1 Danke

Hi @ All!

Ich arbeite bei einem großen Dienstleister im Bereich Client Automation & Virtualization, also unter anderem bei der Erstellung von automatisierten Installationsroutinen.
Immer wieder kommt es vor dass einer der Kunden eine Lösung für ein spezielles Problem haben will. Am so einem Problem arbeite ich gerade (VT aktivieren unter Windows) und es scheint als würde ich mir die Zähne ausbeißen.

Das Problem im Detail:

Virtual Box soll installiert werden. Bevor dies aber geschieht, soll gecheckt werden ob
a) VT möglich ist
b) VT auch aktiviert ist
c) wenn VT möglich, aber nicht aktiviert ist, soll diese unter Windows aktiviert werden.

für Punkt A und B habe ich bereits ein Lösung. Nur bei Punkt C bin ich mit meinem Latein am Ende. Auch Google schein keine Antworten für mich zu haben (Kann natürlich auch die falschen Suchkriterien eingegeben haben).

Auch sind leider viele verschiedenen BIOS, Hardware und Hersteller in der Umgebung unterwegs. Es muss also eine möglichst universelle Lösung her. Ich habe aber keine...

Darum greife ich auf die letzte mir bekannte Wissensdatenbank zu. Auf Euch! Ich hoffe sehr, dass jemand eine geniale Idee hat wie sich VT unter Windows von mir aus auch mit Neustart, mit Tool, mit VB, BATCH, C# oder PS, aber unbedingt ohne das BIOS direkt angreifen zu müssen, aktivieren lässt.

Ich kenne mich zwar nur mit VBSCRIPT und VB gut aus, meine Kollegen haben aber gute Kenntnisse mit C#, BATCH und PS. Wäre also für jeden Ansatz dankbar.

Vielen Dank für eure Rückmeldungen!

mayho
Mitglied: certifiedit.net
02.05.2013 um 12:08 Uhr
Hi,

Das wirst du so wohl nicht hinbekommen. Es gab vor einigen Jahren von Seiten HP mal ein Programm, das spezifische BIOS Settings schreiben konnte. Aber da dies doch eher ungewöhnlich ist haben die das wohl eingestampft. Habe so ein Programm von daher von keinem Hersteller mehr gesehen. Was eine Möglichkeit wäre wären BIOS Updates für jedes spezifisch eingesetzte Board, bei dem der VT (oder AMD equi) Flag bereits gesetzt ist. Ob die Mühe das Wert ist? ;)

PS: Bin auch ein Fan der automatisierung. Nur manchmal ist das nicht nur nicht vorgesehen, sondern eher ein Ding der unmöglichkeit. Sorry ;)

Gruß
Bitte warten ..
Mitglied: mayho33
06.05.2013 um 16:33 Uhr
Hi!


Zitat von certifiedit.net:
PS: Bin auch ein Fan der automatisierung. Nur manchmal ist das nicht nur nicht vorgesehen, sondern eher ein Ding der
unmöglichkeit. Sorry ;)

Naja, ich sehe das eher als das Gegenteil von Weitblick an. Mit kommen täglich Setups unter da wäre es wohl besser die Software einfach nicht einzusetzen und das dem hersteller auch zu kommunizieren. Zumal der Großteil der Developer wohl noch nicht geschnallt hat, dass MS ein eindeutiges, aber leider sehr offenens, Modell zur Verfügung stellt wie Software installiert werden muss/soll. Denke da an Scriptgeteuerte Installer.

Aber das ist ja nicht das Thema Zum Glück ist es nun auch nicht mehr Vorraussetzung. Unser Kunde hat wohl eingesehen, dass mit solchen Wünschen die Grenzen klar erreicht sind.

Danke!

lg

Mayho
Bitte warten ..
Neuester Wissensbeitrag
Off Topic

"Ich habe nichts zu verbergen"

(2)

Erfahrungsbericht von FA-jka zum Thema Off Topic ...

Ähnliche Inhalte
Netzwerkmanagement
gelöst SSH bei einem Cisco Switch SF200 24P 24-Port 10 100 PoE Smart Switch aktivieren (12)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Sicherheit
BIOS UEFI mit Ransomware infiziert (1)

Link von sabines zum Thema Sicherheit ...

Festplatten, SSD, Raid
gelöst Software -, Hardware -, Bios Fake Raid (35)

Frage von Winuser zum Thema Festplatten, SSD, Raid ...

Administrator.de Feedback
Entwicklertagebuch: Administrator Technology Webseite überarbeitet

Information von admtech zum Thema Administrator.de Feedback ...

Heiß diskutierte Inhalte
Linux Netzwerk
gelöst DHCP vergibt keine Adressen (31)

Frage von Maik82 zum Thema Linux Netzwerk ...

Exchange Server
gelöst Bestehende eMails autoamatisch weiterleiten (22)

Frage von metal-shot zum Thema Exchange Server ...

Switche und Hubs
LAG zwischen SG300-Switches macht Probleme. Wer weiß Rat? (20)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

Apache Server
gelöst Lets Encrypt SSL mit Apache2 (20)

Frage von banane31 zum Thema Apache Server ...