Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Virtueller Router

Frage Netzwerke Router & Routing

Mitglied: killtec

killtec (Level 3) - Jetzt verbinden

30.01.2013, aktualisiert 12:42 Uhr, 2549 Aufrufe, 17 Kommentare

Hallo zusammen

ich suche eine Software, mit der ich schnell und einfach (und kostenlos) eine Routing-Funktion ermöglichen kann.
Das ganze soll als VM laufen.
Ich habe testweise den ipfire laufen, jedoch weiß ich nicht, wie ich da die FW ausschalten kann.
Das Teil soll nur stumpf Routen. Also kein NAT etc...

Gruß
Mitglied: Hitman4021
30.01.2013, aktualisiert um 12:55 Uhr
Hallo,

seit wann ist ipFire ein Router?

http://en.wikipedia.org/wiki/Quagga_%28Software%29

Also welche "Routing Funktionen" brauchst du nun?

Gruß
Bitte warten ..
Mitglied: killtec
30.01.2013, aktualisiert um 13:03 Uhr
Hi Hitman4021,
ja, ich denke mal ipfire ist eher eine FW mit Routing Funktion. Ich will lediglich eine Statische Route zwischen zwei Netzen erstellen.

Weitere Schwierigkeit, das müsste sich am ehesten als ISO installieren lassen, da ich nur ISO's in die VM einbinden kann.

Gruß
Bitte warten ..
Mitglied: wiesi200
30.01.2013 um 13:12 Uhr
Hallo,

einfach Linux aufsetzen?
Bitte warten ..
Mitglied: killtec
30.01.2013 um 13:14 Uhr
Ok, und dann wenn das geschehen ist? Nehme ich dann das Quagga? Oder gibt es da was anderes?
Bitte warten ..
Mitglied: Lochkartenstanzer
30.01.2013, aktualisiert um 13:46 Uhr

unnötig.

Einfach routing einschalten und gut ist.

Kollgege aqui hat da einer seiner tollen Anleitungen dazu verfaßt. Funktioniert auch mit virtuellen Rechnern.

lks
Bitte warten ..
Mitglied: SlainteMhath
30.01.2013 um 13:46 Uhr
Zitat von killtec:
Ok, und dann wenn das geschehen ist? Nehme ich dann das Quagga? Oder gibt es da was anderes?
Tipp: Linux kann von sich aus routen, es sei denn du willst noch so Sachen wie OSPF, BGP oder RIP etc.

Tutorials dazu gibts haufenwiese bei Google.

lg,
Slainte
Bitte warten ..
Mitglied: catachan
30.01.2013, aktualisiert um 13:48 Uhr
Hi

wenn du nur ein einfaches statisches Routing brauchst dann nimm deine Lieblings-Linuxdistribution.
Da konfigurierst du deine Interfaces und aktivierst dann mit folgendem Befehl das Routing

01.
  
02.
echo 1 > /proc/sys/net/ipv4/ip_forward


Der Befehl besteht allerdings nur bis zum Reboot. Um es permanent einzutragen änderst du in der Datei /etc/sysctl.conf:
Die Zeile net.ipv4.ip_forward = 10 den 0er auf 1.

Fertig
Bitte warten ..
Mitglied: Lochkartenstanzer
30.01.2013 um 13:49 Uhr
Zitat von SlainteMhath:
Tipp: Linux kann von sich aus routen, es sei denn du willst noch so Sachen wie OSPF, BGP oder RIP etc.

Auch RIP, OSPF, und BGP sind bei den meisten Linuxdistributionen mit dabei. Muß man einafch im repository auswählen, wenn man linux installiert.

lks
Bitte warten ..
Mitglied: SlainteMhath
30.01.2013 um 13:51 Uhr
Zitat von Lochkartenstanzer:
> Zitat von SlainteMhath:
> ----
> Tipp: Linux kann von sich aus routen, es sei denn du willst noch so Sachen wie OSPF, BGP oder RIP etc.

Auch RIP, OSPF, und BGP sind bei den meisten Linuxdistributionen mit dabei. Muß man einafch im repository auswählen,
wenn man linux installiert.
Richtig, erfordern aber je ein zusätzliches "apt-get install" - route wir i.d,R. im Basissystem schon mitinstalliert.
Bitte warten ..
Mitglied: Lochkartenstanzer
30.01.2013 um 14:03 Uhr
Zitat von SlainteMhath:
Richtig, erfordern aber je ein zusätzliches "apt-get install" -

Nicht, wenn man bei der Paketauswahl (tasksel) bei der Serverinstallation diese gleich mit auswählt.

Leider ist kein "Router" in tasksel mit vorgesehen.

lks
Bitte warten ..
Mitglied: aqui
30.01.2013 um 17:09 Uhr
Details und hilfreiches steht auch HIER in der Rubrik "Testrouter"
Ansonsten wie gesagt Linux oder pfSense in einen VM dafür gibts fertige Images.
Bitte warten ..
Mitglied: killtec
26.02.2013, aktualisiert um 16:21 Uhr
Hi,
so, habe es endlich mal getestet mit dem Linux.
Habe folgende Config:
SLES11 SP2 mit den Adressen:
eth0: 192.168.164.253/24
eth1: 10.2.0.3/16 + 10.2.1.1/16
(zwei 10.2-er Adressen, da der Router / die FW später die 10.2.1.1 bekommen soll)

Wenn ich von den PC's wo der SLES auch ist einen ping starte. Z.B.:Server 1 ist 192.168.164.101 zu Servre 2: 10.2.0.100 anpinge, funktioneirt es (an Server 1 die Route 10.2.0.0/16 192.168.164.253 eingetragen).
Wenn ich jetzt von einem PC:
10.0.3.1 (per VPN mit 192.168.164.0 verbunden) eine Route eintrage auf 10.2.0.0/16 GW:192.168.164.253 dann kann ich weder die 10.2.1.1 noch die 10.2.0.3 noch sonst eine IP aus dem 10.2.0.0/16 anpingen. Vom SLES her kann ich alles erreichen (klar, hat ja auch beide Netze). Auch kann ich die 192.168.164.253 (SLES) erreichen.
Die FW ist deaktivert und IP Forwarding aktiviert.

Habe ich irgendwo einen Denkfehler? Fehlt mir irgendwo eine Route? Default Route am SLES ist 192.168.164.254 (aktuelle Router/FW IP) Der SLES müsste ja auch beide Netzte kennen, da er in beiden ist, also würde er doch keine weitere static route benötigen, korrekt?

Gruß
Bitte warten ..
Mitglied: aqui
26.02.2013 um 22:10 Uhr
Wenn der VPN Rechner im 10.0.3.0 /24er Netzwerk ist und eine statische Route ins 10.2.0.0 /16er Netzwerk hat kann das default Gateway doch niemals in einem Netzwerk liegen in dem der VPN Adapter gar nicht ist also 192.168.164.253 !!
Das ist, sorry wenn es so drastisch ist, routertechnischer Schwachsinn !
Wie bitte soll der Rechner denn eine Gateway Adresse erreichen in einem Netz was er nicht kennt. Da hast du entweder den Sinn (oder Unsinn) von Routen nicht verstanden oder nicht nachgedacht.
Das Next Hop Gateway kann doch immer nur in dem Netz leigen das der Client auch kennt sprich direkt an ihm angeschlossen ist. Folglich muss es auch im 10.0.3er Netz liegen...logo !!
Klare Sache also das es nicht funktioniert.
Nimm Open VPN als VPN Server, dort kannst du mit dem "push route..." Kommando diese Routen automatisch an den VPN Client propagieren lassen wenn er den VPN Tunnel aufbaut.
Dann musst du auch nicht mit statischen Routen am Client rumfricklen. Kein Netzwerker macht sowas !!
Bitte warten ..
Mitglied: killtec
27.02.2013 um 07:54 Uhr
Hi Aqui,
kurz mal die NW-Übersicht:
Hauptnetz - VPN - (Nebennetz - Router - nebennetz2) [ein Standort]
10.0.0.0/16 - VPN-Verbindung - 192.168.164.0/24 - <192.168.164.253><10.2.1.1|10.2.0.3> - 10.2.0.0/16

An einem Standort funktioniert es Also zwischen dem 192.168.164.0 und 10.2.0.0. Statische Routen reichen hier aus. Es soll nachher erstmal "nur" Telefonie laufen. Die Geräte im 10.2-er Netz haben natürlich die 10.2.1.1 als GW eingetragen.

Das ganze soll natürlich nur eine Übergangslösung sein.

Gruß
Bitte warten ..
Mitglied: aqui
28.02.2013 um 18:45 Uhr
Trotzdem ist die Routing Beschreibung oben IP technsicher Unsinn.
Machst du eine Site to Site VPN Kopplung oder ist das ein simpler VPN Client ?
OK, für Telefonie macht natürlich nur Site to Site Sinn.
Generell ist der Weg mit der VPN Kopplung der Netze aber natürlich der richtige !
Bitte warten ..
Mitglied: killtec
01.03.2013 um 07:51 Uhr
Hi Aqui,
danke für die Antworten. Es ist eine Site-To-Site Kopplung. Vermutlich werden jedoch die Telefone noch im "alten" netz laufen, da diese demnächst installiert werden und vorher da noch andere Sachen geklärt werden müssen.

Gruß
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (17)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...