Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Vista Frage zu Batch Datei

Frage Microsoft Windows Vista

Mitglied: potshock

potshock (Level 1) - Jetzt verbinden

25.05.2009, aktualisiert 12:04 Uhr, 4925 Aufrufe, 4 Kommentare

Moin Admins,

irgendwie stehe ich heute morgen mal wieder ziemlich auf der Leitung.
Ich habe mir zu Testzwecken ein Multibootsystem mit Windows Xp und Vista aufgebaut. Windows 7 soll in Kürze folgen.

Auf dem Xp System habe ich im Autostart folgende Batch Datei welche mir Bginfo startet:
start C:\Programme\Bginfo\Bginfo.exe /timer:0
Diese funktioniert einwandfrei!

Nun möchte ich dasselbe auf dem Vista System,bei dem ich als wahrer Administrator angemeldet bin.
start "C:\Program Files\Bginfo\Bginfo.exe /timer:0"
Dies führt leider nur dazu, daß eine neue Eingabeaufforderung mit dem Pfad C:\Windows\system32> aufpoppt.

Gebe ich direkt in der Eingabeaufforderung "C:\Program Files\Bginfo\Bginfo.exe" ein, so wird Bginfo gestartet.
start "C:\Program Files\Bginfo\Bginfo.exe" in der Batchdatei geht aber auch nicht.

Gebe ich in der Eingabeaufforderung "C:\Program Files\Bginfo\Bginfo.exe /timer:0" ein, so erscheint die Meldung Der Verzeichnisname ist ungültig.

Wo liegt mein Fehler?

Ach ja, bei dem Vista handelt es sich mangels anderer verfügbarer Lizens um eine US Ultimate Version mit über die Updatefkt. aufgespieltem deutschen Sprachpaket. Kann da das Problem liegen?

T@cky
Mitglied: bastla
25.05.2009 um 12:08 Uhr
Hallo potshock!

Eine Zeile, die sowohl unter XP wie auch unter Vista funktioniert, könnte so aussehen:
start "" "%ProgramFiles%\Bginfo\Bginfo.exe" /timer:0
wobei ja aber auch ein
"%ProgramFiles%\Bginfo\Bginfo.exe" /timer:0
reichen sollte ...

Grüße
bastla
Bitte warten ..
Mitglied: potshock
25.05.2009 um 13:18 Uhr
Hi bastla,

leider geht das auch nicht!

Bei start "" "%ProgramFiles%\Bginfo\Bginfo.exe" /timer:0
erscheint eine Fehlermeldung:
\Bginfo\Bginfo.exe kann nicht gefunden werden,ist aber definitiv der richtige Pfad.

Bei "%ProgramFiles%\Bginfo\Bginfo.exe" /timer:0
passiert gar nichts, bzw.man sieht ganz kurz die Eingabeaufforderung.

Auch die Verwendung von doppelten %% in der Batch hilft nicht.

Beides direkt in der Eingabeaufforderung eingegeben, ergibt leider auch nur entweder das Aufpoppen einer neuen Eingabeaufforderung bzw. Das System kann den angegeben Pfad nicht finden.

T@cky
Bitte warten ..
Mitglied: 78632
25.05.2009 um 13:47 Uhr
Gib mal unter Vista in der Konsole
set pr ein und berichte, was dort für ein Wert für die Variable Programfiles ausgegeben wird bzw. ob die überhaupt vorhanden ist.

Zitat von potshock:
Gebe ich in der Eingabeaufforderung
"C:\Program Files\Bginfo\Bginfo.exe /timer:0"
ein, so erscheint die Meldung Der Verzeichnisname ist ungültig.

Verständlich. Den Parameter darfst du nicht mit in die Anführungszeichen nehmen.

Lass mal bei einem Test den Parameter /timer:0 weg.
Bitte warten ..
Mitglied: potshock
25.05.2009 um 14:40 Uhr
Hi blablanick, hi bastla,

danke euch erst einmal !

"C:\Program Files\Bginfo\Bginfo.exe" /timer:0
funktioniert jetzt einwandfrei,obwohl das vorher ohne den Parameter /timer:0 nicht ging.

Auch %ProgramFiles%\Bginfo\Bginfo.exe" /timer:0
funktioniert jetzt einwandfrei, obwohl ich das ja vorher schon getestet habe.

Er gibt mir ja auch unter set pr u.a. folgendes aus:
ProgramFiles=C:\Program Files

Hat wohl irgend ein Bit quergestanden

Danke noch einmal

T@cky
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Heiß diskutierte Inhalte
Switche und Hubs
LAG zwischen Cisco SG300 und Dlink DGS1100 herstellen - wie? (18)

Frage von White-Rabbit2 zum Thema Switche und Hubs ...

CPU, RAM, Mainboards
Hardware Fragen (12)

Frage von xaver-2 zum Thema CPU, RAM, Mainboards ...

Grafikkarten & Monitore
Neue Graifkkarte - kein Bild (10)

Frage von bestelitt zum Thema Grafikkarten & Monitore ...

Exchange Server
gelöst Exchange 2013 - Kontakte aus CSV importieren (9)

Frage von hesper zum Thema Exchange Server ...