Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

VLAN über Layer2 Switch und Router

Frage Netzwerke Router & Routing

Mitglied: zahni

zahni (Level 1) - Jetzt verbinden

01.12.2010, aktualisiert 12:15 Uhr, 13534 Aufrufe, 10 Kommentare, 1 Danke

Fragen zum Tutorial: http://www.administrator.de/index.php?content=110259
Default IP-Adresse VLAN Gateway

Hallo,
beziehe mich nochmal auf o.g. Tutorial von aqui und auf u.a. Schaubild (natürlich auch von aqui!!)

b53b8291217646e2aaa365c3b10a1718 - Klicke auf das Bild, um es zu vergrößern

Dazu hätte ich noch folgende Verständnisfrage:

Beim HP-Switch gibt es ja ein Default-VLAN1, mit Port 1-24 als Member. Soll und kann ich das verwenden und nur VLAN2 (Gastnetz) neu aufsetzen oder ist es sinnvoller das Default VLAN1 zu belassen und ein VLAN2 und VLAN 3 zu konfigurieren?

Dem Tagged-Port am HP-Switch kann nur eine PVID zugewiesen werden, das scheint mir irgenwie sinnlos zu sein,weil ja über diesen Port alle VLANS zur Unterscheidung getagged werden müssen! Oder ist es evtl. so, dass der HP-Switch automatisch die VLANS dort tagged, wo ein Port Mitglied in mehreren VLANS ist??

Kurz noch zu den IP-Interfaces in der Linksys-Konfiguration:
Die Router-IP soll ja immer die .1 sein, jetzt habe ich aber folgendes Problem: Ein Netzwerkgerät, dass ich in beiden VLANS brauche hat eine fixe Adresse von 192.168.1.1, das würde ja dann mit der Router-IP kollidieren. oder?


Und jetzt noch was ganz dummes: Die Verbindung VLAN-Router und Internetrouter geht über den WAN-Port, oder?
Internetrouter: 192.168.1.254
Linksys DD-WRT: 192.168.1.253

Grüße
Mitglied: dog
01.12.2010 um 22:30 Uhr
ist es sinnvoller das Default VLAN1 zu belassen und ein VLAN2 und VLAN 3 zu konfigurieren?

Ich lasse VLAN1 immer da, aber auf den Switches wo man Namen vergeben kann heißt das dann "Müllhalde", hat niemals einen Uplink-Port und ist nur auf den Ports die nicht verwendet werden sollen

Dem Tagged-Port am HP-Switch kann nur eine PVID zugewiesen werden,

Die PVID ist nicht das tagged VLAN, sonder das untagged VLAN, alle anderen gehen automatisch.

dass ich in beiden VLANS brauche hat eine fixe Adresse von 192.168.1.1,

In beiden kann es schonmal nicht diese IP haben, weil jedes VLAN auch ein anderes Subnetz sein muss!
Und was der Router für eine IP hat ist ihm völlig egal.

Die Verbindung VLAN-Router und Internetrouter geht über den WAN-Port, oder?

WAN-Port des VLAN-Routers an LAN-Port des Internet-Routers.
Bitte warten ..
Mitglied: zahni
02.12.2010 um 09:47 Uhr
Hallo Dog,
danke erstmal für deine Mühe!

Zwischenzeitlich sieht es bei mir so aus:
VLAN2: 192.168.2.x, DHCP-Server ist der Linksys-Router, Adressen ab .100 - .150.
VLAN3: 192.168.3.x, DCHP wie oben.

Wenn ich mich z.B. mit dem iPad über den AP2 (VLAN2, Gast) verbinde, bekomme ich vom VLAN-Linksysrouter auch eine IP aus dem richtigen Adressraum zugewiesen: 192.168.2.111. So weit so gut. Als Router und DNS-Server steht dann unter Netzwerkeinstellung im iPad (logischerweise) die 192.168.2.1, also die Adresse die ich im IP-Interface des VLAN-Routers vergeben habe. Nur gibt es eben kein Netzwerkteilnehmer mit dieser IP-Adresse und deshalb gibt es wohl auch keine Internetverbindung, denn mein Internetrouter hat ja die 192.168.1.254. Kurzum, habe nicht verstanden was es mit der Router-IP in der IP-Interface Konfig im VLAN-Router auf sich hat.

Wie gehe ich denn nun vor, wenn ich ein NAS in verschiedenen VLANS benötige?
Würdest du den APs einen feste IP aus "Ihrem" Adressraum zuweisen oder über den VLAN-Router per DHCP?

Viele Grüße
Bitte warten ..
Mitglied: aqui
02.12.2010 um 15:16 Uhr
.. ."Default VLAN1 zu belassen und ein VLAN2 und VLAN 3 zu konfigurieren?.."
A.: Das kannst du so machen, denn auch das VLAN-1 ist ein VLAN. Bedenke aber das das VLAN-1 als default VLAN immer untagged an jedem Port anliegt, also auch auf den Tagged Ports !
Weiterer Nachteil: Ungenutze Ports fallen immer ins Default VLAN. Sicherheitsrelevante LANs solltest du also besser nicht ins VLAN-1 nehmen.
Am netztechnisch besten ist es das VLAN-1 nur als Management für den Switch laufen zu lassen und alle relevanten Produktivnetze auf dediziert eingerichtete VLANs zu nehmen. So geht man auf Nummer sicher.
Für nicht Sicherheitsrelevante LANs kannst du aber durchaus auch das VLAN-1 verwenden.

.. ."Dem Tagged-Port am HP-Switch kann nur eine PVID zugewiesen werden.."
A.: Sorry, aber das ist kompletter Unsinn und schlicht falsch ! Siehe ein Auszug aus einer aktuell laufenden HP Konfig hier:

vlan 10
name "Firma"
untagged 3-11
tagged 1
exit
vlan 20
name "Firmen WLAN"
untagged 12-13
tagged 1
exit
vlan 30
name "Server"
untagged 14-19
tagged 1
exit
vlan 40
name "Gaeste Netzwerk"
untagged 20-24
tagged 1
exit

Wie du selber sehen kannst ist der Uplink Port 1 tagged in allen VLAN mit ihrer PVID.
Da solltest du also dringenst nochmals die Doku lesen !
Das ist ein zwingendes Muss beim VLAN Tagging, denn sonst machen VLAN gar keinen Sinn !!

.. ."Die Router-IP soll ja immer die .1 sein.."
A.: Das ist ein IP Adressvorschlag aus dem Tutorial und wie immer bei Beispiel IP Adressen nur lediglich "kosmetisch" ! Genausogut kannst du die .254, .100, .77 oder was auch immer für dich am schönsten ist nehmen ! dog hat es ja schon richtig bemerkt.
Wichtig ist lediglich das diese IP Hostadresse zum IP Netz im VLAN passt...mehr nicht !

... ."VLAN Internet Router Wirrwarr..."
A.: Das Tutorial bezieht sich hier auf einen Routing Prozess wo der Linksys mehrere VLANs an einem VLAN Switch routet und zusätzlich alle ins Internet routet !
Siehe auch die Abbildung dazu:
8ce4b5d68fcd5bf6ae2b2d29b73d1d7c - Klicke auf das Bild, um es zu vergrößern
Auch die Beschreibung ist relativ eindeutig: (Zitat): Als Trunk Port der alle VLANs vom Switch zum Router transportiert wurde am Router hier im Beispiel der Port-1 am integrierten 4 Port Switch ausgewählt !
Also einfach nochmal das Tutorial genau durchlesen !
Vermutlich meinst du den Ausgang des Linksys auf einen bestehenden Router richtig ?
Die Antwort lautet dann JA. Der WAN Port des Linksys geht dann auf den LAN Port des Internet Routers !
Wenn du alles richtig gemacht hast sieht dein Netzwerk so aus:
b22a123e57ea8d8f11920b6be0766c9f - Klicke auf das Bild, um es zu vergrößern

WICHTIG: Du musst auf dem Internet Router statische Routen eintragen wenn der Linksys im Router Modus arbeitet.
Wenn du NAT (Adresstranslation) am WAN Port machst Gateway Modus dann entfallen die statischen Routen !!
Details dazu siehe hier:
http://www.administrator.de/Mit_einem_WLAN_zwei_IP_Netzwerke_verbinden. ...
und
http://www.administrator.de/Mit_einem_WLAN_zwei_IP_Netzwerke_verbinden. ...
Ist dort analog !
Bitte warten ..
Mitglied: zahni
02.12.2010 um 15:59 Uhr
Hallo aqui,

traue mich garnicht dem IT-Meister hier im Forum zu widersprechen, aber die Weboberfläche im Procurve 1700 ist wirklich folgendermaßen:
Bei der Port Configuration kann man bei Packet Type "all" oder "tagged only" angeben. Bei PVID kann man allerdings nur eine Auswahl treffen (None oder eines der konfigurierten VLans).

Zum IP-Interface im Vlan-Router (bei mir linksy 54 + dd-wrt Firmware) war ich nur etwas verunsichert, weil im Tutorial eben steht: "... wobei die Router IP immer die .1 im jeweiligen VLAN IP Netz ist "
Kapiert habe ich es trotzdem nicht, wie meine Nachfrage ja sicher gezeigt hat:

Zwischenzeitlich sieht es bei mir so aus:
HP-Procurve: 192.168.1.252
VLAN-Router: 192.168.1.253
Internet-Router: 192.168.1.254

VLAN2: 192.168.2.x, DHCP-Server ist der Linksys-Router, Adressen ab .100 - .150.
VLAN3: 192.168.3.x, DCHP wie oben.

Wenn ich mich z.B. mit dem iPad über den AP2 (VLAN2, Gast) verbinde, bekomme ich vom VLAN-Linksysrouter auch eine IP aus dem richtigen Adressraum zugewiesen: 192.168.2.111. So weit so gut. Als Router und DNS-Server steht dann unter Netzwerkeinstellung im iPad (logischerweise) die 192.168.2.1, also die Adresse die ich im IP-Interface des VLAN-Routers vergeben habe. Nur gibt es eben kein Netzwerkteilnehmer mit dieser IP-Adresse und deshalb gibt es wohl auch keine Internetverbindung, denn mein Internetrouter hat ja die 192.168.1.254. Kurzum, habe nicht verstanden was es mit der Router-IP in der IP-Interface Konfig im VLAN-Router auf sich hat.
Bitte warten ..
Mitglied: aqui
02.12.2010 um 16:31 Uhr
Die Verwirrung entsteht deshalb das der 1700er ein absolutes Billigteil ist. Die Zuweisung zum VLAN macht der Switch selber. In den VLAN settings müssen nur:
  • VLAN Aware enabled
  • tagged only (Dan geht allerdings das VLAN-1 untagged nicht mehr an diesem Port ! sonst Packet type all)
angehakt sein ! Siehe : http://cdn.procurve.com/training/Manuals/1700_MgmtCfg-June07-59916222.p ... -->> Seite 2-27 ff.

Wichtig ist das "VLAN Aware enabled" angehakt ist damit "lernt" der 1700er die VLAN ID und forwardet den Frame in das entsprechende VLAN sofern diese ID konfiguriert ist !!
Trotz Widerspruch ist das VLAN Verhalten beim 1700er also identisch auch wenn es eine "Bastelkonfigoberfläche" ist.
Die Aussage "... wobei die Router IP immer die .1 im jeweiligen VLAN IP Netz ist " bezieht sich nur auf das LAN Interface was die VLANs routet ! also die LAN Router IP Adresse im Linksys.
Was du da nimmst ist vollkommen kosmetisch und kann sich natürlich auch an bestehende IP Adressierung in einem VLAN orientieren. Es ist also völlig "Latte" was du hier einträgst, Hauptsache es stimmt mit dem IP Netz im jeweiligen VLAN Segment überein !!

Deine Aussage steht dann unter Netzwerkeinstellung im iPad (logischerweise) die 192.168.2.1... und Nur gibt es eben kein Netzwerkteilnehmer mit dieser IP-Adresse... ist doch vollkommen unlogisch und verwirrend !! Denn der Router hat ja die .2.1 (VLAN2: 192.168.2.x, !!) wie du selber schreibst.
Folglich gibt es also sehr wohl einen Netzwerkteilnehmer mit dieser IP-Adresse, nämlich den Linksys Router am VLAN 20 LAN Port selber. Siehst du allein schon daran das er eine IP per DHCP vergibt ! Wenn du diese IP anpingst wirst du auch ganz klar sehen das der Ping beantwortet wird !

Vermutlich liegt dein Problem aber ganz woanders nämlich in einem falschen IP Adressdesign !!
Dem HP Switch hast du als Mgmt IP Adresse die 192.168.1.252 gegeben folglich hast du also damit das 192.168.1.0er Netz auf der LAN Seite des Linksys.
Parallel dazu hast du aber auch das 192.168.1.0er Netz als Koppelnetz zwischen Linksys WAN Port und Internet Router !!
Damit hast du 2mal das gleiche IP Netz ! vergeben an einem Router. Damit ist eine Wegefindung im Routing völlig unmöglich, denn in Layer 3 Netzen müssen IP Netze immer einzigartig sein. Das gehört zum Grundschulwissen 1. Klasse IP Adressierung !!
Stelle also deine IP Adressierung RICHTIG um:

HP-Procurve: 192.168.1.252 ==>> VLAN 1
VLAN-Router LAN Port: 192.168.1.253
VLAN-Router WAN Port: 192.168.10.1
Internet-Router: 192.168.10.254

VLAN2: 192.168.2.x, DHCP-Server ist der Linksys-Router, Adressen ab .100 - .150.
VLAN3: 192.168.3.x, DCHP wie oben.

Dann wird auch ein Schuh draus und alles funktioiert wie es soll und auch im Tutorial beschrieben ist oder hast du dort etwas von doppelt vergebenen IP Netzen gelesen ???
Der Linksys kann immer auch DNS Server sein, denn er ist DNS Proxy und gibt den DNS Request final an den Internet Router weiter 192.168.10.254 und der wiederum an den Provider DNS.
Um DNS Fehler erstmal zu eliminieren solltest du von Endgeräten immer erstmal "nackte" IPa im Internet anpingen wie z.B. 193.99.144.85 (heise.de) oder 195.71.11.67 (spiegel.de).
Damit kannst du generell verifizieren das deine Konfig ins Internet funktioniert !
Bitte warten ..
Mitglied: zahni
02.12.2010 um 16:57 Uhr
aqui,
danke, danke, danke!!
Ich glaube es hat "klick" gemacht, dank Deiner ausführlichen Erklärung.
Kann es aber erst heute Abend testen ...

Viele Grüße
Bitte warten ..
Mitglied: aqui
02.12.2010 um 17:03 Uhr
Klar das wir jetzt hier eine positive "Vollzugsmeldung" hören wollen von dir !!
Bitte warten ..
Mitglied: zahni
03.12.2010 um 22:42 Uhr
Hallo aqui,

kann leider noch nicht komplett positiven Vollzug melden.
VLANS habe ich wie folgt definiert:

Standard-VLAN1 belassen, hat aber nur noch einen Port 24
VLAN2: P1-P18, AP ist linksys 54 mit dd-wrt Firmware geflasht.
VLAN3: P1, P19-23, AP eine alte Fritzbox 7050
P1 = getagged

Hatte mich ja eins zu eins an deine IP-Adressierung gehalten und nun folgenden Effekt:

a) Verbindung über Fritzbox (VLAN3): Clients bekommen IP-Adresse wie im Vlan-Router "hinterlegt", Internetzugang OK
b) Verbindung über linksys-AP (VLAN2): Clients bekommen keine Adresse aus dem VLAN2-Bereich, sondern aus dem 169.x.x Bereich, kein ping auf VLAN-Router
c) Umstöpseln den linksys-AP auf VLAN1-Port: Wieder gibt es Adressen aus dem 169. Bereich, ping auf VLAN-Router geht nicht.
c) Umstöpseln den linksys-AP auf VLAN3-Port: Clients bekommen wieder IP-Adresse aus dem VLAN3-Bereich, also alles in Ordnung

Scheint also so, als ob die VLANS 1 und 2 entweder vom Switch nicht korrekt getagged und auf die Reise geschickt werden, oder ob evtl. der VLAN-Router die beiden VLANs nicht korrekt interpretiert. Kann man am VLAN-Router ein Log-File mitführen, um zu sehen was an Daten "reinkommt"?

Grüße
Bitte warten ..
Mitglied: aqui
20.12.2010 um 11:06 Uhr
Poste bitte einmal einen Screenshot deiner VLAN Einrichtung auf dem DD-WRT. Ein Bild sagt mehr als 1000 Worte !
Das VLAN Routing machst du doch mit dem DD-WRT, richtig ??
Vermutlich ist nur der DHCP Server im VLAN-2 nicht aktiv ?!
Bitte warten ..
Mitglied: zahni
20.12.2010 um 11:46 Uhr
Problem gelöst: IP-Adressfehler in VLAN2.
Danke nochmal für Deine Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(2)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Switche und Hubs
gelöst VLAN fähiger VPN Router gesucht (33)

Frage von Leo-le zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Backup
Clients als Server missbrauchen? (10)

Frage von 1410640014 zum Thema Backup ...