Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

VLAN und der RVS4000 Router

Frage Netzwerke LAN, WAN, Wireless

Mitglied: momai

momai (Level 1) - Jetzt verbinden

18.06.2013, aktualisiert 18:00 Uhr, 1641 Aufrufe, 8 Kommentare

Hallo,

ich habe eine Frage an euch bzw. auch ein Problem bei dem ihr mir vielleicht helfen könnt.

Ich besitze einen Cisco Small Business Router RVS4000 welcher VLANs unterstützt. Dieser Router hat 4 Ports, davon sind im Moment 2 Stück belegt.
Port 1 geht auf einen SBS2003 Server auf dem ein paar Dienste laufen unteranderem ein DHCP Server. Port 4, dort hängt der Access Point drauf der zwei SSIDs aufspannt.

Der Access Point hat eine öffentliche und eine interne SSID diese sind jeweils Passwort geschützt und per VLAN getrennt. VLAN1 ist das private WLAN und VLAN2 ist das öffentliche WLAN. Beide funktionieren und sind sichtbar, allerdings beim privaten WLAN hab ich Probleme. Beide VLANs sollen per DHCP mit IPs versorgt werden. Das VLAN2 bekommt die IPs direkt vom Router den der hat einen DHCP der nur dem VLAN2 zugewiesen ist. Dies funktioniert auch und alle im öffentlichen WLAN bekommen eine IP und erhalten zugriff auf das Internet.

Beim VLAN1 ist das ein bisschen größeres Problem. Dieses VLAN soll die IPs vom DHCP auf dem SBS2003 erhalten. Der ganze Router hat als Standardeinstellung auf den Ports 1untag af den VLANs also gehe ich mal davon aus das er default auch so Arbeitet. Jetzt ist der Port4 auf dem Router so eingestellt das er nur 1tag und 2tag entgegennimmt. Jetzt bekommt natürlich das private WLAN keine IPs vom SBS DHCP.

Am Port1 hängen aber nicht nur der Server sondern auch noch ein paar Arbeitstationen. Wenn ich auf Port 1 am Router das VLAN auf 1tag einstelle bekommen die Workstations kein Internet mehr und das private WLAN auch noch immer kein DHCP. Ich geh mal davon aus das der Router nur noch getagged Pakete durchlässt aber hier kommen ja keine getagged Pakete an.

So jetzt die große Frage, was kann ich hier machen das ich es wie gewünscht zum laufen bekomme?

Für jede Hilfe wäre ich sehr dankbar...Danke!


Hier mal eine kleiner "Netzplan"

bffc31bd2780736a751ca56340a3a60a - Klicke auf das Bild, um es zu vergrößern
Mitglied: Hitman4021
18.06.2013 um 18:41 Uhr
Hallo,

du benötigst für jedes VLan eine eigene DHCP Zone am SBS und musst am Router ein DHCP Relay einrichten.

Router grenzen deine Broadcastsomänen ab = kein DHCP.

Gruß
Bitte warten ..
Mitglied: momai
18.06.2013, aktualisiert um 18:57 Uhr
Das VLAN2 wird vom Router selber versorgt mit DHCP und das funktioniert auch...

Sprich wenn ich dem VLAN1 am Router sage DHCP Relax auf 192.168.0.50 also den SBS dann sollte es funktionieren?

So sieht das hier aus auf dem Router, meinst du das?
http://sw.nohold.net/CiscoSB/Images/dhcp%20relay.png

Aber damit kommen doch die private WLAN Clients nicht auf den SBS um z.B. eine Freigabe zu bekommen, das sollte nämlich funktionieren
Bitte warten ..
Mitglied: Hitman4021
18.06.2013 um 19:20 Uhr
Hi,

ich kenne den Router selbst nicht, aber im Prinzip hast du 2 Möglichkeiten:

1) DHCP Relay, transparentes Routing
2) Du bringst dem Router bei auf den betreffenden Ports auf Layer 2 zu arbeiten also einen dummen Switch zu spielen

Gruß
Bitte warten ..
Mitglied: MrNetman
18.06.2013, aktualisiert 19.06.2013
Oder, nicht ganz den Regeln entsprechend:
SBS ist Bestandteil von deinem VLAN1, also Port 1. Dann bekommen alle internen WLAN Teilnehmer ohne großes Zutun eine IP vom SBS, da sie ja in der selben Broadcastdomäne sind.

Gruß
Netman
Bitte warten ..
Mitglied: momai
19.06.2013 um 14:41 Uhr
Also was ich sicher nicht kann ist das VLAN ändern mit dem der Router arbeitet. Der hat als Standard immer 1untag und das lässt sich leider nicht ändern. Das ist es ja was mich hier fragen lässt.

Der SBS ist nicht Bestandteil von VLAN1 den Port 1 arbeitet untagged lässt also auch untagged druch. Der SBS gibt auch keine Pakete raus die taggen.

Ich werde das jetzt mit dem Relay mal versuchen leider bin ich im Moment nicht vor ort...

Aber was könnte ich den noch tun wenn das nicht funktioniert...?
Bitte warten ..
Mitglied: MrNetman
19.06.2013 um 19:07 Uhr
Tagged und VLAN Zugehörigkeit werden innerhalb des Switches fest gelegt, nicht im SBS.
Bitte warten ..
Mitglied: momai
19.06.2013 um 19:11 Uhr
Yepp weis ich, ich meinte auch nur das ich es bis jetzt immer am Router versucht habe
Bitte warten ..
Mitglied: MrNetman
20.06.2013 um 07:42 Uhr
Der Switch benutzt VLANs und verteilt sie.
Der Router verbindet VLANs.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Linux Netzwerk
OpenVPN, zwei OpenWRT Router verbinden und VLAN durchs VPN leiten (6)

Frage von sharbich zum Thema Linux Netzwerk ...

Switche und Hubs
gelöst VLAN fähiger VPN Router gesucht (33)

Frage von Leo-le zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...